]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated but still not useable
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 # - subpackage with rpasswd daemon
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.3.94
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 Source1:        %{name}.useradd
14 Source2:        %{name}.rpasswdd.init
15 Source3:        %{name}.login.defs
16 Source4:        chage.pamd
17 Source5:        chfn.pamd
18 Source6:        chsh.pamd
19 Source7:        passwd.pamd
20 Source8:        useradd.pamd
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gettext-devel
24 BuildRequires:  openldap-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  pam-devel
27 Obsoletes:      shadow
28 Obsoletes:      shadow-extras
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 pwdutils is a collection of utilities to manage the passwd and shadow
33 user information. The difference to the shadow suite is that these
34 utilities can also modify the information stored in NIS, NIS+, or
35 LDAP. PAM is used for user authentication and changing the pasword. It
36 contains passwd, chage, chfn, chsh, and a daemon for changing the
37 password on a remote machine over a secure SSL connection. The daemon
38 also uses PAM so that it can change passwords independent of where
39 they are stored.
40
41 %description -l pl
42 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
43 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
44 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
45 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
46 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
47 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
48 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
49 has³a niezale¿nie od tego, gdzie s± przechowywane.
50
51 %prep
52 %setup -q
53
54 %build
55 %{__gettextize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__automake}
59 %configure \
60         --disable-rpath
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT/etc/pwdutils/
71 install %{SOURCE1} $RPM_BUILD_ROOT/etc/default/useradd
72 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
73 install %{SOURCE3} $RPM_BUILD_ROOT/etc/login.defs
74
75 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
76 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
77 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
78 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
79 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
80
81 %find_lang %{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 /sbin/ldconfig
88 if [ ! -f /etc/shadow ]; then
89         %{_sbindir}/pwconv
90 fi
91
92 %postun -p /sbin/ldconfig
93
94 %files -f %{name}.lang
95 %defattr(644,root,root,755)
96 %doc NEWS README THANKS TODO
97 %attr(750,root,root) %dir %{_sysconfdir}/default
98 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
99 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
100 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
101 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
102 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
103 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
104 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
105 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
106 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
107 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
108 %dir /etc/skel
109 %attr(755,root,root) %{_bindir}/chage
110 %attr(4755,root,root) %{_bindir}/chfn
111 %attr(4755,root,root) %{_bindir}/chsh
112 %attr(4755,root,root) %{_bindir}/expiry
113 %attr(4755,root,root) %{_bindir}/passwd
114 %attr(755,root,root) %{_bindir}/rpasswd
115 %attr(755,root,root) %{_sbindir}/chpasswd
116 %attr(755,root,root) %{_sbindir}/groupadd
117 %attr(755,root,root) %{_sbindir}/groupdel
118 %attr(755,root,root) %{_sbindir}/rpasswdd
119 %attr(755,root,root) %{_sbindir}/useradd
120 %attr(755,root,root) %{_sbindir}/userdel
121 %{_mandir}/man?/*.gz
122 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
This page took 0.041375 seconds and 4 git commands to generate.