]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- spaces -> tabs
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.6.4
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  d2f4313ed1e8f40f47f336f6340eef54
14 Source1:        %{name}.useradd
15 Source2:        %{name}.rpasswdd.init
16 Source3:        %{name}.login.defs
17 Source4:        chage.pamd
18 Source5:        chfn.pamd
19 Source6:        chsh.pamd
20 Source7:        passwd.pamd
21 Source8:        useradd.pamd
22 Source9:        userdb.pamd
23 URL:            http://www.thkukuk.de/pam/pwdutils/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gcc >= 5:3.2
27 BuildRequires:  gettext-devel
28 BuildRequires:  libselinux-devel
29 %{?with_ldap:BuildRequires:     openldap-devel}
30 BuildRequires:  openssl-devel >= 0.9.7d
31 BuildRequires:  openslp-devel
32 BuildRequires:  pam-devel
33 BuildRequires:  sed >= 4.0
34 Provides:       shadow = 2:%{version}-%{release}
35 Provides:       shadow-extras = 2:%{version}-%{release}
36 Obsoletes:      shadow
37 Obsoletes:      shadow-extras
38 Conflicts:      util-linux < 2.12-10
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # for pam module in /%{_lib}/security
42 %define         _libdir         /%{_lib}
43
44 %description
45 pwdutils is a collection of utilities to manage the passwd and shadow
46 user information. The difference to the shadow suite is that these
47 utilities can also modify the information stored in NIS, NIS+, or
48 LDAP. PAM is used for user authentication and changing the pasword. It
49 contains passwd, chage, chfn, chsh, and a daemon for changing the
50 password on a remote machine over a secure SSL connection. The daemon
51 also uses PAM so that it can change passwords independent of where
52 they are stored.
53
54 %description -l pl
55 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
56 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
57 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
58 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
59 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
60 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
61 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
62 has³a niezale¿nie od tego, gdzie s± przechowywane.
63
64 %package -n rpasswdd
65 Summary:        Remote password update daemon
66 Summary(pl):    Demon do zdalnego uaktualniania hase³
67 Group:          Applications/System
68
69 %description -n rpasswdd
70 rpasswdd is a daemon that lets users change their passwords in the
71 presence of a directory service like NIS, NIS+ or LDAP over a secure
72 SSL connection. rpasswdd behaves like the normal passwd(1) program and
73 uses PAM for authentication and changing the password, so it can be
74 configured very flexibel for the local requirements.
75
76 %description -n rpasswdd -l pl
77 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
78 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
79 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
80 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
81 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
82
83 %package -n pam-pam_rpasswd
84 Summary:        pam_rpasswd - PAM module to change remote password
85 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
86 Group:          Base
87 # rpasswd.conf is in base
88 Requires:       %{name} = %{version}-%{release}
89
90 %description -n pam-pam_rpasswd
91 The pam_rpasswd PAM module is for changing the password of user
92 accounts on a remote server over a secure SSL connection. It only
93 provides functionality for one PAM management group: password
94 changing.
95
96 %description -n pam-pam_rpasswd -l pl
97 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
98 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
99 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
100
101 %prep
102 %setup -q
103
104 %build
105 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
106 %{__gettextize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --enable-pam_rpasswd \
113         --enable-selinux \
114         --enable-slp \
115         --enable-ssl \
116         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
117         --enable-nls \
118         --disable-rpath
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,skel}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
129 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
130 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
131 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
132
133 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
134 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
135 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
136 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
137 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
138 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
139
140 :> $RPM_BUILD_ROOT/etc/shadow
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 if [ ! -f /etc/shadow ]; then
149         %{_sbindir}/pwconv
150 fi
151
152 %post -n rpasswdd
153 /sbin/chkconfig --add rpasswdd
154 if [ -f /var/lock/subsys/rpasswdd ]; then
155         /etc/rc.d/init.d/rpasswdd restart 1>&2
156 else
157         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
158 fi
159
160 %preun -n rpasswdd
161 if [ "$1" = "0" ]; then
162         if [ -f /var/lock/subsys/rpasswdd ]; then
163                 /etc/rc.d/init.d/rpasswdd stop 1>&2
164         fi
165         /sbin/chkconfig --del rpasswdd
166 fi
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc ChangeLog NEWS README THANKS TODO
171 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
172 %attr(750,root,root) %dir %{_sysconfdir}/default
173 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
174 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
175 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
176 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
177 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
178 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
179 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
180 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
181 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
182 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
183 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
184 %dir /etc/skel
185 %attr(755,root,root) %{_bindir}/chage
186 %attr(4755,root,root) %{_bindir}/chfn
187 %attr(4755,root,root) %{_bindir}/chsh
188 %attr(4755,root,root) %{_bindir}/expiry
189 %attr(4755,root,root) %{_bindir}/gpasswd
190 %attr(755,root,root) %{_bindir}/newgrp
191 %attr(4755,root,root) %{_bindir}/passwd
192 %attr(755,root,root) %{_bindir}/rpasswd
193 %attr(755,root,root) %{_bindir}/sg
194 %attr(755,root,root) %{_sbindir}/chpasswd
195 %attr(755,root,root) %{_sbindir}/groupadd
196 %attr(755,root,root) %{_sbindir}/groupdel
197 %attr(755,root,root) %{_sbindir}/groupmod
198 %attr(755,root,root) %{_sbindir}/grpconv
199 %attr(755,root,root) %{_sbindir}/grpck
200 %attr(755,root,root) %{_sbindir}/grpunconv
201 %attr(755,root,root) %{_sbindir}/pwconv
202 %attr(755,root,root) %{_sbindir}/pwck
203 %attr(755,root,root) %{_sbindir}/pwunconv
204 %attr(755,root,root) %{_sbindir}/rpasswdd
205 %attr(755,root,root) %{_sbindir}/useradd
206 %attr(755,root,root) %{_sbindir}/userdel
207 %attr(755,root,root) %{_sbindir}/usermod
208 %attr(755,root,root) %{_sbindir}/vigr
209 %attr(755,root,root) %{_sbindir}/vipw
210 %{_mandir}/man?/*
211 %exclude %{_mandir}/man8/rpasswdd*
212 %exclude %{_mandir}/man8/pam_rpasswd.8*
213
214 %files -n rpasswdd
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_sbindir}/rpasswdd
217 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
218 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
219 %{_mandir}/man8/rpasswdd*
220
221 %files -n pam-pam_rpasswd
222 %defattr(644,root,root,755)
223 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
224 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.074772 seconds and 4 git commands to generate.