]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated to 2.5.93
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 #
4 Summary:        Utilities to manage the passwd and shadow user information
5 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
6 Name:           pwdutils
7 Version:        2.5.93
8 Release:        1
9 License:        GPL
10 Group:          Applications/System
11 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
12 # Source0-md5:  2886ac0bd345f1525121c5f8c840fd8b
13 Source1:        %{name}.useradd
14 Source2:        %{name}.rpasswdd.init
15 Source3:        %{name}.login.defs
16 Source4:        chage.pamd
17 Source5:        chfn.pamd
18 Source6:        chsh.pamd
19 Source7:        passwd.pamd
20 Source8:        useradd.pamd
21 Source9:        userdb.pamd
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gcc >= 5:3.2
25 BuildRequires:  gettext-devel
26 BuildRequires:  libselinux-devel
27 BuildRequires:  openldap-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  pam-devel
30 Obsoletes:      shadow
31 Obsoletes:      shadow-extras 
32 Provides:       shadow = 2:%{version}-%{release}
33 Provides:       shadow-extras = 2:%{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 pwdutils is a collection of utilities to manage the passwd and shadow
38 user information. The difference to the shadow suite is that these
39 utilities can also modify the information stored in NIS, NIS+, or
40 LDAP. PAM is used for user authentication and changing the pasword. It
41 contains passwd, chage, chfn, chsh, and a daemon for changing the
42 password on a remote machine over a secure SSL connection. The daemon
43 also uses PAM so that it can change passwords independent of where
44 they are stored.
45
46 %description -l pl
47 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
48 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
49 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
50 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
51 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
52 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
53 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
54 has³a niezale¿nie od tego, gdzie s± przechowywane.
55
56 %package -n rpasswdd
57 Summary:        Remote password update daemon
58 Summary(pl):    Demon do zdalnego uaktualniania hase³
59 Group:          Applications/System
60
61 %description -n rpasswdd
62 rpasswdd is a daemon that lets users change their passwords in the
63 presence of a directory service like NIS, NIS+ or LDAP over a secure
64 SSL connection. rpasswdd behaves like the normal passwd(1) program and
65 uses PAM for authentication and changing the password, so it can be
66 configured very flexibel for the local requirements.
67
68 %description -n rpasswdd -l pl
69 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
70 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
71 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
72 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
73 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
74
75 %prep
76 %setup -q
77
78 %build
79 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
80 %{__gettextize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --enable-selinux \
87         --disable-rpath
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
98 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
99 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
100 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
101
102 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
103 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
104 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
105 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
106 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
107 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
108
109 :> $RPM_BUILD_ROOT/etc/shadow
110
111 %find_lang %{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 /sbin/ldconfig
118 if [ ! -f /etc/shadow ]; then
119         %{_sbindir}/pwconv
120 fi
121
122 %postun -p /sbin/ldconfig
123
124 %post -n rpasswdd
125 /sbin/chkconfig --add rpasswdd
126 if [ -f /var/lock/subsys/rpasswdd ]; then
127         /etc/rc.d/init.d/rpasswdd restart 1>&2
128 else
129         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
130 fi
131
132 %preun -n rpasswdd
133 if [ "$1" = "0" ]; then
134         if [ -f /var/lock/subsys/rpasswdd ]; then
135                 /etc/rc.d/init.d/rpasswdd stop 1>&2
136         fi
137         /sbin/chkconfig --del rpasswdd
138 fi
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc ChangeLog NEWS README THANKS TODO
143 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
144 %attr(750,root,root) %dir %{_sysconfdir}/default
145 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
146 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
147 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
148 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
149 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
150 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
151 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
152 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
153 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
154 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
155 %dir /etc/skel
156 %attr(755,root,root) %{_bindir}/chage
157 %attr(4755,root,root) %{_bindir}/chfn
158 %attr(4755,root,root) %{_bindir}/chsh
159 %attr(4755,root,root) %{_bindir}/expiry
160 %attr(4755,root,root) %{_bindir}/gpasswd
161 %attr(4755,root,root) %{_bindir}/passwd
162 %attr(755,root,root) %{_bindir}/rpasswd
163 %attr(755,root,root) %{_sbindir}/chpasswd
164 %attr(755,root,root) %{_sbindir}/groupadd
165 %attr(755,root,root) %{_sbindir}/groupdel
166 %attr(755,root,root) %{_sbindir}/groupmod
167 %attr(755,root,root) %{_sbindir}/grpconv
168 %attr(755,root,root) %{_sbindir}/grpck
169 %attr(755,root,root) %{_sbindir}/grpunconv
170 %attr(755,root,root) %{_sbindir}/pwconv
171 %attr(755,root,root) %{_sbindir}/pwck
172 %attr(755,root,root) %{_sbindir}/pwunconv
173 %attr(755,root,root) %{_sbindir}/rpasswdd
174 %attr(755,root,root) %{_sbindir}/useradd
175 %attr(755,root,root) %{_sbindir}/userdel
176 %attr(755,root,root) %{_sbindir}/usermod
177 %attr(755,root,root) %{_sbindir}/vigr
178 %attr(755,root,root) %{_sbindir}/vipw
179 %{_mandir}/man?/*
180 %exclude %{_mandir}/man8/rpasswdd*
181
182 %files -n rpasswdd
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_sbindir}/rpasswdd
185 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
186 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
187 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
188 %{_mandir}/man8/rpasswdd*
This page took 0.043119 seconds and 4 git commands to generate.