]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated to 2.5.97
[packages/pwdutils.git] / pwdutils.spec
1 #
2 Summary:        Utilities to manage the passwd and shadow user information
3 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
4 Name:           pwdutils
5 Version:        2.5.97
6 Release:        1
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
10 # Source0-md5:  e221330372be7931bd80542082bafe4b
11 Source1:        %{name}.useradd
12 Source2:        %{name}.rpasswdd.init
13 Source3:        %{name}.login.defs
14 Source4:        chage.pamd
15 Source5:        chfn.pamd
16 Source6:        chsh.pamd
17 Source7:        passwd.pamd
18 Source8:        useradd.pamd
19 Source9:        userdb.pamd
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gcc >= 5:3.2
23 BuildRequires:  gettext-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  openldap-devel
26 BuildRequires:  openssl-devel
27 BuildRequires:  pam-devel
28 Provides:       shadow = 2:%{version}-%{release}
29 Provides:       shadow-extras = 2:%{version}-%{release}
30 Obsoletes:      shadow
31 Obsoletes:      shadow-extras 
32 Conflicts:      util-linux < 2.12-10
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 pwdutils is a collection of utilities to manage the passwd and shadow
37 user information. The difference to the shadow suite is that these
38 utilities can also modify the information stored in NIS, NIS+, or
39 LDAP. PAM is used for user authentication and changing the pasword. It
40 contains passwd, chage, chfn, chsh, and a daemon for changing the
41 password on a remote machine over a secure SSL connection. The daemon
42 also uses PAM so that it can change passwords independent of where
43 they are stored.
44
45 %description -l pl
46 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
47 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
48 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
49 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
50 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
51 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
52 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
53 has³a niezale¿nie od tego, gdzie s± przechowywane.
54
55 %package -n rpasswdd
56 Summary:        Remote password update daemon
57 Summary(pl):    Demon do zdalnego uaktualniania hase³
58 Group:          Applications/System
59
60 %description -n rpasswdd
61 rpasswdd is a daemon that lets users change their passwords in the
62 presence of a directory service like NIS, NIS+ or LDAP over a secure
63 SSL connection. rpasswdd behaves like the normal passwd(1) program and
64 uses PAM for authentication and changing the password, so it can be
65 configured very flexibel for the local requirements.
66
67 %description -n rpasswdd -l pl
68 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
69 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
70 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
71 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
72 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
73
74 %prep
75 %setup -q
76
77 %build
78 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
79 %{__gettextize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --enable-selinux \
86         --disable-rpath
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
97 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
98 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
99 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
100
101 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
102 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
103 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
104 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
105 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
106 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
107
108 :> $RPM_BUILD_ROOT/etc/shadow
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 /sbin/ldconfig
117 if [ ! -f /etc/shadow ]; then
118         %{_sbindir}/pwconv
119 fi
120
121 %postun -p /sbin/ldconfig
122
123 %post -n rpasswdd
124 /sbin/chkconfig --add rpasswdd
125 if [ -f /var/lock/subsys/rpasswdd ]; then
126         /etc/rc.d/init.d/rpasswdd restart 1>&2
127 else
128         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
129 fi
130
131 %preun -n rpasswdd
132 if [ "$1" = "0" ]; then
133         if [ -f /var/lock/subsys/rpasswdd ]; then
134                 /etc/rc.d/init.d/rpasswdd stop 1>&2
135         fi
136         /sbin/chkconfig --del rpasswdd
137 fi
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc ChangeLog NEWS README THANKS TODO
142 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
143 %attr(750,root,root) %dir %{_sysconfdir}/default
144 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
145 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
146 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
147 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
148 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
149 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
150 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
151 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
152 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
153 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
154 %dir /etc/skel
155 %attr(755,root,root) %{_bindir}/chage
156 %attr(4755,root,root) %{_bindir}/chfn
157 %attr(4755,root,root) %{_bindir}/chsh
158 %attr(4755,root,root) %{_bindir}/expiry
159 %attr(4755,root,root) %{_bindir}/gpasswd
160 %attr(755,root,root) %{_bindir}/newgrp
161 %attr(4755,root,root) %{_bindir}/passwd
162 %attr(755,root,root) %{_bindir}/rpasswd
163 %attr(755,root,root) %{_sbindir}/chpasswd
164 %attr(755,root,root) %{_sbindir}/groupadd
165 %attr(755,root,root) %{_sbindir}/groupdel
166 %attr(755,root,root) %{_sbindir}/groupmod
167 %attr(755,root,root) %{_sbindir}/grpconv
168 %attr(755,root,root) %{_sbindir}/grpck
169 %attr(755,root,root) %{_sbindir}/grpunconv
170 %attr(755,root,root) %{_sbindir}/pwconv
171 %attr(755,root,root) %{_sbindir}/pwck
172 %attr(755,root,root) %{_sbindir}/pwunconv
173 %attr(755,root,root) %{_sbindir}/rpasswdd
174 %attr(755,root,root) %{_sbindir}/useradd
175 %attr(755,root,root) %{_sbindir}/userdel
176 %attr(755,root,root) %{_sbindir}/usermod
177 %attr(755,root,root) %{_sbindir}/vigr
178 %attr(755,root,root) %{_sbindir}/vipw
179 %{_mandir}/man?/*
180 %exclude %{_mandir}/man8/rpasswdd*
181
182 %files -n rpasswdd
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_sbindir}/rpasswdd
185 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
186 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
187 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
188 %{_mandir}/man8/rpasswdd*
This page took 0.042639 seconds and 4 git commands to generate.