]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- added rpasswdd subpackage
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 # - subpackage with rpasswd daemon
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.4
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7635c09b005f0e9447df8b42b3942187
14 Source1:        %{name}.useradd
15 Source2:        %{name}.rpasswdd.init
16 Source3:        %{name}.login.defs
17 Source4:        chage.pamd
18 Source5:        chfn.pamd
19 Source6:        chsh.pamd
20 Source7:        passwd.pamd
21 Source8:        useradd.pamd
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel
25 BuildRequires:  libselinux-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  pam-devel
29 Obsoletes:      shadow
30 Obsoletes:      shadow-extras
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 pwdutils is a collection of utilities to manage the passwd and shadow
35 user information. The difference to the shadow suite is that these
36 utilities can also modify the information stored in NIS, NIS+, or
37 LDAP. PAM is used for user authentication and changing the pasword. It
38 contains passwd, chage, chfn, chsh, and a daemon for changing the
39 password on a remote machine over a secure SSL connection. The daemon
40 also uses PAM so that it can change passwords independent of where
41 they are stored.
42
43 %description -l pl
44 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
45 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
46 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
47 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
48 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
49 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
50 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
51 has³a niezale¿nie od tego, gdzie s± przechowywane.
52
53 %package -n rpasswdd
54 Summary:        Remote password update daemon
55 Group:          Applications/System
56
57 %description -n rpasswdd
58 rpasswdd is a daemon that lets users change their passwords in the
59 presence of a directory service like NIS, NIS+ or LDAP over a secure
60 SSL connection. rpasswdd behaves like the normal passwd(1) program and
61 uses PAM for authentification and changing the password, so it can be
62 configured very flexibel for the local requirements.
63
64 %prep
65 %setup -q
66
67 %build
68 %{__gettextize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         --enable-selinux \
75         --disable-rpath
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
86 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
87 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
88 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
89
90 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
91 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
92 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
93 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
94 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
95
96 %find_lang %{name}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 /sbin/ldconfig
103 if [ ! -f /etc/shadow ]; then
104         %{_sbindir}/pwconv
105 fi
106
107 %postun -p /sbin/ldconfig
108
109 %post -n rpasswdd
110 /sbin/chkconfig --add rpasswdd
111 if [ -f /var/lock/subsys/rpasswdd ]; then
112         /etc/rc.d/init.d/rpasswdd restart 1>&2
113 else
114         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
115 fi
116
117 %preun -n rpasswdd
118 if [ "$1" = "0" ]; then
119         if [ -f /var/lock/subsys/rpasswdd ]; then
120                 /etc/rc.d/init.d/rpasswdd stop 1>&2
121         fi
122         /sbin/chkconfig --del rpasswdd
123 fi
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc ChangeLog NEWS README THANKS TODO
128 %attr(750,root,root) %dir %{_sysconfdir}/default
129 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
130 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
131 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
132 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
133 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
134 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
135 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
136 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
137 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
138 %dir /etc/skel
139 %attr(755,root,root) %{_bindir}/chage
140 %attr(4755,root,root) %{_bindir}/chfn
141 %attr(4755,root,root) %{_bindir}/chsh
142 %attr(4755,root,root) %{_bindir}/expiry
143 %attr(4755,root,root) %{_bindir}/gpasswd
144 %attr(4755,root,root) %{_bindir}/passwd
145 %attr(755,root,root) %{_bindir}/rpasswd
146 %attr(755,root,root) %{_sbindir}/chpasswd
147 %attr(755,root,root) %{_sbindir}/groupadd
148 %attr(755,root,root) %{_sbindir}/groupdel
149 %attr(755,root,root) %{_sbindir}/groupmod
150 %attr(755,root,root) %{_sbindir}/rpasswdd
151 %attr(755,root,root) %{_sbindir}/useradd
152 %attr(755,root,root) %{_sbindir}/userdel
153 %attr(755,root,root) %{_sbindir}/usermod
154 %attr(755,root,root) %{_sbindir}/vigr
155 %attr(755,root,root) %{_sbindir}/vipw
156 %{_mandir}/man?/*
157 %exclude %{_mandir}/man8/rpasswdd*
158
159 %files -n rpasswdd
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_sbindir}/rpasswdd
162 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
163 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
164 %{_mandir}/man8/rpasswdd*
This page took 0.064547 seconds and 4 git commands to generate.