]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- missing provides shadow/shadow-extras
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 # - subpackage with rpasswd daemon
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.4
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7635c09b005f0e9447df8b42b3942187
14 Source1:        %{name}.useradd
15 Source2:        %{name}.rpasswdd.init
16 Source3:        %{name}.login.defs
17 Source4:        chage.pamd
18 Source5:        chfn.pamd
19 Source6:        chsh.pamd
20 Source7:        passwd.pamd
21 Source8:        useradd.pamd
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel
25 BuildRequires:  libselinux-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  pam-devel
29 Obsoletes:      shadow
30 Obsoletes:      shadow-extras
31 Provides:       shadow
32 Provides:       shadow-extras
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 pwdutils is a collection of utilities to manage the passwd and shadow
37 user information. The difference to the shadow suite is that these
38 utilities can also modify the information stored in NIS, NIS+, or
39 LDAP. PAM is used for user authentication and changing the pasword. It
40 contains passwd, chage, chfn, chsh, and a daemon for changing the
41 password on a remote machine over a secure SSL connection. The daemon
42 also uses PAM so that it can change passwords independent of where
43 they are stored.
44
45 %description -l pl
46 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
47 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
48 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
49 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
50 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
51 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
52 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
53 has³a niezale¿nie od tego, gdzie s± przechowywane.
54
55 %package -n rpasswdd
56 Summary:        Remote password update daemon
57 Group:          Applications/System
58
59 %description -n rpasswdd
60 rpasswdd is a daemon that lets users change their passwords in the
61 presence of a directory service like NIS, NIS+ or LDAP over a secure
62 SSL connection. rpasswdd behaves like the normal passwd(1) program and
63 uses PAM for authentification and changing the password, so it can be
64 configured very flexibel for the local requirements.
65
66 %prep
67 %setup -q
68
69 %build
70 %{__gettextize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --enable-selinux \
77         --disable-rpath
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
88 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
89 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
90 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
91
92 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
93 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
94 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
95 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
96 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
97
98 %find_lang %{name}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 /sbin/ldconfig
105 if [ ! -f /etc/shadow ]; then
106         %{_sbindir}/pwconv
107 fi
108
109 %postun -p /sbin/ldconfig
110
111 %post -n rpasswdd
112 /sbin/chkconfig --add rpasswdd
113 if [ -f /var/lock/subsys/rpasswdd ]; then
114         /etc/rc.d/init.d/rpasswdd restart 1>&2
115 else
116         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
117 fi
118
119 %preun -n rpasswdd
120 if [ "$1" = "0" ]; then
121         if [ -f /var/lock/subsys/rpasswdd ]; then
122                 /etc/rc.d/init.d/rpasswdd stop 1>&2
123         fi
124         /sbin/chkconfig --del rpasswdd
125 fi
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc ChangeLog NEWS README THANKS TODO
130 %attr(750,root,root) %dir %{_sysconfdir}/default
131 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
132 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
133 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
134 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
135 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
136 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
137 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
138 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
139 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
140 %dir /etc/skel
141 %attr(755,root,root) %{_bindir}/chage
142 %attr(4755,root,root) %{_bindir}/chfn
143 %attr(4755,root,root) %{_bindir}/chsh
144 %attr(4755,root,root) %{_bindir}/expiry
145 %attr(4755,root,root) %{_bindir}/gpasswd
146 %attr(4755,root,root) %{_bindir}/passwd
147 %attr(755,root,root) %{_bindir}/rpasswd
148 %attr(755,root,root) %{_sbindir}/chpasswd
149 %attr(755,root,root) %{_sbindir}/groupadd
150 %attr(755,root,root) %{_sbindir}/groupdel
151 %attr(755,root,root) %{_sbindir}/groupmod
152 %attr(755,root,root) %{_sbindir}/rpasswdd
153 %attr(755,root,root) %{_sbindir}/useradd
154 %attr(755,root,root) %{_sbindir}/userdel
155 %attr(755,root,root) %{_sbindir}/usermod
156 %attr(755,root,root) %{_sbindir}/vigr
157 %attr(755,root,root) %{_sbindir}/vipw
158 %{_mandir}/man?/*
159 %exclude %{_mandir}/man8/rpasswdd*
160
161 %files -n rpasswdd
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_sbindir}/rpasswdd
164 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
165 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
166 %{_mandir}/man8/rpasswdd*
This page took 0.167931 seconds and 3 git commands to generate.