]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 10
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 #
11 Summary:        Small, fast and secure FTP server
12 Summary(pl):    Ma³y, szybki i bezpieczny serwer FTP
13 Name:           pure-ftpd
14 Version:        1.0.20
15 Release:        10%{?with_extra:extra}
16 Epoch:          0
17 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
18 Group:          Daemons
19 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
20 # Source0-md5:  e928e9e15adf6b52bfe6183fdad20144
21 Source1:        %{name}.pamd
22 Source2:        %{name}.init
23 Source3:        ftpusers.tar.bz2
24 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
25 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
26 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
27 Patch0:         %{name}-config.patch
28 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
29 Patch2:         %{name}-pure-pw_passwd.patch
30 Patch3:         %{name}-userlength.patch
31 Patch4:         %{name}-mysql_config.patch
32 Patch5:         %{name}-nosymlinks-hideuidmismatch.patch
33 Patch6:         %{name}-auth-can-delete-pure.patch
34 URL:            http://www.pureftpd.org/
35 %{?with_extra:BuildRequires:    autoconf}
36 %{?with_extra:BuildRequires:    automake}
37 BuildRequires:  libcap-devel
38 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
39 %{?with_ldap:BuildRequires:     openldap-devel}
40 %{?with_mysql:BuildRequires:    mysql-devel}
41 %{?with_pgsql:BuildRequires:    postgresql-devel}
42 %{?with_tls:BuildRequires:      openssl-devel}
43 BuildRequires:  pam-devel
44 PreReq:         rc-scripts
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Provides:       ftpserver
49 Obsoletes:      ftpserver
50 Obsoletes:      anonftp
51 Obsoletes:      bftpd
52 Obsoletes:      ftpd-BSD
53 Obsoletes:      glftpd
54 Obsoletes:      heimdal-ftpd
55 Obsoletes:      linux-ftpd
56 Obsoletes:      muddleftpd
57 Obsoletes:      proftpd
58 Obsoletes:      proftpd-common
59 Obsoletes:      proftpd-inetd
60 Obsoletes:      proftpd-standalone
61 Obsoletes:      troll-ftpd
62 Obsoletes:      vsftpd
63 Obsoletes:      wu-ftpd
64 Conflicts:      man-pages < 1.51
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sysconfdir     /etc/ftpd
68 %define         _ftpdir         /home/services/ftp
69
70 %description
71 Pure-FTPd is a fast, production-quality, standard-comformant FTP
72 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
73 has no known security flaw, it is really trivial to set up and it is
74 especially designed for modern Linux kernels (setfsuid, sendfile,
75 capabilities) . Features include PAM support, IPv6, chroot()ed home
76 directories, virtual domains, built-in LS, anti-warez system, bounded
77 ports for passive downloads...
78
79 %description -l pl
80 Pure-FTPD to szybki, wysokiej jako¶ci, odpowiadaj±cy standardom serwer
81 FTP bazuj±cy na Troll-FTPd. W przeciwieñstwie do innych serwerów FTP
82 nie ma znanych luk w bezpieczeñstwie. Ponadto jest trywialny w
83 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
84 (setfsuid, sendfile, capabilibies). Mo¿liwo¶ci to wsparcie dla PAM-a,
85 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
86 LS, system anty-warezowy, ograniczanie portów dla pasywnych
87 po³±czeñ...
88
89 %prep
90 %setup -q -a 4
91 %patch0 -p0
92 %patch4 -p1
93 %patch5 -p1
94 %patch6 -p1
95 %{?with_longusername:%patch3 -p1}
96 %{?with_extra:%patch1 -p1}
97 %{?with_extra:%patch2 -p1}
98
99 %build
100 %configure \
101         --with-boring \
102         --with-altlog \
103         --with-cookie \
104         --with-diraliases \
105         --with-extauth \
106         --with-ftpwho \
107         --with-language=english \
108         --with-largefile \
109         %{?with_ldap:--with-ldap} \
110         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
111         --with-pam \
112         --with-peruserlimits \
113         %{?with_pgsql:--with-pgsql} \
114         --with-privsep \
115         %{?with_puredb:--with-puredb} \
116         --with-quotas \
117         --with-ratios \
118         --with-throttling \
119         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
120         --with-uploadscript \
121         --with-virtualchroot \
122         --with-virtualhosts
123
124 %if %{with extra}
125 cd pure-config
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure
131 %{__make}
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
137         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
143 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
144
145 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
146 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
147 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
148 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
149 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
150 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
151
152 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
153
154 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
155
156 %if %{with extra}
157 cd pure-config
158 %{__make} install DESTDIR=$RPM_BUILD_ROOT
159 %endif
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 /sbin/chkconfig --add %{name}
166 if [ -f %{_var}/lock/subsys/%{name} ]; then
167         /etc/rc.d/init.d/%{name} restart 1>&2
168 else
169         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start PureFTPD daemon."
170 fi
171
172 %preun
173 if [ "$1" = "0" ]; then
174         if [ -f %{_var}/lock/subsys/%{name} ]; then
175                 /etc/rc.d/init.d/%{name} stop 1>&2
176         fi
177         /sbin/chkconfig --del %{name}
178 fi
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
183 %attr(755,root,root) %{_bindir}/*
184 %attr(755,root,root) %{_sbindir}/*
185 %attr(754,root,root) /etc/rc.d/init.d/%{name}
186 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
187 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.ftp
188 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
189 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
190 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
191 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
192 %attr(710,root,ftp) %dir %{_sysconfdir}
193 %dir %{_sysconfdir}/vhosts
194 %dir %{_sysconfdir}/pure-ftpd
195 %dir %{_ftpdir}
196 %{_mandir}/man?/*
197 %lang(ja) %{_mandir}/ja/man5/ftpusers*
198 %lang(pl) %{_mandir}/pl/man5/ftpusers*
199 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
200 %lang(ru) %{_mandir}/ru/man5/ftpusers*
This page took 0.093713 seconds and 4 git commands to generate.