]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- cosmetic
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 # _with_mysql - enables MySQL auth but disables PAM auth
4 # _with_ldap  - enabled LDAP auth
5 #
6 Summary:        Small, fast and secure FTP server
7 Summary(pl):    Ma³y, szybki i bezpieczny serwer FTP
8 Name:           pure-ftpd
9 Version:        1.0.12
10 Release:        3
11 Epoch:          0
12 License:        GPL
13 Group:          Daemons
14 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.pamd
16 Source2:        %{name}.init
17 Source3:        ftpusers.tar.bz2
18 Patch0:         %{name}-config.patch
19 URL:            http://www.pureftpd.org/
20 BuildRequires:  libcap-devel
21 %{?_with_mysql:BuildRequires:   mysql-devel}
22 %{?_with_ldap:BuildRequires:    openldap-devel}
23 BuildRequires:  pam-devel
24 Prereq:         rc-scripts
25 Requires(post,preun):/sbin/chkconfig
26 Provides:       ftpserver
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      ftpserver
29 Obsoletes:      anonftp
30 Obsoletes:      bftpd
31 Obsoletes:      ftpd-BSD
32 Obsoletes:      heimdal-ftpd
33 Obsoletes:      linux-ftpd
34 Obsoletes:      muddleftpd
35 Obsoletes:      proftpd
36 Obsoletes:      proftpd-common
37 Obsoletes:      proftpd-inetd
38 Obsoletes:      proftpd-standalone
39 Obsoletes:      troll-ftpd
40 Obsoletes:      vsftpd
41 Obsoletes:      wu-ftpd
42 Conflicts:      man-pages < 1.51
43
44 %define         _sysconfdir     /etc/ftpd
45
46 %description
47 Pure-FTPd is a fast, production-quality, standard-comformant FTP
48 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
49 has no known security flaw, it is really trivial to set up and it is
50 especially designed for modern Linux kernels (setfsuid, sendfile,
51 capabilities) . Features include PAM support, IPv6, chroot()ed home
52 directories, virtual domains, built-in LS, anti-warez system, bounded
53 ports for passive downloads...
54
55 %description -l pl
56 Pure-FTPD to szybki, wysokiej jako¶ci, odpowiadaj±cy standardom serwer
57 FTP bazuj±cy na Troll-FTPd. W przeciwieñstwie do innych serwerów FTP
58 nie ma znanych luk w bezpieczeñstwie. Ponadto jest trywialny w
59 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
60 (setfsuid, sendfile, capabilibies). Mo¿liwo¶ci to wsparcie dla PAMa,
61 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
62 LS, system anty-warezowy, ograniczanie portów dla pasywnych
63 po³±czeñ...
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 %configure \
71         %{?_with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
72         --with-altlog \
73         --with-puredb \
74         %{?!_with_mysql:--with-pam} \
75         --with-cookie \
76         --with-throttling \
77         --with-ratios \
78         --with-quotas \
79         --with-ftpwho \
80         --with-largefile \
81         --with-uploadscript \
82         --with-virtualhosts \
83         --with-language=english \
84         --with-virtualchroot \
85         %{?_with_ldap:--with-ldap}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
90         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts},/home/ftp/Incoming}
91
92 %{__make} install DESTDIR=$RPM_BUILD_ROOT
93
94 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
95 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
96 install contrib/redhat.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
97 install pureftpd-mysql.conf      $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf
98 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
99
100 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 /sbin/chkconfig --add %{name}
107 if [ -f %{_var}/lock/subsys/%{name} ]; then
108         /etc/rc.d/init.d/%{name} restart 1>&2
109 else
110         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start PureFTPD daemon."
111 fi
112
113 %preun
114 if [ "$1" = "0" ]; then
115         if [ -f %{_var}/lock/subsys/%{name} ]; then
116                 /etc/rc.d/init.d/%{name} stop 1>&2
117         fi
118         /sbin/chkconfig --del %{name}
119 fi
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README* AUTHORS ChangeLog HISTORY NEWS THANKS pure*.conf
124 %attr(755,root,root) %{_bindir}/*
125 %attr(755,root,root) %{_sbindir}/*
126 %attr(754,root,root) /etc/rc.d/init.d/%{name}
127 %{?!_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*}
128 %{?!_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.ftp}
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
130 %{?_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
131 %attr(740,root,root) %dir %{_sysconfdir}
132 %dir %{_sysconfdir}/vhosts
133 %dir /home/ftp
134 %attr(775,root,ftp) %dir /home/ftp/Incoming
135 %{_mandir}/man?/*
136 %lang(ja) %{_mandir}/ja/man5/ftpusers*
137 %lang(pl) %{_mandir}/pl/man5/ftpusers*
138 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
139 %lang(ru) %{_mandir}/ru/man5/ftpusers*
This page took 0.082329 seconds and 4 git commands to generate.