]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 7; log tls sni hostname
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     7
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.47
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  a41fa531c0d21bd3416dd524d75495ae
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 # from Fedora
34 Patch4:         0003-Allow-having-both-options-and-config-file-on-command.patch
35 Patch5:         tls.patch
36 Patch6:         sni.patch
37 Patch7:         audit_cap.patch
38 Patch8:         %{name}-apparmor.patch
39 Patch9:         %{name}-mysql-utf8.patch
40 URL:            http://www.pureftpd.org/
41 %{?with_extra:BuildRequires:    autoconf}
42 %{?with_extra:BuildRequires:    automake}
43 BuildRequires:  libapparmor-devel
44 %{?with_cap:BuildRequires:      libcap-devel}
45 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
46 BuildRequires:  libsodium-devel
47 %{?with_mysql:BuildRequires:    mysql-devel}
48 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
49 %{?with_tls:BuildRequires:      openssl-devel}
50 BuildRequires:  pam-devel
51 %{?with_pgsql:BuildRequires:    postgresql-devel}
52 BuildRequires:  rpmbuild(macros) >= 1.304
53 Requires(post,preun):   /sbin/chkconfig
54 Requires(postun):       /usr/sbin/groupdel
55 Requires(postun):       /usr/sbin/userdel
56 Requires(pre):  /bin/id
57 Requires(pre):  /usr/bin/getgid
58 Requires(pre):  /usr/sbin/groupadd
59 Requires(pre):  /usr/sbin/useradd
60 Requires:       pam >= 0.79.0
61 %{!?with_extra:Requires:        perl-base}
62 Requires:       rc-scripts
63 Provides:       ftpserver
64 Provides:       user(ftpauth)
65 Provides:       group(ftpauth)
66 Conflicts:      man-pages < 1.51
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _sysconfdir     /etc/ftpd
70 %define         _ftpdir         /home/services/ftp
71 %define         schemadir       /usr/share/openldap/schema
72
73 %description
74 Pure-FTPd is a fast, production-quality, standard-comformant FTP
75 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
76 has no known security flaw, it is really trivial to set up and it is
77 especially designed for modern Linux kernels (setfsuid, sendfile,
78 capabilities) . Features include PAM support, IPv6, chroot()ed home
79 directories, virtual domains, built-in LS, anti-warez system, bounded
80 ports for passive downloads...
81
82 %description -l pl.UTF-8
83 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
84 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
85 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
86 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
87 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
88 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
89 LS, system anty-warezowy, ograniczanie portów dla pasywnych
90 połączeń...
91
92 %package -n openldap-schema-pureftpd
93 Summary:        Pure-FTPd LDAP schema
94 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
95 Group:          Networking/Daemons
96 Requires(post,postun):  sed >= 4.0
97 Requires:       openldap-servers
98 Requires:       sed >= 4.0
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description -n openldap-schema-pureftpd
104 This package contains an Pure-FTPd openldap schema.
105
106 %description -n openldap-schema-pureftpd -l pl.UTF-8
107 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
108
109 %prep
110 %setup -q -a 5
111 %patch0 -p0
112 %patch1 -p1
113 %patch3 -p1
114 %patch4 -p1
115 %patch5 -p1
116 %patch6 -p1
117 %patch7 -p1
118 %patch8 -p1
119 %patch9 -p1
120
121 %{?with_extra:%patch2 -p1}
122
123 %build
124 %{__aclocal} -Im4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
130         --with-boring \
131         --with-altlog \
132         --with-cookie \
133         --with-diraliases \
134         --with-extauth \
135         --with-ftpwho \
136         --with-language=english \
137         %{!?with_cap:--without-capabilities} \
138         %{?with_ldap:--with-ldap} \
139         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
140         --with-pam \
141         --with-peruserlimits \
142         --with-rfc2640 \
143         %{?with_pgsql:--with-pgsql} \
144         --with-privsep \
145         %{?with_puredb:--with-puredb} \
146         --with-quotas \
147         --with-ratios \
148         --with-throttling \
149         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
150         --with-uploadscript \
151         --with-virtualchroot \
152         --with-virtualhosts \
153         --with-apparmor
154
155 %if %{with extra}
156 cd pure-config
157 %{__aclocal}
158 %{__autoconf}
159 %{__autoheader}
160 %{__automake}
161 %configure
162 %{__make}
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
168         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
174 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
175 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
176
177 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
178 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
179 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
180 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
181
182 mv $RPM_BUILD_ROOT%{_sysconfdir}/{pure-ftpd,pureftpd}.conf
183
184 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
185
186 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
187
188 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
189 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
190
191 %if %{with extra}
192 %{__make} -C pure-config install \
193         DESTDIR=$RPM_BUILD_ROOT
194 %endif
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 /sbin/chkconfig --add %{name}
201 %service %{name} restart "PureFTPD daemon"
202
203 %pre
204 %groupadd -g 326 ftpauth
205 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
206
207 %preun
208 if [ "$1" = "0" ]; then
209         %service %{name} stop
210         /sbin/chkconfig --del %{name}
211 fi
212
213 %postun
214 if [ "$1" = "0" ]; then
215         %userremove ftpauth
216         %groupremove ftpauth
217 fi
218
219 %post -n openldap-schema-pureftpd
220 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
221 %service -q ldap restart
222
223 %postun -n openldap-schema-pureftpd
224 if [ "$1" = "0" ]; then
225         %openldap_schema_unregister %{schemadir}/pureftpd.schema
226         %service -q ldap restart
227 fi
228
229 %triggerpostun -- %{name} < 1.0.41-2
230 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
231 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
232 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
233 exit 0
234
235 %files
236 %defattr(644,root,root,755)
237 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
238 %attr(755,root,root) %{_bindir}/*
239 %attr(755,root,root) %{_sbindir}/*
240 %attr(754,root,root) /etc/rc.d/init.d/%{name}
241 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
242 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
243 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
244 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
245 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
246 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
247 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
248 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
249 %attr(710,root,ftp) %dir %{_sysconfdir}
250 %dir %{_sysconfdir}/vhosts
251 %dir %{_sysconfdir}/pure-ftpd
252 %dir %{_ftpdir}
253 %{_mandir}/man?/*
254 %lang(ja) %{_mandir}/ja/man5/ftpusers*
255 %lang(pl) %{_mandir}/pl/man5/ftpusers*
256 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
257 %lang(ru) %{_mandir}/ru/man5/ftpusers*
258
259 %files -n openldap-schema-pureftpd
260 %defattr(644,root,root,755)
261 %{schemadir}/pureftpd.schema
This page took 0.126154 seconds and 4 git commands to generate.