]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- quick, quick... rename the subpacke to fit schemas name and noone will notice.. :)
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        4%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        ftpusers.tar.bz2
25 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
26 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
27 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
28 Patch0:         %{name}-config.patch
29 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
30 Patch2:         %{name}-pure-pw_passwd.patch
31 Patch3:         %{name}-mysql_config.patch
32 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
33 Patch5:         %{name}-auth-can-delete-pure.patch
34 URL:            http://www.pureftpd.org/
35 %{?with_extra:BuildRequires:    autoconf}
36 %{?with_extra:BuildRequires:    automake}
37 %{?with_cap:BuildRequires:      libcap-devel}
38 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
39 %{?with_mysql:BuildRequires:    mysql-devel}
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 %{?with_tls:BuildRequires:      openssl-devel}
42 BuildRequires:  pam-devel
43 %{?with_pgsql:BuildRequires:    postgresql-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Requires:       rc-scripts
49 Provides:       ftpserver
50 Obsoletes:      anonftp
51 Obsoletes:      bftpd
52 Obsoletes:      ftpd-BSD
53 Obsoletes:      ftpserver
54 Obsoletes:      glftpd
55 Obsoletes:      heimdal-ftpd
56 Obsoletes:      linux-ftpd
57 Obsoletes:      muddleftpd
58 Obsoletes:      proftpd
59 Obsoletes:      proftpd-common
60 Obsoletes:      proftpd-inetd
61 Obsoletes:      proftpd-standalone
62 Obsoletes:      troll-ftpd
63 Obsoletes:      vsftpd
64 Obsoletes:      wu-ftpd
65 Conflicts:      man-pages < 1.51
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/ftpd
69 %define         _ftpdir         /home/services/ftp
70
71 %description
72 Pure-FTPd is a fast, production-quality, standard-comformant FTP
73 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
74 has no known security flaw, it is really trivial to set up and it is
75 especially designed for modern Linux kernels (setfsuid, sendfile,
76 capabilities) . Features include PAM support, IPv6, chroot()ed home
77 directories, virtual domains, built-in LS, anti-warez system, bounded
78 ports for passive downloads...
79
80 %description -l pl.UTF-8
81 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
82 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
83 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
84 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
85 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
86 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
87 LS, system anty-warezowy, ograniczanie portów dla pasywnych
88 połączeń...
89
90 %package -n openldap-schema-pureftpd
91 Summary:        Pure-FTPd LDAP schema
92 Summary(pl.UTF-8):    Schemat LDAP Pure-FTPd'a
93 Group:          Netwrokinf/Daemons
94 Requires:       openldap-servers
95
96 %description -n openldap-schema-pureftpd
97 This package contains an Pure-FTPd openldap schema.
98
99 %description -n openldap-schema-pureftpd -l pl.UTF-8
100 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
101
102 %prep
103 %setup -q -a 4
104 %patch0 -p0
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108 %{?with_extra:%patch1 -p1}
109 %{?with_extra:%patch2 -p1}
110
111 %build
112 # drop --without-cork for Th
113 %configure \
114         --without-cork \
115         --with-boring \
116         --with-altlog \
117         --with-cookie \
118         --with-diraliases \
119         --with-extauth \
120         --with-ftpwho \
121         --with-language=english \
122         --with-largefile \
123         %{!?with_cap:--without-capabilities} \
124         %{?with_ldap:--with-ldap} \
125         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
126         --with-pam \
127         --with-peruserlimits \
128         %{?with_pgsql:--with-pgsql} \
129         --with-privsep \
130         %{?with_puredb:--with-puredb} \
131         --with-quotas \
132         --with-ratios \
133         --with-throttling \
134         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
135         --with-uploadscript \
136         --with-virtualchroot \
137         --with-virtualhosts
138
139 %if %{with extra}
140 cd pure-config
141 %{__aclocal}
142 %{__autoconf}
143 %{__autoheader}
144 %{__automake}
145 %configure
146 %{__make}
147 %endif
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
152         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{_datadir}/openldap/schema}
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
158 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
159
160 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
161 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
162 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
163 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
164 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
165 install pureftpd.schema $RPM_BUILD_ROOT%{_datadir}/openldap/schema/pureftpd.schema
166 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
167
168 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
169
170 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
171 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
172
173 %if %{with extra}
174 %{__make} -C pure-config install \
175         DESTDIR=$RPM_BUILD_ROOT
176 %endif
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 /sbin/chkconfig --add %{name}
183 %service %{name} restart "PureFTPD daemon"
184
185 %preun
186 if [ "$1" = "0" ]; then
187         %service %{name} stop
188         /sbin/chkconfig --del %{name}
189 fi
190
191 %files
192 %defattr(644,root,root,755)
193 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
194 %attr(755,root,root) %{_bindir}/*
195 %attr(755,root,root) %{_sbindir}/*
196 %attr(754,root,root) /etc/rc.d/init.d/%{name}
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.ftp
199 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
200 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
201 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
202 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
203 %attr(710,root,ftp) %dir %{_sysconfdir}
204 %dir %{_sysconfdir}/vhosts
205 %dir %{_sysconfdir}/pure-ftpd
206 %dir %{_ftpdir}
207 %{_mandir}/man?/*
208 %lang(ja) %{_mandir}/ja/man5/ftpusers*
209 %lang(pl) %{_mandir}/pl/man5/ftpusers*
210 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
211 %lang(ru) %{_mandir}/ru/man5/ftpusers*
212
213 %files -n openldap-schema-pureftpd
214 %defattr(644,root,root,755) %{_datadir}/openldap/schema/pureftpd.schema
This page took 0.039251 seconds and 4 git commands to generate.