]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- 0.99.9, STBR
[packages/pure-ftpd.git] / pure-ftpd.spec
1 # _with_mysql - enables MySQL auth but disables PAM auth
2 Summary:        Small, fast and secure FTP server
3 Summary(pl):    Ma³y, szybki i bezpieczny serwer FTP
4 Name:           pure-ftpd
5 Version:        0.99.9
6 Release:        1
7 License:        GPL
8 Group:          Daemons
9 Group(de):      Server
10 Group(pl):      Serwery
11 Source0:        http://prdownloads.sourceforge.net/pureftpd/%{name}-%{version}.tar.gz
12 Source1:        %{name}.pamd
13 Source2:        %{name}.init
14 URL:            http://www.pureftpd.org/
15 %{?_with_mysql:BuildRequires:   mysql-devel}
16 BuildRequires:  libcap-devel
17 BuildRequires:  pam-devel
18 BuildRequires:  automake
19 BuildRequires:  autoconf
20 Prereq:         rc-scripts
21 Prereq:         /sbin/chkconfig
22 Provides:       ftpserver
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Obsoletes:      ftpserver
25 Obsoletes:      anonftp
26 Obsoletes:      bftpd
27 Obsoletes:      ftpd-BSD
28 Obsoletes:      heimdal-ftpd
29 Obsoletes:      linux-ftpd
30 Obsoletes:      muddleftpd
31 Obsoletes:      proftpd
32 Obsoletes:      troll-ftpd
33 Obsoletes:      wu-ftpd
34
35 %description
36 Pure-FTPd is a fast, production-quality, standard-comformant FTP
37 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
38 has no known security flaw, it is really trivial to set up and it is
39 especially designed for modern Linux kernels (setfsuid, sendfile,
40 capabilities) . Features include PAM support, IPv6, chroot()ed home
41 directories, virtual domains, built-in LS, anti-warez system, bounded
42 ports for passive downloads...
43
44 %description -l pl
45 Pure-FTPD to szybki, wysokiej jako¶ci, odpowiadaj±cy standardom serwer
46 FTP bazuj±cy na Troll-FTPd. W przeciwieñstwie do innych serwerów FTP
47 nie ma znanych luk w bezpieczeñstwie. Ponadto jest trywialny w
48 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuxa
49 (setfsuid, sendfile, capabilibies). Mo¿liwo¶ci to wsparcie dla PAMa,
50 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
51 LS, system anty-warezowy, ograniczanie portów dla pasywnych
52 po³±czeñ...
53
54 %prep
55 %setup -q
56
57 %build
58 aclocal
59 autoconf
60 automake -a -c
61 %configure \
62         %{?_with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
63         --with-altlog \
64         %{?!_with_mysql:--with-pam} \
65         --with-cookie \
66         --with-throttling \
67         --with-ratios \
68         --with-ftpwho \
69         --with-largefile \
70         --with-uploadscript \
71         --with-virtualhosts \
72         --with-language=english
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,ftpd/vhosts,security,rc.d/init.d} \
77         $RPM_BUILD_ROOT/home/ftp/Incoming
78
79 %{__make} install DESTDIR=$RPM_BUILD_ROOT
80
81 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
82 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
83 install contrib/redhat.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/ftpd/pureftpd.conf
84 install pureftpd-mysql.conf      $RPM_BUILD_ROOT%{_sysconfdir}/ftpd/pureftpd-mysql.conf
85 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
86
87 gzip -9nf README* AUTHORS ChangeLog HISTORY NEWS THANKS
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 /sbin/chkconfig --add %{name}
94 if [ -f %{_var}/lock/subsys/%{name} ]; then
95         /etc/rc.d/init.d/%{name} restart 1>&2
96 else
97         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start PureFTPD daemon."
98 fi
99
100 %preun
101 if [ "$1" = "0" ]; then
102         if [ -f %{_var}/lock/subsys/%{name} ]; then
103                 /etc/rc.d/init.d/%{name} stop 1>&2
104         fi
105         /sbin/chkconfig --del %{name}
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc *.gz pure*.conf
111 %attr(755,root,root) %{_sbindir}/*
112 %attr(640,root,root) %dir /etc/ftpd
113 %dir %{_sysconfdir}/ftpd/vhosts
114 %attr(754,root,root) /etc/rc.d/init.d/%{name}
115 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpd/pureftpd.conf
116 %{?_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpd/pureftpd-mysql.conf}
117 %{?!_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*}
118 %{?!_with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.ftp}
119 %dir /home/ftp
120 %attr(755,ftp,ftp) %dir /home/ftp/Incoming
121 %{_mandir}/man?/*
This page took 0.041297 seconds and 4 git commands to generate.