]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
noarch openldap schema package
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     1
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.36
17 Release:        %{rel}%{?with_extra:extra}
18 Epoch:          0
19 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
20 Group:          Daemons
21 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
22 # Source0-md5:  7899c75c1fed7dbad0352eb31080e066
23 Source1:        %{name}.pamd
24 Source2:        %{name}.init
25 Source3:        %{name}.sysconfig
26 Source4:        ftpusers.tar.bz2
27 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
28 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
29 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
30 Patch0:         %{name}-config.patch
31 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
32 Patch2:         %{name}-pure-pw_passwd.patch
33 Patch3:         %{name}-mysql_config.patch
34 Patch4:         %{name}-allauth.patch
35 Patch5:         %{name}-passwd_location.patch
36 Patch6:         %{name}-additionalgid.patch
37 Patch7:         audit_cap.patch
38 URL:            http://www.pureftpd.org/
39 %{?with_extra:BuildRequires:    autoconf}
40 %{?with_extra:BuildRequires:    automake}
41 %{?with_cap:BuildRequires:      libcap-devel}
42 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
43 %{?with_mysql:BuildRequires:    mysql-devel}
44 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
45 %{?with_tls:BuildRequires:      openssl-devel}
46 BuildRequires:  pam-devel
47 %{?with_pgsql:BuildRequires:    postgresql-devel}
48 BuildRequires:  rpmbuild(macros) >= 1.304
49 Requires(post,preun):   /sbin/chkconfig
50 Requires:       pam >= 0.79.0
51 %{!?with_extra:Requires:        perl-base}
52 Requires:       rc-scripts
53 Provides:       ftpserver
54 Conflicts:      man-pages < 1.51
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _sysconfdir     /etc/ftpd
58 %define         _ftpdir         /home/services/ftp
59 %define         schemadir       /usr/share/openldap/schema
60
61 %description
62 Pure-FTPd is a fast, production-quality, standard-comformant FTP
63 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
64 has no known security flaw, it is really trivial to set up and it is
65 especially designed for modern Linux kernels (setfsuid, sendfile,
66 capabilities) . Features include PAM support, IPv6, chroot()ed home
67 directories, virtual domains, built-in LS, anti-warez system, bounded
68 ports for passive downloads...
69
70 %description -l pl.UTF-8
71 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
72 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
73 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
74 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
75 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
76 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
77 LS, system anty-warezowy, ograniczanie portów dla pasywnych
78 połączeń...
79
80 %package -n openldap-schema-pureftpd
81 Summary:        Pure-FTPd LDAP schema
82 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
83 Group:          Networking/Daemons
84 Requires(post,postun):  sed >= 4.0
85 Requires:       openldap-servers
86 Requires:       sed >= 4.0
87 %if "%{_rpmversion}" >= "5"
88 BuildArch:      noarch
89 %endif
90
91 %description -n openldap-schema-pureftpd
92 This package contains an Pure-FTPd openldap schema.
93
94 %description -n openldap-schema-pureftpd -l pl.UTF-8
95 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
96
97 %prep
98 %setup -q -a 5
99 %patch0 -p0
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p1
103 %patch6 -p1
104 %patch7 -p1
105
106 %{?with_extra:%patch1 -p1}
107 %{?with_extra:%patch2 -p1}
108
109 %build
110 %{__aclocal} -Im4
111 %{__autoconf}
112 %{__autoheader}
113 %configure \
114         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
115         --with-boring \
116         --with-altlog \
117         --with-cookie \
118         --with-diraliases \
119         --with-extauth \
120         --with-ftpwho \
121         --with-language=english \
122         %{!?with_cap:--without-capabilities} \
123         %{?with_ldap:--with-ldap} \
124         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
125         --with-pam \
126         --with-peruserlimits \
127         %{?with_pgsql:--with-pgsql} \
128         --with-privsep \
129         %{?with_puredb:--with-puredb} \
130         --with-quotas \
131         --with-ratios \
132         --with-throttling \
133         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
134         --with-uploadscript \
135         --with-virtualchroot \
136         --with-virtualhosts
137
138 %if %{with extra}
139 cd pure-config
140 %{__aclocal}
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure
145 %{__make}
146 %endif
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
151         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
157 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
158 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
159
160 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
161 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
162 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
163 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
164 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
165 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
166
167 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
168
169 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
170
171 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
172 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
173
174 %if %{with extra}
175 %{__make} -C pure-config install \
176         DESTDIR=$RPM_BUILD_ROOT
177 %endif
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post
183 /sbin/chkconfig --add %{name}
184 %service %{name} restart "PureFTPD daemon"
185
186 %preun
187 if [ "$1" = "0" ]; then
188         %service %{name} stop
189         /sbin/chkconfig --del %{name}
190 fi
191
192 %post -n openldap-schema-pureftpd
193 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
194 %service -q ldap restart
195
196 %postun -n openldap-schema-pureftpd
197 if [ "$1" = "0" ]; then
198         %openldap_schema_unregister %{schemadir}/pureftpd.schema
199         %service -q ldap restart
200 fi
201
202
203 %files
204 %defattr(644,root,root,755)
205 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
206 %attr(755,root,root) %{_bindir}/*
207 %attr(755,root,root) %{_sbindir}/*
208 %attr(754,root,root) /etc/rc.d/init.d/%{name}
209 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
210 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
211 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
213 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
214 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
215 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
216 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
217 %attr(710,root,ftp) %dir %{_sysconfdir}
218 %dir %{_sysconfdir}/vhosts
219 %dir %{_sysconfdir}/pure-ftpd
220 %dir %{_ftpdir}
221 %{_mandir}/man?/*
222 %lang(ja) %{_mandir}/ja/man5/ftpusers*
223 %lang(pl) %{_mandir}/pl/man5/ftpusers*
224 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
225 %lang(ru) %{_mandir}/ru/man5/ftpusers*
226
227 %files -n openldap-schema-pureftpd
228 %defattr(644,root,root,755)
229 %{schemadir}/pureftpd.schema
This page took 3.174621 seconds and 4 git commands to generate.