]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 3; restore old allauth behaviour broken at upgrade to 1.0.40
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     3
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.41
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  76c2364591418f153ed815034621d058
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33
34 Patch5:         %{name}-passwd_location.patch
35 Patch6:         %{name}-additionalgid.patch
36 Patch7:         audit_cap.patch
37 Patch8:         %{name}-apparmor.patch
38 Patch9:         %{name}-mysql-utf8.patch
39 URL:            http://www.pureftpd.org/
40 %{?with_extra:BuildRequires:    autoconf}
41 %{?with_extra:BuildRequires:    automake}
42 BuildRequires:  libapparmor-devel
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post,preun):   /sbin/chkconfig
53 Requires:       pam >= 0.79.0
54 %{!?with_extra:Requires:        perl-base}
55 Requires:       rc-scripts
56 Provides:       ftpserver
57 Conflicts:      man-pages < 1.51
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _sysconfdir     /etc/ftpd
61 %define         _ftpdir         /home/services/ftp
62 %define         schemadir       /usr/share/openldap/schema
63
64 %description
65 Pure-FTPd is a fast, production-quality, standard-comformant FTP
66 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
67 has no known security flaw, it is really trivial to set up and it is
68 especially designed for modern Linux kernels (setfsuid, sendfile,
69 capabilities) . Features include PAM support, IPv6, chroot()ed home
70 directories, virtual domains, built-in LS, anti-warez system, bounded
71 ports for passive downloads...
72
73 %description -l pl.UTF-8
74 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
75 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
76 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
77 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
78 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
79 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
80 LS, system anty-warezowy, ograniczanie portów dla pasywnych
81 połączeń...
82
83 %package -n openldap-schema-pureftpd
84 Summary:        Pure-FTPd LDAP schema
85 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
86 Group:          Networking/Daemons
87 Requires(post,postun):  sed >= 4.0
88 Requires:       openldap-servers
89 Requires:       sed >= 4.0
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n openldap-schema-pureftpd
95 This package contains an Pure-FTPd openldap schema.
96
97 %description -n openldap-schema-pureftpd -l pl.UTF-8
98 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
99
100 %prep
101 %setup -q -a 5
102 %patch0 -p0
103 %patch1 -p1
104 %patch3 -p1
105
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109 %patch8 -p1
110 %patch9 -p1
111
112 %{?with_extra:%patch2 -p1}
113
114 %build
115 %{__aclocal} -Im4
116 %{__autoconf}
117 %{__autoheader}
118 %configure \
119         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
120         --with-boring \
121         --with-altlog \
122         --with-cookie \
123         --with-diraliases \
124         --with-extauth \
125         --with-ftpwho \
126         --with-language=english \
127         %{!?with_cap:--without-capabilities} \
128         %{?with_ldap:--with-ldap} \
129         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
130         --with-pam \
131         --with-peruserlimits \
132         --with-rfc2640 \
133         %{?with_pgsql:--with-pgsql} \
134         --with-privsep \
135         %{?with_puredb:--with-puredb} \
136         --with-quotas \
137         --with-ratios \
138         --with-throttling \
139         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
140         --with-uploadscript \
141         --with-virtualchroot \
142         --with-virtualhosts \
143         --with-apparmor
144
145 %if %{with extra}
146 cd pure-config
147 %{__aclocal}
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 %configure
152 %{__make}
153 %endif
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
158         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
164 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
165 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
166
167 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
168 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
169 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
170 cp -p configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
171 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
172 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
173
174 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
175
176 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
177
178 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
179 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
180
181 %if %{with extra}
182 %{__make} -C pure-config install \
183         DESTDIR=$RPM_BUILD_ROOT
184 %endif
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post
190 /sbin/chkconfig --add %{name}
191 %service %{name} restart "PureFTPD daemon"
192
193 %preun
194 if [ "$1" = "0" ]; then
195         %service %{name} stop
196         /sbin/chkconfig --del %{name}
197 fi
198
199 %post -n openldap-schema-pureftpd
200 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
201 %service -q ldap restart
202
203 %postun -n openldap-schema-pureftpd
204 if [ "$1" = "0" ]; then
205         %openldap_schema_unregister %{schemadir}/pureftpd.schema
206         %service -q ldap restart
207 fi
208
209 %triggerpostun -- %{name} < 1.0.41-2
210 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
211 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
212 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
213 exit 0
214
215 %files
216 %defattr(644,root,root,755)
217 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
218 %attr(755,root,root) %{_bindir}/*
219 %attr(755,root,root) %{_sbindir}/*
220 %attr(754,root,root) /etc/rc.d/init.d/%{name}
221 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
222 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
223 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
224 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
225 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
226 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
227 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
228 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
229 %attr(710,root,ftp) %dir %{_sysconfdir}
230 %dir %{_sysconfdir}/vhosts
231 %dir %{_sysconfdir}/pure-ftpd
232 %dir %{_ftpdir}
233 %{_mandir}/man?/*
234 %lang(ja) %{_mandir}/ja/man5/ftpusers*
235 %lang(pl) %{_mandir}/pl/man5/ftpusers*
236 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
237 %lang(ru) %{_mandir}/ru/man5/ftpusers*
238
239 %files -n openldap-schema-pureftpd
240 %defattr(644,root,root,755)
241 %{schemadir}/pureftpd.schema
This page took 0.048879 seconds and 4 git commands to generate.