]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 16
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        16%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
34 Patch5:         %{name}-auth-can-delete-pure.patch
35 Patch6:         %{name}-nonssl-die.patch
36 Patch7:         %{name}-del-log-path.patch
37 Patch8:         %{name}-anonymous.patch
38 Patch9:         %{name}-sleep.patch
39 Patch10:        %{name}-passwd_location.patch
40 URL:            http://www.pureftpd.org/
41 %{?with_extra:BuildRequires:    autoconf}
42 %{?with_extra:BuildRequires:    automake}
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 %{?with_mysql:BuildRequires:    mysql-devel}
46 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
47 %{?with_tls:BuildRequires:      openssl-devel}
48 BuildRequires:  pam-devel
49 %{?with_pgsql:BuildRequires:    postgresql-devel}
50 BuildRequires:  rpmbuild(macros) >= 1.304
51 Requires(post,preun):   /sbin/chkconfig
52 Requires:       pam >= 0.79.0
53 %{!?with_extra:Requires:        perl-base}
54 Requires:       rc-scripts
55 Provides:       ftpserver
56 Conflicts:      man-pages < 1.51
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _sysconfdir     /etc/ftpd
60 %define         _ftpdir         /home/services/ftp
61 %define         schemadir       /usr/share/openldap/schema
62
63 %description
64 Pure-FTPd is a fast, production-quality, standard-comformant FTP
65 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
66 has no known security flaw, it is really trivial to set up and it is
67 especially designed for modern Linux kernels (setfsuid, sendfile,
68 capabilities) . Features include PAM support, IPv6, chroot()ed home
69 directories, virtual domains, built-in LS, anti-warez system, bounded
70 ports for passive downloads...
71
72 %description -l pl.UTF-8
73 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
74 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
75 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
76 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
77 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
78 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
79 LS, system anty-warezowy, ograniczanie portów dla pasywnych
80 połączeń...
81
82 %package -n openldap-schema-pureftpd
83 Summary:        Pure-FTPd LDAP schema
84 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
85 Group:          Networking/Daemons
86 Requires(post,postun):  sed >= 4.0
87 Requires:       openldap-servers
88 Requires:       sed >= 4.0 
89
90 %description -n openldap-schema-pureftpd
91 This package contains an Pure-FTPd openldap schema.
92
93 %description -n openldap-schema-pureftpd -l pl.UTF-8
94 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
95
96 %prep
97 %setup -q -a 5
98 %patch0 -p0
99 %patch3 -p1
100 %patch4 -p1
101 %patch5 -p1
102 %patch6 -p0
103 %patch7 -p1
104 %patch8 -p1
105 %patch9 -p1
106 %patch10 -p1
107 %{?with_extra:%patch1 -p1}
108 %{?with_extra:%patch2 -p1}
109
110 %build
111 # drop --without-cork for Th
112 %configure \
113         --without-cork \
114         --with-boring \
115         --with-altlog \
116         --with-cookie \
117         --with-diraliases \
118         --with-extauth \
119         --with-ftpwho \
120         --with-language=english \
121         --with-largefile \
122         %{!?with_cap:--without-capabilities} \
123         %{?with_ldap:--with-ldap} \
124         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
125         --with-pam \
126         --with-peruserlimits \
127         %{?with_pgsql:--with-pgsql} \
128         --with-privsep \
129         %{?with_puredb:--with-puredb} \
130         --with-quotas \
131         --with-ratios \
132         --with-throttling \
133         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
134         --with-uploadscript \
135         --with-virtualchroot \
136         --with-virtualhosts
137
138 %if %{with extra}
139 cd pure-config
140 %{__aclocal}
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure
145 %{__make}
146 %endif
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
151         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
157 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
158 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
159
160 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
161 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
162 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
163 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
164 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
165 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
166
167 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
168
169 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
170
171 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
172 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
173
174 %if %{with extra}
175 %{__make} -C pure-config install \
176         DESTDIR=$RPM_BUILD_ROOT
177 %endif
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post
183 /sbin/chkconfig --add %{name}
184 %service %{name} restart "PureFTPD daemon"
185
186 %preun
187 if [ "$1" = "0" ]; then
188         %service %{name} stop
189         /sbin/chkconfig --del %{name}
190 fi
191
192 %post -n openldap-schema-pureftpd
193 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
194 %service -q ldap restart
195
196 %postun -n openldap-schema-pureftpd
197 if [ "$1" = "0" ]; then
198         %openldap_schema_unregister %{schemadir}/pureftpd.schema
199         %service -q ldap restart
200 fi
201
202
203 %files
204 %defattr(644,root,root,755)
205 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
206 %attr(755,root,root) %{_bindir}/*
207 %attr(755,root,root) %{_sbindir}/*
208 %attr(754,root,root) /etc/rc.d/init.d/%{name}
209 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
210 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
211 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
213 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
214 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
215 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
216 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
217 %attr(710,root,ftp) %dir %{_sysconfdir}
218 %dir %{_sysconfdir}/vhosts
219 %dir %{_sysconfdir}/pure-ftpd
220 %dir %{_ftpdir}
221 %{_mandir}/man?/*
222 %lang(ja) %{_mandir}/ja/man5/ftpusers*
223 %lang(pl) %{_mandir}/pl/man5/ftpusers*
224 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
225 %lang(ru) %{_mandir}/ru/man5/ftpusers*
226
227 %files -n openldap-schema-pureftpd
228 %defattr(644,root,root,755)
229 %{schemadir}/pureftpd.schema
This page took 0.0579769999999999 seconds and 3 git commands to generate.