]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- schema package fixes
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        4%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        ftpusers.tar.bz2
25 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
26 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
27 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
28 Patch0:         %{name}-config.patch
29 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
30 Patch2:         %{name}-pure-pw_passwd.patch
31 Patch3:         %{name}-mysql_config.patch
32 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
33 Patch5:         %{name}-auth-can-delete-pure.patch
34 URL:            http://www.pureftpd.org/
35 %{?with_extra:BuildRequires:    autoconf}
36 %{?with_extra:BuildRequires:    automake}
37 %{?with_cap:BuildRequires:      libcap-devel}
38 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
39 %{?with_mysql:BuildRequires:    mysql-devel}
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 %{?with_tls:BuildRequires:      openssl-devel}
42 BuildRequires:  pam-devel
43 %{?with_pgsql:BuildRequires:    postgresql-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.304
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Requires:       rc-scripts
49 Provides:       ftpserver
50 Obsoletes:      anonftp
51 Obsoletes:      bftpd
52 Obsoletes:      ftpd-BSD
53 Obsoletes:      ftpserver
54 Obsoletes:      glftpd
55 Obsoletes:      heimdal-ftpd
56 Obsoletes:      linux-ftpd
57 Obsoletes:      muddleftpd
58 Obsoletes:      proftpd
59 Obsoletes:      proftpd-common
60 Obsoletes:      proftpd-inetd
61 Obsoletes:      proftpd-standalone
62 Obsoletes:      troll-ftpd
63 Obsoletes:      vsftpd
64 Obsoletes:      wu-ftpd
65 Conflicts:      man-pages < 1.51
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/ftpd
69 %define         _ftpdir         /home/services/ftp
70 %define         schemadir       /usr/share/openldap/schema
71
72 %description
73 Pure-FTPd is a fast, production-quality, standard-comformant FTP
74 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
75 has no known security flaw, it is really trivial to set up and it is
76 especially designed for modern Linux kernels (setfsuid, sendfile,
77 capabilities) . Features include PAM support, IPv6, chroot()ed home
78 directories, virtual domains, built-in LS, anti-warez system, bounded
79 ports for passive downloads...
80
81 %description -l pl.UTF-8
82 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
83 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
84 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
85 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
86 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
87 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
88 LS, system anty-warezowy, ograniczanie portów dla pasywnych
89 połączeń...
90
91 %package -n openldap-schema-pureftpd
92 Summary:        Pure-FTPd LDAP schema
93 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
94 Group:          Networking/Daemons
95 Requires(post,postun):  sed >= 4.0
96 Requires:       openldap-servers
97 Requires:       sed >= 4.0 
98
99 %description -n openldap-schema-pureftpd
100 This package contains an Pure-FTPd openldap schema.
101
102 %description -n openldap-schema-pureftpd -l pl.UTF-8
103 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
104
105 %prep
106 %setup -q -a 4
107 %patch0 -p0
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111 %{?with_extra:%patch1 -p1}
112 %{?with_extra:%patch2 -p1}
113
114 %build
115 # drop --without-cork for Th
116 %configure \
117         --without-cork \
118         --with-boring \
119         --with-altlog \
120         --with-cookie \
121         --with-diraliases \
122         --with-extauth \
123         --with-ftpwho \
124         --with-language=english \
125         --with-largefile \
126         %{!?with_cap:--without-capabilities} \
127         %{?with_ldap:--with-ldap} \
128         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
129         --with-pam \
130         --with-peruserlimits \
131         %{?with_pgsql:--with-pgsql} \
132         --with-privsep \
133         %{?with_puredb:--with-puredb} \
134         --with-quotas \
135         --with-ratios \
136         --with-throttling \
137         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
138         --with-uploadscript \
139         --with-virtualchroot \
140         --with-virtualhosts
141
142 %if %{with extra}
143 cd pure-config
144 %{__aclocal}
145 %{__autoconf}
146 %{__autoheader}
147 %{__automake}
148 %configure
149 %{__make}
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
155         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
161 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
162
163 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
164 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
165 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
166 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
167 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
168 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
169 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
170
171 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
172
173 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
174 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
175
176 %if %{with extra}
177 %{__make} -C pure-config install \
178         DESTDIR=$RPM_BUILD_ROOT
179 %endif
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post
185 /sbin/chkconfig --add %{name}
186 %service %{name} restart "PureFTPD daemon"
187
188 %preun
189 if [ "$1" = "0" ]; then
190         %service %{name} stop
191         /sbin/chkconfig --del %{name}
192 fi
193
194 %post -n openldap-schema-pureftpd
195 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
196 %service -q ldap restart
197
198 %postun -n openldap-schema-pureftpd
199 if [ "$1" = "0" ]; then
200         %openldap_schema_unregister %{schemadir}/pureftpd.schema
201         %service -q ldap restart
202 fi
203
204
205 %files
206 %defattr(644,root,root,755)
207 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
208 %attr(755,root,root) %{_bindir}/*
209 %attr(755,root,root) %{_sbindir}/*
210 %attr(754,root,root) /etc/rc.d/init.d/%{name}
211 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.ftp
213 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
214 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
215 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
216 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
217 %attr(710,root,ftp) %dir %{_sysconfdir}
218 %dir %{_sysconfdir}/vhosts
219 %dir %{_sysconfdir}/pure-ftpd
220 %dir %{_ftpdir}
221 %{_mandir}/man?/*
222 %lang(ja) %{_mandir}/ja/man5/ftpusers*
223 %lang(pl) %{_mandir}/pl/man5/ftpusers*
224 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
225 %lang(ru) %{_mandir}/ru/man5/ftpusers*
226
227 %files -n openldap-schema-pureftpd
228 %defattr(644,root,root,755)
229 %{schemadir}/pureftpd.schema
This page took 0.068739 seconds and 3 git commands to generate.