]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
b9712dd0a1abae22c906a9f5fb1c9edd207750fe
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl):    Ma³y, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.20
16 Release:        11%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  e928e9e15adf6b52bfe6183fdad20144
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        ftpusers.tar.bz2
25 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
26 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
27 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
28 Patch0:         %{name}-config.patch
29 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
30 Patch2:         %{name}-pure-pw_passwd.patch
31 Patch3:         %{name}-userlength.patch
32 Patch4:         %{name}-mysql_config.patch
33 Patch5:         %{name}-nosymlinks-hideuidmismatch.patch
34 Patch6:         %{name}-auth-can-delete-pure.patch
35 URL:            http://www.pureftpd.org/
36 %{?with_extra:BuildRequires:    autoconf}
37 %{?with_extra:BuildRequires:    automake}
38 %{?with_cap:BuildRequires:      libcap-devel}
39 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
40 %{?with_mysql:BuildRequires:    mysql-devel}
41 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
42 %{?with_tls:BuildRequires:      openssl-devel}
43 BuildRequires:  pam-devel
44 %{?with_pgsql:BuildRequires:    postgresql-devel}
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Requires:       rc-scripts
49 Provides:       ftpserver
50 Obsoletes:      ftpserver
51 Obsoletes:      anonftp
52 Obsoletes:      bftpd
53 Obsoletes:      ftpd-BSD
54 Obsoletes:      glftpd
55 Obsoletes:      heimdal-ftpd
56 Obsoletes:      linux-ftpd
57 Obsoletes:      muddleftpd
58 Obsoletes:      proftpd
59 Obsoletes:      proftpd-common
60 Obsoletes:      proftpd-inetd
61 Obsoletes:      proftpd-standalone
62 Obsoletes:      troll-ftpd
63 Obsoletes:      vsftpd
64 Obsoletes:      wu-ftpd
65 Conflicts:      man-pages < 1.51
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/ftpd
69 %define         _ftpdir         /home/services/ftp
70
71 %description
72 Pure-FTPd is a fast, production-quality, standard-comformant FTP
73 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
74 has no known security flaw, it is really trivial to set up and it is
75 especially designed for modern Linux kernels (setfsuid, sendfile,
76 capabilities) . Features include PAM support, IPv6, chroot()ed home
77 directories, virtual domains, built-in LS, anti-warez system, bounded
78 ports for passive downloads...
79
80 %description -l pl
81 Pure-FTPD to szybki, wysokiej jako¶ci, odpowiadaj±cy standardom serwer
82 FTP bazuj±cy na Troll-FTPd. W przeciwieñstwie do innych serwerów FTP
83 nie ma znanych luk w bezpieczeñstwie. Ponadto jest trywialny w
84 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
85 (setfsuid, sendfile, capabilibies). Mo¿liwo¶ci to wsparcie dla PAM-a,
86 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
87 LS, system anty-warezowy, ograniczanie portów dla pasywnych
88 po³±czeñ...
89
90 %prep
91 %setup -q -a 4
92 %patch0 -p0
93 %patch4 -p1
94 %patch5 -p1
95 %patch6 -p1
96 %{?with_longusername:%patch3 -p1}
97 %{?with_extra:%patch1 -p1}
98 %{?with_extra:%patch2 -p1}
99
100 %build
101 %configure \
102         --with-boring \
103         --with-altlog \
104         --with-cookie \
105         --with-diraliases \
106         --with-extauth \
107         --with-ftpwho \
108         --with-language=english \
109         --with-largefile \
110         %{!?with_cap:--without-capabilities} \
111         %{?with_ldap:--with-ldap} \
112         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
113         --with-pam \
114         --with-peruserlimits \
115         %{?with_pgsql:--with-pgsql} \
116         --with-privsep \
117         %{?with_puredb:--with-puredb} \
118         --with-quotas \
119         --with-ratios \
120         --with-throttling \
121         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
122         --with-uploadscript \
123         --with-virtualchroot \
124         --with-virtualhosts
125
126 %if %{with extra}
127 cd pure-config
128 %{__aclocal}
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure
133 %{__make}
134 %endif
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
139         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir}}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
145 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
146
147 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
148 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
149 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
150 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
151 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
152 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
153
154 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
155
156 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
157
158 %if %{with extra}
159 cd pure-config
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162 %endif
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 /sbin/chkconfig --add %{name}
169 if [ -f %{_var}/lock/subsys/%{name} ]; then
170         /etc/rc.d/init.d/%{name} restart 1>&2
171 else
172         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start PureFTPD daemon."
173 fi
174
175 %preun
176 if [ "$1" = "0" ]; then
177         if [ -f %{_var}/lock/subsys/%{name} ]; then
178                 /etc/rc.d/init.d/%{name} stop 1>&2
179         fi
180         /sbin/chkconfig --del %{name}
181 fi
182
183 %files
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
186 %attr(755,root,root) %{_bindir}/*
187 %attr(755,root,root) %{_sbindir}/*
188 %attr(754,root,root) /etc/rc.d/init.d/%{name}
189 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
190 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.ftp
191 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
192 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
193 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
195 %attr(710,root,ftp) %dir %{_sysconfdir}
196 %dir %{_sysconfdir}/vhosts
197 %dir %{_sysconfdir}/pure-ftpd
198 %dir %{_ftpdir}
199 %{_mandir}/man?/*
200 %lang(ja) %{_mandir}/ja/man5/ftpusers*
201 %lang(pl) %{_mandir}/pl/man5/ftpusers*
202 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
203 %lang(ru) %{_mandir}/ru/man5/ftpusers*
This page took 0.103687 seconds and 3 git commands to generate.