]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- up to 1.0.46; additionalgid no longer in use; passwd_location was wrong anyway...
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     1
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.46
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  efce5529c1f0a39dafdd532c619503f1
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33
34 Patch7:         audit_cap.patch
35 Patch8:         %{name}-apparmor.patch
36 Patch9:         %{name}-mysql-utf8.patch
37 URL:            http://www.pureftpd.org/
38 %{?with_extra:BuildRequires:    autoconf}
39 %{?with_extra:BuildRequires:    automake}
40 BuildRequires:  libapparmor-devel
41 %{?with_cap:BuildRequires:      libcap-devel}
42 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
43 BuildRequires:  libsodium-devel
44 %{?with_mysql:BuildRequires:    mysql-devel}
45 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
46 %{?with_tls:BuildRequires:      openssl-devel}
47 BuildRequires:  pam-devel
48 %{?with_pgsql:BuildRequires:    postgresql-devel}
49 BuildRequires:  rpmbuild(macros) >= 1.304
50 Requires(post,preun):   /sbin/chkconfig
51 Requires(postun):       /usr/sbin/groupdel
52 Requires(postun):       /usr/sbin/userdel
53 Requires(pre):  /bin/id
54 Requires(pre):  /usr/bin/getgid
55 Requires(pre):  /usr/sbin/groupadd
56 Requires(pre):  /usr/sbin/useradd
57 Requires:       pam >= 0.79.0
58 %{!?with_extra:Requires:        perl-base}
59 Requires:       rc-scripts
60 Provides:       ftpserver
61 Provides:       user(ftpauth)
62 Provides:       group(ftpauth)
63 Conflicts:      man-pages < 1.51
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     /etc/ftpd
67 %define         _ftpdir         /home/services/ftp
68 %define         schemadir       /usr/share/openldap/schema
69
70 %description
71 Pure-FTPd is a fast, production-quality, standard-comformant FTP
72 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
73 has no known security flaw, it is really trivial to set up and it is
74 especially designed for modern Linux kernels (setfsuid, sendfile,
75 capabilities) . Features include PAM support, IPv6, chroot()ed home
76 directories, virtual domains, built-in LS, anti-warez system, bounded
77 ports for passive downloads...
78
79 %description -l pl.UTF-8
80 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
81 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
82 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
83 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
84 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
85 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
86 LS, system anty-warezowy, ograniczanie portów dla pasywnych
87 połączeń...
88
89 %package -n openldap-schema-pureftpd
90 Summary:        Pure-FTPd LDAP schema
91 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
92 Group:          Networking/Daemons
93 Requires(post,postun):  sed >= 4.0
94 Requires:       openldap-servers
95 Requires:       sed >= 4.0
96 %if "%{_rpmversion}" >= "5"
97 BuildArch:      noarch
98 %endif
99
100 %description -n openldap-schema-pureftpd
101 This package contains an Pure-FTPd openldap schema.
102
103 %description -n openldap-schema-pureftpd -l pl.UTF-8
104 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
105
106 %prep
107 %setup -q -a 5
108 %patch0 -p0
109 %patch1 -p1
110 %patch3 -p1
111
112 %patch7 -p1
113 %patch8 -p1
114 %patch9 -p1
115
116 %{?with_extra:%patch2 -p1}
117
118 %build
119 %{__aclocal} -Im4
120 %{__autoconf}
121 %{__autoheader}
122 %configure \
123         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
124         --with-boring \
125         --with-altlog \
126         --with-cookie \
127         --with-diraliases \
128         --with-extauth \
129         --with-ftpwho \
130         --with-language=english \
131         %{!?with_cap:--without-capabilities} \
132         %{?with_ldap:--with-ldap} \
133         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
134         --with-pam \
135         --with-peruserlimits \
136         --with-rfc2640 \
137         %{?with_pgsql:--with-pgsql} \
138         --with-privsep \
139         %{?with_puredb:--with-puredb} \
140         --with-quotas \
141         --with-ratios \
142         --with-throttling \
143         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
144         --with-uploadscript \
145         --with-virtualchroot \
146         --with-virtualhosts \
147         --with-apparmor
148
149 %if %{with extra}
150 cd pure-config
151 %{__aclocal}
152 %{__autoconf}
153 %{__autoheader}
154 %{__automake}
155 %configure
156 %{__make}
157 %endif
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
162         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
168 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
169 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
170
171 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
172 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
173 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
174 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
175
176 mv $RPM_BUILD_ROOT%{_sysconfdir}/{pure-ftpd,pureftpd}.conf
177
178 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
179
180 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
181
182 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
183 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
184
185 %if %{with extra}
186 %{__make} -C pure-config install \
187         DESTDIR=$RPM_BUILD_ROOT
188 %endif
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post
194 /sbin/chkconfig --add %{name}
195 %service %{name} restart "PureFTPD daemon"
196
197 %pre
198 %groupadd -g 326 ftpauth
199 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
200
201 %preun
202 if [ "$1" = "0" ]; then
203         %service %{name} stop
204         /sbin/chkconfig --del %{name}
205 fi
206
207 %postun
208 if [ "$1" = "0" ]; then
209         %userremove ftpauth
210         %groupremove ftpauth
211 fi
212
213 %post -n openldap-schema-pureftpd
214 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
215 %service -q ldap restart
216
217 %postun -n openldap-schema-pureftpd
218 if [ "$1" = "0" ]; then
219         %openldap_schema_unregister %{schemadir}/pureftpd.schema
220         %service -q ldap restart
221 fi
222
223 %triggerpostun -- %{name} < 1.0.41-2
224 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
225 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
226 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
227 exit 0
228
229 %files
230 %defattr(644,root,root,755)
231 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
232 %attr(755,root,root) %{_bindir}/*
233 %attr(755,root,root) %{_sbindir}/*
234 %attr(754,root,root) /etc/rc.d/init.d/%{name}
235 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
236 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
237 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
238 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
239 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
240 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
241 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
242 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
243 %attr(710,root,ftp) %dir %{_sysconfdir}
244 %dir %{_sysconfdir}/vhosts
245 %dir %{_sysconfdir}/pure-ftpd
246 %dir %{_ftpdir}
247 %{_mandir}/man?/*
248 %lang(ja) %{_mandir}/ja/man5/ftpusers*
249 %lang(pl) %{_mandir}/pl/man5/ftpusers*
250 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
251 %lang(ru) %{_mandir}/ru/man5/ftpusers*
252
253 %files -n openldap-schema-pureftpd
254 %defattr(644,root,root,755)
255 %{schemadir}/pureftpd.schema
This page took 0.096367 seconds and 3 git commands to generate.