]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
243df88d6b259afae7ae6b50df359e7acca0f9ef
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl):    Ma³y, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        3%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        ftpusers.tar.bz2
25 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
26 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
27 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
28 Patch0:         %{name}-config.patch
29 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
30 Patch2:         %{name}-pure-pw_passwd.patch
31 Patch3:         %{name}-mysql_config.patch
32 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
33 Patch5:         %{name}-auth-can-delete-pure.patch
34 URL:            http://www.pureftpd.org/
35 %{?with_extra:BuildRequires:    autoconf}
36 %{?with_extra:BuildRequires:    automake}
37 %{?with_cap:BuildRequires:      libcap-devel}
38 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
39 %{?with_mysql:BuildRequires:    mysql-devel}
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 %{?with_tls:BuildRequires:      openssl-devel}
42 BuildRequires:  pam-devel
43 %{?with_pgsql:BuildRequires:    postgresql-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Requires:       rc-scripts
49 Provides:       ftpserver
50 Obsoletes:      anonftp
51 Obsoletes:      bftpd
52 Obsoletes:      ftpd-BSD
53 Obsoletes:      ftpserver
54 Obsoletes:      glftpd
55 Obsoletes:      heimdal-ftpd
56 Obsoletes:      linux-ftpd
57 Obsoletes:      muddleftpd
58 Obsoletes:      proftpd
59 Obsoletes:      proftpd-common
60 Obsoletes:      proftpd-inetd
61 Obsoletes:      proftpd-standalone
62 Obsoletes:      troll-ftpd
63 Obsoletes:      vsftpd
64 Obsoletes:      wu-ftpd
65 Conflicts:      man-pages < 1.51
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/ftpd
69 %define         _ftpdir         /home/services/ftp
70
71 %description
72 Pure-FTPd is a fast, production-quality, standard-comformant FTP
73 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
74 has no known security flaw, it is really trivial to set up and it is
75 especially designed for modern Linux kernels (setfsuid, sendfile,
76 capabilities) . Features include PAM support, IPv6, chroot()ed home
77 directories, virtual domains, built-in LS, anti-warez system, bounded
78 ports for passive downloads...
79
80 %description -l pl
81 Pure-FTPD to szybki, wysokiej jako¶ci, odpowiadaj±cy standardom serwer
82 FTP bazuj±cy na Troll-FTPd. W przeciwieñstwie do innych serwerów FTP
83 nie ma znanych luk w bezpieczeñstwie. Ponadto jest trywialny w
84 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
85 (setfsuid, sendfile, capabilibies). Mo¿liwo¶ci to wsparcie dla PAM-a,
86 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
87 LS, system anty-warezowy, ograniczanie portów dla pasywnych
88 po³±czeñ...
89
90 %prep
91 %setup -q -a 4
92 %patch0 -p0
93 %patch3 -p1
94 %patch4 -p1
95 %patch5 -p1
96 %{?with_extra:%patch1 -p1}
97 %{?with_extra:%patch2 -p1}
98
99 %build
100 # drop --without-cork for Th
101 %configure \
102         --without-cork \
103         --with-boring \
104         --with-altlog \
105         --with-cookie \
106         --with-diraliases \
107         --with-extauth \
108         --with-ftpwho \
109         --with-language=english \
110         --with-largefile \
111         %{!?with_cap:--without-capabilities} \
112         %{?with_ldap:--with-ldap} \
113         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
114         --with-pam \
115         --with-peruserlimits \
116         %{?with_pgsql:--with-pgsql} \
117         --with-privsep \
118         %{?with_puredb:--with-puredb} \
119         --with-quotas \
120         --with-ratios \
121         --with-throttling \
122         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
123         --with-uploadscript \
124         --with-virtualchroot \
125         --with-virtualhosts
126
127 %if %{with extra}
128 cd pure-config
129 %{__aclocal}
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure
134 %{__make}
135 %endif
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
140         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir}}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
146 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
147
148 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
149 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
150 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
151 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
152 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
153 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
154
155 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
156
157 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
158 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
159
160 %if %{with extra}
161 %{__make} -C pure-config install \
162         DESTDIR=$RPM_BUILD_ROOT
163 %endif
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post
169 /sbin/chkconfig --add %{name}
170 %service %{name} restart "PureFTPD daemon"
171
172 %preun
173 if [ "$1" = "0" ]; then
174         %service %{name} stop
175         /sbin/chkconfig --del %{name}
176 fi
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
181 %attr(755,root,root) %{_bindir}/*
182 %attr(755,root,root) %{_sbindir}/*
183 %attr(754,root,root) /etc/rc.d/init.d/%{name}
184 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
185 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.ftp
186 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
187 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
188 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
189 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
190 %attr(710,root,ftp) %dir %{_sysconfdir}
191 %dir %{_sysconfdir}/vhosts
192 %dir %{_sysconfdir}/pure-ftpd
193 %dir %{_ftpdir}
194 %{_mandir}/man?/*
195 %lang(ja) %{_mandir}/ja/man5/ftpusers*
196 %lang(pl) %{_mandir}/pl/man5/ftpusers*
197 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
198 %lang(ru) %{_mandir}/ru/man5/ftpusers*
This page took 0.060654 seconds and 3 git commands to generate.