]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 6; fix sending messages to client when built with SSL and connection is unencrypted
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        6%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
34 Patch5:         %{name}-auth-can-delete-pure.patch
35 Patch6:         %{name}-nonssl-die.patch
36 URL:            http://www.pureftpd.org/
37 %{?with_extra:BuildRequires:    autoconf}
38 %{?with_extra:BuildRequires:    automake}
39 %{?with_cap:BuildRequires:      libcap-devel}
40 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
41 %{?with_mysql:BuildRequires:    mysql-devel}
42 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
43 %{?with_tls:BuildRequires:      openssl-devel}
44 BuildRequires:  pam-devel
45 %{?with_pgsql:BuildRequires:    postgresql-devel}
46 BuildRequires:  rpmbuild(macros) >= 1.304
47 Requires(post,preun):   /sbin/chkconfig
48 Requires:       pam >= 0.79.0
49 %{!?with_extra:Requires:        perl-base}
50 Requires:       rc-scripts
51 Provides:       ftpserver
52 Obsoletes:      anonftp
53 Obsoletes:      bftpd
54 Obsoletes:      ftpd-BSD
55 Obsoletes:      ftpserver
56 Obsoletes:      glftpd
57 Obsoletes:      heimdal-ftpd
58 Obsoletes:      krb5-ftpd
59 Obsoletes:      linux-ftpd
60 Obsoletes:      muddleftpd
61 Obsoletes:      proftpd
62 Obsoletes:      proftpd-common
63 Obsoletes:      proftpd-inetd
64 Obsoletes:      proftpd-standalone
65 Obsoletes:      troll-ftpd
66 Obsoletes:      vsftpd
67 Obsoletes:      wu-ftpd
68 Conflicts:      man-pages < 1.51
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/ftpd
72 %define         _ftpdir         /home/services/ftp
73 %define         schemadir       /usr/share/openldap/schema
74
75 %description
76 Pure-FTPd is a fast, production-quality, standard-comformant FTP
77 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
78 has no known security flaw, it is really trivial to set up and it is
79 especially designed for modern Linux kernels (setfsuid, sendfile,
80 capabilities) . Features include PAM support, IPv6, chroot()ed home
81 directories, virtual domains, built-in LS, anti-warez system, bounded
82 ports for passive downloads...
83
84 %description -l pl.UTF-8
85 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
86 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
87 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
88 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
89 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
90 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
91 LS, system anty-warezowy, ograniczanie portów dla pasywnych
92 połączeń...
93
94 %package -n openldap-schema-pureftpd
95 Summary:        Pure-FTPd LDAP schema
96 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
97 Group:          Networking/Daemons
98 Requires(post,postun):  sed >= 4.0
99 Requires:       openldap-servers
100 Requires:       sed >= 4.0 
101
102 %description -n openldap-schema-pureftpd
103 This package contains an Pure-FTPd openldap schema.
104
105 %description -n openldap-schema-pureftpd -l pl.UTF-8
106 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
107
108 %prep
109 %setup -q -a 5
110 %patch0 -p0
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114 %patch6 -p0
115 %{?with_extra:%patch1 -p1}
116 %{?with_extra:%patch2 -p1}
117
118 %build
119 # drop --without-cork for Th
120 %configure \
121         --without-cork \
122         --with-boring \
123         --with-altlog \
124         --with-cookie \
125         --with-diraliases \
126         --with-extauth \
127         --with-ftpwho \
128         --with-language=english \
129         --with-largefile \
130         %{!?with_cap:--without-capabilities} \
131         %{?with_ldap:--with-ldap} \
132         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
133         --with-pam \
134         --with-peruserlimits \
135         %{?with_pgsql:--with-pgsql} \
136         --with-privsep \
137         %{?with_puredb:--with-puredb} \
138         --with-quotas \
139         --with-ratios \
140         --with-throttling \
141         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
142         --with-uploadscript \
143         --with-virtualchroot \
144         --with-virtualhosts
145
146 %if %{with extra}
147 cd pure-config
148 %{__aclocal}
149 %{__autoconf}
150 %{__autoheader}
151 %{__automake}
152 %configure
153 %{__make}
154 %endif
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
159         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
165 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
166 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
167
168 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
169 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
170 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
171 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
172 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
173 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
174
175 touch $RPM_BUILD_ROOT%{_sysconfdir}/ftpusers
176
177 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
178
179 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
180 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
181
182 %if %{with extra}
183 %{__make} -C pure-config install \
184         DESTDIR=$RPM_BUILD_ROOT
185 %endif
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post
191 /sbin/chkconfig --add %{name}
192 %service %{name} restart "PureFTPD daemon"
193
194 %preun
195 if [ "$1" = "0" ]; then
196         %service %{name} stop
197         /sbin/chkconfig --del %{name}
198 fi
199
200 %post -n openldap-schema-pureftpd
201 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
202 %service -q ldap restart
203
204 %postun -n openldap-schema-pureftpd
205 if [ "$1" = "0" ]; then
206         %openldap_schema_unregister %{schemadir}/pureftpd.schema
207         %service -q ldap restart
208 fi
209
210
211 %files
212 %defattr(644,root,root,755)
213 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
214 %attr(755,root,root) %{_bindir}/*
215 %attr(755,root,root) %{_sbindir}/*
216 %attr(754,root,root) /etc/rc.d/init.d/%{name}
217 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
218 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
219 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
220 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
221 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
222 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
223 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
224 %attr(710,root,ftp) %dir %{_sysconfdir}
225 %dir %{_sysconfdir}/vhosts
226 %dir %{_sysconfdir}/pure-ftpd
227 %dir %{_ftpdir}
228 %{_mandir}/man?/*
229 %lang(ja) %{_mandir}/ja/man5/ftpusers*
230 %lang(pl) %{_mandir}/pl/man5/ftpusers*
231 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
232 %lang(ru) %{_mandir}/ru/man5/ftpusers*
233
234 %files -n openldap-schema-pureftpd
235 %defattr(644,root,root,755)
236 %{schemadir}/pureftpd.schema
This page took 0.048035 seconds and 3 git commands to generate.