]> git.pld-linux.org Git - packages/protobuf.git/blob - protobuf.spec
- add -lite subpackage, move compiler related lib to base pkg; update BR
[packages/protobuf.git] / protobuf.spec
1 # TODO:
2 #       - add bindings for java and python
3 #       - add vim syntax package
4
5 Summary:        Protocol Buffers - Google's data interchange format
6 Summary(pl.UTF-8):      Protocol Buffers - format wymiany danych Google
7 Name:           protobuf
8 Version:        2.4.1
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
13 # Source0-md5:  79a8072490f863139f32488c3ff84d39
14 URL:            http://code.google.com/p/protobuf/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 BuildRequires:  zlib-devel
21 Requires:       %{name}-libs = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Protocol Buffers are a way of encoding structured data in an efficient
26 yet extensible format. Google uses Protocol Buffers for almost all of
27 its internal RPC protocols and file formats.
28
29 Protocol buffers are a flexible, efficient, automated mechanism for
30 serializing structured data – think XML, but smaller, faster, and
31 simpler. You define how you want your data to be structured once, then
32 you can use special generated source code to easily write and read
33 your structured data to and from a variety of data streams and using a
34 variety of languages. You can even update your data structure without
35 breaking deployed programs that are compiled against the "old" format.
36
37 This package contains Protocol Buffers compiler for all programming
38 languages
39
40 %description -l pl.UTF-8
41 Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
42 serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
43 szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
44 a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
45 zapisu i odczytu danych strukturalnych do i z różnych strumieni
46 danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
47 danych bez psucia programów skompilowanych w oparciu o "stary" format.
48
49 Google używa buforów protokołowych (Protocol Buffers) do prawie
50 wszystkich wewnętrznych protokołów RPC i formatów plików.
51
52 %package libs
53 Summary:        protobuf libraries
54 Summary(pl.UTF-8):      Biblioteki protobuf
55 Group:          Libraries
56
57 %description libs
58 protobuf libraries.
59
60 %description libs -l pl.UTF-8
61 Biblioteki protobuf.
62
63 %package lite
64 Summary:        Protocol Buffers LITE_RUNTIME libraries
65 Group:          Development/Libraries
66
67 %description lite
68 Protocol Buffers built with optimize_for = LITE_RUNTIME.
69
70 The "optimize_for = LITE_RUNTIME" option causes the compiler to
71 generate code which only depends libprotobuf-lite, which is much
72 smaller than libprotobuf but lacks descriptors, reflection, and some
73 other features.
74
75 %package devel
76 Summary:        Protocol Buffers C++ headers and libraries
77 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek protobuf
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       %{name}-libs = %{version}-%{release}
81 Requires:       libstdc++-devel
82
83 %description devel
84 This package contains Protocol Buffers compiler for all languages and
85 C++ headers and libraries
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe bibliotek protobuf.
89
90 %package static
91 Summary:        Static development files for protobuf
92 Summary(pl.UTF-8):      Statyczne biblioteki protobuf
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static libraries for Protocol Buffers
98
99 %description static -l pl.UTF-8
100 Statyczne biblioteki protobuf.
101
102 %prep
103 %setup -q
104
105 %build
106 %configure
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112
113 %{__make} install \
114         STRIPBINARIES=no \
115         INSTALL="install -p"  \
116         CPPROG="cp -p" \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %post   libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %post   lite -p /sbin/ldconfig
131 %postun lite -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc CHANGES.txt CONTRIBUTORS.txt README.txt
136 %attr(755,root,root) %{_bindir}/protoc
137 %attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libprotoc.so.7
139
140 %files libs
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.7
144
145 %files lite
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.7
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so
153 %attr(755,root,root) %{_libdir}/libprotobuf.so
154 %attr(755,root,root) %{_libdir}/libprotoc.so
155 %{_libdir}/libprotobuf-lite.la
156 %{_libdir}/libprotobuf.la
157 %{_libdir}/libprotoc.la
158 %{_includedir}/google
159 %{_examplesdir}/%{name}-%{version}
160 %{_pkgconfigdir}/protobuf-lite.pc
161 %{_pkgconfigdir}/protobuf.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libprotobuf-lite.a
166 %{_libdir}/libprotobuf.a
167 %{_libdir}/libprotoc.a
This page took 0.060485 seconds and 4 git commands to generate.