]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- fix format string warnings
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v11-2.9.1
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.9.4
37 Release:        5
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  230bc3c00c051946eccd850058d75f6c
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  a54a21428de5eeae91b4bb670976e37a
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Source12:       %{name}.service
59 Patch0:         %{name}-config.patch
60 Patch1:         %{name}-conf_msg.patch
61 Patch2:         %{name}-dynamicmaps.patch
62 Patch3:         %{name}-master.cf_cyrus.patch
63 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
64 Patch4:         %{name}-header_if_reject.patch
65 Patch5:         %{name}-ident.patch
66 Patch6:         %{name}-lib64.patch
67 Patch7:         %{name}-conf.patch
68 Patch8:         %{name}-dictname.patch
69 Patch9:         %{name}-make-jN.patch
70 Patch10:        %{name}-link.patch
71 Patch11:        %{name}-scache_clnt.patch
72 Patch12:        format-security.patch
73 URL:            http://www.postfix.org/
74 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
75 BuildRequires:  db-devel
76 # getifaddrs() with IPv6 support
77 BuildRequires:  glibc-devel >= 6:2.3.4
78 %{?with_mysql:BuildRequires:    mysql-devel}
79 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
80 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
81 BuildRequires:  pcre-devel
82 BuildRequires:  perl-base
83 %{?with_pgsql:BuildRequires:    postgresql-devel}
84 BuildRequires:  rpm >= 4.4.9-56
85 BuildRequires:  rpmbuild(macros) >= 1.644
86 BuildRequires:  sed >= 4.0
87 %{?with_sqlite:BuildRequires:   sqlite3-devel}
88 %{?with_cdb:BuildRequires:      tinycdb-devel}
89 %{?with_mysql:BuildRequires:    zlib-devel}
90 Requires(post): /bin/hostname
91 Requires(post,postun):  /sbin/ldconfig
92 Requires(post,preun):   /sbin/chkconfig
93 Requires(postun):       /usr/sbin/groupdel
94 Requires(postun):       /usr/sbin/userdel
95 Requires(pre):  /bin/id
96 Requires(pre):  /usr/bin/getgid
97 Requires(pre):  /usr/sbin/groupadd
98 Requires(pre):  /usr/sbin/useradd
99 Requires:       /sbin/chkconfig
100 Requires:       diffutils
101 Requires:       findutils
102 Requires:       rc-scripts
103 Requires:       sed
104 %{?with_cdb:Requires:tinycdb}
105 Requires:       systemd-units >= 38
106 Suggests:       cyrus-sasl-saslauthd
107 Provides:       group(postfix)
108 Provides:       smtpdaemon
109 Provides:       user(postfix)
110 Obsoletes:      smtpdaemon
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %description
114 Postfix is attempt to provide an alternative to the widely-used
115 Sendmail program. Postfix attempts to be fast, easy to administer, and
116 hopefully secure, while at the same time being sendmail compatible
117 enough to not upset your users. This version has IPv6 support.
118
119 %description -l es.UTF-8
120 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
121 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
122
123 %description -l fr.UTF-8
124 Postfix (voir http://www.postfix.org/) se veut une alternative à
125 sendmail, responsable de l'acheminement de 70% des courriers
126 électroniques sur Internet. IBM en a suppotré le développement, mais
127 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
128 plus grand nombre de systèmes possible. Dans cette optique, il a été
129 écrit pour être totalement sous le contrôle de l'utilisateur.
130
131 %description -l it.UTF-8
132 Postfix (http://www.postfix.org/) e' un'alternativa al programma
133 sendmail utilizzato per la gestione del 70 per cento della posta
134 Internet.
135
136 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
137 evoluzione.
138
139 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
140 quale troverete le indicazioni per una corretta installazione e
141 configurazione di questo programma.
142
143 %description -l pl.UTF-8
144 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
145 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
146 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
147 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
148
149 %description -l pt_BR.UTF-8
150 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
151 você deseja um servidor SMTP *rápido*, instale este pacote.
152
153 %description -l sk.UTF-8
154 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
155 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
156 elektronickej pošty doručenej na Internete.
157
158 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
159 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
160 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
161 môže vyvíjať podľa jeho používateľov.
162
163 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
164 popísané kroky potrebné pred a po inštalácii Postfixu.
165
166 %package devel
167 Summary:        Postfix loadable modules development package
168 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
169 Group:          Development/Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description devel
173 Header files to build additional map types for Postfix.
174
175 %description devel -l pl.UTF-8
176 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
177
178 %package dict-ldap
179 Summary:        LDAP map support for Postfix
180 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
181 Group:          Networking/Daemons/SMTP
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183 Requires:       openldap >= 2.3.6
184
185 %description dict-ldap
186 This package provides support for LDAP maps in Postfix.
187
188 %description dict-ldap -l pl.UTF-8
189 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
190
191 %package dict-mysql
192 Summary:        MySQL map support for Postfix
193 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
194 Group:          Networking/Daemons/SMTP
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196
197 %description dict-mysql
198 This package provides support for MySQL maps in Postfix.
199
200 %description dict-mysql -l pl.UTF-8
201 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
202
203 %package dict-pcre
204 Summary:        PCRE map support for Postfix
205 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
206 Group:          Networking/Daemons/SMTP
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208
209 %description dict-pcre
210 This package provides support for PCRE maps in Postfix.
211
212 %description dict-pcre -l pl.UTF-8
213 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
214
215 %package dict-pgsql
216 Summary:        PostgreSQL map support for Postfix
217 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
218 Group:          Networking/Daemons/SMTP
219 Requires:       %{name} = %{epoch}:%{version}-%{release}
220
221 %description dict-pgsql
222 This package provides support for PostgreSQL maps in Postfix.
223
224 %description dict-pgsql -l pl.UTF-8
225 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
226
227 %package dict-sqlite
228 Summary:        SQLite map support for Postfix
229 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
230 Group:          Networking/Daemons/SMTP
231 Requires:       %{name} = %{epoch}:%{version}-%{release}
232
233 %description dict-sqlite
234 This package provides support for SQLite maps in Postfix.
235
236 %description dict-sqlite -l pl.UTF-8
237 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
238
239 %package qshape
240 Summary:        qshape - Print Postfix queue domain and age distribution
241 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
242 Group:          Networking/Daemons/SMTP
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244
245 %description qshape
246 The qshape program helps the administrator understand the Postfix
247 queue message distribution in time and by sender domain or recipient
248 domain. The program needs read access to the queue directories and
249 queue files, so it must run as the superuser or the mail_owner
250 specified in main.cf (typically postfix).
251
252 %description qshape -l pl.UTF-8
253 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
254 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
255 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
256 kolejki, więc musi być uruchamiany przez superużytkownika lub
257 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
258 postfix).
259
260 %package -n monit-rc-%{name}
261 Summary:        monit support for Postfix
262 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
263 Group:          Applications/System
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265 Requires:       monit
266
267 %description -n monit-rc-%{name}
268 monitrc file for monitoring Postfix.
269
270 %description -n monit-rc-%{name} -l pl.UTF-8
271 Plik monitrc do monitorowania serwera Postfix.
272
273 %prep
274 %setup -q
275 %if %{with vda}
276 cat %{SOURCE7} | %{__patch} -p1 -s
277 cat %{SOURCE11} | %{__patch} -p1 -s
278 %endif
279
280 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
281
282 %patch0 -p1
283 %patch1 -p0
284 %patch2 -p1
285 %patch3 -p1
286 %{?with_hir:%patch4 -p0}
287 %patch5 -p1
288 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
289 %if "%{_lib}" == "lib64"
290 %patch6 -p1
291 %endif
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch10 -p1
296 %patch11 -p1
297 %patch12 -p1
298
299 %if %{with tcp}
300 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
301 %endif
302
303 %build
304 %{__make} -f Makefile.init makefiles
305 %{__make} tidy
306 CC="%{__cc}"
307 export CC
308 %{__make} \
309         DEBUG="" \
310         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
311         %{!?with_ldap:LDAPSO=""} \
312         %{!?with_mysql:MYSQLSO=""} \
313         %{!?with_pgsql:PGSQLSO=""} \
314         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
315         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
316
317 %install
318 rm -rf $RPM_BUILD_ROOT
319 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
320         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
321         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
322         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
323         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
324         $RPM_BUILD_ROOT%{_var}/lib/postfix \
325         $RPM_BUILD_ROOT%{systemdunitdir}
326
327 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
328
329 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
330 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
331 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
332 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
333 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
334 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
335         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
336
337 for f in dns global master util ; do
338         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
339         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
340 done
341 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
342 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
343
344 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
345
346 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
347 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
348 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
349 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
350 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
351 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
352 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
353 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
354 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
355 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
356 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
357 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
358
359 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
360 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
361 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
362
363 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
364         {aliases,access,canonical,relocated,transport,virtual}{,.db}
365
366 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
367
368 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
369
370 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
371 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
372
373 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %pre
379 %groupadd -g 62 postfix
380 %groupadd -g 63 maildrop
381 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
382
383 %post
384 /sbin/ldconfig
385 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
386         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
387         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
388 fi
389 if [ "$1" = "1" ]; then
390         # only on installation, not upgrade; set sane defaults
391         # postfix expects gethostname() to return FQDN, which is obviously wrong
392         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
393                 domain=$(/bin/hostname -d 2>/dev/null)
394                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
395                         postconf -e mydomain="$domain"
396         fi
397 else
398         %{_sbindir}/postfix upgrade-configuration
399 fi
400
401 %{_bindir}/newaliases
402 /sbin/chkconfig --add postfix
403 %service postfix restart "Postfix Daemon"
404 %systemd_post
405
406 %preun
407 if [ "$1" = "0" ]; then
408         %service postfix stop
409         /sbin/chkconfig --del postfix
410 fi
411 %systemd_preun
412
413 %postun
414 /sbin/ldconfig
415 if [ "$1" = "0" ]; then
416         %groupremove maildrop
417         %userremove postfix
418         %groupremove postfix
419 fi
420 %systemd_postun
421
422 %files
423 %defattr(644,root,root,755)
424 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
425 %doc README_FILES/*README
426 %doc examples/smtpd-policy
427 %dir %{_sysconfdir}/mail
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
430 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
431 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
432 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
433 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
434 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
435 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
436 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
440 #%ghost %{_sysconfdir}/mail/*.db
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
444 %{_sysconfdir}/mail/postfix-wrapper
445 %{_sysconfdir}/mail/postmulti-script
446 %attr(740,root,root) /etc/cron.daily/postfix
447 %attr(754,root,root) /etc/rc.d/init.d/postfix
448 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
449 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
450 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
451 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
452 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
453 %attr(755,root,root) %{_bindir}/mailq
454 %attr(755,root,root) %{_bindir}/newaliases
455 %attr(755,root,root) %{_bindir}/rmail
456 %attr(755,root,root) %{_sbindir}/s*
457 %attr(755,root,root) %{_sbindir}/postfix
458 %attr(755,root,root) %{_sbindir}/postalias
459 %attr(755,root,root) %{_sbindir}/postkick
460 %attr(755,root,root) %{_sbindir}/postl*
461 %attr(755,root,root) %{_sbindir}/postc*
462 %attr(755,root,root) %{_sbindir}/postmap
463 %attr(755,root,root) %{_sbindir}/postmulti
464 %attr(2755,root,maildrop) %{_sbindir}/postqueue
465 %attr(755,root,root) %{_sbindir}/postsuper
466 %attr(2755,root,maildrop) %{_sbindir}/postdrop
467 %attr(755,root,root) %{_sbindir}/qmqp-sink
468 %attr(755,root,root) %{_sbindir}/qmqp-source
469 %attr(755,root,root) /usr/lib/sendmail
470 %dir %{_libdir}/postfix
471 %attr(755,root,root) %{_libdir}/postfix/[!d]*
472 %attr(755,root,root) %{_libdir}/postfix/discard
473 %attr(755,root,root) %{_libdir}/postfix/dnsblog
474 %attr(755,root,root) %dir %{_var}/spool/postfix
475 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
476 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
477 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
478 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
479 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
480 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
481 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
482 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
483 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
484 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
485 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
486 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
487 %attr(700,postfix,root) %{_var}/lib/postfix
488 %{_mandir}/man1/mailq.1*
489 %{_mandir}/man1/newaliases.1*
490 %{_mandir}/man1/post*.1*
491 %{_mandir}/man1/qmqp-*.1*
492 %{_mandir}/man1/sendmail.1*
493 %{_mandir}/man1/smtp-*.1*
494 %{_mandir}/man5/access.5*
495 %{_mandir}/man5/aliases.5*
496 %{_mandir}/man5/body_checks.5*
497 %{_mandir}/man5/bounce.5*
498 %{_mandir}/man5/canonical.5*
499 %{_mandir}/man5/cidr_table.5*
500 %{_mandir}/man5/generic.5*
501 %{_mandir}/man5/header_checks.5*
502 %{_mandir}/man5/master.5*
503 %{_mandir}/man5/memcache_table.5*
504 %{_mandir}/man5/nisplus_table.5*
505 %{_mandir}/man5/postconf.5*
506 %{_mandir}/man5/postfix-wrapper.5*
507 %{_mandir}/man5/regexp_table.5*
508 %{_mandir}/man5/relocated.5*
509 %{_mandir}/man5/tcp_table.5*
510 %{_mandir}/man5/transport.5*
511 %{_mandir}/man5/virtual.5*
512 %{_mandir}/man8/*.8*
513 %{systemdunitdir}/%{name}.service
514
515 %files devel
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/libpostfix-*.so
518 %{_includedir}/postfix
519
520 %if %{with ldap}
521 %files dict-ldap
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
524 %{_mandir}/man5/ldap_table.5*
525 %endif
526
527 %if %{with mysql}
528 %files dict-mysql
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
531 %{_mandir}/man5/mysql_table.5*
532 %endif
533
534 %files dict-pcre
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
537 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
538 %{_mandir}/man5/pcre_table.5*
539
540 %if %{with pgsql}
541 %files dict-pgsql
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
544 %{_mandir}/man5/pgsql_table.5*
545 %endif
546
547 %if %{with sqlite}
548 %files dict-sqlite
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
551 %{_mandir}/man5/sqlite_table.5*
552 %endif
553
554 %files qshape
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/qshape
557 %{_mandir}/man1/qshape.1*
558
559 %files -n monit-rc-%{name}
560 %defattr(644,root,root,755)
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.111831 seconds and 4 git commands to generate.