]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- use macros in %{pre,post}{,un}
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:    
3 # --without sasl - build wihtout SMTP AUTH support
4 # --without ldap - build without LDAP support
5 # --without pcre - build without Perl Compatible Regular Expresion support
6 # --without ssl  - build without SSL/TLS support
7 # --with mysql - build with MySQL support
8 # --without ipv6  - build without IPv6 support
9 #
10 %define tls_ver 0.7.3-snap20010525-0.9.6a
11 Summary:        Postfix Mail Transport Agent
12 Summary(pl):    Serwer SMTP Postfix
13 Name:           postfix
14 Version:        20010525
15 Release:        0.1
16 Group:          Networking/Daemons
17 Group(de):      Netzwerkwesen/Server
18 Group(pl):      Sieciowe/Serwery
19 Copyright:      Distributable
20 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/snapshot-%{version}.tar.gz
21 Source1:        %{name}.aliases
22 Source2:        %{name}.cron
23 Source3:        %{name}.init
24 Source5:        %{name}.sysconfig
25 Source6:        ftp://ftp.aet.tu-cottbus.de/pub/pfixtls/pfixtls-%{tls_ver}.tar.gz
26 Patch0:         %{name}-config.patch
27 Patch1:         %{name}-pl.patch
28 # ftp://ftp.aet.tu-cottbus.de/pub/pfixtls
29 #Patch2:                %{name}-ssl.patch
30 Patch3:         %{name}-ipv6.patch.gz
31 Patch5:         %{name}-conf_msg.patch
32 URL:            http://www.postfix.org/
33 Provides:       smtpdaemon
34 Prereq:         rc-scripts
35 %{!?_without_ldap:BuildRequires:        openldap-devel >= 2.0.0}
36 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
37 %{!?_without_pcre:BuildRequires:        pcre-devel}
38 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel}
39 %{!?_without_ipv6:BuildRequires:        libinet6}
40 BuildRequires:  db3-devel
41 BuildRequires:  grep
42 Prereq:         /sbin/chkconfig
43 Prereq:         /usr/sbin/useradd
44 Prereq:         /usr/sbin/groupadd
45 Prereq:         /usr/sbin/userdel
46 Prereq:         /usr/sbin/groupdel
47 Prereq:         /usr/bin/getgid
48 Prereq:         /bin/id
49 Prereq:         /bin/hostname
50 %{!?_without_ldap:Prereq:       openldap >= 2.0.0}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52 Obsoletes:      smtpdaemon
53 Obsoletes:      exim
54 Obsoletes:      sendmail
55 Obsoletes:      sendmail-cf
56 Obsoletes:      sendmail-doc
57
58 %define         _sysconfdir     /etc
59
60 %description
61 Postfix is attempt to provide an alternative to the widely-used
62 Sendmail program. Postfix attempts to be fast, easy to administer, and
63 hopefully secure, while at the same time being sendmail compatible
64 enough to not upset your users. This version have IPv6 support and
65 %{!?_without_ldap:no }LDAP support.
66
67 %description -l pl
68 Postfix jest prób± dostarczenia alternatywnego MTA w stosunku do
69 szeroko u¿ywanego sendmaila. Postfix w zamierzeniu ma byæ szybki,
70 ³atwy w administrowaniu, bezpieczny oraz ma byæ na tyle kompatybilny z
71 sendmailem by nie denerwowaæ Twoich u¿ytkowników. Ta wersja wspiera
72 IPv6%{!?_without_ldap: oraz LDAP}.
73
74 %prep
75 %setup -q -n snapshot-%{version} -a 6 
76 %patch0 -p1
77 %patch1 -p1
78 patch -p1 -s <pfixtls-%{tls_ver}/pfixtls.diff 
79 %patch5 -p1 
80 %{!?_without_ipv6:%patch3 -p1 }
81
82 %build
83 %{__make} -f Makefile.init makefiles
84 %{__make} tidy
85 %{__make} DEBUG="" OPT="%{rpmcflags}" \
86         CCARGS="%{!?_without_ldap:-DHAS_LDAP} %{!?_without_pcre:-DHAS_PCRE} %{!?_without_sasl:-DUSE_SASL_AUTH} %{?_with_mysql:-DHAS_MYSQL -I%{_includedir}/mysql} %{!?_without_ssl:-DHAS_SSL -I%{_includedir}/openssl}" \
87         AUXLIBS="%{!?_without_ldap:-llber -lldap} -lnsl -ldb -lresolv %{!?_without_pcre:-lpcre} %{!?_without_sasl:-lsasl} %{?_with_mysql:-lmysqlclient} %{!?_without_ssl:-lssl -lcrypto}"
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{mail,cron.daily,rc.d/init.d,sysconfig} \
92            $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,%{_mandir}/man{1,5,8}} \
93            $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
94            pfixtls
95
96 rm -f {html,man}/Makefile.in conf/{LICENSE,main.cf.default}
97
98 install -d sample-conf; mv -f conf/sample* sample-conf/ || :
99
100 install bin/* $RPM_BUILD_ROOT%{_sbindir}
101 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
102 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
103
104 (cd man; tar cf - .) | (cd $RPM_BUILD_ROOT%{_mandir}; tar xf -)
105
106 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
107 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
108 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
109 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/postfix
110
111 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
112 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
113 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_libdir}/sendmail
114
115 mv -f  $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-sgid \
116         $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script
117
118 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-{diff,nosgid}
119
120 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
121         {aliases,access,canonical,relocated,transport,virtual}{,.db}
122
123 gzip -9nf *README HISTORY COMPATIBILITY LICENSE RELEASE_NOTES \
124            RESTRICTION_CLASS TODO
125
126 touch $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
127
128 %pre
129 GID=62; %groupadd
130 UID=62; HOMEDIR=/var/spool/postfix; COMMENT="Postfix User"; %useradd
131 GROUP=maildrop; GID=63; %groupadd
132
133 %post
134 if ! grep -q "^postmaster:" /etc/mail/aliases; then
135         echo "Adding Entry for postmaster in /etc/mail/aliases" >&2
136         echo "postmaster:       root" >>/etc/mail/aliases
137 fi
138 if ! grep -q "^myhostname" /etc/mail/main.cf; then
139         postconf -e myhostname=`/bin/hostname -f`
140 fi
141
142 newaliases
143 DESC="postfix daemon"; %chkconfig_add
144
145 %preun
146 %chkconfig_del
147
148 %postun
149 %userdel
150 %groupdel
151 GROUP=maildrop; %groupdel
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc html *README.gz
159 %doc {HISTORY,COMPATIBILITY,LICENSE,RELEASE_NOTES,RESTRICTION_CLASS,TODO}.gz
160 %doc sample-conf
161 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/access
162 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/aliases
163 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/canonical
164 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/relocated
165 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/transport
166 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/virtual
167 #%ghost %{_sysconfdir}/mail/*.db
168 %dir %{_sysconfdir}/mail
169 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/main.cf
170 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/master.cf
171 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/postfix-script
172 %attr(740,root,root) /etc//cron.daily/postfix
173 %attr(754,root,root) /etc/rc.d/init.d/postfix
174 %attr(640,root,root) %config(noreplace) /etc/sysconfig/postfix
175 %attr(755,root,root) %{_bindir}/*
176 %attr(755,root,root) %{_sbindir}/s*
177 %attr(755,root,root) %{_sbindir}/post*i*
178 %attr(755,root,root) %{_sbindir}/postl*
179 %attr(755,root,root) %{_sbindir}/postc*
180 %attr(755,root,root) %{_sbindir}/postmap
181 %attr(755,root,root) %{_sbindir}/postsuper
182 %attr(2755,root,maildrop) %{_sbindir}/postdrop
183 %attr(755,root,root) %{_libdir}/sendmail
184 %attr(755,root,root) %{_libdir}/postfix
185 %attr(755,root,root) %dir %{_var}/spool/postfix
186 %attr(700, postfix,root) %dir %{_var}/spool/postfix/active
187 %attr(700, postfix,root) %dir %{_var}/spool/postfix/bounce
188 %attr(700, postfix,root) %dir %{_var}/spool/postfix/corrupt
189 %attr(700, postfix,root) %dir %{_var}/spool/postfix/defer
190 %attr(700, postfix,root) %dir %{_var}/spool/postfix/deferred
191 %attr(700, postfix,root) %dir %{_var}/spool/postfix/incoming
192 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
193 %attr(755, postfix,root) %dir %{_var}/spool/postfix/pid
194 %attr(700, postfix,root) %dir %{_var}/spool/postfix/private
195 %attr(755, postfix,root) %dir %{_var}/spool/postfix/public
196 %attr(700, postfix,root) %dir %{_var}/spool/postfix/saved
197 %attr(644, postfix,root) %{_var}/spool/postfix/.nofinger
198 %{_mandir}/man*/*
This page took 0.055606 seconds and 4 git commands to generate.