]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- 64-bit long long support in vbuf_print()
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v13-2.10.0
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.11.8
37 Release:        1
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  cbc473f2aaf3d78f500287f370c91324
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  01e1b031d79b85f3cb67d98ceddd775d
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Source12:       %{name}.service
59 Patch0:         %{name}-config.patch
60 Patch1:         %{name}-conf_msg.patch
61 Patch2:         %{name}-dynamicmaps.patch
62 Patch3:         %{name}-master.cf_cyrus.patch
63 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
64 Patch4:         %{name}-header_if_reject.patch
65 Patch5:         %{name}-ident.patch
66 Patch6:         %{name}-lib64.patch
67 Patch7:         %{name}-conf.patch
68 Patch8:         %{name}-dictname.patch
69 Patch9:         %{name}-make-jN.patch
70 Patch10:        %{name}-link.patch
71 Patch11:        %{name}-scache_clnt.patch
72 Patch12:        format-security.patch
73 Patch13:        %{name}-no_cdb.patch
74 Patch14:        %{name}-vbuf_print.patch
75 URL:            http://www.postfix.org/
76 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
77 BuildRequires:  db-devel
78 # getifaddrs() with IPv6 support
79 BuildRequires:  glibc-devel >= 6:2.3.4
80 %{?with_mysql:BuildRequires:    mysql-devel}
81 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
82 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
83 BuildRequires:  pcre-devel
84 BuildRequires:  perl-base
85 %{?with_pgsql:BuildRequires:    postgresql-devel}
86 BuildRequires:  rpm >= 4.4.9-56
87 BuildRequires:  rpmbuild(macros) >= 1.644
88 BuildRequires:  sed >= 4.0
89 %{?with_sqlite:BuildRequires:   sqlite3-devel}
90 %{?with_cdb:BuildRequires:      tinycdb-devel}
91 %{?with_mysql:BuildRequires:    zlib-devel}
92 Requires(post): /bin/hostname
93 Requires(post,postun):  /sbin/ldconfig
94 Requires(post,preun):   /sbin/chkconfig
95 Requires(postun):       /usr/sbin/groupdel
96 Requires(postun):       /usr/sbin/userdel
97 Requires(pre):  /bin/id
98 Requires(pre):  /usr/bin/getgid
99 Requires(pre):  /usr/sbin/groupadd
100 Requires(pre):  /usr/sbin/useradd
101 Requires:       /sbin/chkconfig
102 Requires:       diffutils
103 Requires:       findutils
104 Requires:       rc-scripts
105 Requires:       sed
106 %{?with_cdb:Requires:tinycdb}
107 Requires:       systemd-units >= 38
108 Suggests:       cyrus-sasl-saslauthd
109 Provides:       group(postfix)
110 Provides:       smtpdaemon
111 Provides:       user(postfix)
112 Obsoletes:      smtpdaemon
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %description
116 Postfix is attempt to provide an alternative to the widely-used
117 Sendmail program. Postfix attempts to be fast, easy to administer, and
118 hopefully secure, while at the same time being sendmail compatible
119 enough to not upset your users. This version has IPv6 support.
120
121 %description -l es.UTF-8
122 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
123 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
124
125 %description -l fr.UTF-8
126 Postfix (voir http://www.postfix.org/) se veut une alternative à
127 sendmail, responsable de l'acheminement de 70% des courriers
128 électroniques sur Internet. IBM en a suppotré le développement, mais
129 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
130 plus grand nombre de systèmes possible. Dans cette optique, il a été
131 écrit pour être totalement sous le contrôle de l'utilisateur.
132
133 %description -l it.UTF-8
134 Postfix (http://www.postfix.org/) e' un'alternativa al programma
135 sendmail utilizzato per la gestione del 70 per cento della posta
136 Internet.
137
138 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
139 evoluzione.
140
141 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
142 quale troverete le indicazioni per una corretta installazione e
143 configurazione di questo programma.
144
145 %description -l pl.UTF-8
146 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
147 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
148 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
149 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
150
151 %description -l pt_BR.UTF-8
152 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
153 você deseja um servidor SMTP *rápido*, instale este pacote.
154
155 %description -l sk.UTF-8
156 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
157 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
158 elektronickej pošty doručenej na Internete.
159
160 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
161 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
162 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
163 môže vyvíjať podľa jeho používateľov.
164
165 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
166 popísané kroky potrebné pred a po inštalácii Postfixu.
167
168 %package devel
169 Summary:        Postfix loadable modules development package
170 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
171 Group:          Development/Libraries
172 Requires:       %{name} = %{epoch}:%{version}-%{release}
173
174 %description devel
175 Header files to build additional map types for Postfix.
176
177 %description devel -l pl.UTF-8
178 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
179
180 %package dict-ldap
181 Summary:        LDAP map support for Postfix
182 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
183 Group:          Networking/Daemons/SMTP
184 Requires:       %{name} = %{epoch}:%{version}-%{release}
185 Requires:       openldap >= 2.3.6
186
187 %description dict-ldap
188 This package provides support for LDAP maps in Postfix.
189
190 %description dict-ldap -l pl.UTF-8
191 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
192
193 %package dict-mysql
194 Summary:        MySQL map support for Postfix
195 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
196 Group:          Networking/Daemons/SMTP
197 Requires:       %{name} = %{epoch}:%{version}-%{release}
198
199 %description dict-mysql
200 This package provides support for MySQL maps in Postfix.
201
202 %description dict-mysql -l pl.UTF-8
203 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
204
205 %package dict-pcre
206 Summary:        PCRE map support for Postfix
207 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
208 Group:          Networking/Daemons/SMTP
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210
211 %description dict-pcre
212 This package provides support for PCRE maps in Postfix.
213
214 %description dict-pcre -l pl.UTF-8
215 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
216
217 %package dict-pgsql
218 Summary:        PostgreSQL map support for Postfix
219 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
220 Group:          Networking/Daemons/SMTP
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222
223 %description dict-pgsql
224 This package provides support for PostgreSQL maps in Postfix.
225
226 %description dict-pgsql -l pl.UTF-8
227 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
228
229 %package dict-sqlite
230 Summary:        SQLite map support for Postfix
231 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
232 Group:          Networking/Daemons/SMTP
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234
235 %description dict-sqlite
236 This package provides support for SQLite maps in Postfix.
237
238 %description dict-sqlite -l pl.UTF-8
239 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
240
241 %package qshape
242 Summary:        qshape - Print Postfix queue domain and age distribution
243 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
244 Group:          Networking/Daemons/SMTP
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246
247 %description qshape
248 The qshape program helps the administrator understand the Postfix
249 queue message distribution in time and by sender domain or recipient
250 domain. The program needs read access to the queue directories and
251 queue files, so it must run as the superuser or the mail_owner
252 specified in main.cf (typically postfix).
253
254 %description qshape -l pl.UTF-8
255 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
256 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
257 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
258 kolejki, więc musi być uruchamiany przez superużytkownika lub
259 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
260 postfix).
261
262 %package -n monit-rc-%{name}
263 Summary:        monit support for Postfix
264 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
265 Group:          Applications/System
266 Requires:       %{name} = %{epoch}:%{version}-%{release}
267 Requires:       monit
268
269 %description -n monit-rc-%{name}
270 monitrc file for monitoring Postfix.
271
272 %description -n monit-rc-%{name} -l pl.UTF-8
273 Plik monitrc do monitorowania serwera Postfix.
274
275 %prep
276 %setup -q
277 %if %{with vda}
278 cat %{SOURCE7} | %{__patch} -p1 -s
279 cat %{SOURCE11} | %{__patch} -p1 -s
280 %endif
281
282 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
283
284 %patch0 -p1
285 %patch1 -p0
286 %patch2 -p1
287 %patch3 -p1
288 %{?with_hir:%patch4 -p0}
289 %patch5 -p1
290 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
291 %if "%{_lib}" == "lib64"
292 %patch6 -p1
293 %endif
294 %patch7 -p1
295 %patch8 -p1
296 %patch9 -p1
297 %patch10 -p1
298 %patch11 -p1
299 %if %{with vda}
300 %patch12 -p1
301 %endif
302 %{!?with_cdb:%patch13 -p1}
303 %patch14 -p1
304
305 %if %{with tcp}
306 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
307 %endif
308
309 %build
310 %{__make} -f Makefile.init makefiles
311 %{__make} tidy
312 export CC="%{__cc}"
313 %{__make} -j1 \
314         DEBUG="" \
315         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
316         %{!?with_ldap:LDAPSO=""} \
317         %{!?with_mysql:MYSQLSO=""} \
318         %{!?with_pgsql:PGSQLSO=""} \
319         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
320         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
321
322 %install
323 rm -rf $RPM_BUILD_ROOT
324 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
325         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
326         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
327         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
328         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
329         $RPM_BUILD_ROOT%{_var}/lib/postfix \
330         $RPM_BUILD_ROOT%{systemdunitdir}
331
332 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
333
334 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
335 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
336 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
337 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
338 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
339 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
340         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
341
342 for f in dns global master util ; do
343         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
344         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
345 done
346 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
347 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
348
349 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
350
351 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
352 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
353 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
354 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
355 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
356 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
357 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
358 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
359 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
360 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
361 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
362 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
363
364 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
365 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
366 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
367
368 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
369         {aliases,access,canonical,relocated,transport,virtual}{,.db}
370
371 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
372
373 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
374
375 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
376 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
377
378 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
379
380 %clean
381 rm -rf $RPM_BUILD_ROOT
382
383 %pre
384 %groupadd -g 62 postfix
385 %groupadd -g 63 maildrop
386 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
387
388 %post
389 /sbin/ldconfig
390 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
391         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
392         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
393 fi
394 if [ "$1" = "1" ]; then
395         # only on installation, not upgrade; set sane defaults
396         # postfix expects gethostname() to return FQDN, which is obviously wrong
397         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
398                 domain=$(/bin/hostname -d 2>/dev/null)
399                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
400                         postconf -e mydomain="$domain"
401         fi
402 else
403         %{_sbindir}/postfix upgrade-configuration
404 fi
405
406 %{_bindir}/newaliases
407 /sbin/chkconfig --add postfix
408 %service postfix restart "Postfix Daemon"
409 %systemd_post postfix.service
410
411 %preun
412 if [ "$1" = "0" ]; then
413         %service postfix stop
414         /sbin/chkconfig --del postfix
415 fi
416 %systemd_preun postfix.service
417
418 %postun
419 /sbin/ldconfig
420 if [ "$1" = "0" ]; then
421         %groupremove maildrop
422         %userremove postfix
423         %groupremove postfix
424 fi
425 %systemd_reload
426
427 %triggerpostun -- postfix < 2:2.9.4-4
428 %systemd_trigger postfix.service
429
430 %files
431 %defattr(644,root,root,755)
432 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
433 %doc README_FILES/*README
434 %doc examples/smtpd-policy
435 %dir %{_sysconfdir}/mail
436 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
439 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
440 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
443 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
448 #%ghost %{_sysconfdir}/mail/*.db
449 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
450 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
451 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
452 %{_sysconfdir}/mail/postfix-wrapper
453 %{_sysconfdir}/mail/postmulti-script
454 %attr(740,root,root) /etc/cron.daily/postfix
455 %attr(754,root,root) /etc/rc.d/init.d/postfix
456 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
457 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
458 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
459 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
460 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
461 %attr(755,root,root) %{_bindir}/mailq
462 %attr(755,root,root) %{_bindir}/newaliases
463 %attr(755,root,root) %{_bindir}/rmail
464 %attr(755,root,root) %{_sbindir}/s*
465 %attr(755,root,root) %{_sbindir}/postfix
466 %attr(755,root,root) %{_sbindir}/postalias
467 %attr(755,root,root) %{_sbindir}/postkick
468 %attr(755,root,root) %{_sbindir}/postl*
469 %attr(755,root,root) %{_sbindir}/postc*
470 %attr(755,root,root) %{_sbindir}/postmap
471 %attr(755,root,root) %{_sbindir}/postmulti
472 %attr(2755,root,maildrop) %{_sbindir}/postqueue
473 %attr(755,root,root) %{_sbindir}/postsuper
474 %attr(755,root,root) %{_sbindir}/posttls-finger
475 %attr(2755,root,maildrop) %{_sbindir}/postdrop
476 %attr(755,root,root) %{_sbindir}/qmqp-sink
477 %attr(755,root,root) %{_sbindir}/qmqp-source
478 %attr(755,root,root) /usr/lib/sendmail
479 %dir %{_libdir}/postfix
480 %attr(755,root,root) %{_libdir}/postfix/[!d]*
481 %attr(755,root,root) %{_libdir}/postfix/discard
482 %attr(755,root,root) %{_libdir}/postfix/dnsblog
483 %attr(755,root,root) %dir %{_var}/spool/postfix
484 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
485 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
486 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
487 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
488 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
489 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
490 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
491 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
492 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
493 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
494 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
495 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
496 %attr(700,postfix,root) %{_var}/lib/postfix
497 %{_mandir}/man1/mailq.1*
498 %{_mandir}/man1/newaliases.1*
499 %{_mandir}/man1/post*.1*
500 %{_mandir}/man1/qmqp-*.1*
501 %{_mandir}/man1/sendmail.1*
502 %{_mandir}/man1/smtp-*.1*
503 %{_mandir}/man5/access.5*
504 %{_mandir}/man5/aliases.5*
505 %{_mandir}/man5/body_checks.5*
506 %{_mandir}/man5/bounce.5*
507 %{_mandir}/man5/canonical.5*
508 %{_mandir}/man5/cidr_table.5*
509 %{_mandir}/man5/generic.5*
510 %{_mandir}/man5/header_checks.5*
511 %{_mandir}/man5/lmdb_table.5*
512 %{_mandir}/man5/master.5*
513 %{_mandir}/man5/memcache_table.5*
514 %{_mandir}/man5/nisplus_table.5*
515 %{_mandir}/man5/postconf.5*
516 %{_mandir}/man5/postfix-wrapper.5*
517 %{_mandir}/man5/regexp_table.5*
518 %{_mandir}/man5/relocated.5*
519 %{_mandir}/man5/socketmap_table.5*
520 %{_mandir}/man5/tcp_table.5*
521 %{_mandir}/man5/transport.5*
522 %{_mandir}/man5/virtual.5*
523 %{_mandir}/man8/*.8*
524 %{systemdunitdir}/%{name}.service
525
526 %files devel
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/libpostfix-*.so
529 %{_includedir}/postfix
530
531 %if %{with ldap}
532 %files dict-ldap
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
535 %{_mandir}/man5/ldap_table.5*
536 %endif
537
538 %if %{with mysql}
539 %files dict-mysql
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
542 %{_mandir}/man5/mysql_table.5*
543 %endif
544
545 %files dict-pcre
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
548 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
549 %{_mandir}/man5/pcre_table.5*
550
551 %if %{with pgsql}
552 %files dict-pgsql
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
555 %{_mandir}/man5/pgsql_table.5*
556 %endif
557
558 %if %{with sqlite}
559 %files dict-sqlite
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
562 %{_mandir}/man5/sqlite_table.5*
563 %endif
564
565 %files qshape
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_bindir}/qshape
568 %{_mandir}/man1/qshape.1*
569
570 %files -n monit-rc-%{name}
571 %defattr(644,root,root,755)
572 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.060723 seconds and 4 git commands to generate.