]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- up to 3.6.15
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # LDAP map module
4 %bcond_without  mysql   # MySQL map module
5 %bcond_without  pgsql   # PostgreSQL map module
6 %bcond_without  sqlite  # SQLite map module
7 %bcond_without  sasl    # SMTP AUTH support
8 %bcond_without  ssl     # SSL/TLS support
9 %bcond_without  cdb     # cdb map support
10 %bcond_without  lmdb    # lmdb map support
11 %bcond_with     vda     # VDA patch
12 %bcond_with     hir     # Beeth's header_if_reject patch
13 %bcond_with     tcp     # unofficial tcp: lookup table
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll   # epoll support for 2.6 kernels
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll   # epoll support (Linux >= 2.6)
22 %endif
23
24 %define         vda_ver v13-2.10.0
25 Summary:        Postfix Mail Transport Agent
26 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
27 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
29 Summary(pl.UTF-8):      Serwer SMTP Postfix
30 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
32 Name:           postfix
33 Version:        3.6.15
34 Release:        1
35 Epoch:          2
36 License:        IBM Public License or Eclipse Public License v2.0
37 Group:          Networking/Daemons/SMTP
38 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39 # Source0-md5:  88471ed95d8f779d16e5c77c000367d5
40 Source1:        %{name}.aliases
41 Source2:        %{name}.cron
42 Source3:        %{name}.init
43 Source4:        %{name}.sysconfig
44 Source5:        %{name}.sasl
45 Source6:        %{name}.pamd
46 Source7:        %{name}-vda.patch
47 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
49 Source8:        %{name}-bounce.cf.pl
50 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51 Source9:        %{name}-bounce.cf.de
52 Source10:       %{name}.monitrc
53 Source11:       %{name}-vda-bigquota.patch
54 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
56 Source12:       %{name}.service
57 Patch0:         %{name}-config.patch
58 Patch1:         %{name}-egrep.patch
59
60 Patch3:         %{name}-master.cf_cyrus.patch
61 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
62 Patch4:         %{name}-header_if_reject.patch
63
64 Patch7:         %{name}-conf.patch
65 Patch8:         %{name}-dictname.patch
66
67 Patch11:        %{name}-scache_clnt.patch
68 Patch12:        format-security.patch
69 Patch13:        glibc-2.34.patch
70 URL:            http://www.postfix.org/
71 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
72 BuildRequires:  db-devel
73 # getifaddrs() with IPv6 support
74 BuildRequires:  glibc-devel >= 6:2.3.4
75 BuildRequires:  libicu-devel
76 BuildRequires:  libnsl-devel
77 BuildRequires:  m4
78 %{?with_lmdb:BuildRequires:     lmdb-devel}
79 %{?with_mysql:BuildRequires:    mysql-devel}
80 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
81 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
82 BuildRequires:  pcre-devel
83 BuildRequires:  perl-base
84 %{?with_pgsql:BuildRequires:    postgresql-devel}
85 BuildRequires:  rpm >= 4.4.9-56
86 BuildRequires:  rpmbuild(macros) >= 1.644
87 BuildRequires:  sed >= 4.0
88 %{?with_sqlite:BuildRequires:   sqlite3-devel}
89 %{?with_cdb:BuildRequires:      tinycdb-devel}
90 %{?with_mysql:BuildRequires:    zlib-devel}
91 Requires(post): /bin/hostname
92 Requires(post,postun):  /sbin/ldconfig
93 Requires(post,preun):   /sbin/chkconfig
94 Requires(postun):       /usr/sbin/groupdel
95 Requires(postun):       /usr/sbin/userdel
96 Requires(pre):  /bin/id
97 Requires(pre):  /usr/bin/getgid
98 Requires(pre):  /usr/sbin/groupadd
99 Requires(pre):  /usr/sbin/useradd
100 Requires:       /sbin/chkconfig
101 Requires:       diffutils
102 Requires:       findutils
103 Requires:       rc-scripts
104 Requires:       sed
105 %{?with_cdb:Requires:tinycdb}
106 Requires:       systemd-units >= 38
107 Suggests:       cyrus-sasl-saslauthd
108 Provides:       group(postfix)
109 Provides:       smtpdaemon
110 Provides:       user(postfix)
111 Obsoletes:      smtpdaemon
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %description
115 Postfix is attempt to provide an alternative to the widely-used
116 Sendmail program. Postfix attempts to be fast, easy to administer, and
117 hopefully secure, while at the same time being sendmail compatible
118 enough to not upset your users. This version has IPv6 support.
119
120 %description -l es.UTF-8
121 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
122 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
123
124 %description -l fr.UTF-8
125 Postfix (voir http://www.postfix.org/) se veut une alternative à
126 sendmail, responsable de l'acheminement de 70% des courriers
127 électroniques sur Internet. IBM en a suppotré le développement, mais
128 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
129 plus grand nombre de systèmes possible. Dans cette optique, il a été
130 écrit pour être totalement sous le contrôle de l'utilisateur.
131
132 %description -l it.UTF-8
133 Postfix (http://www.postfix.org/) e' un'alternativa al programma
134 sendmail utilizzato per la gestione del 70 per cento della posta
135 Internet.
136
137 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
138 evoluzione.
139
140 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
141 quale troverete le indicazioni per una corretta installazione e
142 configurazione di questo programma.
143
144 %description -l pl.UTF-8
145 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
146 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
147 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
148 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
149
150 %description -l pt_BR.UTF-8
151 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
152 você deseja um servidor SMTP *rápido*, instale este pacote.
153
154 %description -l sk.UTF-8
155 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
156 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
157 elektronickej pošty doručenej na Internete.
158
159 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
160 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
161 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
162 môže vyvíjať podľa jeho používateľov.
163
164 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
165 popísané kroky potrebné pred a po inštalácii Postfixu.
166
167 %package devel
168 Summary:        Postfix loadable modules development package
169 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
170 Group:          Development/Libraries
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172
173 %description devel
174 Header files to build additional map types for Postfix.
175
176 %description devel -l pl.UTF-8
177 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
178
179 %package dict-ldap
180 Summary:        LDAP map support for Postfix
181 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
182 Group:          Networking/Daemons/SMTP
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184 Requires:       openldap >= 2.3.6
185
186 %description dict-ldap
187 This package provides support for LDAP maps in Postfix.
188
189 %description dict-ldap -l pl.UTF-8
190 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
191
192 %package dict-mysql
193 Summary:        MySQL map support for Postfix
194 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
195 Group:          Networking/Daemons/SMTP
196 Requires:       %{name} = %{epoch}:%{version}-%{release}
197
198 %description dict-mysql
199 This package provides support for MySQL maps in Postfix.
200
201 %description dict-mysql -l pl.UTF-8
202 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
203
204 %package dict-pcre
205 Summary:        PCRE map support for Postfix
206 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
207 Group:          Networking/Daemons/SMTP
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209
210 %description dict-pcre
211 This package provides support for PCRE maps in Postfix.
212
213 %description dict-pcre -l pl.UTF-8
214 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
215
216 %package dict-pgsql
217 Summary:        PostgreSQL map support for Postfix
218 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
219 Group:          Networking/Daemons/SMTP
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221
222 %description dict-pgsql
223 This package provides support for PostgreSQL maps in Postfix.
224
225 %description dict-pgsql -l pl.UTF-8
226 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
227
228 %package dict-sqlite
229 Summary:        SQLite map support for Postfix
230 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
231 Group:          Networking/Daemons/SMTP
232 Requires:       %{name} = %{epoch}:%{version}-%{release}
233
234 %description dict-sqlite
235 This package provides support for SQLite maps in Postfix.
236
237 %description dict-sqlite -l pl.UTF-8
238 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
239
240 %package dict-lmdb
241 Summary:        LMDB map support for Postfix
242 Summary(pl.UTF-8):      Obsługa map LMDB dla Postfiksa
243 Group:          Networking/Daemons/SMTP
244 Requires:       %{name} = %{epoch}:%{version}-%{release}
245
246 %description dict-lmdb
247 This package provides support for LMDB maps in Postfix.
248
249 %description dict-lmdb -l pl.UTF-8
250 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
251
252 %package dict-cdb
253 Summary:        CDB map support for Postfix
254 Summary(pl.UTF-8):      Obsługa map CDB dla Postfiksa
255 Group:          Networking/Daemons/SMTP
256 Requires:       %{name} = %{epoch}:%{version}-%{release}
257
258 %description dict-cdb
259 This package provides support for CDB maps in Postfix.
260
261 %description dict-cdb -l pl.UTF-8
262 Ten pakiet dodaje obsługę map CDB do Postfiksa.
263
264 %package qshape
265 Summary:        qshape - Print Postfix queue domain and age distribution
266 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
267 Group:          Networking/Daemons/SMTP
268 Requires:       %{name} = %{epoch}:%{version}-%{release}
269
270 %description qshape
271 The qshape program helps the administrator understand the Postfix
272 queue message distribution in time and by sender domain or recipient
273 domain. The program needs read access to the queue directories and
274 queue files, so it must run as the superuser or the mail_owner
275 specified in main.cf (typically postfix).
276
277 %description qshape -l pl.UTF-8
278 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
279 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
280 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
281 kolejki, więc musi być uruchamiany przez superużytkownika lub
282 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
283 postfix).
284
285 %package -n monit-rc-%{name}
286 Summary:        monit support for Postfix
287 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
288 Group:          Applications/System
289 Requires:       %{name} = %{epoch}:%{version}-%{release}
290 Requires:       monit
291
292 %description -n monit-rc-%{name}
293 monitrc file for monitoring Postfix.
294
295 %description -n monit-rc-%{name} -l pl.UTF-8
296 Plik monitrc do monitorowania serwera Postfix.
297
298 %prep
299 %setup -q
300 %if %{with vda}
301 cat %{SOURCE7} | %{__patch} -p1 -s
302 cat %{SOURCE11} | %{__patch} -p1 -s
303 %endif
304
305 find -type f | xargs %{__sed} -i -e 's|/etc/postfix|/etc/mail|g'
306
307 %patch0 -p1
308 %patch1 -p1
309
310 %patch3 -p1
311 %{?with_hir:%patch4 -p0}
312
313 %{__sed} -i -e '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
314 %patch7 -p1
315 %patch8 -p1
316
317 %patch11 -p1
318 %if %{with vda}
319 %patch12 -p1
320 %endif
321 %patch13 -p1
322
323 %if %{with tcp}
324 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
325 %endif
326
327 %{__sed} -i -e 's,/lib64\>,/%{_lib},' makedefs
328
329 %build
330 # export, as the same variables must be passed both to 'make makefiles' and 'make'
331 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
332 export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto"
333 export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
334 export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
335 export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
336 export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
337 export AUXLIBS_PCRE="-lpcre"
338 export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
339 export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
340
341 export CC="%{__cc}"
342 %{__make} makefiles \
343         shared=yes \
344         dynamicmaps=yes \
345         daemon_directory="%{_libdir}/postfix" \
346         shlib_directory="%{_libdir}/postfix" \
347         manpage_directory="%{_mandir}"
348
349 %{__make} -j1 \
350         DEBUG="" \
351         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
356         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
357         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
358         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
359         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
360         $RPM_BUILD_ROOT%{_var}/lib/postfix \
361         $RPM_BUILD_ROOT%{systemdunitdir}
362
363 %{__make} non-interactive-package \
364        install_root=$RPM_BUILD_ROOT
365
366 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
367 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
368         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
369
370 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
371
372 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
373 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
374 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
375 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
376 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
377 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
378 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
379 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
380 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
381 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
382 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
383 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
384
385 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
386 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
387 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
388
389 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
390         {aliases,access,canonical,relocated,transport,virtual}{,.db}
391
392 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
393
394 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
395
396 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
397 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
398
399 %clean
400 rm -rf $RPM_BUILD_ROOT
401
402 %pre
403 %groupadd -g 62 postfix
404 %groupadd -g 63 maildrop
405 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
406
407 %post
408 /sbin/ldconfig
409 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
410         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
411         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
412 fi
413 if [ "$1" = "1" ]; then
414         # only on installation, not upgrade; set sane defaults
415         # postfix expects gethostname() to return FQDN, which is obviously wrong
416         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
417                 domain=$(/bin/hostname -d 2>/dev/null)
418                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
419                         postconf -e mydomain="$domain"
420         fi
421 else
422         %{_sbindir}/postfix upgrade-configuration
423 fi
424
425 %{_bindir}/newaliases
426 /sbin/chkconfig --add postfix
427 %service postfix restart "Postfix Daemon"
428 %systemd_post postfix.service
429
430 %preun
431 if [ "$1" = "0" ]; then
432         %service postfix stop
433         /sbin/chkconfig --del postfix
434 fi
435 %systemd_preun postfix.service
436
437 %postun
438 /sbin/ldconfig
439 if [ "$1" = "0" ]; then
440         %groupremove maildrop
441         %userremove postfix
442         %groupremove postfix
443 fi
444 %systemd_reload
445
446 %triggerpostun -- postfix < 2:2.9.4-4
447 %systemd_trigger postfix.service
448
449 %files
450 %defattr(644,root,root,755)
451 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
452 %doc README_FILES/*README
453 %doc examples/smtpd-policy
454 %dir %{_sysconfdir}/mail
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
457 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
458 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
459 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
460 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
461 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
462 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
464 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
465 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
466 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
467 #%ghost %{_sysconfdir}/mail/*.db
468 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
469 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
470 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
471 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
472 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
473 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
474 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
475 %attr(740,root,root) /etc/cron.daily/postfix
476 %attr(754,root,root) /etc/rc.d/init.d/postfix
477 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
478 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
479 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
480 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
481 %attr(755,root,root) %{_bindir}/mailq
482 %attr(755,root,root) %{_bindir}/newaliases
483 %attr(755,root,root) %{_bindir}/rmail
484 %attr(755,root,root) %{_sbindir}/s*
485 %attr(755,root,root) %{_sbindir}/postfix
486 %attr(755,root,root) %{_sbindir}/postalias
487 %attr(755,root,root) %{_sbindir}/postkick
488 %attr(755,root,root) %{_sbindir}/postl*
489 %attr(755,root,root) %{_sbindir}/postc*
490 %attr(755,root,root) %{_sbindir}/postmap
491 %attr(755,root,root) %{_sbindir}/postmulti
492 %attr(2755,root,maildrop) %{_sbindir}/postqueue
493 %attr(755,root,root) %{_sbindir}/postsuper
494 %attr(2755,root,maildrop) %{_sbindir}/postdrop
495 %attr(755,root,root) /usr/lib/sendmail
496 %dir %{_libdir}/postfix
497 %attr(755,root,root) %{_libdir}/postfix/anvil
498 %attr(755,root,root) %{_libdir}/postfix/bounce
499 %attr(755,root,root) %{_libdir}/postfix/cleanup
500 %attr(755,root,root) %{_libdir}/postfix/discard
501 %attr(755,root,root) %{_libdir}/postfix/dnsblog
502 %attr(755,root,root) %{_libdir}/postfix/error
503 %attr(755,root,root) %{_libdir}/postfix/flush
504 %attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
505 %attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
506 %attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
507 %attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
508 %attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
509 %attr(755,root,root) %{_libdir}/postfix/lmtp
510 %attr(755,root,root) %{_libdir}/postfix/local
511 %attr(755,root,root) %{_libdir}/postfix/master
512 %attr(755,root,root) %{_libdir}/postfix/nqmgr
513 %attr(755,root,root) %{_libdir}/postfix/oqmgr
514 %attr(755,root,root) %{_libdir}/postfix/pickup
515 %attr(755,root,root) %{_libdir}/postfix/pipe
516 %attr(755,root,root) %{_libdir}/postfix/postfix-script
517 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
518 %attr(755,root,root) %{_libdir}/postfix/postlogd
519 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
520 %attr(755,root,root) %{_libdir}/postfix/post-install
521 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
522 %attr(755,root,root) %{_libdir}/postfix/postscreen
523 %attr(755,root,root) %{_libdir}/postfix/proxymap
524 %attr(755,root,root) %{_libdir}/postfix/qmgr
525 %attr(755,root,root) %{_libdir}/postfix/qmqpd
526 %attr(755,root,root) %{_libdir}/postfix/scache
527 %attr(755,root,root) %{_libdir}/postfix/showq
528 %attr(755,root,root) %{_libdir}/postfix/smtp
529 %attr(755,root,root) %{_libdir}/postfix/smtpd
530 %attr(755,root,root) %{_libdir}/postfix/spawn
531 %attr(755,root,root) %{_libdir}/postfix/tlsmgr
532 %attr(755,root,root) %{_libdir}/postfix/tlsproxy
533 %attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
534 %attr(755,root,root) %{_libdir}/postfix/verify
535 %attr(755,root,root) %{_libdir}/postfix/virtual
536 %attr(755,root,root) %dir %{_var}/spool/postfix
537 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
538 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
539 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
540 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
541 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
542 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
543 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
544 %attr(755,root,root) %dir %{_var}/spool/postfix/pid
545 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
546 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
547 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
548 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
549 %attr(700,postfix,root) %{_var}/lib/postfix
550 %{_mandir}/man1/mailq.1*
551 %{_mandir}/man1/newaliases.1*
552 %{_mandir}/man1/post*.1*
553 %{_mandir}/man1/sendmail.1*
554 %{_mandir}/man5/access.5*
555 %{_mandir}/man5/aliases.5*
556 %{_mandir}/man5/body_checks.5*
557 %{_mandir}/man5/bounce.5*
558 %{_mandir}/man5/canonical.5*
559 %{_mandir}/man5/cidr_table.5*
560 %{_mandir}/man5/generic.5*
561 %{_mandir}/man5/header_checks.5*
562 %{_mandir}/man5/master.5*
563 %{_mandir}/man5/memcache_table.5*
564 %{_mandir}/man5/nisplus_table.5*
565 %{_mandir}/man5/postconf.5*
566 %{_mandir}/man5/postfix-wrapper.5*
567 %{_mandir}/man5/regexp_table.5*
568 %{_mandir}/man5/relocated.5*
569 %{_mandir}/man5/socketmap_table.5*
570 %{_mandir}/man5/tcp_table.5*
571 %{_mandir}/man5/transport.5*
572 %{_mandir}/man5/virtual.5*
573 %{_mandir}/man8/*.8*
574 %{systemdunitdir}/%{name}.service
575
576 %files devel
577 %defattr(644,root,root,755)
578 %{_includedir}/postfix
579
580 %if %{with ldap}
581 %files dict-ldap
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
584 %{_mandir}/man5/ldap_table.5*
585 %endif
586
587 %if %{with mysql}
588 %files dict-mysql
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
591 %{_mandir}/man5/mysql_table.5*
592 %endif
593
594 %files dict-pcre
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
597 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
598 %{_mandir}/man5/pcre_table.5*
599
600 %if %{with pgsql}
601 %files dict-pgsql
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
604 %{_mandir}/man5/pgsql_table.5*
605 %endif
606
607 %if %{with sqlite}
608 %files dict-sqlite
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
611 %{_mandir}/man5/sqlite_table.5*
612 %endif
613
614 %if %{with lmdb}
615 %files dict-lmdb
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
618 %{_mandir}/man5/lmdb_table.5*
619 %endif
620
621 %if %{with cdb}
622 %files dict-cdb
623 %attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
624 %endif
625
626 %files qshape
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/qshape
629
630 %files -n monit-rc-%{name}
631 %defattr(644,root,root,755)
632 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.07721 seconds and 4 git commands to generate.