]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- release 4 (by relup.sh)
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v11-2.9.1
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.9.4
37 Release:        4
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  230bc3c00c051946eccd850058d75f6c
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  a54a21428de5eeae91b4bb670976e37a
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Source12:       %{name}.service
59 Patch0:         %{name}-config.patch
60 Patch1:         %{name}-conf_msg.patch
61 Patch2:         %{name}-dynamicmaps.patch
62 Patch3:         %{name}-master.cf_cyrus.patch
63 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
64 Patch4:         %{name}-header_if_reject.patch
65 Patch5:         %{name}-ident.patch
66 Patch6:         %{name}-lib64.patch
67 Patch7:         %{name}-conf.patch
68 Patch8:         %{name}-dictname.patch
69 Patch9:         %{name}-make-jN.patch
70 Patch10:        %{name}-link.patch
71 Patch11:        %{name}-scache_clnt.patch
72 URL:            http://www.postfix.org/
73 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
74 BuildRequires:  db-devel
75 # getifaddrs() with IPv6 support
76 BuildRequires:  glibc-devel >= 6:2.3.4
77 %{?with_mysql:BuildRequires:    mysql-devel}
78 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
79 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
80 BuildRequires:  pcre-devel
81 BuildRequires:  perl-base
82 %{?with_pgsql:BuildRequires:    postgresql-devel}
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.644
85 BuildRequires:  sed >= 4.0
86 %{?with_sqlite:BuildRequires:   sqlite3-devel}
87 %{?with_cdb:BuildRequires:      tinycdb-devel}
88 %{?with_mysql:BuildRequires:    zlib-devel}
89 Requires(post): /bin/hostname
90 Requires(post,postun):  /sbin/ldconfig
91 Requires(post,preun):   /sbin/chkconfig
92 Requires(postun):       /usr/sbin/groupdel
93 Requires(postun):       /usr/sbin/userdel
94 Requires(pre):  /bin/id
95 Requires(pre):  /usr/bin/getgid
96 Requires(pre):  /usr/sbin/groupadd
97 Requires(pre):  /usr/sbin/useradd
98 Requires:       /sbin/chkconfig
99 Requires:       diffutils
100 Requires:       findutils
101 Requires:       rc-scripts
102 Requires:       sed
103 %{?with_cdb:Requires:tinycdb}
104 Requires:       systemd-units >= 38
105 Suggests:       cyrus-sasl-saslauthd
106 Provides:       group(postfix)
107 Provides:       smtpdaemon
108 Provides:       user(postfix)
109 Obsoletes:      smtpdaemon
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 Postfix is attempt to provide an alternative to the widely-used
114 Sendmail program. Postfix attempts to be fast, easy to administer, and
115 hopefully secure, while at the same time being sendmail compatible
116 enough to not upset your users. This version has IPv6 support.
117
118 %description -l es.UTF-8
119 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
120 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
121
122 %description -l fr.UTF-8
123 Postfix (voir http://www.postfix.org/) se veut une alternative à
124 sendmail, responsable de l'acheminement de 70% des courriers
125 électroniques sur Internet. IBM en a suppotré le développement, mais
126 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
127 plus grand nombre de systèmes possible. Dans cette optique, il a été
128 écrit pour être totalement sous le contrôle de l'utilisateur.
129
130 %description -l it.UTF-8
131 Postfix (http://www.postfix.org/) e' un'alternativa al programma
132 sendmail utilizzato per la gestione del 70 per cento della posta
133 Internet.
134
135 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
136 evoluzione.
137
138 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
139 quale troverete le indicazioni per una corretta installazione e
140 configurazione di questo programma.
141
142 %description -l pl.UTF-8
143 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
144 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
145 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
146 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
147
148 %description -l pt_BR.UTF-8
149 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
150 você deseja um servidor SMTP *rápido*, instale este pacote.
151
152 %description -l sk.UTF-8
153 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
154 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
155 elektronickej pošty doručenej na Internete.
156
157 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
158 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
159 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
160 môže vyvíjať podľa jeho používateľov.
161
162 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
163 popísané kroky potrebné pred a po inštalácii Postfixu.
164
165 %package devel
166 Summary:        Postfix loadable modules development package
167 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
168 Group:          Development/Libraries
169 Requires:       %{name} = %{epoch}:%{version}-%{release}
170
171 %description devel
172 Header files to build additional map types for Postfix.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
176
177 %package dict-ldap
178 Summary:        LDAP map support for Postfix
179 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
180 Group:          Networking/Daemons/SMTP
181 Requires:       %{name} = %{epoch}:%{version}-%{release}
182 Requires:       openldap >= 2.3.6
183
184 %description dict-ldap
185 This package provides support for LDAP maps in Postfix.
186
187 %description dict-ldap -l pl.UTF-8
188 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
189
190 %package dict-mysql
191 Summary:        MySQL map support for Postfix
192 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
193 Group:          Networking/Daemons/SMTP
194 Requires:       %{name} = %{epoch}:%{version}-%{release}
195
196 %description dict-mysql
197 This package provides support for MySQL maps in Postfix.
198
199 %description dict-mysql -l pl.UTF-8
200 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
201
202 %package dict-pcre
203 Summary:        PCRE map support for Postfix
204 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
205 Group:          Networking/Daemons/SMTP
206 Requires:       %{name} = %{epoch}:%{version}-%{release}
207
208 %description dict-pcre
209 This package provides support for PCRE maps in Postfix.
210
211 %description dict-pcre -l pl.UTF-8
212 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
213
214 %package dict-pgsql
215 Summary:        PostgreSQL map support for Postfix
216 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
217 Group:          Networking/Daemons/SMTP
218 Requires:       %{name} = %{epoch}:%{version}-%{release}
219
220 %description dict-pgsql
221 This package provides support for PostgreSQL maps in Postfix.
222
223 %description dict-pgsql -l pl.UTF-8
224 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
225
226 %package dict-sqlite
227 Summary:        SQLite map support for Postfix
228 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
229 Group:          Networking/Daemons/SMTP
230 Requires:       %{name} = %{epoch}:%{version}-%{release}
231
232 %description dict-sqlite
233 This package provides support for SQLite maps in Postfix.
234
235 %description dict-sqlite -l pl.UTF-8
236 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
237
238 %package qshape
239 Summary:        qshape - Print Postfix queue domain and age distribution
240 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
241 Group:          Networking/Daemons/SMTP
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243
244 %description qshape
245 The qshape program helps the administrator understand the Postfix
246 queue message distribution in time and by sender domain or recipient
247 domain. The program needs read access to the queue directories and
248 queue files, so it must run as the superuser or the mail_owner
249 specified in main.cf (typically postfix).
250
251 %description qshape -l pl.UTF-8
252 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
253 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
254 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
255 kolejki, więc musi być uruchamiany przez superużytkownika lub
256 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
257 postfix).
258
259 %package -n monit-rc-%{name}
260 Summary:        monit support for Postfix
261 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
262 Group:          Applications/System
263 Requires:       %{name} = %{epoch}:%{version}-%{release}
264 Requires:       monit
265
266 %description -n monit-rc-%{name}
267 monitrc file for monitoring Postfix.
268
269 %description -n monit-rc-%{name} -l pl.UTF-8
270 Plik monitrc do monitorowania serwera Postfix.
271
272 %prep
273 %setup -q
274 %if %{with vda}
275 cat %{SOURCE7} | %{__patch} -p1 -s
276 cat %{SOURCE11} | %{__patch} -p1 -s
277 %endif
278
279 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
280
281 %patch0 -p1
282 %patch1 -p0
283 %patch2 -p1
284 %patch3 -p1
285 %{?with_hir:%patch4 -p0}
286 %patch5 -p1
287 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
288 %if "%{_lib}" == "lib64"
289 %patch6 -p1
290 %endif
291 %patch7 -p1
292 %patch8 -p1
293 %patch9 -p1
294 %patch10 -p1
295 %patch11 -p1
296
297 %if %{with tcp}
298 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
299 %endif
300
301 %build
302 %{__make} -f Makefile.init makefiles
303 %{__make} tidy
304 CC="%{__cc}"
305 export CC
306 %{__make} \
307         DEBUG="" \
308         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
309         %{!?with_ldap:LDAPSO=""} \
310         %{!?with_mysql:MYSQLSO=""} \
311         %{!?with_pgsql:PGSQLSO=""} \
312         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
313         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
314
315 %install
316 rm -rf $RPM_BUILD_ROOT
317 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
318         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
319         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
320         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
321         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
322         $RPM_BUILD_ROOT%{_var}/lib/postfix \
323         $RPM_BUILD_ROOT%{systemdunitdir}
324
325 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
326
327 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
328 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
329 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
330 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
331 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
332 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
333         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
334
335 for f in dns global master util ; do
336         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
337         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
338 done
339 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
340 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
341
342 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
343
344 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
345 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
346 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
347 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
348 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
349 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
350 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
351 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
352 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
353 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
354 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
355 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
356
357 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
358 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
359 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
360
361 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
362         {aliases,access,canonical,relocated,transport,virtual}{,.db}
363
364 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
365
366 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
367
368 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
369 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
370
371 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
372
373 %clean
374 rm -rf $RPM_BUILD_ROOT
375
376 %pre
377 %groupadd -g 62 postfix
378 %groupadd -g 63 maildrop
379 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
380
381 %post
382 /sbin/ldconfig
383 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
384         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
385         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
386 fi
387 if [ "$1" = "1" ]; then
388         # only on installation, not upgrade; set sane defaults
389         # postfix expects gethostname() to return FQDN, which is obviously wrong
390         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
391                 domain=$(/bin/hostname -d 2>/dev/null)
392                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
393                         postconf -e mydomain="$domain"
394         fi
395 else
396         %{_sbindir}/postfix upgrade-configuration
397 fi
398
399 %{_bindir}/newaliases
400 /sbin/chkconfig --add postfix
401 %service postfix restart "Postfix Daemon"
402 %systemd_post
403
404 %preun
405 if [ "$1" = "0" ]; then
406         %service postfix stop
407         /sbin/chkconfig --del postfix
408 fi
409 %systemd_preun
410
411 %postun
412 /sbin/ldconfig
413 if [ "$1" = "0" ]; then
414         %groupremove maildrop
415         %userremove postfix
416         %groupremove postfix
417 fi
418 %systemd_postun
419
420 %files
421 %defattr(644,root,root,755)
422 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
423 %doc README_FILES/*README
424 %doc examples/smtpd-policy
425 %dir %{_sysconfdir}/mail
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
429 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
430 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
433 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
434 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
435 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
436 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
438 #%ghost %{_sysconfdir}/mail/*.db
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
442 %{_sysconfdir}/mail/postfix-wrapper
443 %{_sysconfdir}/mail/postmulti-script
444 %attr(740,root,root) /etc/cron.daily/postfix
445 %attr(754,root,root) /etc/rc.d/init.d/postfix
446 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
447 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
448 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
449 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
450 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
451 %attr(755,root,root) %{_bindir}/mailq
452 %attr(755,root,root) %{_bindir}/newaliases
453 %attr(755,root,root) %{_bindir}/rmail
454 %attr(755,root,root) %{_sbindir}/s*
455 %attr(755,root,root) %{_sbindir}/postfix
456 %attr(755,root,root) %{_sbindir}/postalias
457 %attr(755,root,root) %{_sbindir}/postkick
458 %attr(755,root,root) %{_sbindir}/postl*
459 %attr(755,root,root) %{_sbindir}/postc*
460 %attr(755,root,root) %{_sbindir}/postmap
461 %attr(755,root,root) %{_sbindir}/postmulti
462 %attr(2755,root,maildrop) %{_sbindir}/postqueue
463 %attr(755,root,root) %{_sbindir}/postsuper
464 %attr(2755,root,maildrop) %{_sbindir}/postdrop
465 %attr(755,root,root) %{_sbindir}/qmqp-sink
466 %attr(755,root,root) %{_sbindir}/qmqp-source
467 %attr(755,root,root) /usr/lib/sendmail
468 %dir %{_libdir}/postfix
469 %attr(755,root,root) %{_libdir}/postfix/[!d]*
470 %attr(755,root,root) %{_libdir}/postfix/discard
471 %attr(755,root,root) %{_libdir}/postfix/dnsblog
472 %attr(755,root,root) %dir %{_var}/spool/postfix
473 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
474 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
475 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
476 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
477 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
478 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
479 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
480 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
481 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
482 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
483 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
484 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
485 %attr(700,postfix,root) %{_var}/lib/postfix
486 %{_mandir}/man1/mailq.1*
487 %{_mandir}/man1/newaliases.1*
488 %{_mandir}/man1/post*.1*
489 %{_mandir}/man1/qmqp-*.1*
490 %{_mandir}/man1/sendmail.1*
491 %{_mandir}/man1/smtp-*.1*
492 %{_mandir}/man5/access.5*
493 %{_mandir}/man5/aliases.5*
494 %{_mandir}/man5/body_checks.5*
495 %{_mandir}/man5/bounce.5*
496 %{_mandir}/man5/canonical.5*
497 %{_mandir}/man5/cidr_table.5*
498 %{_mandir}/man5/generic.5*
499 %{_mandir}/man5/header_checks.5*
500 %{_mandir}/man5/master.5*
501 %{_mandir}/man5/memcache_table.5*
502 %{_mandir}/man5/nisplus_table.5*
503 %{_mandir}/man5/postconf.5*
504 %{_mandir}/man5/postfix-wrapper.5*
505 %{_mandir}/man5/regexp_table.5*
506 %{_mandir}/man5/relocated.5*
507 %{_mandir}/man5/tcp_table.5*
508 %{_mandir}/man5/transport.5*
509 %{_mandir}/man5/virtual.5*
510 %{_mandir}/man8/*.8*
511 %{systemdunitdir}/%{name}.service
512
513 %files devel
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_libdir}/libpostfix-*.so
516 %{_includedir}/postfix
517
518 %if %{with ldap}
519 %files dict-ldap
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
522 %{_mandir}/man5/ldap_table.5*
523 %endif
524
525 %if %{with mysql}
526 %files dict-mysql
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
529 %{_mandir}/man5/mysql_table.5*
530 %endif
531
532 %files dict-pcre
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
535 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
536 %{_mandir}/man5/pcre_table.5*
537
538 %if %{with pgsql}
539 %files dict-pgsql
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
542 %{_mandir}/man5/pgsql_table.5*
543 %endif
544
545 %if %{with sqlite}
546 %files dict-sqlite
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
549 %{_mandir}/man5/sqlite_table.5*
550 %endif
551
552 %files qshape
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_bindir}/qshape
555 %{_mandir}/man1/qshape.1*
556
557 %files -n monit-rc-%{name}
558 %defattr(644,root,root,755)
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.088932 seconds and 4 git commands to generate.