]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
aec468cc6b977d726a003a4cbb38ad99ce84452d
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sasl    # without SMTP AUTH support
7 %bcond_without  ssl     # without SSL/TLS support
8 %bcond_without  cdb     # without cdb map support
9 %if "%{pld_release}" == "th"
10 %bcond_without  vda     # without VDA patch
11 %else
12 %bcond_with     vda     # with VDA patch
13 %endif
14 %bcond_with     hir     # with Beeth's header_if_reject patch
15 %bcond_with     tcp     # with unofficial tcp: lookup table
16 %if "%{pld_release}" == "ac"
17 %bcond_with             epoll   # enable epoll for 2.6 kernels
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll   # disable epoll for 2.4 kernels
24 %endif
25
26 %define         vda_ver 2.5.5
27 Summary:        Postfix Mail Transport Agent
28 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
29 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
30 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
31 Summary(pl.UTF-8):      Serwer SMTP Postfix
32 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
33 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
34 Name:           postfix
35 Version:        2.6.4
36 Release:        1
37 Epoch:          2
38 License:        distributable
39 Group:          Networking/Daemons/SMTP
40 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
41 # Source0-md5:  578464f4dfee5468f8a6b5abfbb26bcc
42 Source1:        %{name}.aliases
43 Source2:        %{name}.cron
44 Source3:        %{name}.init
45 Source4:        %{name}.sysconfig
46 Source5:        %{name}.sasl
47 Source6:        %{name}.pamd
48 Source7:        http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng.patch.gz
49 # Source7-md5:  1e30fdda918cf7e87e124b0a551337d3
50 Source8:        %{name}-bounce.cf.pl
51 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
52 Source9:        %{name}-bounce.cf.de
53 Source10:       %{name}.monitrc
54 Source11:       http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-64bit.patch.gz
55 # Source11-md5: 3b982959b6bbe7eebada34dc0c26038b
56 Patch0:         %{name}-config.patch
57 Patch1:         %{name}-conf_msg.patch
58 Patch2:         %{name}-dynamicmaps.patch
59 Patch3:         %{name}-master.cf_cyrus.patch
60 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61 Patch4:         %{name}-header_if_reject.patch
62 Patch5:         %{name}-log-proxy-rejects.patch
63 Patch6:         %{name}-ident.patch
64 Patch7:         %{name}-lib64.patch
65 Patch8:         %{name}-conf.patch
66 Patch9:         %{name}-dictname.patch
67 Patch10:        %{name}-make-jN.patch
68 URL:            http://www.postfix.org/
69 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
70 BuildRequires:  db-devel
71 # getifaddrs() with IPv6 support
72 BuildRequires:  glibc-devel >= 6:2.3.4
73 %{?with_mysql:BuildRequires:    mysql-devel}
74 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
75 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
76 BuildRequires:  pcre-devel
77 BuildRequires:  perl-base
78 %{?with_pgsql:BuildRequires:    postgresql-devel}
79 BuildRequires:  rpm >= 4.4.9-56
80 BuildRequires:  rpmbuild(macros) >= 1.268
81 BuildRequires:  sed >= 4.0
82 %{?with_cdb:BuildRequires:      tinycdb-devel}
83 %{?with_mysql:BuildRequires:    zlib-devel}
84 Requires(post): /bin/hostname
85 Requires(post,postun):  /sbin/ldconfig
86 Requires(post,preun):   /sbin/chkconfig
87 Requires(postun):       /usr/sbin/groupdel
88 Requires(postun):       /usr/sbin/userdel
89 Requires(pre):  /bin/id
90 Requires(pre):  /usr/bin/getgid
91 Requires(pre):  /usr/sbin/groupadd
92 Requires(pre):  /usr/sbin/useradd
93 Requires:       /sbin/chkconfig
94 Requires:       diffutils
95 Requires:       findutils
96 Requires:       rc-scripts
97 Requires:       sed
98 %{?with_cdb:Requires:tinycdb}
99 Suggests:       cyrus-sasl-saslauthd
100 Provides:       group(postfix)
101 Provides:       smtpdaemon
102 Provides:       user(postfix)
103 Obsoletes:      smtpdaemon
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %description
107 Postfix is attempt to provide an alternative to the widely-used
108 Sendmail program. Postfix attempts to be fast, easy to administer, and
109 hopefully secure, while at the same time being sendmail compatible
110 enough to not upset your users. This version has IPv6 support.
111
112 %description -l es.UTF-8
113 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
114 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
115
116 %description -l fr.UTF-8
117 Postfix (voir http://www.postfix.org/) se veut une alternative à
118 sendmail, responsable de l'acheminement de 70% des courriers
119 électroniques sur Internet. IBM en a suppotré le développement, mais
120 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
121 plus grand nombre de systèmes possible. Dans cette optique, il a été
122 écrit pour être totalement sous le contrôle de l'utilisateur.
123
124 %description -l it.UTF-8
125 Postfix (http://www.postfix.org/) e' un'alternativa al programma
126 sendmail utilizzato per la gestione del 70 per cento della posta
127 Internet.
128
129 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
130 evoluzione.
131
132 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
133 quale troverete le indicazioni per una corretta installazione e
134 configurazione di questo programma.
135
136 %description -l pl.UTF-8
137 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
138 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
139 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
140 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
141
142 %description -l pt_BR.UTF-8
143 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
144 você deseja um servidor SMTP *rápido*, instale este pacote.
145
146 %description -l sk.UTF-8
147 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
148 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
149 elektronickej pošty doručenej na Internete.
150
151 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
152 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
153 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
154 môže vyvíjať podľa jeho používateľov.
155
156 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
157 popísané kroky potrebné pred a po inštalácii Postfixu.
158
159 %package devel
160 Summary:        Postfix loadable modules development package
161 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
162 Group:          Development/Libraries
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164
165 %description devel
166 Header files to build additional map types for Postfix.
167
168 %description devel -l pl.UTF-8
169 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
170
171 %package dict-ldap
172 Summary:        LDAP map support for Postfix
173 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
174 Group:          Networking/Daemons/SMTP
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Requires:       openldap >= 2.3.6
177
178 %description dict-ldap
179 This package provides support for LDAP maps in Postfix.
180
181 %description dict-ldap -l pl.UTF-8
182 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
183
184 %package dict-mysql
185 Summary:        MySQL map support for Postfix
186 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
187 Group:          Networking/Daemons/SMTP
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189
190 %description dict-mysql
191 This package provides support for MySQL maps in Postfix.
192
193 %description dict-mysql -l pl.UTF-8
194 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
195
196 %package dict-pcre
197 Summary:        PCRE map support for Postfix
198 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
199 Group:          Networking/Daemons/SMTP
200 Requires:       %{name} = %{epoch}:%{version}-%{release}
201
202 %description dict-pcre
203 This package provides support for PCRE maps in Postfix.
204
205 %description dict-pcre -l pl.UTF-8
206 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
207
208 %package dict-pgsql
209 Summary:        PostgreSQL map support for Postfix
210 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
211 Group:          Networking/Daemons/SMTP
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213
214 %description dict-pgsql
215 This package provides support for PostgreSQL maps in Postfix.
216
217 %description dict-pgsql -l pl.UTF-8
218 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
219
220 %package qshape
221 Summary:        qshape - Print Postfix queue domain and age distribution
222 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
223 Group:          Networking/Daemons/SMTP
224 Requires:       %{name} = %{epoch}:%{version}-%{release}
225
226 %description qshape
227 The qshape program helps the administrator understand the Postfix
228 queue message distribution in time and by sender domain or recipient
229 domain. The program needs read access to the queue directories and
230 queue files, so it must run as the superuser or the mail_owner
231 specified in main.cf (typically postfix).
232
233 %description qshape -l pl.UTF-8
234 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
235 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
236 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
237 kolejki, więc musi być uruchamiany przez superużytkownika lub
238 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
239 postfix).
240
241 %package -n monit-rc-%{name}
242 Summary:        monit support for Postfix
243 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
244 Group:          Applications/System
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246 Requires:       monit
247
248 %description -n monit-rc-%{name}
249 monitrc file for monitoring Postfix.
250
251 %description -n monit-rc-%{name} -l pl.UTF-8
252 Plik monitrc do monitorowania serwera Postfix.
253
254 %prep
255 %setup -q
256 %{?with_vda:zcat %{SOURCE7} | %{__patch} -p1 -s}
257 %{?with_vda:zcat %{SOURCE11} | %{__patch} -p1 -s}
258
259 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
260
261 %patch0 -p1
262 %patch1 -p0
263 %patch2 -p1
264 %patch3 -p1
265 %{?with_hir:%patch4 -p0}
266 %patch5 -p1
267 %patch6 -p1
268 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
269 %if "%{_lib}" == "lib64"
270 %patch7 -p1
271 %endif
272 %patch8 -p1
273 %patch9 -p1
274 %patch10 -p1
275
276 %if %{with tcp}
277 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
278 %endif
279
280 %build
281 %{__make} -f Makefile.init makefiles
282 %{__make} tidy
283 CC="%{__cc}"
284 export CC
285 %{__make} \
286         DEBUG="" \
287         OPT="%{rpmcflags} -D_FILE_OFFSET_BITS=64" \
288         %{!?with_ldap:LDAPSO=""} \
289         %{!?with_mysql:MYSQLSO=""} \
290         %{!?with_pgsql:PGSQLSO=""} \
291         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} -DHAVE_GETIFADDRS" \
292         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
297         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
298         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
299         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
300         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
301         $RPM_BUILD_ROOT%{_var}/lib/postfix
302 rm -f html/Makefile.in conf/{LICENSE,main.cf.default}
303
304 install bin/* $RPM_BUILD_ROOT%{_sbindir}
305 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
306 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
307 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
308 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
309 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
310         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
311
312 for f in dns global master util ; do
313         install lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
314         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
315 done
316 install lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
317 install include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
318
319 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
320
321 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
322 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
323 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
324 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
325 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
326 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
327 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
328 install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
329 install %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
330 install auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
331 install auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
332
333 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
334 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
335 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
336
337 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
338         {aliases,access,canonical,relocated,transport,virtual}{,.db}
339
340 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
341
342 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
343
344 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
345 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
346
347 rm $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
348
349 %clean
350 rm -rf $RPM_BUILD_ROOT
351
352 %pre
353 %groupadd -g 62 postfix
354 %groupadd -g 63 maildrop
355 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
356
357 %post
358 /sbin/ldconfig
359 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
360         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
361         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
362 fi
363 if [ "$1" = "1" ]; then
364         # only on installation, not upgrade; set sane defaults
365         # postfix expects gethostname() to return FQDN, which is obviously wrong
366         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
367                 [ `/bin/hostname -d` != 'localdomain' ] && \
368                         postconf -e mydomain=`/bin/hostname -d`
369         fi
370 else
371         %{_sbindir}/postfix upgrade-configuration
372 fi
373
374 %{_bindir}/newaliases
375 /sbin/chkconfig --add postfix
376 %service postfix restart "Postfix Daemon"
377
378 %preun
379 if [ "$1" = "0" ]; then
380         %service postfix stop
381         /sbin/chkconfig --del postfix
382 fi
383
384 %postun
385 /sbin/ldconfig
386 if [ "$1" = "0" ]; then
387         %groupremove maildrop
388         %userremove postfix
389         %groupremove postfix
390 fi
391
392 %files
393 %defattr(644,root,root,755)
394 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
395 %doc README_FILES/*README
396 %doc examples/smtpd-policy
397 %dir %{_sysconfdir}/mail
398 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
399 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
400 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
401 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
402 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
403 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
404 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
405 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
406 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
407 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
408 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
409 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
410 #%ghost %{_sysconfdir}/mail/*.db
411 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
412 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
413 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
414 %{_sysconfdir}/mail/postfix-wrapper
415 %{_sysconfdir}/mail/postmulti-script
416 %attr(740,root,root) /etc/cron.daily/postfix
417 %attr(754,root,root) /etc/rc.d/init.d/postfix
418 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
419 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
420 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
421 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
422 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
423 %attr(755,root,root) %{_bindir}/mailq
424 %attr(755,root,root) %{_bindir}/newaliases
425 %attr(755,root,root) %{_bindir}/rmail
426 %attr(755,root,root) %{_sbindir}/s*
427 %attr(755,root,root) %{_sbindir}/postfix
428 %attr(755,root,root) %{_sbindir}/postalias
429 %attr(755,root,root) %{_sbindir}/postkick
430 %attr(755,root,root) %{_sbindir}/postl*
431 %attr(755,root,root) %{_sbindir}/postc*
432 %attr(755,root,root) %{_sbindir}/postmap
433 %attr(755,root,root) %{_sbindir}/postmulti
434 %attr(2755,root,maildrop) %{_sbindir}/postqueue
435 %attr(755,root,root) %{_sbindir}/postsuper
436 %attr(2755,root,maildrop) %{_sbindir}/postdrop
437 %attr(755,root,root) %{_sbindir}/qmqp-sink
438 %attr(755,root,root) %{_sbindir}/qmqp-source
439 %attr(755,root,root) /usr/lib/sendmail
440 %dir %{_libdir}/postfix
441 %attr(755,root,root) %{_libdir}/postfix/[!d]*
442 %attr(755,root,root) %{_libdir}/postfix/discard
443 %attr(755,root,root) %dir %{_var}/spool/postfix
444 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
445 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
446 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
447 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
448 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
449 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
450 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
451 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
452 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
453 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
454 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
455 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
456 %attr(700,postfix,root) %{_var}/lib/postfix
457 %{_mandir}/man1/mailq.1*
458 %{_mandir}/man1/newaliases.1*
459 %{_mandir}/man1/post*.1*
460 %{_mandir}/man1/qmqp-*.1*
461 %{_mandir}/man1/sendmail.1*
462 %{_mandir}/man1/smtp-*.1*
463 %{_mandir}/man5/access.5*
464 %{_mandir}/man5/aliases.5*
465 %{_mandir}/man5/body_checks.5*
466 %{_mandir}/man5/bounce.5*
467 %{_mandir}/man5/canonical.5*
468 %{_mandir}/man5/cidr_table.5*
469 %{_mandir}/man5/generic.5*
470 %{_mandir}/man5/header_checks.5*
471 %{_mandir}/man5/master.5*
472 %{_mandir}/man5/nisplus_table.5*
473 %{_mandir}/man5/postconf.5*
474 %{_mandir}/man5/postfix-wrapper.5*
475 %{_mandir}/man5/regexp_table.5*
476 %{_mandir}/man5/relocated.5*
477 %{_mandir}/man5/tcp_table.5*
478 %{_mandir}/man5/transport.5*
479 %{_mandir}/man5/virtual.5*
480 %{_mandir}/man8/*.8*
481
482 %files devel
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_libdir}/libpostfix-*.so
485 %{_includedir}/postfix
486
487 %if %{with ldap}
488 %files dict-ldap
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
491 %{_mandir}/man5/ldap_table.5*
492 %endif
493
494 %if %{with mysql}
495 %files dict-mysql
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
498 %{_mandir}/man5/mysql_table.5*
499 %endif
500
501 %files dict-pcre
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
504 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
505 %{_mandir}/man5/pcre_table.5*
506
507 %if %{with pgsql}
508 %files dict-pgsql
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
511 %{_mandir}/man5/pgsql_table.5*
512 %endif
513
514 %files qshape
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/qshape
517 %{_mandir}/man1/qshape.1*
518
519 %files -n monit-rc-%{name}
520 %defattr(644,root,root,755)
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.079127 seconds and 3 git commands to generate.