]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- updated to 20011127 becouse 20011115 generated strange
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:    
3 # --without sasl - build wihtout SMTP AUTH support
4 # --without ldap - build without LDAP support
5 # --without pcre - build without Perl Compatible Regular Expresion support
6 # --without ssl  - build without SSL/TLS support
7 # --with mysql - build with MySQL support
8 # --without ipv6  - build without IPv6 support
9 #
10 %define tls_ver 0.7.13c-snap20011127-0.9.6b
11 Summary:        Postfix Mail Transport Agent
12 Summary(pl):    Serwer SMTP Postfix
13 Name:           postfix
14 Version:        20011127
15 Release:        1
16 Group:          Networking/Daemons
17 Group(de):      Netzwerkwesen/Server
18 Group(pl):      Sieciowe/Serwery
19 License:        distributable
20 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/snapshot-%{version}.tar.gz
21 Source1:        %{name}.aliases
22 Source2:        %{name}.cron
23 Source3:        %{name}.init
24 Source5:        %{name}.sysconfig
25 Source6:        ftp://ftp.aet.tu-cottbus.de/pub/pfixtls/pfixtls-%{tls_ver}.tar.gz
26 Source7:        %{name}.sasl
27 Patch0:         %{name}-config.patch
28 Patch1:         %{name}-pl.patch
29 Patch2:         %{name}-conf_msg.patch
30 Patch3:         %{name}-ipv6.patch
31 URL:            http://www.postfix.org/
32 Provides:       smtpdaemon
33 Prereq:         rc-scripts
34 %{!?_without_ldap:BuildRequires:        openldap-devel >= 2.0.0}
35 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
36 %{!?_without_pcre:BuildRequires:        pcre-devel}
37 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel}
38 %{!?_without_ipv6:BuildRequires:        libinet6 >= 0.20010420-3}
39 BuildRequires:  db3-devel
40 BuildRequires:  grep
41 Prereq:         /sbin/chkconfig
42 Prereq:         /usr/sbin/useradd
43 Prereq:         /usr/sbin/groupadd
44 Prereq:         /usr/sbin/userdel
45 Prereq:         /usr/sbin/groupdel
46 Prereq:         /usr/bin/getgid
47 Prereq:         /bin/id
48 Prereq:         /bin/hostname
49 %{!?_without_ldap:Prereq:       openldap >= 2.0.0}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51 Obsoletes:      smtpdaemon
52 Obsoletes:      exim
53 Obsoletes:      masqmail
54 Obsoletes:      omta
55 Obsoletes:      qmail
56 Obsoletes:      sendmail
57 Obsoletes:      sendmail-cf
58 Obsoletes:      sendmail-doc
59 Obsoletes:      smail
60 Obsoletes:      zmailer
61 Requires:       procmail
62
63 %description
64 Postfix is attempt to provide an alternative to the widely-used
65 Sendmail program. Postfix attempts to be fast, easy to administer, and
66 hopefully secure, while at the same time being sendmail compatible
67 enough to not upset your users. This version have IPv6 support and
68 %{!?_without_ldap:no }LDAP support.
69
70 %description -l pl
71 Postfix jest prób± dostarczenia alternatywnego MTA w stosunku do
72 szeroko u¿ywanego sendmaila. Postfix w zamierzeniu ma byæ szybki,
73 ³atwy w administrowaniu, bezpieczny oraz ma byæ na tyle kompatybilny z
74 sendmailem by nie denerwowaæ Twoich u¿ytkowników. Ta wersja wspiera
75 IPv6%{!?_without_ldap: oraz LDAP}.
76
77 %prep
78 %setup -q -n snapshot-%{version} -a 6 
79 %patch0 -p1
80 %patch1 -p1
81 patch -p1 -s <pfixtls-%{tls_ver}/pfixtls.diff 
82 %patch2 -p1
83 %{!?_without_ipv6:%patch3 -p1 }
84
85 %build
86 %{__make} -f Makefile.init makefiles
87 %{__make} tidy
88 %{__make} DEBUG="" OPT="%{rpmcflags}" \
89         CCARGS="%{!?_without_ldap:-DHAS_LDAP} %{!?_without_pcre:-DHAS_PCRE} %{!?_without_sasl:-DUSE_SASL_AUTH} %{?_with_mysql:-DHAS_MYSQL -I%{_includedir}/mysql} %{!?_without_ssl:-DHAS_SSL -I%{_includedir}/openssl}" \
90         AUXLIBS="%{!?_without_ldap:-llber -lldap} -lnsl -ldb -lresolv %{!?_without_pcre:-lpcre} %{!?_without_sasl:-lsasl} %{?_with_mysql:-lmysqlclient} %{!?_without_ssl:-lssl -lcrypto}"
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{mail,cron.daily,rc.d/init.d,sasl,sysconfig} \
95            $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,%{_mandir}/man{1,5,8}} \
96            $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
97            pfixtls
98
99 rm -f {html,man}/Makefile.in conf/{LICENSE,main.cf.default}
100
101 install -d sample-conf; mv -f conf/sample* sample-conf/ || :
102
103 install bin/* $RPM_BUILD_ROOT%{_sbindir}
104 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
105 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
106
107 (cd man; tar cf - .) | (cd $RPM_BUILD_ROOT%{_mandir}; tar xf -)
108
109 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
111 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
112 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/postfix
113 install %{SOURCE7} $RPM_BUILD_ROOT/etc/sasl/smtpd.conf
114 install auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
115
116 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
117 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
118 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_libdir}/sendmail
119
120 mv -f  $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-sgid \
121         $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script
122
123 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-{diff,nosgid}
124
125 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
126         {aliases,access,canonical,relocated,transport,virtual}{,.db}
127
128 gzip -9nf *README HISTORY COMPATIBILITY LICENSE RELEASE_NOTES \
129            RESTRICTION_CLASS TODO
130
131 touch $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %pre
137 if [ -n "`/usr/bin/getgid postfix`" ]; then
138         if [ "`getgid postfix`" != "62" ]; then
139                 echo "Warning: group postfix haven't gid=62. Correct this before installing postfix" 1>&2
140                 exit 1
141         fi
142 else
143         /usr/sbin/groupadd -g 62 -r -f postfix
144 fi
145 if [ -n "`/usr/bin/getgid maildrop`" ]; then
146         if [ "`/usr/bin/getgid maildrop`" != "63" ]; then
147                 echo "Warning: group maildrop haven't gid=63. Correct this before installing postfix" 1>&2
148                 exit 1
149         fi
150 else
151         /usr/sbin/groupadd -g 63 -r -f maildrop
152 fi
153 if [ -n "`/bin/id -u postfix 2>/dev/null`" ]; then
154         if [ "`/bin/id -u postfix`" != "62" ]; then
155                 echo "Warning: user postfix haven't uid=62. Correct this before installing postfix" 1>&2
156                 exit 1
157         fi
158 else
159         /usr/sbin/useradd -u 62 -r -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix 1>&2
160 fi
161
162 %post
163 if ! grep -q "^postmaster:" /etc/mail/aliases; then
164         echo "Adding Entry for postmaster in /etc/mail/aliases" >&2
165         echo "postmaster:       root" >>/etc/mail/aliases
166 fi
167 if ! grep -q "^myhostname" /etc/mail/main.cf; then
168         postconf -e myhostname=`/bin/hostname -f`
169 fi
170
171 newaliases
172 /sbin/chkconfig --add postfix
173 if [ -f /var/lock/subsys/postfix ]; then
174         /etc/rc.d/init.d/postfix restart >&2
175 else
176         echo "Run \"/etc/rc.d/init.d/postfix start\" to start postfix daemon." >&2
177 fi
178
179 %preun
180 if [ "$1" = "0" ]; then
181         if [ -f /var/lock/subsys/postfix ]; then
182                 /etc/rc.d/init.d/postfix stop >&2
183         fi
184         /sbin/chkconfig --del postfix
185 fi
186
187 %postun
188 if [ $1 = 0 ]; then
189         /usr/sbin/groupdel maildrop 2> /dev/null
190         /usr/sbin/userdel postfix 2> /dev/null
191         /usr/sbin/groupdel postfix 2> /dev/null
192 fi
193
194 %files
195 %defattr(644,root,root,755)
196 %doc html *README.gz
197 %doc {HISTORY,COMPATIBILITY,LICENSE,RELEASE_NOTES,RESTRICTION_CLASS,TODO}.gz
198 %doc sample-conf
199 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/access
200 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/aliases
201 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/canonical
202 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/relocated
203 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/transport
204 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/virtual
205 #%ghost %{_sysconfdir}/mail/*.db
206 %dir %{_sysconfdir}/mail
207 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/main.cf
208 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/master.cf
209 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/postfix-script
210 %attr(740,root,root) /etc/cron.daily/postfix
211 %attr(754,root,root) /etc/rc.d/init.d/postfix
212 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/postfix
213 %{!?_without_sasl:%config(noreplace) %verify(not size mtime md5) /etc/sasl/smtpd.conf}
214 %attr(755,root,root) %{_bindir}/*
215 %attr(755,root,root) %{_sbindir}/s*
216 %attr(755,root,root) %{_sbindir}/post*i*
217 %attr(755,root,root) %{_sbindir}/postl*
218 %attr(755,root,root) %{_sbindir}/postc*
219 %attr(755,root,root) %{_sbindir}/postmap
220 %attr(755,root,root) %{_sbindir}/postsuper
221 %attr(2755,root,maildrop) %{_sbindir}/postdrop
222 %attr(755,root,root) %{_libdir}/sendmail
223 %attr(755,root,root) %{_libdir}/postfix
224 %attr(755,root,root) %dir %{_var}/spool/postfix
225 %attr(700, postfix,root) %dir %{_var}/spool/postfix/active
226 %attr(700, postfix,root) %dir %{_var}/spool/postfix/bounce
227 %attr(700, postfix,root) %dir %{_var}/spool/postfix/corrupt
228 %attr(700, postfix,root) %dir %{_var}/spool/postfix/defer
229 %attr(700, postfix,root) %dir %{_var}/spool/postfix/deferred
230 %attr(700, postfix,root) %dir %{_var}/spool/postfix/incoming
231 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
232 %attr(755, postfix,root) %dir %{_var}/spool/postfix/pid
233 %attr(700, postfix,root) %dir %{_var}/spool/postfix/private
234 %attr(755, postfix,root) %dir %{_var}/spool/postfix/public
235 %attr(700, postfix,root) %dir %{_var}/spool/postfix/saved
236 %attr(644, postfix,root) %{_var}/spool/postfix/.nofinger
237 %{_mandir}/man*/*
This page took 0.093304 seconds and 3 git commands to generate.