]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- two fixes in ipv6 patch:
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:    
3 # --without sasl - build wihtout SMTP AUTH support
4 # --without ldap - build without LDAP support
5 # --without pcre - build without Perl Compatible Regular Expresion support
6 # --without ssl  - build without SSL/TLS support
7 # --with mysql - build with MySQL support
8 # --without ipv6  - build without IPv6 support
9 #
10 %define tls_ver 0.7.12-snap20011105-0.9.6b
11 Summary:        Postfix Mail Transport Agent
12 Summary(pl):    Serwer SMTP Postfix
13 Name:           postfix
14 Version:        20011115
15 Release:        0.2
16 Group:          Networking/Daemons
17 Group(de):      Netzwerkwesen/Server
18 Group(pl):      Sieciowe/Serwery
19 License:        distributable
20 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/snapshot-%{version}.tar.gz
21 Source1:        %{name}.aliases
22 Source2:        %{name}.cron
23 Source3:        %{name}.init
24 Source5:        %{name}.sysconfig
25 Source6:        ftp://ftp.aet.tu-cottbus.de/pub/pfixtls/pfixtls-%{tls_ver}.tar.gz
26 Source7:        %{name}.sasl
27 Patch0:         %{name}-config.patch
28 Patch1:         %{name}-pl.patch
29 Patch2:         %{name}-conf_msg.patch
30 Patch3:         %{name}-ipv6.patch
31 Patch4:         %{name}-authinfo.patch
32 URL:            http://www.postfix.org/
33 Provides:       smtpdaemon
34 Prereq:         rc-scripts
35 %{!?_without_ldap:BuildRequires:        openldap-devel >= 2.0.0}
36 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
37 %{!?_without_pcre:BuildRequires:        pcre-devel}
38 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel}
39 %{!?_without_ipv6:BuildRequires:        libinet6 >= 0.20010420-3}
40 BuildRequires:  db3-devel
41 BuildRequires:  grep
42 Prereq:         /sbin/chkconfig
43 Prereq:         /usr/sbin/useradd
44 Prereq:         /usr/sbin/groupadd
45 Prereq:         /usr/sbin/userdel
46 Prereq:         /usr/sbin/groupdel
47 Prereq:         /usr/bin/getgid
48 Prereq:         /bin/id
49 Prereq:         /bin/hostname
50 %{!?_without_ldap:Prereq:       openldap >= 2.0.0}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52 Obsoletes:      smtpdaemon
53 Obsoletes:      exim
54 Obsoletes:      masqmail
55 Obsoletes:      omta
56 Obsoletes:      qmail
57 Obsoletes:      sendmail
58 Obsoletes:      sendmail-cf
59 Obsoletes:      sendmail-doc
60 Obsoletes:      smail
61 Obsoletes:      zmailer
62 Requires:       procmail
63
64 %define         _sysconfdir     /etc
65
66 %description
67 Postfix is attempt to provide an alternative to the widely-used
68 Sendmail program. Postfix attempts to be fast, easy to administer, and
69 hopefully secure, while at the same time being sendmail compatible
70 enough to not upset your users. This version have IPv6 support and
71 %{!?_without_ldap:no }LDAP support.
72
73 %description -l pl
74 Postfix jest prób± dostarczenia alternatywnego MTA w stosunku do
75 szeroko u¿ywanego sendmaila. Postfix w zamierzeniu ma byæ szybki,
76 ³atwy w administrowaniu, bezpieczny oraz ma byæ na tyle kompatybilny z
77 sendmailem by nie denerwowaæ Twoich u¿ytkowników. Ta wersja wspiera
78 IPv6%{!?_without_ldap: oraz LDAP}.
79
80 %prep
81 %setup -q -n snapshot-%{version} -a 6 
82 %patch0 -p1
83 %patch1 -p1
84 patch -p1 -s <pfixtls-%{tls_ver}/pfixtls.diff 
85 %patch2 -p1 
86 %{!?_without_ipv6:%patch3 -p1 }
87 %patch4 -p1
88
89 %build
90 %{__make} -f Makefile.init makefiles
91 %{__make} tidy
92 %{__make} DEBUG="" OPT="%{rpmcflags}" \
93         CCARGS="%{!?_without_ldap:-DHAS_LDAP} %{!?_without_pcre:-DHAS_PCRE} %{!?_without_sasl:-DUSE_SASL_AUTH} %{?_with_mysql:-DHAS_MYSQL -I%{_includedir}/mysql} %{!?_without_ssl:-DHAS_SSL -I%{_includedir}/openssl}" \
94         AUXLIBS="%{!?_without_ldap:-llber -lldap} -lnsl -ldb -lresolv %{!?_without_pcre:-lpcre} %{!?_without_sasl:-lsasl} %{?_with_mysql:-lmysqlclient} %{!?_without_ssl:-lssl -lcrypto}"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{mail,cron.daily,rc.d/init.d,sasl,sysconfig} \
99            $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,%{_mandir}/man{1,5,8}} \
100            $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
101            pfixtls
102
103 rm -f {html,man}/Makefile.in conf/{LICENSE,main.cf.default}
104
105 install -d sample-conf; mv -f conf/sample* sample-conf/ || :
106
107 install bin/* $RPM_BUILD_ROOT%{_sbindir}
108 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
109 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
110
111 (cd man; tar cf - .) | (cd $RPM_BUILD_ROOT%{_mandir}; tar xf -)
112
113 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
114 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
115 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
116 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/postfix
117 install %{SOURCE7} $RPM_BUILD_ROOT/etc/sasl/smtpd.conf
118
119 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
120 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
121 ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_libdir}/sendmail
122
123 mv -f  $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-sgid \
124         $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script
125
126 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-{diff,nosgid}
127
128 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
129         {aliases,access,canonical,relocated,transport,virtual}{,.db}
130
131 gzip -9nf *README HISTORY COMPATIBILITY LICENSE RELEASE_NOTES \
132            RESTRICTION_CLASS TODO
133
134 touch $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %pre
140 if [ -n "`/usr/bin/getgid postfix`" ]; then
141         if [ "`getgid postfix`" != "62" ]; then
142                 echo "Warning: group postfix haven't gid=62. Correct this before installing postfix" 1>&2
143                 exit 1
144         fi
145 else
146         /usr/sbin/groupadd -g 62 -r -f postfix
147 fi
148 if [ -n "`/usr/bin/getgid maildrop`" ]; then
149         if [ "`/usr/bin/getgid maildrop`" != "63" ]; then
150                 echo "Warning: group maildrop haven't gid=63. Correct this before installing postfix" 1>&2
151                 exit 1
152         fi
153 else
154         /usr/sbin/groupadd -g 63 -r -f maildrop
155 fi
156 if [ -n "`/bin/id -u postfix 2>/dev/null`" ]; then
157         if [ "`/bin/id -u postfix`" != "62" ]; then
158                 echo "Warning: user postfix haven't uid=62. Correct this before installing postfix" 1>&2
159                 exit 1
160         fi
161 else
162         /usr/sbin/useradd -u 62 -r -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix 1>&2
163 fi
164
165 %post
166 if ! grep -q "^postmaster:" /etc/mail/aliases; then
167         echo "Adding Entry for postmaster in /etc/mail/aliases" >&2
168         echo "postmaster:       root" >>/etc/mail/aliases
169 fi
170 if ! grep -q "^myhostname" /etc/mail/main.cf; then
171         postconf -e myhostname=`/bin/hostname -f`
172 fi
173
174 newaliases
175 /sbin/chkconfig --add postfix
176 if [ -f /var/lock/subsys/postfix ]; then
177         /etc/rc.d/init.d/postfix restart >&2
178 else
179         echo "Run \"/etc/rc.d/init.d/postfix start\" to start postfix daemon." >&2
180 fi
181
182 %preun
183 if [ "$1" = "0" ]; then
184         if [ -f /var/lock/subsys/postfix ]; then
185                 /etc/rc.d/init.d/postfix stop >&2
186         fi
187         /sbin/chkconfig --del postfix
188 fi
189
190 %postun
191 if [ $1 = 0 ]; then
192         /usr/sbin/groupdel maildrop 2> /dev/null
193         /usr/sbin/userdel postfix 2> /dev/null
194         /usr/sbin/groupdel postfix 2> /dev/null
195 fi
196
197 %files
198 %defattr(644,root,root,755)
199 %doc html *README.gz
200 %doc {HISTORY,COMPATIBILITY,LICENSE,RELEASE_NOTES,RESTRICTION_CLASS,TODO}.gz
201 %doc sample-conf
202 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/access
203 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/aliases
204 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/canonical
205 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/relocated
206 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/transport
207 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/virtual
208 #%ghost %{_sysconfdir}/mail/*.db
209 %dir %{_sysconfdir}/mail
210 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/main.cf
211 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/master.cf
212 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/postfix-script
213 %attr(740,root,root) /etc/cron.daily/postfix
214 %attr(754,root,root) /etc/rc.d/init.d/postfix
215 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/postfix
216 %{!?_without_sasl:%config(noreplace) %verify(not size mtime md5) /etc/sasl/smtpd.conf}
217 %attr(755,root,root) %{_bindir}/*
218 %attr(755,root,root) %{_sbindir}/s*
219 %attr(755,root,root) %{_sbindir}/post*i*
220 %attr(755,root,root) %{_sbindir}/postl*
221 %attr(755,root,root) %{_sbindir}/postc*
222 %attr(755,root,root) %{_sbindir}/postmap
223 %attr(755,root,root) %{_sbindir}/postsuper
224 %attr(2755,root,maildrop) %{_sbindir}/postdrop
225 %attr(755,root,root) %{_libdir}/sendmail
226 %attr(755,root,root) %{_libdir}/postfix
227 %attr(755,root,root) %dir %{_var}/spool/postfix
228 %attr(700, postfix,root) %dir %{_var}/spool/postfix/active
229 %attr(700, postfix,root) %dir %{_var}/spool/postfix/bounce
230 %attr(700, postfix,root) %dir %{_var}/spool/postfix/corrupt
231 %attr(700, postfix,root) %dir %{_var}/spool/postfix/defer
232 %attr(700, postfix,root) %dir %{_var}/spool/postfix/deferred
233 %attr(700, postfix,root) %dir %{_var}/spool/postfix/incoming
234 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
235 %attr(755, postfix,root) %dir %{_var}/spool/postfix/pid
236 %attr(700, postfix,root) %dir %{_var}/spool/postfix/private
237 %attr(755, postfix,root) %dir %{_var}/spool/postfix/public
238 %attr(700, postfix,root) %dir %{_var}/spool/postfix/saved
239 %attr(644, postfix,root) %{_var}/spool/postfix/.nofinger
240 %{_mandir}/man*/*
This page took 0.126342 seconds and 3 git commands to generate.