]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
2e02082f093145f64331458c511be9c5c9193c68
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %bcond_with     vda     # with VDA patch
11 %bcond_with     hir     # with Beeth's header_if_reject patch
12 %bcond_with     tcp     # with unofficial tcp: lookup table
13 %if "%{pld_release}" == "ac"
14 %bcond_with             epoll   # enable epoll for 2.6 kernels
15 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
16 %ifarch %{x8664}
17 %define         with_epoll      1
18 %endif
19 %else
20 %bcond_without  epoll   # disable epoll for 2.4 kernels
21 %endif
22
23 %define         vda_ver v13-2.10.0
24 Summary:        Postfix Mail Transport Agent
25 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
26 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
27 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
28 Summary(pl.UTF-8):      Serwer SMTP Postfix
29 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
30 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
31 Name:           postfix
32 Version:        3.3.1
33 Release:        0.1
34 Epoch:          2
35 License:        distributable
36 Group:          Networking/Daemons/SMTP
37 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
38 # Source0-md5:  4381c6492f415e4a69cf5099d4acea76
39 Source1:        %{name}.aliases
40 Source2:        %{name}.cron
41 Source3:        %{name}.init
42 Source4:        %{name}.sysconfig
43 Source5:        %{name}.sasl
44 Source6:        %{name}.pamd
45 Source7:        %{name}-vda.patch
46 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
47 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
48 Source8:        %{name}-bounce.cf.pl
49 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
50 Source9:        %{name}-bounce.cf.de
51 Source10:       %{name}.monitrc
52 Source11:       %{name}-vda-bigquota.patch
53 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
54 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
55 Source12:       %{name}.service
56 Patch0:         %{name}-config.patch
57
58 Patch3:         %{name}-master.cf_cyrus.patch
59 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
60 Patch4:         %{name}-header_if_reject.patch
61
62 Patch7:         %{name}-conf.patch
63 Patch8:         %{name}-dictname.patch
64
65 Patch11:        %{name}-scache_clnt.patch
66 Patch12:        format-security.patch
67 Patch13:        %{name}-no_cdb.patch
68 URL:            http://www.postfix.org/
69 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
70 BuildRequires:  db-devel
71 # getifaddrs() with IPv6 support
72 BuildRequires:  glibc-devel >= 6:2.3.4
73 %{?with_mysql:BuildRequires:    mysql-devel}
74 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
75 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
76 BuildRequires:  pcre-devel
77 BuildRequires:  perl-base
78 %{?with_pgsql:BuildRequires:    postgresql-devel}
79 BuildRequires:  rpm >= 4.4.9-56
80 BuildRequires:  rpmbuild(macros) >= 1.644
81 BuildRequires:  sed >= 4.0
82 %{?with_sqlite:BuildRequires:   sqlite3-devel}
83 %{?with_cdb:BuildRequires:      tinycdb-devel}
84 %{?with_mysql:BuildRequires:    zlib-devel}
85 Requires(post): /bin/hostname
86 Requires(post,postun):  /sbin/ldconfig
87 Requires(post,preun):   /sbin/chkconfig
88 Requires(postun):       /usr/sbin/groupdel
89 Requires(postun):       /usr/sbin/userdel
90 Requires(pre):  /bin/id
91 Requires(pre):  /usr/bin/getgid
92 Requires(pre):  /usr/sbin/groupadd
93 Requires(pre):  /usr/sbin/useradd
94 Requires:       /sbin/chkconfig
95 Requires:       diffutils
96 Requires:       findutils
97 Requires:       rc-scripts
98 Requires:       sed
99 %{?with_cdb:Requires:tinycdb}
100 Requires:       systemd-units >= 38
101 Suggests:       cyrus-sasl-saslauthd
102 Provides:       group(postfix)
103 Provides:       smtpdaemon
104 Provides:       user(postfix)
105 Obsoletes:      smtpdaemon
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %description
109 Postfix is attempt to provide an alternative to the widely-used
110 Sendmail program. Postfix attempts to be fast, easy to administer, and
111 hopefully secure, while at the same time being sendmail compatible
112 enough to not upset your users. This version has IPv6 support.
113
114 %description -l es.UTF-8
115 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
116 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
117
118 %description -l fr.UTF-8
119 Postfix (voir http://www.postfix.org/) se veut une alternative à
120 sendmail, responsable de l'acheminement de 70% des courriers
121 électroniques sur Internet. IBM en a suppotré le développement, mais
122 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
123 plus grand nombre de systèmes possible. Dans cette optique, il a été
124 écrit pour être totalement sous le contrôle de l'utilisateur.
125
126 %description -l it.UTF-8
127 Postfix (http://www.postfix.org/) e' un'alternativa al programma
128 sendmail utilizzato per la gestione del 70 per cento della posta
129 Internet.
130
131 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
132 evoluzione.
133
134 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
135 quale troverete le indicazioni per una corretta installazione e
136 configurazione di questo programma.
137
138 %description -l pl.UTF-8
139 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
140 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
141 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
142 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
143
144 %description -l pt_BR.UTF-8
145 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
146 você deseja um servidor SMTP *rápido*, instale este pacote.
147
148 %description -l sk.UTF-8
149 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
150 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
151 elektronickej pošty doručenej na Internete.
152
153 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
154 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
155 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
156 môže vyvíjať podľa jeho používateľov.
157
158 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
159 popísané kroky potrebné pred a po inštalácii Postfixu.
160
161 %package devel
162 Summary:        Postfix loadable modules development package
163 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
164 Group:          Development/Libraries
165 Requires:       %{name} = %{epoch}:%{version}-%{release}
166
167 %description devel
168 Header files to build additional map types for Postfix.
169
170 %description devel -l pl.UTF-8
171 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
172
173 %package dict-ldap
174 Summary:        LDAP map support for Postfix
175 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
176 Group:          Networking/Daemons/SMTP
177 Requires:       %{name} = %{epoch}:%{version}-%{release}
178 Requires:       openldap >= 2.3.6
179
180 %description dict-ldap
181 This package provides support for LDAP maps in Postfix.
182
183 %description dict-ldap -l pl.UTF-8
184 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
185
186 %package dict-mysql
187 Summary:        MySQL map support for Postfix
188 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
189 Group:          Networking/Daemons/SMTP
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191
192 %description dict-mysql
193 This package provides support for MySQL maps in Postfix.
194
195 %description dict-mysql -l pl.UTF-8
196 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
197
198 %package dict-pcre
199 Summary:        PCRE map support for Postfix
200 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
201 Group:          Networking/Daemons/SMTP
202 Requires:       %{name} = %{epoch}:%{version}-%{release}
203
204 %description dict-pcre
205 This package provides support for PCRE maps in Postfix.
206
207 %description dict-pcre -l pl.UTF-8
208 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
209
210 %package dict-pgsql
211 Summary:        PostgreSQL map support for Postfix
212 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
213 Group:          Networking/Daemons/SMTP
214 Requires:       %{name} = %{epoch}:%{version}-%{release}
215
216 %description dict-pgsql
217 This package provides support for PostgreSQL maps in Postfix.
218
219 %description dict-pgsql -l pl.UTF-8
220 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
221
222 %package dict-sqlite
223 Summary:        SQLite map support for Postfix
224 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
225 Group:          Networking/Daemons/SMTP
226 Requires:       %{name} = %{epoch}:%{version}-%{release}
227
228 %description dict-sqlite
229 This package provides support for SQLite maps in Postfix.
230
231 %description dict-sqlite -l pl.UTF-8
232 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
233
234 %package qshape
235 Summary:        qshape - Print Postfix queue domain and age distribution
236 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
237 Group:          Networking/Daemons/SMTP
238 Requires:       %{name} = %{epoch}:%{version}-%{release}
239
240 %description qshape
241 The qshape program helps the administrator understand the Postfix
242 queue message distribution in time and by sender domain or recipient
243 domain. The program needs read access to the queue directories and
244 queue files, so it must run as the superuser or the mail_owner
245 specified in main.cf (typically postfix).
246
247 %description qshape -l pl.UTF-8
248 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
249 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
250 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
251 kolejki, więc musi być uruchamiany przez superużytkownika lub
252 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
253 postfix).
254
255 %package -n monit-rc-%{name}
256 Summary:        monit support for Postfix
257 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
258 Group:          Applications/System
259 Requires:       %{name} = %{epoch}:%{version}-%{release}
260 Requires:       monit
261
262 %description -n monit-rc-%{name}
263 monitrc file for monitoring Postfix.
264
265 %description -n monit-rc-%{name} -l pl.UTF-8
266 Plik monitrc do monitorowania serwera Postfix.
267
268 %prep
269 %setup -q
270 %if %{with vda}
271 cat %{SOURCE7} | %{__patch} -p1 -s
272 cat %{SOURCE11} | %{__patch} -p1 -s
273 %endif
274
275 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
276
277 %patch0 -p1
278
279 %patch3 -p1
280 %{?with_hir:%patch4 -p0}
281
282 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
283 %patch7 -p1
284 %patch8 -p1
285
286 %patch11 -p1
287 %if %{with vda}
288 %patch12 -p1
289 %endif
290 %{!?with_cdb:%patch13 -p1}
291
292 %if %{with tcp}
293 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
294 %endif
295
296 %build
297 %{__make} -f Makefile.init makefiles
298 %{__make} tidy
299 export CC="%{__cc}"
300 %{__make} -j1 \
301         DEBUG="" \
302         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
303         %{!?with_ldap:LDAPSO=""} \
304         %{!?with_mysql:MYSQLSO=""} \
305         %{!?with_pgsql:PGSQLSO=""} \
306         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
307         AUXLIBS="-ldb -lresolv %{?with_mysql:-lmysqlclient} %{?with_pgsql:-lpq} %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre %{?with_ldap:-lldap -llber}"
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
312         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
313         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
314         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
315         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
316         $RPM_BUILD_ROOT%{_var}/lib/postfix \
317         $RPM_BUILD_ROOT%{systemdunitdir}
318
319 %{__make} non-interactive-package \
320        install_root=$RPM_BUILD_ROOT
321
322 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
323 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
324         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
325
326 for f in dns global master util ; do
327         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
328         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
329 done
330 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
331
332 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
333
334 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
335 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
336 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
337 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
338 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
339 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
340 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
341 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
342 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
343 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
344 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
345 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
346
347 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
348 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
349 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
350
351 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
352         {aliases,access,canonical,relocated,transport,virtual}{,.db}
353
354 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
355
356 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
357
358 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
359 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
360
361 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
362
363 %clean
364 rm -rf $RPM_BUILD_ROOT
365
366 %pre
367 %groupadd -g 62 postfix
368 %groupadd -g 63 maildrop
369 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
370
371 %post
372 /sbin/ldconfig
373 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
374         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
375         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
376 fi
377 if [ "$1" = "1" ]; then
378         # only on installation, not upgrade; set sane defaults
379         # postfix expects gethostname() to return FQDN, which is obviously wrong
380         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
381                 domain=$(/bin/hostname -d 2>/dev/null)
382                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
383                         postconf -e mydomain="$domain"
384         fi
385 else
386         %{_sbindir}/postfix upgrade-configuration
387 fi
388
389 %{_bindir}/newaliases
390 /sbin/chkconfig --add postfix
391 %service postfix restart "Postfix Daemon"
392 %systemd_post postfix.service
393
394 %preun
395 if [ "$1" = "0" ]; then
396         %service postfix stop
397         /sbin/chkconfig --del postfix
398 fi
399 %systemd_preun postfix.service
400
401 %postun
402 /sbin/ldconfig
403 if [ "$1" = "0" ]; then
404         %groupremove maildrop
405         %userremove postfix
406         %groupremove postfix
407 fi
408 %systemd_reload
409
410 %triggerpostun -- postfix < 2:2.9.4-4
411 %systemd_trigger postfix.service
412
413 %files
414 %defattr(644,root,root,755)
415 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
416 %doc README_FILES/*README
417 %doc examples/smtpd-policy
418 %dir %{_sysconfdir}/mail
419 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
420 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
421 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
422 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
423 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
424 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
425 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
426 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
430 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
431 #%ghost %{_sysconfdir}/mail/*.db
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
433 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
434 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
435 %{_sysconfdir}/mail/postfix-wrapper
436 %{_sysconfdir}/mail/postmulti-script
437 %attr(740,root,root) /etc/cron.daily/postfix
438 %attr(754,root,root) /etc/rc.d/init.d/postfix
439 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
440 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
441 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
442 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
443 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
444 %attr(755,root,root) %{_bindir}/mailq
445 %attr(755,root,root) %{_bindir}/newaliases
446 %attr(755,root,root) %{_bindir}/rmail
447 %attr(755,root,root) %{_sbindir}/s*
448 %attr(755,root,root) %{_sbindir}/postfix
449 %attr(755,root,root) %{_sbindir}/postalias
450 %attr(755,root,root) %{_sbindir}/postkick
451 %attr(755,root,root) %{_sbindir}/postl*
452 %attr(755,root,root) %{_sbindir}/postc*
453 %attr(755,root,root) %{_sbindir}/postmap
454 %attr(755,root,root) %{_sbindir}/postmulti
455 %attr(2755,root,maildrop) %{_sbindir}/postqueue
456 %attr(755,root,root) %{_sbindir}/postsuper
457 %attr(755,root,root) %{_sbindir}/posttls-finger
458 %attr(2755,root,maildrop) %{_sbindir}/postdrop
459 %attr(755,root,root) %{_sbindir}/qmqp-sink
460 %attr(755,root,root) %{_sbindir}/qmqp-source
461 %attr(755,root,root) /usr/lib/sendmail
462 %dir %{_libdir}/postfix
463 %attr(755,root,root) %{_libdir}/postfix/[!d]*
464 %attr(755,root,root) %{_libdir}/postfix/discard
465 %attr(755,root,root) %{_libdir}/postfix/dnsblog
466 %attr(755,root,root) %dir %{_var}/spool/postfix
467 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
468 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
469 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
470 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
471 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
472 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
473 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
474 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
475 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
476 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
477 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
478 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
479 %attr(700,postfix,root) %{_var}/lib/postfix
480 %{_mandir}/man1/mailq.1*
481 %{_mandir}/man1/newaliases.1*
482 %{_mandir}/man1/post*.1*
483 %{_mandir}/man1/qmqp-*.1*
484 %{_mandir}/man1/sendmail.1*
485 %{_mandir}/man1/smtp-*.1*
486 %{_mandir}/man5/access.5*
487 %{_mandir}/man5/aliases.5*
488 %{_mandir}/man5/body_checks.5*
489 %{_mandir}/man5/bounce.5*
490 %{_mandir}/man5/canonical.5*
491 %{_mandir}/man5/cidr_table.5*
492 %{_mandir}/man5/generic.5*
493 %{_mandir}/man5/header_checks.5*
494 %{_mandir}/man5/lmdb_table.5*
495 %{_mandir}/man5/master.5*
496 %{_mandir}/man5/memcache_table.5*
497 %{_mandir}/man5/nisplus_table.5*
498 %{_mandir}/man5/postconf.5*
499 %{_mandir}/man5/postfix-wrapper.5*
500 %{_mandir}/man5/regexp_table.5*
501 %{_mandir}/man5/relocated.5*
502 %{_mandir}/man5/socketmap_table.5*
503 %{_mandir}/man5/tcp_table.5*
504 %{_mandir}/man5/transport.5*
505 %{_mandir}/man5/virtual.5*
506 %{_mandir}/man8/*.8*
507 %{systemdunitdir}/%{name}.service
508
509 %files devel
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_libdir}/libpostfix-*.so
512 %{_includedir}/postfix
513
514 %if %{with ldap}
515 %files dict-ldap
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
518 %{_mandir}/man5/ldap_table.5*
519 %endif
520
521 %if %{with mysql}
522 %files dict-mysql
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
525 %{_mandir}/man5/mysql_table.5*
526 %endif
527
528 %files dict-pcre
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
531 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
532 %{_mandir}/man5/pcre_table.5*
533
534 %if %{with pgsql}
535 %files dict-pgsql
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
538 %{_mandir}/man5/pgsql_table.5*
539 %endif
540
541 %if %{with sqlite}
542 %files dict-sqlite
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
545 %{_mandir}/man5/sqlite_table.5*
546 %endif
547
548 %files qshape
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/qshape
551 %{_mandir}/man1/qshape.1*
552
553 %files -n monit-rc-%{name}
554 %defattr(644,root,root,755)
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.096616 seconds and 3 git commands to generate.