]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
0ba5dae77767606ab1f4d14d0a3a87c118953a6e
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v13-2.10.0
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.11.5
37 Release:        1
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  8523f6d1de6f522313207524d794ee9c
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  01e1b031d79b85f3cb67d98ceddd775d
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Source12:       %{name}.service
59 Patch0:         %{name}-config.patch
60 Patch1:         %{name}-conf_msg.patch
61 Patch2:         %{name}-dynamicmaps.patch
62 Patch3:         %{name}-master.cf_cyrus.patch
63 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
64 Patch4:         %{name}-header_if_reject.patch
65 Patch5:         %{name}-ident.patch
66 Patch6:         %{name}-lib64.patch
67 Patch7:         %{name}-conf.patch
68 Patch8:         %{name}-dictname.patch
69 Patch9:         %{name}-make-jN.patch
70 Patch10:        %{name}-link.patch
71 Patch11:        %{name}-scache_clnt.patch
72 Patch12:        format-security.patch
73 Patch13:        %{name}-no_cdb.patch
74 URL:            http://www.postfix.org/
75 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
76 BuildRequires:  db-devel
77 # getifaddrs() with IPv6 support
78 BuildRequires:  glibc-devel >= 6:2.3.4
79 %{?with_mysql:BuildRequires:    mysql-devel}
80 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
81 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
82 BuildRequires:  pcre-devel
83 BuildRequires:  perl-base
84 %{?with_pgsql:BuildRequires:    postgresql-devel}
85 BuildRequires:  rpm >= 4.4.9-56
86 BuildRequires:  rpmbuild(macros) >= 1.644
87 BuildRequires:  sed >= 4.0
88 %{?with_sqlite:BuildRequires:   sqlite3-devel}
89 %{?with_cdb:BuildRequires:      tinycdb-devel}
90 %{?with_mysql:BuildRequires:    zlib-devel}
91 Requires(post): /bin/hostname
92 Requires(post,postun):  /sbin/ldconfig
93 Requires(post,preun):   /sbin/chkconfig
94 Requires(postun):       /usr/sbin/groupdel
95 Requires(postun):       /usr/sbin/userdel
96 Requires(pre):  /bin/id
97 Requires(pre):  /usr/bin/getgid
98 Requires(pre):  /usr/sbin/groupadd
99 Requires(pre):  /usr/sbin/useradd
100 Requires:       /sbin/chkconfig
101 Requires:       diffutils
102 Requires:       findutils
103 Requires:       rc-scripts
104 Requires:       sed
105 %{?with_cdb:Requires:tinycdb}
106 Requires:       systemd-units >= 38
107 Suggests:       cyrus-sasl-saslauthd
108 Provides:       group(postfix)
109 Provides:       smtpdaemon
110 Provides:       user(postfix)
111 Obsoletes:      smtpdaemon
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %description
115 Postfix is attempt to provide an alternative to the widely-used
116 Sendmail program. Postfix attempts to be fast, easy to administer, and
117 hopefully secure, while at the same time being sendmail compatible
118 enough to not upset your users. This version has IPv6 support.
119
120 %description -l es.UTF-8
121 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
122 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
123
124 %description -l fr.UTF-8
125 Postfix (voir http://www.postfix.org/) se veut une alternative à
126 sendmail, responsable de l'acheminement de 70% des courriers
127 électroniques sur Internet. IBM en a suppotré le développement, mais
128 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
129 plus grand nombre de systèmes possible. Dans cette optique, il a été
130 écrit pour être totalement sous le contrôle de l'utilisateur.
131
132 %description -l it.UTF-8
133 Postfix (http://www.postfix.org/) e' un'alternativa al programma
134 sendmail utilizzato per la gestione del 70 per cento della posta
135 Internet.
136
137 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
138 evoluzione.
139
140 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
141 quale troverete le indicazioni per una corretta installazione e
142 configurazione di questo programma.
143
144 %description -l pl.UTF-8
145 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
146 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
147 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
148 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
149
150 %description -l pt_BR.UTF-8
151 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
152 você deseja um servidor SMTP *rápido*, instale este pacote.
153
154 %description -l sk.UTF-8
155 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
156 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
157 elektronickej pošty doručenej na Internete.
158
159 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
160 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
161 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
162 môže vyvíjať podľa jeho používateľov.
163
164 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
165 popísané kroky potrebné pred a po inštalácii Postfixu.
166
167 %package devel
168 Summary:        Postfix loadable modules development package
169 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
170 Group:          Development/Libraries
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172
173 %description devel
174 Header files to build additional map types for Postfix.
175
176 %description devel -l pl.UTF-8
177 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
178
179 %package dict-ldap
180 Summary:        LDAP map support for Postfix
181 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
182 Group:          Networking/Daemons/SMTP
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184 Requires:       openldap >= 2.3.6
185
186 %description dict-ldap
187 This package provides support for LDAP maps in Postfix.
188
189 %description dict-ldap -l pl.UTF-8
190 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
191
192 %package dict-mysql
193 Summary:        MySQL map support for Postfix
194 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
195 Group:          Networking/Daemons/SMTP
196 Requires:       %{name} = %{epoch}:%{version}-%{release}
197
198 %description dict-mysql
199 This package provides support for MySQL maps in Postfix.
200
201 %description dict-mysql -l pl.UTF-8
202 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
203
204 %package dict-pcre
205 Summary:        PCRE map support for Postfix
206 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
207 Group:          Networking/Daemons/SMTP
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209
210 %description dict-pcre
211 This package provides support for PCRE maps in Postfix.
212
213 %description dict-pcre -l pl.UTF-8
214 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
215
216 %package dict-pgsql
217 Summary:        PostgreSQL map support for Postfix
218 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
219 Group:          Networking/Daemons/SMTP
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221
222 %description dict-pgsql
223 This package provides support for PostgreSQL maps in Postfix.
224
225 %description dict-pgsql -l pl.UTF-8
226 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
227
228 %package dict-sqlite
229 Summary:        SQLite map support for Postfix
230 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
231 Group:          Networking/Daemons/SMTP
232 Requires:       %{name} = %{epoch}:%{version}-%{release}
233
234 %description dict-sqlite
235 This package provides support for SQLite maps in Postfix.
236
237 %description dict-sqlite -l pl.UTF-8
238 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
239
240 %package qshape
241 Summary:        qshape - Print Postfix queue domain and age distribution
242 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
243 Group:          Networking/Daemons/SMTP
244 Requires:       %{name} = %{epoch}:%{version}-%{release}
245
246 %description qshape
247 The qshape program helps the administrator understand the Postfix
248 queue message distribution in time and by sender domain or recipient
249 domain. The program needs read access to the queue directories and
250 queue files, so it must run as the superuser or the mail_owner
251 specified in main.cf (typically postfix).
252
253 %description qshape -l pl.UTF-8
254 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
255 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
256 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
257 kolejki, więc musi być uruchamiany przez superużytkownika lub
258 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
259 postfix).
260
261 %package -n monit-rc-%{name}
262 Summary:        monit support for Postfix
263 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
264 Group:          Applications/System
265 Requires:       %{name} = %{epoch}:%{version}-%{release}
266 Requires:       monit
267
268 %description -n monit-rc-%{name}
269 monitrc file for monitoring Postfix.
270
271 %description -n monit-rc-%{name} -l pl.UTF-8
272 Plik monitrc do monitorowania serwera Postfix.
273
274 %prep
275 %setup -q
276 %if %{with vda}
277 cat %{SOURCE7} | %{__patch} -p1 -s
278 cat %{SOURCE11} | %{__patch} -p1 -s
279 %endif
280
281 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
282
283 %patch0 -p1
284 %patch1 -p0
285 %patch2 -p1
286 %patch3 -p1
287 %{?with_hir:%patch4 -p0}
288 %patch5 -p1
289 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
290 %if "%{_lib}" == "lib64"
291 %patch6 -p1
292 %endif
293 %patch7 -p1
294 %patch8 -p1
295 %patch9 -p1
296 %patch10 -p1
297 %patch11 -p1
298 %if %{with vda}
299 %patch12 -p1
300 %endif
301 %{!?with_cdb:%patch13 -p1}
302
303 %if %{with tcp}
304 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
305 %endif
306
307 %build
308 %{__make} -f Makefile.init makefiles
309 %{__make} tidy
310 export CC="%{__cc}"
311 %{__make} -j1 \
312         DEBUG="" \
313         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
314         %{!?with_ldap:LDAPSO=""} \
315         %{!?with_mysql:MYSQLSO=""} \
316         %{!?with_pgsql:PGSQLSO=""} \
317         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
318         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
319
320 %install
321 rm -rf $RPM_BUILD_ROOT
322 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
323         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
324         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
325         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
326         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
327         $RPM_BUILD_ROOT%{_var}/lib/postfix \
328         $RPM_BUILD_ROOT%{systemdunitdir}
329
330 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
331
332 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
333 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
334 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
335 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
336 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
337 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
338         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
339
340 for f in dns global master util ; do
341         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
342         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
343 done
344 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
345 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
346
347 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
348
349 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
350 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
351 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
352 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
353 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
354 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
355 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
356 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
357 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
358 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
359 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
360 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
361
362 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
363 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
364 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
365
366 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
367         {aliases,access,canonical,relocated,transport,virtual}{,.db}
368
369 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
370
371 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
372
373 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
374 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
375
376 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
377
378 %clean
379 rm -rf $RPM_BUILD_ROOT
380
381 %pre
382 %groupadd -g 62 postfix
383 %groupadd -g 63 maildrop
384 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
385
386 %post
387 /sbin/ldconfig
388 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
389         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
390         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
391 fi
392 if [ "$1" = "1" ]; then
393         # only on installation, not upgrade; set sane defaults
394         # postfix expects gethostname() to return FQDN, which is obviously wrong
395         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
396                 domain=$(/bin/hostname -d 2>/dev/null)
397                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
398                         postconf -e mydomain="$domain"
399         fi
400 else
401         %{_sbindir}/postfix upgrade-configuration
402 fi
403
404 %{_bindir}/newaliases
405 /sbin/chkconfig --add postfix
406 %service postfix restart "Postfix Daemon"
407 %systemd_post postfix.service
408
409 %preun
410 if [ "$1" = "0" ]; then
411         %service postfix stop
412         /sbin/chkconfig --del postfix
413 fi
414 %systemd_preun postfix.service
415
416 %postun
417 /sbin/ldconfig
418 if [ "$1" = "0" ]; then
419         %groupremove maildrop
420         %userremove postfix
421         %groupremove postfix
422 fi
423 %systemd_reload
424
425 %triggerpostun -- postfix < 2:2.9.4-4
426 %systemd_trigger postfix.service
427
428 %files
429 %defattr(644,root,root,755)
430 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
431 %doc README_FILES/*README
432 %doc examples/smtpd-policy
433 %dir %{_sysconfdir}/mail
434 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
435 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
436 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
437 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
438 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
441 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
446 #%ghost %{_sysconfdir}/mail/*.db
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
448 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
449 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
450 %{_sysconfdir}/mail/postfix-wrapper
451 %{_sysconfdir}/mail/postmulti-script
452 %attr(740,root,root) /etc/cron.daily/postfix
453 %attr(754,root,root) /etc/rc.d/init.d/postfix
454 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
455 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
456 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
457 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
458 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
459 %attr(755,root,root) %{_bindir}/mailq
460 %attr(755,root,root) %{_bindir}/newaliases
461 %attr(755,root,root) %{_bindir}/rmail
462 %attr(755,root,root) %{_sbindir}/s*
463 %attr(755,root,root) %{_sbindir}/postfix
464 %attr(755,root,root) %{_sbindir}/postalias
465 %attr(755,root,root) %{_sbindir}/postkick
466 %attr(755,root,root) %{_sbindir}/postl*
467 %attr(755,root,root) %{_sbindir}/postc*
468 %attr(755,root,root) %{_sbindir}/postmap
469 %attr(755,root,root) %{_sbindir}/postmulti
470 %attr(2755,root,maildrop) %{_sbindir}/postqueue
471 %attr(755,root,root) %{_sbindir}/postsuper
472 %attr(755,root,root) %{_sbindir}/posttls-finger
473 %attr(2755,root,maildrop) %{_sbindir}/postdrop
474 %attr(755,root,root) %{_sbindir}/qmqp-sink
475 %attr(755,root,root) %{_sbindir}/qmqp-source
476 %attr(755,root,root) /usr/lib/sendmail
477 %dir %{_libdir}/postfix
478 %attr(755,root,root) %{_libdir}/postfix/[!d]*
479 %attr(755,root,root) %{_libdir}/postfix/discard
480 %attr(755,root,root) %{_libdir}/postfix/dnsblog
481 %attr(755,root,root) %dir %{_var}/spool/postfix
482 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
483 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
484 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
485 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
486 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
487 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
488 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
489 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
490 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
491 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
492 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
493 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
494 %attr(700,postfix,root) %{_var}/lib/postfix
495 %{_mandir}/man1/mailq.1*
496 %{_mandir}/man1/newaliases.1*
497 %{_mandir}/man1/post*.1*
498 %{_mandir}/man1/qmqp-*.1*
499 %{_mandir}/man1/sendmail.1*
500 %{_mandir}/man1/smtp-*.1*
501 %{_mandir}/man5/access.5*
502 %{_mandir}/man5/aliases.5*
503 %{_mandir}/man5/body_checks.5*
504 %{_mandir}/man5/bounce.5*
505 %{_mandir}/man5/canonical.5*
506 %{_mandir}/man5/cidr_table.5*
507 %{_mandir}/man5/generic.5*
508 %{_mandir}/man5/header_checks.5*
509 %{_mandir}/man5/lmdb_table.5*
510 %{_mandir}/man5/master.5*
511 %{_mandir}/man5/memcache_table.5*
512 %{_mandir}/man5/nisplus_table.5*
513 %{_mandir}/man5/postconf.5*
514 %{_mandir}/man5/postfix-wrapper.5*
515 %{_mandir}/man5/regexp_table.5*
516 %{_mandir}/man5/relocated.5*
517 %{_mandir}/man5/socketmap_table.5*
518 %{_mandir}/man5/tcp_table.5*
519 %{_mandir}/man5/transport.5*
520 %{_mandir}/man5/virtual.5*
521 %{_mandir}/man8/*.8*
522 %{systemdunitdir}/%{name}.service
523
524 %files devel
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/libpostfix-*.so
527 %{_includedir}/postfix
528
529 %if %{with ldap}
530 %files dict-ldap
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
533 %{_mandir}/man5/ldap_table.5*
534 %endif
535
536 %if %{with mysql}
537 %files dict-mysql
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
540 %{_mandir}/man5/mysql_table.5*
541 %endif
542
543 %files dict-pcre
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
546 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
547 %{_mandir}/man5/pcre_table.5*
548
549 %if %{with pgsql}
550 %files dict-pgsql
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
553 %{_mandir}/man5/pgsql_table.5*
554 %endif
555
556 %if %{with sqlite}
557 %files dict-sqlite
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
560 %{_mandir}/man5/sqlite_table.5*
561 %endif
562
563 %files qshape
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/qshape
566 %{_mandir}/man1/qshape.1*
567
568 %files -n monit-rc-%{name}
569 %defattr(644,root,root,755)
570 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.065855 seconds and 3 git commands to generate.