]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- added rev-promote patch (should fix pango/gtk+2 upgrade problem, but needs testing)
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.6
14 Release:        10
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  21e4b2fa1695d95479e01fe82a4d84da
19 Source1:        %{name}.conf
20 Patch0:         %{name}-etc_dir.patch
21 Patch1:         %{name}-retr_term.patch
22 Patch2:         %{name}-simplestatic.patch
23 Patch3:         %{name}-pkgorder.patch
24 Patch4:         %{name}-sigsegv.patch
25 Patch5:         %{name}-caplookup.patch
26 Patch6:         %{name}-progress2.patch
27 Patch7:         %{name}-po.patch
28 Patch8:         %{name}-deps-fix.patch
29 Patch9:         %{name}-obsoletes_provides.patch
30 Patch10:        %{name}-rev-promote.patch
31 URL:            http://team.pld.org.pl/~mis/poldek/
32 BuildRequires:  automake
33 BuildRequires:  autoconf
34 BuildRequires:  bzip2-devel
35 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
36 BuildRequires:  db-devel >= %{ver_db}
37 BuildRequires:  gettext-autopoint
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  pcre-devel
40 BuildRequires:  popt-devel
41 BuildRequires:  readline-devel
42 BuildRequires:  rpm-devel >= %{ver_rpm}
43 BuildRequires:  zlib-devel
44 BuildRequires:  perl-tools-pod
45 %if %{with static}
46 BuildRequires:  bzip2-static
47 %{?with_curl:BuildRequires:     curl-static}
48 BuildRequires:  db-static >= %{ver_db}
49 BuildRequires:  glibc-static
50 BuildRequires:  libselinux-static
51 BuildRequires:  ncurses-static
52 BuildRequires:  openssl-static
53 BuildRequires:  pcre-static
54 BuildRequires:  popt-static
55 BuildRequires:  readline-static
56 BuildRequires:  rpm-static
57 BuildRequires:  zlib-static
58 %endif
59 Requires:       db >= %{ver_db}
60 Requires:       ed
61 Requires:       rpm >= %{ver_rpm}
62 Requires:       sed
63 Requires:       openssl >= 0.9.7c
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 poldek is an RPM package management tool which allows you to easily
68 perform package verification, installation (including system
69 installation from scratch), upgrading, and removal.
70
71 Program can be used in batch (like apt-get from Debian's APT) or
72 interactive mode. The interactive mode puts you into a readline
73 interface with command line autocompletion and history, similar to the
74 shell mode of Perl's CPAN.
75
76 %{?with_static:This version is statically linked.}
77
78 %{!?with_imode:This version hasn't got interactive mode.}
79
80 %description -l pl
81 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
82 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
83 usuwania pakietów.
84
85 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
86 interaktywnym. Tryb interaktywny posiada interfejs readline z
87 dope³nianiem komend i histori±, podobny do trybu shell perlowego
88 modu³u CPAN.
89
90 %{?with_static:Ta wersja jest konsolidowana statycznie.}
91
92 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p0
99 %patch3 -p0
100 %patch4 -p0
101 %patch5 -p0
102 %patch6 -p1
103 %patch7 -p1
104 %patch8 -p0
105 %patch9 -p0
106 %patch10 -p0
107
108 %build
109 %{__autopoint}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__automake}
113 cp -f config.sub trurlib
114 %configure \
115         %{?with_static:--enable-static} \
116         %{!?with_imode:--disable-imode} \
117         %{?with_curl:--with-curl}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_sysconfdir}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
128 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
129
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %triggerpostun -- poldek <= 0.18.3-5
136 if grep -q '^promoteepoch.*yes' /etc/poldek.conf ; then
137         echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s /etc/poldek.conf
138 fi
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc README* NEWS TODO *sample* conf/poldekrc*
143 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
144 %attr(755,root,root) %{_bindir}/*
145 %{_mandir}/man1/%{name}*
146 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.039892 seconds and 4 git commands to generate.