]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- added BR automake and autoconf
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18.1
11 Release:        1
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 URL:            http://team.pld.org.pl/~mis/poldek/
17 Requires:       rpm >= 4.0.2-62
18 Requires:       sed
19 BuildRequires:  bzip2-devel
20 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
21 BuildRequires:  automake
22 BuildRequires:  autoconf
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre-devel
25 BuildRequires:  popt-devel
26 BuildRequires:  readline-devel
27 BuildRequires:  rpm-devel >= 4.0.2-62
28 BuildRequires:  zlib-devel
29 BuildRequires:  /usr/bin/pod2man
30 %{?_with_static:BuildRequires:  bzip2-static}
31 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
32 %{?_with_static:BuildRequires:  openssl-static}
33 %{?_with_static:BuildRequires:  pcre-static}
34 %{?_with_static:BuildRequires:  popt-static}
35 %{?_with_static:BuildRequires:  rpm-static}
36 %{?_with_static:BuildRequires:  zlib-static}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 poldek is an RPM package management tool which allows you to easily
41 perform package verification, installation (including system
42 installation from scratch), upgrading, and removal.
43
44 Program can be used in batch (like apt-get from Debian's APT) or
45 interactive mode. The interactive mode puts you into a readline
46 interface with command line autocompletion and history, similar to the
47 shell mode of Perl's CPAN.
48
49 %{?_with_static:This version is statically linked.}
50
51 %{?_without_imode:This version hasn't got interactive mode.}
52
53 %description -l pl
54 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
55 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
56 i usuwania pakietów.
57
58 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
59 lub interaktywnym. Tryb interaktywny posiada interfejs readline
60 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
61 modu³u CPAN.
62
63 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
64
65 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
66
67 %prep
68 %setup -q
69
70 %build
71 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
72         cp configure.in configure.in.orig
73         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
74 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
75                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
76                 configure.in.orig >configure.in
77         autopoint --force
78 fi
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         %{?_with_static:--enable-static} \
84         %{?_without_imode:--disable-imode} \
85         %{?_with_curl:--with-curl}
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_sysconfdir}
91
92 # no strip cause program's beta stage and core may be useful
93 %{__make} install DESTDIR=$RPM_BUILD_ROOT
94 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
95 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
96
97 %find_lang %{name}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files -f %{name}.lang
103 %defattr(644,root,root,755)
104 %doc README* NEWS TODO *sample* conf/poldekrc*
105 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
106 %attr(755,root,root) %{_bindir}/*
107 %{_mandir}/man1/%{name}*
108 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.044193 seconds and 4 git commands to generate.