]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- builds and seems to work fine with rpm 4.4.9
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.3.27-1
9 %define ver_rpm 4.4.8
10 %define snap 20070108.22
11 Summary:        RPM packages management helper tool
12 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
13 Name:           poldek
14 Version:        0.20.1
15 Release:        0.20070108.1.5
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
19 # Source0-md5:  47025233d8ebb7082567cbf1392cf16f
20 Source1:        %{name}.conf
21 Source2:        %{name}-multilib.conf
22 Source3:        %{name}-aliases.conf
23 Patch1:         %{name}-vserver-packages.patch
24 Patch2:         %{name}-config.patch
25 Patch3:         %{name}-multilib.patch
26 Patch4:         %{name}-configure_in.patch
27 Patch5:         %{name}-rpm-4.4.8.patch
28 Patch6:         %{name}-rpm-4.4.9.patch
29 URL:            http://poldek.pld-linux.org/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 BuildRequires:  check
34 BuildRequires:  db-devel >= %{ver_db}
35 BuildRequires:  gettext-autopoint
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  pcre-devel
40 BuildRequires:  perl-tools-pod
41 BuildRequires:  popt-devel
42 %{?with_python:BuildRequires:   python-devel}
43 BuildRequires:  readline-devel >= 5.0
44 BuildRequires:  rpm-devel >= %{ver_rpm}
45 %{?with_python:BuildRequires:   rpm-pythonprov}
46 BuildRequires:  xmlto
47 BuildRequires:  zlib-devel
48 %if %{with static}
49 BuildRequires:  bzip2-static
50 BuildRequires:  db-static >= %{ver_db}
51 BuildRequires:  glibc-static
52 BuildRequires:  libselinux-static
53 BuildRequires:  libxml2-static
54 BuildRequires:  ncurses-static
55 BuildRequires:  openssl-static
56 BuildRequires:  pcre-static
57 BuildRequires:  popt-static
58 BuildRequires:  readline-static
59 BuildRequires:  rpm-static
60 BuildRequires:  zlib-static
61 %endif
62 Requires(triggerpostun):        awk
63 Requires(triggerpostun):        sed >= 4.0
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       db >= %{ver_db}
66 Requires:       rpm >= %{ver_rpm}
67 Requires:       sed
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 poldek is an RPM package management tool which allows you to easily
72 perform package verification, installation (including system
73 installation from scratch), upgrading, and removal.
74
75 Program can be used in batch (like apt-get from Debian's APT) or
76 interactive mode. The interactive mode puts you into a readline
77 interface with command line autocompletion and history, similar to the
78 shell mode of Perl's CPAN.
79
80 %{?with_static:This version is statically linked.}
81
82 %{!?with_imode:This version hasn't got interactive mode.}
83 #'vim
84
85 %description -l pl.UTF-8
86 poldek jest narzędziem linii poleceń służącym do weryfikacji,
87 instalacji (włączając instalację systemu od zera), aktualizacji i
88 usuwania pakietów.
89
90 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
91 interaktywnym. Tryb interaktywny posiada interfejs readline z
92 dopełnianiem komend i historią, podobny do trybu shell perlowego
93 modułu CPAN.
94
95 %{?with_static:Ta wersja jest konsolidowana statycznie.}
96
97 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
98
99 %package libs
100 Summary:        poldek libraries
101 Summary(pl.UTF-8):      Biblioteki poldka
102 Group:          Libraries
103
104 %description libs
105 poldek libraries.
106
107 %description libs -l pl.UTF-8
108 Biblioteki poldka.
109
110 %package devel
111 Summary:        Header files for poldek libraries
112 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
113 Group:          Development/Libraries
114 Requires:       %{name}-libs = %{version}-%{release}
115
116 %description devel
117 Header files for poldek libraries.
118
119 %description devel -l pl.UTF-8
120 Pliki nagłówkowe bibliotek poldka.
121
122 %package static
123 Summary:        poldek static libraries
124 Summary(pl.UTF-8):      Biblioteki statyczne poldka
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127
128 %description static
129 poldek static libraries.
130
131 %description static -l pl.UTF-8
132 Biblioteki statyczne poldka.
133
134 %package -n python-poldek
135 Summary:        Python modules for poldek
136 Summary(pl.UTF-8):      Moduły języka Python dla poldka
137 Group:          Libraries/Python
138 Requires:       %{name}-libs = %{version}-%{release}
139 %pyrequires_eq  python-libs
140
141 %description -n python-poldek
142 Python modules for poldek.
143
144 %description -n python-poldek -l pl.UTF-8
145 Moduły języka Python dla poldka.
146
147 %prep
148 %setup -q -n %{name}-%{version}%{?snap:-cvs%{snap}}
149 %patch1 -p1
150 %patch2 -p1
151 %ifarch %{x8664}
152 %patch3 -p1
153 %endif
154 %patch4 -p1
155 %patch5 -p1
156 %patch6 -p1
157
158 %build
159 %{__autopoint}
160 %{__aclocal} -I m4
161 %{__autoconf}
162 %{__automake}
163 cp -f config.sub trurlib
164
165 %configure \
166         %{?with_static:--enable-static --disable-shared} \
167         %{!?with_imode:--disable-imode} \
168         --enable-nls \
169         %{?with_python:--with-python}
170 %{__make}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT%{_sysconfdir}
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 %if %{with python}
180 %{__make} -C python install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         libdir=%{py_sitedir}
183 %endif
184
185 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
186
187 %ifarch i486 i686 ppc sparc alpha athlon
188 %define         _ftp_arch       %{_target_cpu}
189 %else
190 %ifarch %{x8664}
191 %define         _ftp_arch       x86_64
192 %define         _ftp_alt_arch   i686
193 %else
194 %ifarch i586
195 %define         _ftp_arch       i486
196 %else
197 %ifarch pentium2 pentium3 pentium4
198 %define         _ftp_arch       i686
199 %else
200 %ifarch sparcv9 sparc64
201 %define         _ftp_arch       sparc
202 %endif
203 %endif
204 %endif
205 %endif
206 %endif
207
208 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
209
210 sed -e '
211         s|%%ARCH%%|%{_ftp_arch}|g
212 ' < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/pld-source.conf
213
214 %ifarch %{x8664}
215 sed '
216         s|%%ARCH%%|%{_ftp_alt_arch}|g
217 ' < %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/pld-multilib-source.conf
218 %endif
219
220 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/aliases.conf
221
222 # get rid of non-pld sources
223 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora}-source.conf
224 # include them in %doc
225 rm -rf configs
226 cp -a conf configs
227 rm -f configs/Makefile*
228
229 %if %{with python}
230 %py_postclean
231 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
232 %endif
233
234 %find_lang %{name}
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %post
240 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
241
242 %postun
243 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
244
245 %post   libs -p /sbin/ldconfig
246 %postun libs -p /sbin/ldconfig
247
248 %triggerpostun -- poldek <= 0.18.3-5
249 if [ -f /etc/poldek.conf ]; then
250         sed -i -e '/^promoteepoch:.*yes/s/^/#/' /etc/poldek.conf
251 fi
252
253 # otherwise don't touch
254 %ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
255 %triggerpostun -- poldek <= 0.18.7-1
256 if [ -f /etc/poldek.conf ]; then
257         sed -i -e 's://ftp.pld-linux.org://ftp.ac.pld-linux.org:g' /etc/poldek.conf
258 fi
259 %endif
260
261 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
262 if [ -f /etc/poldek.conf.rpmsave ]; then
263         awk '/^source/ {
264         name = $3;
265         path = $4;
266         auto = "yes";
267         autoup = "yes";
268         type = "pdir";
269         pri = "";
270
271         if (sub(",noauto", "", name)) {
272                 auto = "no";
273         }
274
275         # process pri=\d+
276         if (match(name, /,pri=[0-9]+/)) {
277                 pri = substr(name, RSTART + 5, RLENGTH - 5);
278                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
279         }
280
281         # skip ac sources. already in new config.
282         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
283                 print "";
284                 print "[source]";
285                 print "name = " name;
286                 print "type = " type;
287                 print "path = " path;
288                 print "auto = " auto;
289                 print "autoup = " autoup;
290                 if (pri) {
291                         print "pri = " pri;
292                 }
293         }
294
295         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
296         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
297
298         # copy hold=
299         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
300         if [ "$hold" ]; then
301                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
302         fi
303 fi
304
305 %files -f %{name}.lang
306 %defattr(644,root,root,755)
307 %doc README* NEWS TODO configs/
308 %dir %{_sysconfdir}/%{name}
309 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
310 %attr(755,root,root) %{_bindir}/*
311 %dir %{_libdir}/%{name}
312 %attr(755,root,root) %{_libdir}/%{name}/*
313 %{_mandir}/man1/%{name}*
314 %lang(pl) %{_mandir}/pl/man1/%{name}*
315 %{_infodir}/poldek.info*
316
317 %if !%{with static}
318 %files libs
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
321 %endif
322
323 %files devel
324 %defattr(644,root,root,755)
325 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
326 %{_libdir}/lib*.la
327 %{_includedir}/*
328
329 %files static
330 %defattr(644,root,root,755)
331 %{_libdir}/lib*.a
332
333 %if %{with python}
334 %files -n python-poldek
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
337 %{py_sitescriptdir}/poldek.py[co]
338 %{py_sitescriptdir}/poldekmod.py[co]
339 %endif
This page took 0.061615 seconds and 4 git commands to generate.