]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
fix buildrequires
[packages/poldek.git] / poldek.spec
1 Summary:        RPM packages management helper tool
2 Name:           poldek
3 Version:        0.12
4 Release:        1
5 License:        GPL
6 Group:          Applications/System
7 Group(de):      Applikationen/System
8 Group(pl):      Aplikacje/System
9 Source0:        %{name}-%{version}.tar.gz
10 Requires:       /bin/rpm
11 BuildRequires:  db3-devel >= 3.1.14-2
12 BuildRequires:  rpm-devel >= 3.0.5
13 BuildRequires:  zlib-static
14 BuildRequires:  bzip2-static
15 BuildRequires:  /usr/bin/pod2man
16 BuildRequires:  trurlib-devel >= 0.43.1
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 poldek is a cmdline tool which can be used to verify, install and
21 upgrade given package sets.
22
23 %if %{?BOOT:1}%{!?BOOT:0}
24 %package BOOT
25 Summary:        poldek for bootdisk
26 Group:          Applications/System
27
28 %description BOOT
29 %endif
30
31 %prep 
32 %setup -q 
33
34 %build
35 %if %{?BOOT:1}%{!?BOOT:0}
36 %configure --enable-static --disable-imode
37 %{__make}
38 mv -f %{name} %{name}-BOOT
39 mv -f rpmvercmp rpmvercmp-BOOT
40 %{__make} clean
41 %endif
42
43 %configure 
44 %{__make} 
45
46 #CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O0 -g}" all
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %if %{?BOOT:1}%{!?BOOT:0}
52 install -d $RPM_BUILD_ROOT/usr/lib/bootdisk/sbin
53 install -s %{name}-BOOT $RPM_BUILD_ROOT/usr/lib/bootdisk/sbin/%{name}
54 install -s rpmvercmp-BOOT $RPM_BUILD_ROOT/usr/lib/bootdisk/sbin/rpmvercmp
55 %endif
56
57 # no strip cause program's alpha stage and core may be useful
58 %{__make} install DESTDIR=$RPM_BUILD_ROOT
59
60 gzip -9nf README* *sample* poldek.1
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_bindir}/*
68 %{_mandir}/man1/%{name}*
69 %doc README* *sample*
70
71 %if %{?BOOT:1}%{!?BOOT:0}
72 %files BOOT
73 %defattr(644,root,root,755)
74 %attr(755,root,root) /usr/lib/bootdisk/sbin/poldek
75 %endif
This page took 0.054003 seconds and 4 git commands to generate.