]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- allow proxy to cache data
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.1
14 Release:        19
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  8af8090d401254939911e456e2f09e60
19 Source1:        %{name}.conf
20 Patch0:         %{name}-static.patch
21 Patch1:         %{name}-etc_dir.patch
22 Patch2:         %{name}-rpm4.2.patch
23 Patch3:         %{name}-rpm4.1-fix.patch
24 Patch4:         %{name}-retr_term.patch
25 Patch5:         %{name}-deps-fix.patch
26 Patch6:         %{name}-broken-rpmdb.patch
27 Patch7:         %{name}-epoch0.patch
28 Patch8:         %{name}-ldb4.patch
29 Patch9:         %{name}-unaligned.patch
30 Patch10:        %{name}-be-nice-for-proxy.patch
31 URL:            http://team.pld.org.pl/~mis/poldek/
32 BuildRequires:  automake
33 BuildRequires:  autoconf
34 BuildRequires:  bzip2-devel
35 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
36 BuildRequires:  db-devel >= %{ver_db}
37 BuildRequires:  gettext-autopoint
38 BuildRequires:  openssl-devel >= 0.9.7c
39 BuildRequires:  pcre-devel
40 BuildRequires:  popt-devel
41 BuildRequires:  readline-devel
42 BuildRequires:  rpm-devel >= %{ver_rpm}
43 BuildRequires:  zlib-devel
44 BuildRequires:  perl-tools-pod
45 %if %{with static}
46 BuildRequires:  bzip2-static
47 %{?with_curl:BuildRequires:     curl-static}
48 BuildRequires:  db-static >= %{ver_db}
49 BuildRequires:  ncurses-static
50 BuildRequires:  openssl-static
51 BuildRequires:  pcre-static
52 BuildRequires:  popt-static
53 BuildRequires:  readline-static
54 BuildRequires:  rpm-static
55 BuildRequires:  zlib-static
56 BuildRequires:  glibc-static
57 %endif
58 Requires:       db >= %{ver_db}
59 Requires:       rpm >= %{ver_rpm}
60 Requires:       sed
61 Requires:       openssl >= 0.9.7c
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 poldek is an RPM package management tool which allows you to easily
66 perform package verification, installation (including system
67 installation from scratch), upgrading, and removal.
68
69 Program can be used in batch (like apt-get from Debian's APT) or
70 interactive mode. The interactive mode puts you into a readline
71 interface with command line autocompletion and history, similar to the
72 shell mode of Perl's CPAN.
73
74 %{?with_static:This version is statically linked.}
75
76 %{!?with_imode:This version hasn't got interactive mode.}
77
78 %description -l pl
79 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
80 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
81 usuwania pakietów.
82
83 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
84 interaktywnym. Tryb interaktywny posiada interfejs readline z
85 dope³nianiem komend i histori±, podobny do trybu shell perlowego
86 modu³u CPAN.
87
88 %{?with_static:Ta wersja jest konsolidowana statycznie.}
89
90 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p0
98 %patch4 -p1
99 %patch5 -p0
100 %patch6 -p1
101 %patch7 -p1
102 %patch8 -p1
103 %patch9 -p1
104 %patch10 -p1
105
106 %build
107 %{__autopoint}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         %{?with_static:--enable-static} \
113         %{!?with_imode:--disable-imode} \
114         %{?with_curl:--with-curl}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_sysconfdir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
125 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files -f %{name}.lang
133 %defattr(644,root,root,755)
134 %doc README* NEWS TODO *sample* conf/poldekrc*
135 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
136 %attr(755,root,root) %{_bindir}/*
137 %{_mandir}/man1/%{name}*
138 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.043422 seconds and 4 git commands to generate.