]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- from DEVEL
[packages/poldek.git] / poldek.spec
1 # conditional build
2 #  --with static   -- don't use shared libraries
3 #  --without imode -- don't build interactive mode
4 #  --without curl  -- don't link curl
5 Summary:        RPM packages management helper tool
6 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
7 Name:           poldek
8 Version:        0.17.9rpm4
9 Release:        2
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
13 Source1:        %{name}.conf
14 URL:            http://team.pld.org.pl/~mis/poldek/
15 Requires:       rpm >= 4.1
16 Requires:       sed
17 BuildRequires:  bzip2-devel
18 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
19 BuildRequires:  db-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  pcre-devel
22 BuildRequires:  popt-devel
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm-devel >= 4.1
25 BuildRequires:  zlib-devel
26 BuildRequires:  /usr/bin/pod2man
27 %{?_with_static:BuildRequires:  bzip2-static}
28 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
29 %{?_with_static:BuildRequires:  openssl-static}
30 %{?_with_static:BuildRequires:  pcre-static}
31 %{?_with_static:BuildRequires:  popt-static}
32 %{?_with_static:BuildRequires:  rpm-static}
33 %{?_with_static:BuildRequires:  zlib-static}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 poldek is an RPM package management tool which allows you to easily
38 perform package verification, installation (including system
39 installation from scratch), upgrading, and removal.
40
41 Program can be used in batch (like apt-get from Debian's APT) or
42 interactive mode. The interactive mode puts you into a readline
43 interface with command line autocompletion and history, similar to the
44 shell mode of Perl's CPAN.
45
46 %{?_with_static:This version is statically linked.}
47
48 %{?_without_imode:This version hasn't got interactive mode.}
49
50 %description -l pl
51 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
52 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
53 i usuwania pakietów.
54
55 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
56 lub interaktywnym. Tryb interaktywny posiada interfejs readline
57 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
58 modu³u CPAN.
59
60 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
61
62 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
63
64 %prep
65 %setup -q
66
67 %build
68 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
69         cp configure.in configure.in.orig
70         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
71 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
72                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
73                 configure.in.orig >configure.in
74         autopoint --force
75 fi
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__automake}
79 %configure \
80         %{?_with_static:--enable-static} \
81         %{?_without_imode:--disable-imode} \
82         %{?_with_curl:--with-curl}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_sysconfdir}
88
89 # no strip cause program's beta stage and core may be useful
90 %{__make} install DESTDIR=$RPM_BUILD_ROOT
91 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
92 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
93
94 %find_lang %{name}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc README* NEWS TODO *sample* conf/poldekrc*
102 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
103 %attr(755,root,root) %{_bindir}/*
104 %{_mandir}/man1/%{name}*
This page took 0.034287 seconds and 3 git commands to generate.