]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
9513e64351ca8d16030cab83f38864a1172c452c
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc2
20 %define         rel     2
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        0.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  14135ae2960da09990c50d5b5342be64
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         ac-prog-libtool.patch
47 Patch4:         %{name}-Os-fail-workaround.patch
48 URL:            http://poldek.pld-linux.org/
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  bzip2-devel
52 BuildRequires:  check-devel
53 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
54 BuildRequires:  docbook-dtd412-xml
55 BuildRequires:  gettext-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel
58 BuildRequires:  neon-devel
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  popt-devel
63 %{?with_python:BuildRequires:   python-devel}
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-devel >= %{ver_rpm}
66 %{?with_python:BuildRequires:   rpm-pythonprov}
67 BuildRequires:  swig-python
68 BuildRequires:  zlib-devel
69 %if %{with static}
70 BuildRequires:  bzip2-static
71 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
72 BuildRequires:  glibc-static
73 BuildRequires:  libselinux-static
74 BuildRequires:  libxml2-static
75 BuildRequires:  ncurses-static
76 BuildRequires:  openssl-static
77 BuildRequires:  pcre-static
78 BuildRequires:  popt-static
79 BuildRequires:  readline-static
80 BuildRequires:  rpm-static
81 BuildRequires:  zlib-static
82 %endif
83 Requires(triggerpostun):        awk
84 Requires(triggerpostun):        sed >= 4.0
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       db >= %{ver_db}-%{ver_db_rel}
87 Requires:       rpm >= %{ver_rpm}
88 Requires:       rpm-db-ver = %{ver_db}
89 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
90 # vf* scripts use sed
91 Requires:       sed
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %description
95 poldek is an RPM package management tool which allows you to easily
96 perform package verification, installation (including system
97 installation from scratch), upgrading, and removal.
98
99 Program can be used in batch (like apt-get from Debian's APT) or
100 interactive mode. The interactive mode puts you into a readline
101 interface with command line autocompletion and history, similar to the
102 shell mode of Perl's CPAN.
103
104 %{?with_static:This version is statically linked.}
105
106 %{!?with_imode:This version hasn't got interactive mode.}
107 #'vim
108
109 %description -l hu.UTF-8
110 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
111 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
112 nulláról), frissítést és eltávolítást.
113
114 A program használható parancssorból (mint a Debian apt-get programja)
115 vagy interaktív módban. Az interaktív mód egy readline környezetet
116 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
117 shell módjához.
118
119 %{?with_static:Ez a verzió statikusan linkelt.}
120
121 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
122
123 %description -l pl.UTF-8
124 poldek jest narzędziem linii poleceń służącym do weryfikacji,
125 instalacji (włączając instalację systemu od zera), aktualizacji i
126 usuwania pakietów.
127
128 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
129 interaktywnym. Tryb interaktywny posiada interfejs readline z
130 dopełnianiem komend i historią, podobny do trybu shell perlowego
131 modułu CPAN.
132
133 %{?with_static:Ta wersja jest konsolidowana statycznie.}
134
135 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
136
137 %package libs
138 Summary:        poldek libraries
139 Summary(hu.UTF-8):      A poldek könyvtárai
140 Summary(pl.UTF-8):      Biblioteki poldka
141 Group:          Libraries
142
143 %description libs
144 poldek libraries.
145
146 %description libs -l hu.UTF-8
147 A poldek könyvtárai.
148
149 %description libs -l pl.UTF-8
150 Biblioteki poldka.
151
152 %package devel
153 Summary:        Header files for poldek libraries
154 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
155 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
156 Group:          Development/Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158 Requires:       rpm-devel >= %{ver_rpm}
159
160 %description devel
161 Header files for poldek libraries.
162
163 %description devel -l hu.UTF-8
164 A poldek könyvtár fejlesztői fájljai.
165
166 %description devel -l pl.UTF-8
167 Pliki nagłówkowe bibliotek poldka.
168
169 %package static
170 Summary:        poldek static libraries
171 Summary(hu.UTF-8):      poldek statikus könyvtárak
172 Summary(pl.UTF-8):      Biblioteki statyczne poldka
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175
176 %description static
177 poldek static libraries.
178
179 %description static -l hu.UTF-8
180 poldek statikus könyvtárak.
181
182 %description static -l pl.UTF-8
183 Biblioteki statyczne poldka.
184
185 %package -n python-poldek
186 Summary:        Python modules for poldek
187 Summary(hu.UTF-8):      Python modulok poldek-hez
188 Summary(pl.UTF-8):      Moduły języka Python dla poldka
189 Group:          Libraries/Python
190 Requires:       %{name}-libs = %{version}-%{release}
191 %pyrequires_eq  python-libs
192
193 %description -n python-poldek
194 Python modules for poldek.
195
196 %description -n python-poldek -l hu.UTF-8
197 Python modulok poldek-hez.
198
199 %description -n python-poldek -l pl.UTF-8
200 Moduły języka Python dla poldka.
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207 #%patch3 -p1
208 %patch4 -p1
209
210 rm -f m4/libtool.m4 m4/lt*.m4
211
212 # cleanup backups after patching
213 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
214 chmod u+x ./configure ./doc/conf-xml2.sh
215
216 %build
217 %{__libtoolize}
218 %{__aclocal} -I m4
219 %{__autoheader}
220 %{__autoconf}
221 %{__automake}
222 cp -f config.sub trurlib
223
224 CPPFLAGS="-std=gnu99"
225 %configure \
226         %{?with_static:--enable-static --disable-shared} \
227         %{!?with_imode:--disable-imode} \
228         --enable-nls \
229         %{?with_python:--with-python}
230 %{__make}
231 #       --enable-trace
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
236
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT
239
240 %if %{with python}
241 %{__make} -C python install \
242         DESTDIR=$RPM_BUILD_ROOT \
243         libdir=%{py_sitedir}
244 %endif
245
246 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
247
248 %ifarch i486 i686 ppc sparc alpha athlon
249         %define         _ftp_arch       %{_target_cpu}
250 %endif
251 %ifarch %{x8664}
252         %define         _ftp_arch       x86_64
253         %define         _ftp_alt_arch   i686
254 %endif
255 %ifarch i586
256         %if "%{pld_release}" == "ti"
257                 %define         _ftp_arch       i586
258         %else
259                 %define         _ftp_arch       i486
260         %endif
261 %endif
262 %ifarch pentium2 pentium3 pentium4
263         %define         _ftp_arch       i686
264 %endif
265 %ifarch sparcv9 sparc64
266         %define         _ftp_arch       sparc
267         %if "%{pld_release}" == "th"
268                 %define         _ftp_arch       %{_target_cpu}
269                 %ifarch sparc64
270                 %define         _ftp_alt_arch   sparcv9
271                 %endif
272         %endif
273 %endif
274
275 %if "%{pld_release}" == "ti"
276         %define pld_conf %{SOURCE3}
277         %ifarch %{x8664}
278                 %define pld_multilib_conf %{SOURCE4}
279         %endif
280 %endif
281
282 %if "%{pld_release}" == "th"
283         %define pld_conf %{SOURCE1}
284         %define pld_debuginfo_conf %{SOURCE8}
285         %define pld_archive_conf %{SOURCE11}
286
287         %ifarch %{x8664}
288                 %define pld_multilib_conf %{SOURCE2}
289         %endif
290
291         # aidath
292         %ifarch sparcv9 sparc64
293                 %define pld_conf %{SOURCE9}
294                 %undefine pld_archive_conf
295         %endif
296         %ifarch sparc64
297                 %define pld_multilib_conf %{SOURCE10}
298         %endif
299 %endif
300
301 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
302
303 %if 0%{?pld_multilib_conf:1}
304         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
305 %endif
306
307 %if 0%{?pld_debuginfo_conf:1}
308 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
309 %endif
310
311 %if 0%{?pld_archive_conf:1}
312 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
313 %endif
314
315 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
316
317 %if %{with imode}
318 # add desktop file and icon
319 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
320 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
321 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
322 %endif
323
324 # sources we don't package
325 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
326 # include them in %doc
327 rm -rf configs
328 cp -a conf configs
329 rm -f configs/Makefile*
330
331 %if %{with python}
332 %py_postclean
333 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
334 %endif
335
336 %find_lang %{name}
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 %post
342 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
343 if [ "$1" = "1" ]; then
344         # remove ignore = vserver-packages inside vserver on first install
345         {
346                 while read f ctx; do
347                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
348                 done </proc/self/status
349         } 2>/dev/null
350         if [ -z "$ctx" -o "$ctx" = "0" ]; then
351                 VSERVER=no
352         else
353                 VSERVER=yes
354         fi
355         if [ "$VSERVER" = "yes" ]; then
356                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
357         fi
358 fi
359
360 %postun -p      /sbin/postshell
361 -/usr/sbin/fix-info-dir -c %{_infodir}
362
363 %post   libs -p /sbin/ldconfig
364 %postun libs -p /sbin/ldconfig
365
366 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
367 if [ -f /etc/poldek.conf.rpmsave ]; then
368         awk '/^source/ {
369         name = $3;
370         path = $4;
371         auto = "yes";
372         autoup = "yes";
373         type = "pdir";
374         pri = "";
375
376         if (sub(",noauto", "", name)) {
377                 auto = "no";
378         }
379
380         # process pri=\d+
381         if (match(name, /,pri=[0-9]+/)) {
382                 pri = substr(name, RSTART + 5, RLENGTH - 5);
383                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
384         }
385
386         # skip ac sources. already in new config.
387         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
388                 print "";
389                 print "[source]";
390                 print "name = " name;
391                 print "type = " type;
392                 print "path = " path;
393                 print "auto = " auto;
394                 print "autoup = " autoup;
395                 if (pri) {
396                         print "pri = " pri;
397                 }
398         }
399
400         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
401         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
402
403         # copy hold=
404         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
405         if [ "$hold" ]; then
406                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
407         fi
408 fi
409
410 %triggerpostun -- poldek < 0.30-0.20080225.00.1
411 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
412         %{__sed} -i -e '/^%%include source.conf/{
413                 a
414                 a# /etc/poldek/repos.d/*.conf
415                 a%%includedir repos.d
416         }' %{_sysconfdir}/%{name}/poldek.conf
417 fi
418
419 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
420 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
421
422 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
423         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
424         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
425 fi
426
427 %ifarch %{x8664}
428 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
429         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
430         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
431 fi
432 %endif
433
434 %files -f %{name}.lang
435 %defattr(644,root,root,755)
436 %doc ChangeLog README* NEWS TODO configs
437 %dir %{_sysconfdir}/%{name}
438 %dir %{_sysconfdir}/%{name}/repos.d
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
441 %attr(755,root,root) %{_bindir}/*
442 %dir %{_libdir}/%{name}
443 %attr(755,root,root) %{_libdir}/%{name}/*
444 %{_mandir}/man1/%{name}*
445 %lang(pl) %{_mandir}/pl/man1/%{name}*
446 %{_infodir}/poldek.info*
447 %if %{with imode}
448 %{_desktopdir}/%{name}.desktop
449 %{_pixmapsdir}/%{name}.png
450 %endif
451
452 %if %{without static}
453 %files libs
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
456 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
457 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
458 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
459 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
461 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
462 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
463 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
464 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
465 %endif
466
467 %files devel
468 %defattr(644,root,root,755)
469 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
470 %{_libdir}/lib*.la
471 %{_includedir}/*
472
473 %files static
474 %defattr(644,root,root,755)
475 %{_libdir}/lib*.a
476
477 %if %{with python}
478 %files -n python-poldek
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
481 %{py_sitescriptdir}/poldek.py[co]
482 %{py_sitescriptdir}/poldekmod.py[co]
483 %endif
This page took 0.092441 seconds and 2 git commands to generate.