]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- fixes cosmetic bug of progress bar
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18
11 Release:        1
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 URL:            http://team.pld.org.pl/~mis/poldek/
17 Requires:       rpm >= 4.0.2-62
18 Requires:       sed
19 BuildRequires:  bzip2-devel
20 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
21 BuildRequires:  openssl-devel
22 BuildRequires:  pcre-devel
23 BuildRequires:  popt-devel
24 BuildRequires:  readline-devel
25 BuildRequires:  rpm-devel >= 4.0.2-62
26 BuildRequires:  zlib-devel
27 BuildRequires:  /usr/bin/pod2man
28 %{?_with_static:BuildRequires:  bzip2-static}
29 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
30 %{?_with_static:BuildRequires:  openssl-static}
31 %{?_with_static:BuildRequires:  pcre-static}
32 %{?_with_static:BuildRequires:  popt-static}
33 %{?_with_static:BuildRequires:  rpm-static}
34 %{?_with_static:BuildRequires:  zlib-static}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 poldek is an RPM package management tool which allows you to easily
39 perform package verification, installation (including system
40 installation from scratch), upgrading, and removal.
41
42 Program can be used in batch (like apt-get from Debian's APT) or
43 interactive mode. The interactive mode puts you into a readline
44 interface with command line autocompletion and history, similar to the
45 shell mode of Perl's CPAN.
46
47 %{?_with_static:This version is statically linked.}
48
49 %{?_without_imode:This version hasn't got interactive mode.}
50
51 %description -l pl
52 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
53 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
54 i usuwania pakietów.
55
56 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
57 lub interaktywnym. Tryb interaktywny posiada interfejs readline
58 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
59 modu³u CPAN.
60
61 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
62
63 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
64
65 %prep
66 %setup -q
67
68 %build
69 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
70         cp configure.in configure.in.orig
71         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
72 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
73                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
74                 configure.in.orig >configure.in
75         autopoint --force
76 fi
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         %{?_with_static:--enable-static} \
82         %{?_without_imode:--disable-imode} \
83         %{?_with_curl:--with-curl}
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_sysconfdir}
89
90 # no strip cause program's beta stage and core may be useful
91 %{__make} install DESTDIR=$RPM_BUILD_ROOT
92 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
93 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
94
95 %find_lang %{name}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc README* NEWS TODO *sample* conf/poldekrc*
103 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
104 %attr(755,root,root) %{_bindir}/*
105 %{_mandir}/man1/%{name}*
106 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.053809 seconds and 3 git commands to generate.