]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- added epoch0 patch (follow rpm 4.2.1+: no Epoch means Epoch 0)
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18.1
11 Release:        13
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 # Source0-md5:  8af8090d401254939911e456e2f09e60
16 Source1:        %{name}.conf
17 Patch0:         %{name}-static.patch
18 Patch1:         %{name}-etc_dir.patch
19 Patch2:         %{name}-rpm4.2.patch
20 Patch3:         %{name}-rpm4.1-fix.patch
21 Patch4:         %{name}-retr_term.patch
22 Patch5:         %{name}-deps-fix.patch
23 Patch6:         %{name}-broken-rpmdb.patch
24 Patch7:         %{name}-epoch0.patch
25 URL:            http://team.pld.org.pl/~mis/poldek/
26 BuildRequires:  bzip2-devel
27 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
28 BuildRequires:  automake
29 BuildRequires:  autoconf
30 BuildRequires:  gettext-autopoint
31 BuildRequires:  openssl-devel >= 0.9.7c
32 BuildRequires:  pcre-devel
33 BuildRequires:  popt-devel
34 BuildRequires:  readline-devel
35 BuildRequires:  rpm-devel >= 4.2.1
36 BuildRequires:  zlib-devel
37 BuildRequires:  /usr/bin/pod2man
38 %{?with_static:BuildRequires:   bzip2-static}
39 %{?with_curl:%{?with_static:BuildRequires:      curl-static}}
40 %{?with_static:BuildRequires:   ncurses-static}
41 %{?with_static:BuildRequires:   openssl-static}
42 %{?with_static:BuildRequires:   pcre-static}
43 %{?with_static:BuildRequires:   popt-static}
44 %{?with_static:BuildRequires:   readline-static}
45 %{?with_static:BuildRequires:   rpm-static}
46 %{?with_static:BuildRequires:   zlib-static}
47 %{?with_static:BuildRequires:   glibc-static}
48 Requires:       rpm >= 4.2.1
49 Requires:       sed
50 Requires:       openssl >= 0.9.7c
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 poldek is an RPM package management tool which allows you to easily
55 perform package verification, installation (including system
56 installation from scratch), upgrading, and removal.
57
58 Program can be used in batch (like apt-get from Debian's APT) or
59 interactive mode. The interactive mode puts you into a readline
60 interface with command line autocompletion and history, similar to the
61 shell mode of Perl's CPAN.
62
63 %{?with_static:This version is statically linked.}
64
65 %{!?with_imode:This version hasn't got interactive mode.}
66
67 %description -l pl
68 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
69 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
70 usuwania pakietów.
71
72 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
73 interaktywnym. Tryb interaktywny posiada interfejs readline z
74 dope³nianiem komend i histori±, podobny do trybu shell perlowego
75 modu³u CPAN.
76
77 %{?with_static:Ta wersja jest konsolidowana statycznie.}
78
79 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p0
87 %patch4 -p1
88 %patch5 -p0
89 %patch6 -p1
90 %patch7 -p1
91
92 %build
93 %{__autopoint}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         %{?with_static:--enable-static} \
99         %{!?with_imode:--disable-imode} \
100         %{?with_curl:--with-curl}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_sysconfdir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
111 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc README* NEWS TODO *sample* conf/poldekrc*
121 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
122 %attr(755,root,root) %{_bindir}/*
123 %{_mandir}/man1/%{name}*
124 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.056599 seconds and 3 git commands to generate.