]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- removed outdated patches, added cap_match_req-fix patch from author
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.3
14 Release:        6
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
18 # Source0-md5:  339c54b86bfd733851c0f7125057f446
19 Source1:        %{name}.conf
20 Patch0:         %{name}-etc_dir.patch
21 Patch1:         %{name}-retr_term.patch
22 Patch2:         %{name}-cap_match_req-fix.patch
23 URL:            http://team.pld.org.pl/~mis/poldek/
24 BuildRequires:  automake
25 BuildRequires:  autoconf
26 BuildRequires:  bzip2-devel
27 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
28 BuildRequires:  db-devel >= %{ver_db}
29 BuildRequires:  gettext-autopoint
30 BuildRequires:  openssl-devel >= 0.9.7c
31 BuildRequires:  pcre-devel
32 BuildRequires:  popt-devel
33 BuildRequires:  readline-devel
34 BuildRequires:  rpm-devel >= %{ver_rpm}
35 BuildRequires:  zlib-devel
36 BuildRequires:  perl-tools-pod
37 %if %{with static}
38 BuildRequires:  bzip2-static
39 %{?with_curl:BuildRequires:     curl-static}
40 BuildRequires:  db-static >= %{ver_db}
41 BuildRequires:  ncurses-static
42 BuildRequires:  openssl-static
43 BuildRequires:  pcre-static
44 BuildRequires:  popt-static
45 BuildRequires:  readline-static
46 BuildRequires:  rpm-static
47 BuildRequires:  zlib-static
48 BuildRequires:  glibc-static
49 %endif
50 Requires:       db >= %{ver_db}
51 Requires:       ed
52 Requires:       rpm >= %{ver_rpm}
53 Requires:       sed
54 Requires:       openssl >= 0.9.7c
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 poldek is an RPM package management tool which allows you to easily
59 perform package verification, installation (including system
60 installation from scratch), upgrading, and removal.
61
62 Program can be used in batch (like apt-get from Debian's APT) or
63 interactive mode. The interactive mode puts you into a readline
64 interface with command line autocompletion and history, similar to the
65 shell mode of Perl's CPAN.
66
67 %{?with_static:This version is statically linked.}
68
69 %{!?with_imode:This version hasn't got interactive mode.}
70
71 %description -l pl
72 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
73 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
74 usuwania pakietów.
75
76 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
77 interaktywnym. Tryb interaktywny posiada interfejs readline z
78 dope³nianiem komend i histori±, podobny do trybu shell perlowego
79 modu³u CPAN.
80
81 %{?with_static:Ta wersja jest konsolidowana statycznie.}
82
83 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p0
90
91 %build
92 %{__autopoint}
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__automake}
96 cp -f config.sub trurlib
97 %configure \
98         %{?with_static:--enable-static} \
99         %{!?with_imode:--disable-imode} \
100         %{?with_curl:--with-curl}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_sysconfdir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
111 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %triggerpostun -- poldek <= 0.18.3-3
119 if ! grep -q '^promoteepoch.*yes' /etc/poldek.conf ; then
120         echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed /etc/poldek.conf
121 fi
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc README* NEWS TODO *sample* conf/poldekrc*
126 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
127 %attr(755,root,root) %{_bindir}/*
128 %{_mandir}/man1/%{name}*
129 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.043522 seconds and 3 git commands to generate.