]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- cleanup db bconds and deps
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     rpm4    # use rpm4 instead of rpm5
11
12 # current snapshot name
13 %define         SNAP    2019
14
15 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
16 %if %{with rpm4}
17 %define         db_pkg          db
18 %define         ver_db          5.3
19 %define         ver_db_rel      3
20 %define         ver_rpm         1:4.14
21 %define         ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
22 %else
23 %define         db_pkg          db5.2
24 %define         ver_db          5.2
25 %define         ver_db_rel      3
26 %define         ver_rpm         5.4.10
27 %endif
28
29 %define         rel     2
30 Summary:        RPM packages management helper tool
31 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
32 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
33 Name:           poldek
34 Version:        0.40.0
35 Release:        %{rel}%{?with_snap:.%{SNAP}}
36 License:        GPL v2
37 Group:          Applications/System
38 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
39 Source0:        https://launchpad.net/poldek/master/head/+download/%{name}-%{version}.tar.xz
40 # Source0-md5:  c88f3ada99799d0e1af78aeda428d041
41 Source1:        %{name}.conf
42 Source2:        %{name}-multilib.conf
43 Source3:        %{name}-config.sh
44 Source5:        %{name}-aliases.conf
45 Source6:        %{name}.desktop
46 Source7:        %{name}.png
47 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
48 Source8:        %{name}-debuginfo.conf
49 Source9:        %{name}-aidath.conf
50 Source10:       %{name}-multilib-aidath.conf
51 Source11:       %{name}-archive.conf
52 Source100:      %{name}-snap.conf
53 Source101:      %{name}-multilib-snap.conf
54 Source102:      %{name}-debuginfo-snap.conf
55 Patch0:         %{name}-config.patch
56 Patch1:         pm-hooks.patch
57 Patch2:         poldek-ext-down-enable.patch
58 Patch3:         multiple-options.patch
59 Patch4:         rpm.org-system-db.patch
60 URL:            http://poldek.pld-linux.org/
61 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
62 BuildRequires:  autoconf
63 BuildRequires:  automake >= 1:1.11
64 BuildRequires:  bzip2-devel
65 BuildRequires:  check-devel
66 BuildRequires:  docbook-dtd412-xml
67 BuildRequires:  gettext-tools
68 BuildRequires:  libgomp-devel
69 BuildRequires:  libtool
70 BuildRequires:  libxml2-devel
71 BuildRequires:  openssl-devel >= 0.9.7d
72 BuildRequires:  pcre-devel
73 BuildRequires:  pkgconfig
74 BuildRequires:  popt-devel
75 %{?with_python:BuildRequires:   python-devel}
76 BuildRequires:  readline-devel >= 5.0
77 BuildRequires:  rpm-devel >= %{ver_rpm}
78 %{?with_python:BuildRequires:   rpm-pythonprov}
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xmlto
81 BuildRequires:  xz
82 BuildRequires:  zlib-devel
83 BuildRequires:  zstd-devel
84 %if %{with static}
85 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
86 BuildRequires:  bzip2-static
87 BuildRequires:  glibc-static
88 BuildRequires:  libxml2-static
89 BuildRequires:  ncurses-static
90 BuildRequires:  openssl-static
91 BuildRequires:  pcre-static
92 BuildRequires:  popt-static
93 BuildRequires:  readline-static
94 BuildRequires:  rpm-static
95 BuildRequires:  zlib-static
96 BuildRequires:  zstd-static
97 %endif
98 Requires(triggerpostun):        awk
99 Requires(triggerpostun):        sed >= 4.0
100 %if %{with rpm4}
101 Requires:       %{db_pkg} >= %{ver_db_devel}
102 %else
103 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
104 Requires:       rpm-db-ver = %{ver_db}
105 %endif
106 Requires:       %{name}-libs = %{version}-%{release}
107 Requires:       /bin/run-parts
108 Requires:       rpm >= %{ver_rpm}
109 Requires:       rpm-lib >= %{ver_rpm}
110 Requires:       sed
111 Conflicts:      etckeeper < 1.18-2
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _libexecdir     %{_prefix}/lib/%{name}
115
116 %description
117 poldek is an RPM package management tool which allows you to easily
118 perform package verification, installation (including system
119 installation from scratch), upgrading, and removal.
120
121 Program can be used in batch (like apt-get from Debian's APT) or
122 interactive mode. The interactive mode puts you into a readline
123 interface with command line autocompletion and history, similar to the
124 shell mode of Perl's CPAN.
125
126 %{?with_static:This version is statically linked.}
127
128 %{!?with_imode:This version hasn't got interactive mode.}
129 #'vim
130
131 %description -l hu.UTF-8
132 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134 nulláról), frissítést és eltávolítást.
135
136 A program használható parancssorból (mint a Debian apt-get programja)
137 vagy interaktív módban. Az interaktív mód egy readline környezetet
138 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139 shell módjához.
140
141 %{?with_static:Ez a verzió statikusan linkelt.}
142
143 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
145 %description -l pl.UTF-8
146 poldek jest narzędziem linii poleceń służącym do weryfikacji,
147 instalacji (włączając instalację systemu od zera), aktualizacji i
148 usuwania pakietów.
149
150 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
151 interaktywnym. Tryb interaktywny posiada interfejs readline z
152 dopełnianiem komend i historią, podobny do trybu shell perlowego
153 modułu CPAN.
154
155 %{?with_static:Ta wersja jest konsolidowana statycznie.}
156
157 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
158
159 %package libs
160 Summary:        poldek libraries
161 Summary(hu.UTF-8):      A poldek könyvtárai
162 Summary(pl.UTF-8):      Biblioteki poldka
163 Group:          Libraries
164
165 %description libs
166 poldek libraries.
167
168 %description libs -l hu.UTF-8
169 A poldek könyvtárai.
170
171 %description libs -l pl.UTF-8
172 Biblioteki poldka.
173
174 %package devel
175 Summary:        Header files for poldek libraries
176 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
177 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
178 Group:          Development/Libraries
179 Requires:       %{name}-libs = %{version}-%{release}
180 Requires:       rpm-devel >= %{ver_rpm}
181
182 %description devel
183 Header files for poldek libraries.
184
185 %description devel -l hu.UTF-8
186 A poldek könyvtár fejlesztői fájljai.
187
188 %description devel -l pl.UTF-8
189 Pliki nagłówkowe bibliotek poldka.
190
191 %package static
192 Summary:        poldek static libraries
193 Summary(hu.UTF-8):      poldek statikus könyvtárak
194 Summary(pl.UTF-8):      Biblioteki statyczne poldka
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197
198 %description static
199 poldek static libraries.
200
201 %description static -l hu.UTF-8
202 poldek statikus könyvtárak.
203
204 %description static -l pl.UTF-8
205 Biblioteki statyczne poldka.
206
207 %package -n python-poldek
208 Summary:        Python modules for poldek
209 Summary(hu.UTF-8):      Python modulok poldek-hez
210 Summary(pl.UTF-8):      Moduły języka Python dla poldka
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{version}-%{release}
213 Requires:       python-libs
214
215 %description -n python-poldek
216 Python modules for poldek.
217
218 %description -n python-poldek -l hu.UTF-8
219 Python modulok poldek-hez.
220
221 %description -n python-poldek -l pl.UTF-8
222 Moduły języka Python dla poldka.
223
224 %prep
225 %setup -q
226 %patch0 -p1
227 %patch1 -p1
228 %patch2 -p1
229 %patch3 -p1
230 %patch4 -p1
231
232 %{__rm} m4/libtool.m4 m4/lt*.m4
233
234 # cleanup backups after patching
235 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
236 chmod u+x ./configure ./doc/conf-xml2.sh
237
238 %build
239 %{__gettextize}
240 %{__libtoolize}
241 %{__aclocal} -I m4
242 %{__autoheader}
243 %{__autoconf}
244 %{__automake}
245 cd tndb
246 %{__libtoolize}
247 %{__aclocal}
248 %{__autoheader}
249 %{__autoconf}
250 %{__automake}
251 cd ../trurlib
252 %{__libtoolize}
253 %{__aclocal}
254 %{__autoheader}
255 %{__autoconf}
256 %{__automake}
257 cd ..
258
259 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline -D_GNU_SOURCE=1"
260 %configure \
261         %{?with_static:--enable-static --disable-shared} \
262         %{!?with_imode:--disable-imode} \
263         --with-pkglibdir=%{_libexecdir} \
264         --enable-nls \
265         %{?with_python:--with-python}
266 %{__make} -j1
267 #       --enable-trace
268
269 %if %{with python}
270 %{__make} -C python
271 %endif
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275 install -d $RPM_BUILD_ROOT/var/cache/%{name}
276
277 %{__make} install -j1 \
278         DESTDIR=$RPM_BUILD_ROOT
279
280 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
281
282 %if %{with python}
283 %{__make} -C python -j1 install \
284         DESTDIR=$RPM_BUILD_ROOT \
285         py_sitedir=%{py_sitedir}
286 %endif
287
288 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
289
290 %ifarch i486 i686 ppc sparc alpha athlon
291         %define         ftp_arch        %{_target_cpu}
292 %endif
293 %ifarch %{x8664}
294         %define         ftp_arch        x86_64
295         %define         ftp_alt_arch    i686
296         %define         ftp_alt2_arch   x32
297 %endif
298 %ifarch x32
299         %define         ftp_arch        x32
300         %define         ftp_alt_arch    x86_64
301         %define         ftp_alt2_arch   i686
302 %endif
303 %ifarch i586
304         %define         ftp_arch        i486
305 %endif
306 %ifarch pentium2 pentium3 pentium4
307         %define         ftp_arch        i686
308 %endif
309 %ifarch sparcv9 sparc64
310         %define         ftp_arch        sparc
311         %define         ftp_arch        %{_target_cpu}
312         %ifarch sparc64
313                 %define         ftp_alt_arch    sparcv9
314         %endif
315 %endif
316
317 %define pld_conf %{SOURCE1}
318 %define pld_debuginfo_conf %{SOURCE8}
319 %define pld_archive_conf %{SOURCE11}
320
321 %ifarch %{x8664} x32
322         %define pld_multilib_conf %{SOURCE2}
323         %define pld_multilib2_conf %{SOURCE2}
324 %endif
325
326 # aidath
327 %ifarch sparcv9 sparc64
328         %define pld_conf %{SOURCE9}
329         %undefine pld_archive_conf
330 %endif
331 %ifarch sparc64
332         %define pld_multilib_conf %{SOURCE10}
333 %endif
334
335 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
336
337 %if 0%{?pld_multilib_conf:1}
338         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
339 %endif
340
341 %if 0%{?pld_multilib2_conf:1}
342         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
343 %endif
344
345 %if 0%{?pld_debuginfo_conf:1}
346 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
347 %endif
348
349 %if 0%{?pld_archive_conf:1}
350 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
351 %endif
352
353 # Always install snapshot configs
354 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
355         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
356 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
357         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
358 %ifarch %{x8664} x32
359         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
360                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
361         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
362                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
363 %endif
364
365 %if %{with snap}
366 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
367 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
368 %else
369 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
370 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
371 %endif
372
373 # create "all" meta repo
374 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
375 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
376 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
377 [source]
378 type    = group
379 name    = th-all
380 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
381 EOF
382 %endif
383
384 # th-2014 snap does not exist for x32 yet
385 %if "%{ftp_arch}" == "x32"
386 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
387 %endif
388 %if "%{ftp_alt2_arch}" == "x32"
389 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
390 %endif
391
392 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
393
394 %if %{with imode}
395 # add desktop file and icon
396 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
397 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
398 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
399 %endif
400
401 # sources we don't package
402 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
403 # include them in %doc
404 %{__rm} -rf configs
405 cp -a conf configs
406 %{__rm} -f configs/Makefile*
407
408 %if %{with python}
409 %py_postclean
410 %{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
411 %endif
412
413 %find_lang %{name}
414
415 %clean
416 rm -rf $RPM_BUILD_ROOT
417
418 %post
419 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
420 if [ "$1" = "1" ]; then
421         # remove ignore = vserver-packages inside vserver on first install
422         {
423                 while read f ctx; do
424                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
425                 done </proc/self/status
426         } 2>/dev/null
427         if [ -z "$ctx" -o "$ctx" = "0" ]; then
428                 VSERVER=no
429         else
430                 VSERVER=yes
431         fi
432         if [ "$VSERVER" = "yes" ]; then
433                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
434         fi
435 fi
436
437 %postun -p      /sbin/postshell
438 -/usr/sbin/fix-info-dir -c %{_infodir}
439
440 %post   libs -p /sbin/ldconfig
441 %postun libs -p /sbin/ldconfig
442
443 %triggerpostun -- poldek < 0.30-0.20080225.00.1
444 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
445         %{__sed} -i -e '/^%%include source.conf/{
446                 a
447                 a# /etc/poldek/repos.d/*.conf
448                 a%%includedir repos.d
449         }' %{_sysconfdir}/%{name}/poldek.conf
450 fi
451
452 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
453 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
454
455 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
456         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
457         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
458 fi
459
460 %ifarch %{x8664}
461 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
462         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
463         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
464 fi
465 %endif
466
467 %triggerpostun -- poldek < 0.30.1-3
468 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
469         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
470         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
471 fi
472 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
473         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
474         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
475 fi
476
477 %triggerpostun -- %{name} < 0.30.1-8
478 if [ $1 -le 1 ]; then
479         # revert change on  --downgrade
480         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
481 else
482         # setup pm command
483         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
484 fi
485
486 %files -f %{name}.lang
487 %defattr(644,root,root,755)
488 %doc ChangeLog README* NEWS TODO configs
489 %dir %{_sysconfdir}/%{name}
490 %dir %{_sysconfdir}/%{name}/pre-install.d
491 %{_sysconfdir}/%{name}/pre-install.d/README
492 %dir %{_sysconfdir}/%{name}/post-install.d
493 %{_sysconfdir}/%{name}/post-install.d/README
494 %dir %{_sysconfdir}/%{name}/repos.d
495 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
496 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
497 %attr(755,root,root) %{_bindir}/ipoldek
498 %attr(755,root,root) %{_bindir}/poldek
499 %attr(755,root,root) %{_bindir}/poldek-config
500 %attr(755,root,root) %{_bindir}/rpmvercmp
501 %dir %{_libexecdir}
502 %attr(755,root,root) %{_libexecdir}/pm-command.sh
503 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
504 %attr(755,root,root) %{_libexecdir}/vfcompr
505 %attr(755,root,root) %{_libexecdir}/vfjuggle
506 %attr(755,root,root) %{_libexecdir}/vfsmb
507 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
508 %{_mandir}/man1/%{name}*.1*
509 %lang(pl) %{_mandir}/pl/man1/%{name}*
510 %{_infodir}/poldek.info*
511 %if %{with imode}
512 %{_desktopdir}/%{name}.desktop
513 %{_pixmapsdir}/%{name}.png
514 %endif
515 %dir /var/cache/%{name}
516
517 %if %{without static}
518 %files libs
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
521 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
522 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
523 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
524 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
525 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
526 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
527 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
528 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
529 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
530 %endif
531
532 %files devel
533 %defattr(644,root,root,755)
534 %if %{without static}
535 %attr(755,root,root) %{_libdir}/libpoclidek.so
536 %attr(755,root,root) %{_libdir}/libpoldek.so
537 %attr(755,root,root) %{_libdir}/libtndb.so
538 %attr(755,root,root) %{_libdir}/libtrurl.so
539 %attr(755,root,root) %{_libdir}/libvfile.so
540 %endif
541 %{_libdir}/libpoclidek.la
542 %{_libdir}/libpoldek.la
543 %{_libdir}/libtndb.la
544 %{_libdir}/libtrurl.la
545 %{_libdir}/libvfile.la
546 %{_includedir}/poldek
547 %{_includedir}/tndb
548 %{_includedir}/trurl
549 %{_includedir}/vfile
550 %{_pkgconfigdir}/tndb.pc
551 %{_pkgconfigdir}/trurlib.pc
552
553 %files static
554 %defattr(644,root,root,755)
555 %{_libdir}/libtndb.a
556 %{_libdir}/libtrurl.a
557
558 %if %{with python}
559 %files -n python-poldek
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
562 %{py_sitescriptdir}/poldek.py[co]
563 %{py_sitescriptdir}/poldekmod.py[co]
564 %endif
This page took 0.060278 seconds and 3 git commands to generate.