]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- removed BOOT
[packages/poldek.git] / poldek.spec
1 # conditional build
2 #  --with static   -- don't use shared libraries
3 #  --without imode -- don't build interactive mode
4 Summary:        RPM packages management helper tool
5 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
6 Name:           poldek
7 Version:        0.16
8 Release:        3
9 License:        GPL
10 Group:          Applications/System
11 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}/%{name}-%{version}.tar.gz
12 %{!?_with_static:Requires:      trurlib >= 0.43.4}
13 Requires:       /bin/rpm
14 BuildRequires:  bzip2-devel
15 BuildRequires:  db3-devel >= 3.1.14-2
16 BuildRequires:  curl-devel >= 7.8
17 BuildRequires:  openssl-devel
18 BuildRequires:  pcre-devel
19 BuildRequires:  popt-devel
20 BuildRequires:  readline-devel
21 BuildRequires:  rpm-devel >= 3.0.5
22 BuildRequires:  trurlib-devel >= 0.43.3
23 BuildRequires:  zlib-devel
24 BuildRequires:  /usr/bin/pod2man
25 %{?_with_static:BuildRequires:  bzip2-static}
26 %{?_with_static:BuildRequires:  curl-static}
27 %{?_with_static:BuildRequires:  openssl-static}
28 %{?_with_static:BuildRequires:  popt-static}
29 %{?_with_static:BuildRequires:  rpm-static}
30 %{?_with_static:BuildRequires:  trurlib-static}
31 %{?_with_static:BuildRequires:  zlib-static}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 poldek is an RPM package management tool which allows you to easily
36 perform package verification, installation (including system
37 installation from scratch), upgrading, and removal.
38
39 Program can be used in batch (like apt-get from Debian's APT) or
40 interactive mode. The interactive mode puts you into a readline
41 interface with command line autocompletion and history, similar to the
42 shell mode of Perl's CPAN.
43
44 %{?_with_static:This version is statically linked}
45
46 %{?_without_imode:This version hasn't got interactive mode.}
47
48 %description -l pl
49 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
50 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji 
51 pakietów i usuwania pakietów.
52
53 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
54 lub interaktywnym. Tryb interaktywny posiada interfajs readline z
55 dope³nianiem komend i histori±, podobny do trybu shell CPANa.
56
57 %{?_with_static:Ta wersja jest zlinkowana statycznie.}
58
59 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
60
61 %prep
62 %setup -q
63
64 %build
65 %configure \
66         %{?_with_static:--enable-static} \
67         %{?_without_imode:--disable-imode}
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_sysconfdir}
73
74 # no strip cause program's alpha stage and core may be useful
75 %{__make} install DESTDIR=$RPM_BUILD_ROOT
76 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
77 sed "s/i686/%{_target_cpu}/g" < poldekrc.sample-pld > $RPM_BUILD_ROOT/etc/%{name}.conf
78
79 gzip -9nf README* *sample* NEWS TODO
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
87 %attr(755,root,root) %{_bindir}/*
88 %{_mandir}/man1/%{name}*
89 %doc *.gz
This page took 0.067024 seconds and 3 git commands to generate.