]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
260dd5880f955e2597065d1823e6968413887ce9
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2014
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         ver_db          4.7.25
27 %define         ver_db_rel      1
28 %define         ver_rpm         4.5-49
29 %else
30 %define         ver_rpm         5.4.10
31 %endif
32
33 %define         rel     9
34 Summary:        RPM packages management helper tool
35 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
36 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
37 Name:           poldek
38 Version:        0.30.1
39 Release:        %{rel}%{?with_snap:.%{SNAP}}
40 License:        GPL v2
41 Group:          Applications/System
42 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
43 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
44 # Source0-md5:  e569c8454df0932df53b09cee9998927
45 Source1:        %{name}.conf
46 Source2:        %{name}-multilib.conf
47 Source5:        %{name}-aliases.conf
48 Source6:        %{name}.desktop
49 Source7:        %{name}.png
50 Source8:        %{name}-debuginfo.conf
51 Source9:        %{name}-aidath.conf
52 Source10:       %{name}-multilib-aidath.conf
53 Source11:       %{name}-archive.conf
54 Source100:      %{name}-snap.conf
55 Source101:      %{name}-multilib-snap.conf
56 Source102:      %{name}-debuginfo-snap.conf
57 Patch0:         %{name}-size-type.patch
58 Patch1:         %{name}-config.patch
59 Patch2:         %{name}-missing-include.patch
60 Patch3:         pm-hooks.patch
61 Patch4:         poldek-setenv-null.patch
62 URL:            http://poldek.pld-linux.org/
63 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
64 BuildRequires:  autoconf
65 BuildRequires:  automake >= 1:1.11
66 BuildRequires:  bzip2-devel
67 BuildRequires:  check-devel
68 BuildRequires:  docbook-dtd412-xml
69 BuildRequires:  gettext-tools
70 BuildRequires:  libtool
71 BuildRequires:  libxml2-devel
72 BuildRequires:  neon-devel
73 BuildRequires:  openssl-devel >= 0.9.7d
74 BuildRequires:  pcre-devel
75 BuildRequires:  pkgconfig
76 BuildRequires:  popt-devel
77 %{?with_python:BuildRequires:   python-devel}
78 BuildRequires:  readline-devel >= 5.0
79 BuildRequires:  rpm-devel >= %{ver_rpm}
80 %{?with_python:BuildRequires:   rpm-pythonprov}
81 BuildRequires:  swig-python
82 BuildRequires:  tar >= 1:1.22
83 BuildRequires:  xmlto
84 BuildRequires:  xz
85 BuildRequires:  zlib-devel
86 %if %{with static}
87 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
88 BuildRequires:  bzip2-static
89 BuildRequires:  glibc-static
90 BuildRequires:  libxml2-static
91 BuildRequires:  ncurses-static
92 BuildRequires:  openssl-static
93 BuildRequires:  pcre-static
94 BuildRequires:  popt-static
95 BuildRequires:  readline-static
96 BuildRequires:  rpm-static
97 BuildRequires:  zlib-static
98 %endif
99 Requires(triggerpostun):        awk
100 Requires(triggerpostun):        sed >= 4.0
101 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
102 Requires:       %{name}-libs = %{version}-%{release}
103 Requires:       /bin/run-parts
104 Requires:       rpm >= %{ver_rpm}
105 Requires:       rpm-db-ver = %{ver_db}
106 Requires:       rpm-lib >= %{ver_rpm}
107 Requires:       sed
108 Conflicts:      etckeeper < 1.18-2
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _libexecdir     %{_prefix}/lib/%{name}
112
113 %description
114 poldek is an RPM package management tool which allows you to easily
115 perform package verification, installation (including system
116 installation from scratch), upgrading, and removal.
117
118 Program can be used in batch (like apt-get from Debian's APT) or
119 interactive mode. The interactive mode puts you into a readline
120 interface with command line autocompletion and history, similar to the
121 shell mode of Perl's CPAN.
122
123 %{?with_static:This version is statically linked.}
124
125 %{!?with_imode:This version hasn't got interactive mode.}
126 #'vim
127
128 %description -l hu.UTF-8
129 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
130 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
131 nulláról), frissítést és eltávolítást.
132
133 A program használható parancssorból (mint a Debian apt-get programja)
134 vagy interaktív módban. Az interaktív mód egy readline környezetet
135 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
136 shell módjához.
137
138 %{?with_static:Ez a verzió statikusan linkelt.}
139
140 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
141
142 %description -l pl.UTF-8
143 poldek jest narzędziem linii poleceń służącym do weryfikacji,
144 instalacji (włączając instalację systemu od zera), aktualizacji i
145 usuwania pakietów.
146
147 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
148 interaktywnym. Tryb interaktywny posiada interfejs readline z
149 dopełnianiem komend i historią, podobny do trybu shell perlowego
150 modułu CPAN.
151
152 %{?with_static:Ta wersja jest konsolidowana statycznie.}
153
154 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
155
156 %package libs
157 Summary:        poldek libraries
158 Summary(hu.UTF-8):      A poldek könyvtárai
159 Summary(pl.UTF-8):      Biblioteki poldka
160 Group:          Libraries
161
162 %description libs
163 poldek libraries.
164
165 %description libs -l hu.UTF-8
166 A poldek könyvtárai.
167
168 %description libs -l pl.UTF-8
169 Biblioteki poldka.
170
171 %package devel
172 Summary:        Header files for poldek libraries
173 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
174 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
175 Group:          Development/Libraries
176 Requires:       %{name}-libs = %{version}-%{release}
177 Requires:       rpm-devel >= %{ver_rpm}
178
179 %description devel
180 Header files for poldek libraries.
181
182 %description devel -l hu.UTF-8
183 A poldek könyvtár fejlesztői fájljai.
184
185 %description devel -l pl.UTF-8
186 Pliki nagłówkowe bibliotek poldka.
187
188 %package static
189 Summary:        poldek static libraries
190 Summary(hu.UTF-8):      poldek statikus könyvtárak
191 Summary(pl.UTF-8):      Biblioteki statyczne poldka
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}-%{release}
194
195 %description static
196 poldek static libraries.
197
198 %description static -l hu.UTF-8
199 poldek statikus könyvtárak.
200
201 %description static -l pl.UTF-8
202 Biblioteki statyczne poldka.
203
204 %package -n python-poldek
205 Summary:        Python modules for poldek
206 Summary(hu.UTF-8):      Python modulok poldek-hez
207 Summary(pl.UTF-8):      Moduły języka Python dla poldka
208 Group:          Libraries/Python
209 Requires:       %{name}-libs = %{version}-%{release}
210 Requires:       python-libs
211
212 %description -n python-poldek
213 Python modules for poldek.
214
215 %description -n python-poldek -l hu.UTF-8
216 Python modulok poldek-hez.
217
218 %description -n python-poldek -l pl.UTF-8
219 Moduły języka Python dla poldka.
220
221 %prep
222 %setup -q
223 %patch0 -p1
224 %patch1 -p1
225 %patch2 -p1
226 %patch3 -p1
227 %patch4 -p1
228
229 %{__rm} m4/libtool.m4 m4/lt*.m4
230
231 # cleanup backups after patching
232 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
233 chmod u+x ./configure ./doc/conf-xml2.sh
234
235 %build
236 %{__gettextize}
237 %{__libtoolize}
238 %{__aclocal} -I m4
239 %{__autoheader}
240 %{__autoconf}
241 %{__automake}
242 cd tndb
243 %{__libtoolize}
244 %{__aclocal}
245 %{__autoheader}
246 %{__autoconf}
247 %{__automake}
248 cd ../trurlib
249 %{__libtoolize}
250 %{__aclocal}
251 %{__autoheader}
252 %{__autoconf}
253 %{__automake}
254 cd ..
255
256 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
257 %configure \
258         %{?with_static:--enable-static --disable-shared} \
259         %{!?with_imode:--disable-imode} \
260         --with-pkglibdir=%{_libexecdir} \
261         --enable-nls \
262         %{?with_python:--with-python}
263 %{__make} -j1
264 #       --enable-trace
265
266 %install
267 rm -rf $RPM_BUILD_ROOT
268 install -d $RPM_BUILD_ROOT/var/cache/%{name}
269
270 %{__make} install -j1 \
271         DESTDIR=$RPM_BUILD_ROOT
272
273 %if %{with python}
274 %{__make} -C python -j1 install \
275         DESTDIR=$RPM_BUILD_ROOT \
276         libdir=%{py_sitedir}
277 %endif
278
279 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
280
281 %ifarch i486 i686 ppc sparc alpha athlon
282         %define         ftp_arch        %{_target_cpu}
283 %endif
284 %ifarch %{x8664}
285         %define         ftp_arch        x86_64
286         %define         ftp_alt_arch    i686
287         %define         ftp_alt2_arch   x32
288 %endif
289 %ifarch x32
290         %define         ftp_arch        x32
291         %define         ftp_alt_arch    x86_64
292         %define         ftp_alt2_arch   i686
293 %endif
294 %ifarch i586
295         %define         ftp_arch        i486
296 %endif
297 %ifarch pentium2 pentium3 pentium4
298         %define         ftp_arch        i686
299 %endif
300 %ifarch sparcv9 sparc64
301         %define         ftp_arch        sparc
302         %define         ftp_arch        %{_target_cpu}
303         %ifarch sparc64
304                 %define         ftp_alt_arch    sparcv9
305         %endif
306 %endif
307
308 %define pld_conf %{SOURCE1}
309 %define pld_debuginfo_conf %{SOURCE8}
310 %define pld_archive_conf %{SOURCE11}
311
312 %ifarch %{x8664} x32
313         %define pld_multilib_conf %{SOURCE2}
314         %define pld_multilib2_conf %{SOURCE2}
315 %endif
316
317 # aidath
318 %ifarch sparcv9 sparc64
319         %define pld_conf %{SOURCE9}
320         %undefine pld_archive_conf
321 %endif
322 %ifarch sparc64
323         %define pld_multilib_conf %{SOURCE10}
324 %endif
325
326 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
327
328 %if 0%{?pld_multilib_conf:1}
329         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
330 %endif
331
332 %if 0%{?pld_multilib2_conf:1}
333         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
334 %endif
335
336 %if 0%{?pld_debuginfo_conf:1}
337 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
338 %endif
339
340 %if 0%{?pld_archive_conf:1}
341 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
342 %endif
343
344 # Always install snapshot configs
345 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
346         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
347 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
348         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
349 %ifarch %{x8664} x32
350         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
351                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
352         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
353                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
354 %endif
355
356 %if %{with snap}
357 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
358 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
359 %else
360 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
361 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
362 %endif
363
364 # create "all" meta repo
365 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
366 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
367 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
368 [source]
369 type    = group
370 name    = th-all
371 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
372 EOF
373 %endif
374
375 # th-2014 snap does not exist for x32 yet
376 %if "%{ftp_arch}" == "x32"
377 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
378 %endif
379 %if "%{ftp_alt2_arch}" == "x32"
380 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
381 %endif
382
383 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
384
385 %if %{with imode}
386 # add desktop file and icon
387 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
388 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
389 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
390 %endif
391
392 # sources we don't package
393 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
394 # include them in %doc
395 %{__rm} -rf configs
396 cp -a conf configs
397 %{__rm} -f configs/Makefile*
398
399 %if %{with python}
400 %py_postclean
401 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
402 %endif
403
404 %find_lang %{name}
405
406 %clean
407 rm -rf $RPM_BUILD_ROOT
408
409 %post
410 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
411 if [ "$1" = "1" ]; then
412         # remove ignore = vserver-packages inside vserver on first install
413         {
414                 while read f ctx; do
415                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
416                 done </proc/self/status
417         } 2>/dev/null
418         if [ -z "$ctx" -o "$ctx" = "0" ]; then
419                 VSERVER=no
420         else
421                 VSERVER=yes
422         fi
423         if [ "$VSERVER" = "yes" ]; then
424                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
425         fi
426 fi
427
428 %postun -p      /sbin/postshell
429 -/usr/sbin/fix-info-dir -c %{_infodir}
430
431 %post   libs -p /sbin/ldconfig
432 %postun libs -p /sbin/ldconfig
433
434 %triggerpostun -- poldek < 0.30-0.20080225.00.1
435 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
436         %{__sed} -i -e '/^%%include source.conf/{
437                 a
438                 a# /etc/poldek/repos.d/*.conf
439                 a%%includedir repos.d
440         }' %{_sysconfdir}/%{name}/poldek.conf
441 fi
442
443 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
444 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
445
446 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
447         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
448         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
449 fi
450
451 %ifarch %{x8664}
452 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
453         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
454         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
455 fi
456 %endif
457
458 %triggerpostun -- poldek < 0.30.1-3
459 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
460         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
461         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
462 fi
463 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
464         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
465         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
466 fi
467
468 %triggerpostun -- %{name} < 0.30.1-8
469 if [ $1 -le 1 ]; then
470         # revert change on  --downgrade
471         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
472 else
473         # setup pm command
474         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
475 fi
476
477 %files -f %{name}.lang
478 %defattr(644,root,root,755)
479 %doc ChangeLog README* NEWS TODO configs
480 %dir %{_sysconfdir}/%{name}
481 %dir %{_sysconfdir}/%{name}/pre-install.d
482 %{_sysconfdir}/%{name}/pre-install.d/README
483 %dir %{_sysconfdir}/%{name}/post-install.d
484 %{_sysconfdir}/%{name}/post-install.d/README
485 %dir %{_sysconfdir}/%{name}/repos.d
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
488 %attr(755,root,root) %{_bindir}/ipoldek
489 %attr(755,root,root) %{_bindir}/poldek
490 %attr(755,root,root) %{_bindir}/rpmvercmp
491 %dir %{_libexecdir}
492 %attr(755,root,root) %{_libexecdir}/pm-command.sh
493 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
494 %attr(755,root,root) %{_libexecdir}/vfcompr
495 %attr(755,root,root) %{_libexecdir}/vfjuggle
496 %attr(755,root,root) %{_libexecdir}/vfsmb
497 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
498 %{_mandir}/man1/%{name}*.1*
499 %lang(pl) %{_mandir}/pl/man1/%{name}*
500 %{_infodir}/poldek.info*
501 %if %{with imode}
502 %{_desktopdir}/%{name}.desktop
503 %{_pixmapsdir}/%{name}.png
504 %endif
505 %dir /var/cache/%{name}
506
507 %if %{without static}
508 %files libs
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
511 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
512 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
513 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
514 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
516 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
517 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
518 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
519 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
520 %endif
521
522 %files devel
523 %defattr(644,root,root,755)
524 %if %{without static}
525 %attr(755,root,root) %{_libdir}/libpoclidek.so
526 %attr(755,root,root) %{_libdir}/libpoldek.so
527 %attr(755,root,root) %{_libdir}/libtndb.so
528 %attr(755,root,root) %{_libdir}/libtrurl.so
529 %attr(755,root,root) %{_libdir}/libvfile.so
530 %endif
531 %{_libdir}/libpoclidek.la
532 %{_libdir}/libpoldek.la
533 %{_libdir}/libtndb.la
534 %{_libdir}/libtrurl.la
535 %{_libdir}/libvfile.la
536 %{_includedir}/poldek
537 %{_includedir}/tndb
538 %{_includedir}/trurl
539 %{_includedir}/vfile
540 %{_pkgconfigdir}/tndb.pc
541 %{_pkgconfigdir}/trurlib.pc
542
543 %files static
544 %defattr(644,root,root,755)
545 %{_libdir}/libtndb.a
546 %{_libdir}/libtrurl.a
547
548 %if %{with python}
549 %files -n python-poldek
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
552 %{py_sitescriptdir}/poldek.py[co]
553 %{py_sitescriptdir}/poldekmod.py[co]
554 %endif
This page took 0.075739 seconds and 3 git commands to generate.