]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
14f5451f13cbf8fc55860fa4db52a6d2f6c97b7a
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.6
14 Release:        10
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  21e4b2fa1695d95479e01fe82a4d84da
19 Source1:        %{name}.conf
20 Patch0:         %{name}-etc_dir.patch
21 Patch1:         %{name}-retr_term.patch
22 Patch2:         %{name}-simplestatic.patch
23 Patch3:         %{name}-pkgorder.patch
24 Patch4:         %{name}-sigsegv.patch
25 Patch5:         %{name}-caplookup.patch
26 Patch6:         %{name}-progress2.patch
27 Patch7:         %{name}-po.patch
28 Patch8:         %{name}-deps-fix.patch
29 Patch9:         %{name}-obsoletes_provides.patch
30 URL:            http://team.pld.org.pl/~mis/poldek/
31 BuildRequires:  automake
32 BuildRequires:  autoconf
33 BuildRequires:  bzip2-devel
34 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
35 BuildRequires:  db-devel >= %{ver_db}
36 BuildRequires:  gettext-autopoint
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  pcre-devel
39 BuildRequires:  popt-devel
40 BuildRequires:  readline-devel
41 BuildRequires:  rpm-devel >= %{ver_rpm}
42 BuildRequires:  zlib-devel
43 BuildRequires:  perl-tools-pod
44 %if %{with static}
45 BuildRequires:  bzip2-static
46 %{?with_curl:BuildRequires:     curl-static}
47 BuildRequires:  db-static >= %{ver_db}
48 BuildRequires:  glibc-static
49 BuildRequires:  libselinux-static
50 BuildRequires:  ncurses-static
51 BuildRequires:  openssl-static
52 BuildRequires:  pcre-static
53 BuildRequires:  popt-static
54 BuildRequires:  readline-static
55 BuildRequires:  rpm-static
56 BuildRequires:  zlib-static
57 %endif
58 Requires:       db >= %{ver_db}
59 Requires:       ed
60 Requires:       rpm >= %{ver_rpm}
61 Requires:       sed
62 Requires:       openssl >= 0.9.7c
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 poldek is an RPM package management tool which allows you to easily
67 perform package verification, installation (including system
68 installation from scratch), upgrading, and removal.
69
70 Program can be used in batch (like apt-get from Debian's APT) or
71 interactive mode. The interactive mode puts you into a readline
72 interface with command line autocompletion and history, similar to the
73 shell mode of Perl's CPAN.
74
75 %{?with_static:This version is statically linked.}
76
77 %{!?with_imode:This version hasn't got interactive mode.}
78
79 %description -l pl
80 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
81 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
82 usuwania pakietów.
83
84 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
85 interaktywnym. Tryb interaktywny posiada interfejs readline z
86 dope³nianiem komend i histori±, podobny do trybu shell perlowego
87 modu³u CPAN.
88
89 %{?with_static:Ta wersja jest konsolidowana statycznie.}
90
91 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p0
98 %patch3 -p0
99 %patch4 -p0
100 %patch5 -p0
101 %patch6 -p1
102 %patch7 -p1
103 %patch8 -p0
104 %patch9 -p0
105
106 %build
107 %{__autopoint}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__automake}
111 cp -f config.sub trurlib
112 %configure \
113         %{?with_static:--enable-static} \
114         %{!?with_imode:--disable-imode} \
115         %{?with_curl:--with-curl}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_sysconfdir}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
126 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %triggerpostun -- poldek <= 0.18.3-5
134 if grep -q '^promoteepoch.*yes' /etc/poldek.conf ; then
135         echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s /etc/poldek.conf
136 fi
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc README* NEWS TODO *sample* conf/poldekrc*
141 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
142 %attr(755,root,root) %{_bindir}/*
143 %{_mandir}/man1/%{name}*
144 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.041357 seconds and 3 git commands to generate.