]> git.pld-linux.org Git - packages/pokerth.git/blob - pokerth.spec
BR tinyxml-devel
[packages/pokerth.git] / pokerth.spec
1 Summary:        The Open Source Texas-Holdem Poker Engine
2 Summary(pl.UTF-8):      Silnik gry Texas-Holdem poker
3 Name:           pokerth
4 Version:        0.9.5
5 Release:        1
6 License:        GPL v2+
7 Group:          X11/Applications/Games
8 Source0:        http://downloads.sourceforge.net/pokerth/PokerTH-%{version}-src.tar.bz2
9 # Source0-md5:  4bdea98bfc142a825c64b77feb4667d0
10 URL:            http://www.pokerth.net/
11 BuildRequires:  QtCore-devel >= 4.3.1
12 BuildRequires:  QtGui-devel >= 4.3.1
13 BuildRequires:  QtNetwork-devel
14 BuildRequires:  QtSql-devel
15 BuildRequires:  SDL_mixer-devel
16 BuildRequires:  boost-devel >= 1.37.0-3
17 BuildRequires:  curl-devel >= 7.16
18 BuildRequires:  gnutls-devel
19 BuildRequires:  gsasl-devel
20 BuildRequires:  qt4-build >= 4.3.1
21 BuildRequires:  qt4-qmake >= 4.3.1
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  tinyxml-devel
24 BuildRequires:  zlib-devel >= 1.2.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 PokerTH is a poker game written in C++/Qt4. You can play the popular
29 "Texas Hold'em" poker variant against up to six computer-opponents or
30 play network games with people all over the world. This poker engine
31 is available for Linux, Windows, and MacOS X.
32
33 %description -l pl.UTF-8
34 PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
35 grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
36 komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
37 Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
38
39 %prep
40 %setup -q -n PokerTH-%{version}-src
41
42 # what is it?
43 sed -i -e '/-no_dead_strip_inits_and_terms/d' *.pro
44
45 %build
46 qmake-qt4 pokerth.pro \
47         QMAKE_CXX="%{__cxx}" \
48         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}"
49         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_bindir}
55 %{__make} install \
56         INSTALL_ROOT=$RPM_BUILD_ROOT
57
58 install pokerth bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc COPYING ChangeLog TODO
66 %attr(755,root,root) %{_bindir}/pokerth*
67 %{_desktopdir}/%{name}.desktop
68 %{_pixmapsdir}/%{name}.png
69 %{_datadir}/%{name}
This page took 0.063018 seconds and 4 git commands to generate.