]> git.pld-linux.org Git - packages/plplot.git/blob - plplot.spec
- require fixed gnome-libs, force 1 jobserver; rel 5
[packages/plplot.git] / plplot.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome           # don't build gnome driver
4 %bcond_with     java            # build Java binding
5 %bcond_without  svga            # don't build linuxvga driver
6 #
7 Summary:        PLplot - a library of functions that are useful for making scientific plots
8 Summary(pl.UTF-8):      PLplot - biblioteka funkcji przydatnych do tworzenia wykresów naukowych
9 Name:           plplot
10 Version:        5.3.1
11 Release:        7
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/plplot/%{name}-%{version}.tar.gz
15 # Source0-md5:  3487a6b2a78a064188a80f244b341d33
16 Patch0:         %{name}-FHS.patch
17 Patch1:         %{name}-lib64.patch
18 URL:            http://plplot.sourceforge.net/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake >= 1:1.8.3
21 BuildRequires:  cd-devel >= 1.3-2
22 BuildRequires:  docbook-style-dsssl
23 BuildRequires:  fftw3-devel
24 BuildRequires:  freetype-devel >= 2.1.0
25 BuildRequires:  gcc-g77
26 BuildRequires:  gd-devel
27 %{?with_gnome:BuildRequires:    gnome-libs-devel >= 1:1.4.2-14}
28 %{?with_gnome:BuildRequires:    gtk+-devel >= 1.2.7}
29 BuildRequires:  itcl-devel
30 BuildRequires:  jadetex
31 %{?with_java:BuildRequires:     jdk}
32 BuildRequires:  lapack-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  octave-devel
38 BuildRequires:  perl-XML-Parser
39 BuildRequires:  python-Numeric-devel >= 15.3
40 BuildRequires:  python-devel >= 1:2.3
41 BuildRequires:  qhull-devel
42 BuildRequires:  sed >= 4.0
43 %{?with_svga:BuildRequires:     svgalib-devel}
44 # checked for but not used (generated files included in sources)
45 #BuildRequires: swig
46 BuildRequires:  tcl-devel >= 8.4.11-3
47 BuildRequires:  tetex-dvips
48 BuildRequires:  texinfo
49 BuildRequires:  tk-devel
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _ulibdir        %{_prefix}/lib
53
54 %description
55 PLplot is a library of functions that are useful for making scientific
56 plots. It can be used from within compiled languages such as C, C++,
57 FORTRAN and Java, and interactively from interpreted languages such as
58 Octave, Python, Perl and Tcl.
59
60 The PLplot library can be used to create standard X-Y plots, semilog
61 plots, log-log plots, contour plots, 3D surface plots, mesh plots, bar
62 charts and pie charts. Multiple graphs (of the same or different
63 sizes) may be placed on a single page with multiple lines in each
64 graph.
65
66 A variety of output file devices such as PostScript, PNG, JPEG, LaTeX
67 and others, as well as interactive devices such as xwin, tk, xterm and
68 Tektronics devices are supported. New devices can be easily added by
69 writing a small number of device dependent routines.
70
71 %description -l pl.UTF-8
72 PLplot to biblioteka funkcji przydatnych do tworzenia wykresów
73 naukowych. Może być używana z poziomu języków kompilowanych takich jak
74 C, C++, FORTRAN czy Java, albo interaktywnie z poziomu języków
75 interpretowanych takich jak Octave, Python, Perl czy Tcl.
76
77 Bibliotekę PLplot można wykorzystać do tworzenia standardowych
78 wykresów X-Y, wykresów półlogarytmicznych, wykresów konturowych,
79 wykresów powierzchni trójwymiarowych, wykresów siatek, wykresów
80 słupkowych i kołowych. Na jednej stronie można umieścić wiele wykresów
81 (o tych samych lub różnych rozmiarach), na jednym wykresie może być
82 wiele linii.
83
84 Obsługiwanych jest wiele urządzeń wyjściowych, w tym PostScript, PNG,
85 JPEG, LaTeX i inne, a także urządzenia interaktywne, takie jak xwin,
86 tk, xterm i Tektronics. Nowe urządzenia można łatwo dodać pisząc parę
87 zależnych od urządzenia funkcji.
88
89 %package driver-gd
90 Summary:        GD driver for PLplot library
91 Summary(pl.UTF-8):      Sterownik GD dla biblioteki PLplot
92 Group:          Libraries
93 Requires:       %{name} = %{version}-%{release}
94
95 %description driver-gd
96 GD driver for PLplot library. It supports JPEG and PNG output formats.
97
98 %description driver-gd -l pl.UTF-8
99 Sterownik GD dla biblioteki PLplot. Obsługuje formaty wyjścia JPEG i
100 PNG.
101
102 %package driver-linuxvga
103 Summary:        linuxvga driver for PLplot library
104 Summary(pl.UTF-8):      Sterownik linuxvga dla biblioteki PLplot
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description driver-linuxvga
109 linuxvga driver for PLplot library. It supports svgalib output.
110
111 %description driver-gd -l pl.UTF-8
112 Sterownik linuxvga dla biblioteki PLplot. Obsługuje wyjście poprzez
113 svgalib.
114
115 %package driver-gnome
116 Summary:        GNOME driver for PLplot library
117 Summary(pl.UTF-8):      Sterownik GNOME dla biblioteki PLplot
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description driver-gnome
122 GNOME driver for PLplot library. It supports GnomeCanvas output.
123
124 %description driver-gnome -l pl.UTF-8
125 Sterownik GNOME dla biblioteki PLplot. Obsługuje wyjście do widgetu
126 GnomeCanvas.
127
128 %package driver-ntk
129 Summary:        ntk driver for PLplot library
130 Summary(pl.UTF-8):      Sterownik ntk dla biblioteki PLplot
131 Group:          Libraries
132 Requires:       %{name} = %{version}-%{release}
133
134 %description driver-ntk
135 ntk (new tk) driver for PLplot library. It supports Tcl/Tk output.
136
137 %description driver-ntk -l pl.UTF-8
138 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście
139 poprzez Tcl/Tk.
140
141 %package driver-tk
142 Summary:        Tk drivers for PLplot library
143 Summary(pl.UTF-8):      Sterowniki Tk dla biblioteki PLplot
144 Group:          Libraries
145 Requires:       %{name}-tcl = %{version}-%{release}
146
147 %description driver-tk
148 Tk and tkwin drivers for PLplot library. They support Tcl/Tk output.
149
150 %description driver-ntk -l pl.UTF-8
151 Sterownik Tk i tkwin dla biblioteki PLplot. Obsługują wyjście poprzez
152 Tcl/Tk.
153
154 %package driver-xwin
155 Summary:        xwin driver for PLplot library
156 Summary(pl.UTF-8):      Sterownik xwin dla biblioteki PLplot
157 Group:          Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description driver-xwin
161 xwin driver for PLplot library. It supports X Window System output.
162
163 %description driver-xwin -l pl.UTF-8
164 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście do
165 okna systemu X Window.
166
167 %package devel
168 Summary:        Header files for PLplot library
169 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PLplot
170 Group:          Development/Libraries
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       freetype-devel >= 2.1
173 Requires:       qhull-devel
174
175 %description devel
176 Header files for PLplot library.
177
178 %description devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki PLplot.
180
181 %package static
182 Summary:        Static PLplot library
183 Summary(pl.UTF-8):      Statyczna biblioteka PLplot
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186
187 %description static
188 Static PLplot library.
189
190 %description static -l pl.UTF-8
191 Statyczna biblioteka PLplot.
192
193 %package c++
194 Summary:        PLplot library - C++ binding
195 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla C++
196 Group:          Libraries
197 Requires:       %{name} = %{version}-%{release}
198
199 %description c++
200 PLplot library - C++ binding.
201
202 %description c++ -l pl.UTF-8
203 Biblioteka PLplot - wiązanie dla C++.
204
205 %package c++-devel
206 Summary:        PLplot library - C++ binding development files
207 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla C++
208 Group:          Development/Libraries
209 Requires:       %{name}-c++ = %{version}-%{release}
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       libstdc++-devel
212
213 %description c++-devel
214 PLplot library - C++ binding development files.
215
216 %description c++-devel -l pl.UTF-8
217 Biblioteka PLplot - pliki programistyczne wiązania dla C++.
218
219 %package c++-static
220 Summary:        PLplot library - C++ binding static library
221 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla C++
222 Group:          Development/Libraries
223 Requires:       %{name}-c++-devel = %{version}-%{release}
224
225 %description c++-static
226 PLplot library - C++ binding static library.
227
228 %description c++-static -l pl.UTF-8
229 Biblioteka PLplot - biblioteka statyczna wiązania dla C++.
230
231 %package f77
232 Summary:        PLplot library - FORTRAN 77 binding
233 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 77
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236
237 %description f77
238 PLplot library - FORTRAN 77 binding.
239
240 %description f77 -l pl.UTF-8
241 Biblioteka PLplot - wiązanie dla języka FORTRAN 77.
242
243 %package f77-devel
244 Summary:        PLplot library - FORTRAN 77 binding development files
245 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
246 Group:          Development/Libraries
247 Requires:       %{name}-devel = %{version}-%{release}
248 Requires:       %{name}-f77 = %{version}-%{release}
249 Requires:       gcc-g77
250
251 %description f77-devel
252 PLplot library - FORTRAN 77 binding development files.
253
254 %description f77-devel -l pl.UTF-8
255 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
256 77.
257
258 %package f77-static
259 Summary:        PLplot library - FORTRAN 77 binding static library
260 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN 77
261 Group:          Development/Libraries
262 Requires:       %{name}-f77-devel = %{version}-%{release}
263
264 %description f77-static
265 PLplot library - FORTRAN 77 binding static library.
266
267 %description f77-static -l pl.UTF-8
268 Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN
269 77.
270
271 %package java
272 Summary:        PLplot library - Java binding
273 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Javy
274 Group:          Libraries
275 Requires:       %{name} = %{version}-%{release}
276
277 %description java
278 PLplot library - Java binding.
279
280 %description java -l pl.UTF-8
281 Biblioteka PLplot - wiązanie dla Javy.
282
283 %package java-devel
284 Summary:        PLplot library - Java binding development files
285 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Javy
286 Group:          Development/Libraries
287 Requires:       %{name}-devel = %{version}-%{release}
288 Requires:       %{name}-java = %{version}-%{release}
289 Obsoletes:      plplot-java-static
290
291 %description java-devel
292 PLplot library - Java binding development files.
293
294 %description java -l pl.UTF-8
295 Biblioteka PLplot - pliki programistyczne wiązania dla Javy.
296
297 %package tcl
298 Summary:        PLplot library - Tcl/Tk binding
299 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Tcl/Tk
300 Group:          Libraries
301 Requires:       %{name} = %{version}-%{release}
302
303 %description tcl
304 PLplot library - Tcl/Tk binding.
305
306 %description tcl -l pl.UTF-8
307 Biblioteka PLplot - wiązanie dla Tcl/Tk.
308
309 %package tcl-devel
310 Summary:        PLplot library - Tcl/Tk binding development files
311 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk
312 Group:          Development/Libraries
313 Requires:       %{name}-devel = %{version}-%{release}
314 Requires:       %{name}-tcl = %{version}-%{release}
315 Requires:       itcl-devel
316
317 %description tcl-devel
318 PLplot library - Tcl/Tk binding development files.
319
320 %description tcl-devel -l pl.UTF-8
321 Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk.
322
323 %package tcl-static
324 Summary:        PLplot library - Tcl/Tk binding static library
325 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk
326 Group:          Development/Libraries
327 Requires:       %{name}-tcl-devel = %{version}-%{release}
328
329 %description tcl-static
330 PLplot library - Tcl/Tk binding static library.
331
332 %description tcl-static -l pl.UTF-8
333 Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk.
334
335 %package octave
336 Summary:        PLplot library - Octave binding
337 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka Octave
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340
341 %description octave
342 PLplot library - Octave binding.
343
344 %description octave -l pl.UTF-8
345 Biblioteka PLplot - wiązanie dla języka Octave.
346
347 %package octave-examples
348 Summary:        PLplot library - examples for Octave binding
349 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla języka Octave
350 Group:          Development/Libraries
351 Requires:       %{name}-devel = %{version}-%{release}
352 Requires:       %{name}-octave = %{version}-%{release}
353
354 %description octave-examples
355 PLplot library - examples for Octave binding.
356
357 %description octave-examples -l pl.UTF-8
358 Biblioteka PLplot - przykłady do wiązania dla języka Octave.
359
360 %package -n python-plplot
361 Summary:        PLplot library - Python binding
362 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona
363 Group:          Libraries/Python
364 Requires:       %{name} = %{version}-%{release}
365 %pyrequires_eq  python-libs
366 Requires:       python-Numeric
367
368 %description -n python-plplot
369 PLplot library - Python binding.
370
371 %description -n python-plplot -l pl.UTF-8
372 Biblioteka PLplot - wiązanie dla Pythona.
373
374 %package -n python-plplot-examples
375 Summary:        PLplot library - Python binding examples
376 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla Pythona
377 Group:          Libraries/Python
378 Requires:       %{name}-devel = %{version}-%{release}
379 Requires:       python-plplot = %{version}-%{release}
380
381 %description -n python-plplot-examples
382 PLplot library - Python binding examples.
383
384 %description -n python-plplot-examples -l pl.UTF-8
385 Biblioteka PLplot - przykłady do wiązania dla Pythona.
386
387 %prep
388 %setup -q
389 %patch0 -p1
390 %if "%{_lib}" == "lib64"
391 %patch1 -p1
392 %endif
393
394 sed -i -e 's#/usr/include/tcl8.4/tcl-private/generic#%{_includedir}/tcl-private/generic#g' configure* \
395         cf/tcl.ac
396
397 %build
398 cp -f /usr/share/automake/config.* libltdl
399 %{__libtoolize}
400 %{__aclocal} -I cf
401 %{__autoconf}
402 %{__autoheader}
403 %{__automake}
404 %configure \
405         DATA_DIR="%{_libdir}/%{name}%{version}/data" \
406         PYTHON_INC_DIR=/usr/include/python%{py_ver} \
407         TCLINCDIR="%{_includedir}/tcl-private/generic" \
408         TCLLIBDIR="%{_ulibdir}" \
409         TKLIBDIR="%{_ulibdir}" \
410         ITCLLIBDIR="%{_ulibdir}" \
411         ITKLIBDIR="%{_ulibdir}" \
412         %{!?with_svga:--disable-linuxvga} \
413         --enable-conex \
414         --enable-dg300 \
415         %{?with_gnome:--enable-gnome} \
416         --enable-imp \
417         %{?with_java:JAVA_HOME=/usr/%{_lib}/java} \
418         %{!?with_java:--disable-java} \
419         --enable-ljii \
420         --enable-ljiip \
421         --enable-mskermit \
422         --enable-ntk \
423         --enable-octave \
424         --enable-tek4010 \
425         --enable-tek4010f \
426         --enable-tek4107 \
427         --enable-tek4107f \
428         --enable-versaterm \
429         --enable-vlt \
430         --enable-xterm \
431         --with-pkg-config \
432         --with-pthreads
433
434 %{__make} -j1
435
436 %install
437 rm -rf $RPM_BUILD_ROOT
438
439 %{__make} install \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 install -d $RPM_BUILD_ROOT%{_examplesdir}
443 mv -f $RPM_BUILD_ROOT%{_libdir}/plplot%{version}/data/examples \
444         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
445 mv -f $RPM_BUILD_ROOT%{_docdir}/plplot installed-docs
446 %if %{with java}
447 # java must stay in libdir - JNI wrapper included
448 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/examples \
449         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java
450 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/core/README.javaAPI installed-docs
451 %endif
452
453 %clean
454 rm -rf $RPM_BUILD_ROOT
455
456 %post   -p /sbin/ldconfig
457 %postun -p /sbin/ldconfig
458
459 %post   c++ -p /sbin/ldconfig
460 %postun c++ -p /sbin/ldconfig
461
462 %post   f77 -p /sbin/ldconfig
463 %postun f77 -p /sbin/ldconfig
464
465 %post   tcl -p /sbin/ldconfig
466 %postun tcl -p /sbin/ldconfig
467
468 %files
469 %defattr(644,root,root,755)
470 %doc AUTHORS ChangeLog Copyright FAQ NEWS PROBLEMS README SERVICE TODO* ToDo
471 %doc installed-docs/{README.1st.csa,README.1st.nn,README.csa,README.nn,README.drivers}
472 %attr(755,root,root) %{_bindir}/plm2gif
473 %attr(755,root,root) %{_bindir}/plpr
474 %attr(755,root,root) %{_bindir}/plrender
475 %attr(755,root,root) %{_bindir}/pltek
476 %attr(755,root,root) %{_bindir}/pstex2eps
477 %attr(755,root,root) %{_libdir}/libcsirocsa.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libcsirocsa.so.0
479 %attr(755,root,root) %{_libdir}/libcsironn.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libcsironn.so.0
481 %attr(755,root,root) %{_libdir}/libplplotd.so.*.*.*
482 %attr(755,root,root) %ghost %{_libdir}/libplplotd.so.9
483 %{_mandir}/man1/plm2gif.1*
484 %{_mandir}/man1/plpr.1*
485 %{_mandir}/man1/plrender.1*
486 %{_mandir}/man1/pltek.1*
487 %{_mandir}/man1/pstex2eps.1*
488 %dir %{_libdir}/plplot%{version}
489 %{_libdir}/plplot%{version}/data
490 %dir %{_libdir}/plplot%{version}/driversd
491 # drivers list; *.la are used (by libltdl)
492 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cgm.so
493 %{_libdir}/plplot%{version}/driversd/cgm.la
494 %{_libdir}/plplot%{version}/driversd/cgm.rc
495 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/dg300.so
496 %{_libdir}/plplot%{version}/driversd/dg300.la
497 %{_libdir}/plplot%{version}/driversd/dg300.rc
498 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/hpgl.so
499 %{_libdir}/plplot%{version}/driversd/hpgl.la
500 %{_libdir}/plplot%{version}/driversd/hpgl.rc
501 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/impress.so
502 %{_libdir}/plplot%{version}/driversd/impress.la
503 %{_libdir}/plplot%{version}/driversd/impress.rc
504 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljii.so
505 %{_libdir}/plplot%{version}/driversd/ljii.la
506 %{_libdir}/plplot%{version}/driversd/ljii.rc
507 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljiip.so
508 %{_libdir}/plplot%{version}/driversd/ljiip.la
509 %{_libdir}/plplot%{version}/driversd/ljiip.rc
510 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/mem.so
511 %{_libdir}/plplot%{version}/driversd/mem.la
512 %{_libdir}/plplot%{version}/driversd/mem.rc
513 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/null.so
514 %{_libdir}/plplot%{version}/driversd/null.la
515 %{_libdir}/plplot%{version}/driversd/null.rc
516 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pbm.so
517 %{_libdir}/plplot%{version}/driversd/pbm.la
518 %{_libdir}/plplot%{version}/driversd/pbm.rc
519 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/plmeta.so
520 %{_libdir}/plplot%{version}/driversd/plmeta.la
521 %{_libdir}/plplot%{version}/driversd/plmeta.rc
522 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ps.so
523 %{_libdir}/plplot%{version}/driversd/ps.la
524 %{_libdir}/plplot%{version}/driversd/ps.rc
525 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pstex.so
526 %{_libdir}/plplot%{version}/driversd/pstex.la
527 %{_libdir}/plplot%{version}/driversd/pstex.rc
528 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tek.so
529 %{_libdir}/plplot%{version}/driversd/tek.la
530 %{_libdir}/plplot%{version}/driversd/tek.rc
531 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xfig.so
532 %{_libdir}/plplot%{version}/driversd/xfig.la
533 %{_libdir}/plplot%{version}/driversd/xfig.rc
534
535 %files driver-gd
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gd.so
538 %{_libdir}/plplot%{version}/driversd/gd.la
539 %{_libdir}/plplot%{version}/driversd/gd.rc
540
541 %if %{with gnome}
542 %files driver-gnome
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gnome.so
545 %{_libdir}/plplot%{version}/driversd/gnome.la
546 %{_libdir}/plplot%{version}/driversd/gnome.rc
547 %endif
548
549 %if %{with svga}
550 %files driver-linuxvga
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/linuxvga.so
553 %{_libdir}/plplot%{version}/driversd/linuxvga.la
554 %{_libdir}/plplot%{version}/driversd/linuxvga.rc
555 %endif
556
557 %files driver-ntk
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ntk.so
560 %{_libdir}/plplot%{version}/driversd/ntk.la
561 %{_libdir}/plplot%{version}/driversd/ntk.rc
562
563 %files driver-tk
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tk.so
566 %{_libdir}/plplot%{version}/driversd/tk.la
567 %{_libdir}/plplot%{version}/driversd/tk.rc
568 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tkwin.so
569 %{_libdir}/plplot%{version}/driversd/tkwin.la
570 %{_libdir}/plplot%{version}/driversd/tkwin.rc
571
572 %files driver-xwin
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xwin.so
575 %{_libdir}/plplot%{version}/driversd/xwin.la
576 %{_libdir}/plplot%{version}/driversd/xwin.rc
577
578 %files devel
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/plplot-config
581 %attr(755,root,root) %{_bindir}/plplot_libtool
582 %attr(755,root,root) %{_libdir}/libcsirocsa.so
583 %attr(755,root,root) %{_libdir}/libcsironn.so
584 %attr(755,root,root) %{_libdir}/libplplotd.so
585 %{_libdir}/libcsirocsa.la
586 %{_libdir}/libcsironn.la
587 %{_libdir}/libplplotd.la
588 %{_includedir}/plplot
589 %exclude %{_includedir}/plplot/pltcl.h
590 %exclude %{_includedir}/plplot/pltk.h
591 %exclude %{_includedir}/plplot/tclMatrix.h
592 %{_pkgconfigdir}/plplotd.pc
593 %{_mandir}/man1/plplot_libtool.1*
594 %dir %{_examplesdir}/%{name}-%{version}
595 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test.sh
596 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c.sh
597 %{_examplesdir}/%{name}-%{version}/Makefile
598 %{_examplesdir}/%{name}-%{version}/c
599 # perl examples use PDL::Graphics::PLplot module found in perl-PDL
600 %{_examplesdir}/%{name}-%{version}/perl
601
602 %files static
603 %defattr(644,root,root,755)
604 %{_libdir}/libcsirocsa.a
605 %{_libdir}/libcsironn.a
606 %{_libdir}/libplplotd.a
607
608 %files c++
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/libplplotcxxd.so.*.*.*
611 %attr(755,root,root) %ghost %{_libdir}/libplplotcxxd.so.9
612
613 %files c++-devel
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/libplplotcxxd.so
616 %{_libdir}/libplplotcxxd.la
617 %{_pkgconfigdir}/plplotd-c++.pc
618 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_cxx.sh
619 %{_examplesdir}/%{name}-%{version}/c++
620
621 %files c++-static
622 %defattr(644,root,root,755)
623 %{_libdir}/libplplotcxxd.a
624
625 %files f77
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/libplplotf77cd.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libplplotf77cd.so.9
629 %attr(755,root,root) %{_libdir}/libplplotf77d.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libplplotf77d.so.9
631
632 %files f77-devel
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libplplotf77cd.so
635 %attr(755,root,root) %{_libdir}/libplplotf77d.so
636 %{_libdir}/libplplotf77cd.la
637 %{_libdir}/libplplotf77d.la
638 %{_pkgconfigdir}/plplotd-f77.pc
639 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f77.sh
640 %{_examplesdir}/%{name}-%{version}/f77
641
642 %files f77-static
643 %defattr(644,root,root,755)
644 %{_libdir}/libplplotf77cd.a
645 %{_libdir}/libplplotf77d.a
646
647 %if %{with java}
648 %files java
649 %defattr(644,root,root,755)
650 %doc installed-docs/README.javaAPI
651 %dir %{_libdir}/java/plplot
652 %dir %{_libdir}/java/plplot/core
653 %attr(755,root,root) %{_libdir}/java/plplot/core/*.so
654 %{_libdir}/java/plplot/core/*.class
655 %{_libdir}/java/plplot/core/*.java
656
657 %files java-devel
658 %defattr(644,root,root,755)
659 %doc installed-docs/README.javaAPI
660 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_java.sh
661 %{_examplesdir}/%{name}-%{version}/java
662 %endif
663
664 %files tcl
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/pltcl
667 %attr(755,root,root) %{_bindir}/plserver
668 %attr(755,root,root) %{_libdir}/libplplottcltkd.so.*.*.*
669 %attr(755,root,root) %ghost %{_libdir}/libplplottcltkd.so.9
670 %attr(755,root,root) %{_libdir}/libtclmatrixd.so.*.*.*
671 %attr(755,root,root) %ghost %{_libdir}/libtclmatrixd.so.9
672 %{_mandir}/man1/pltcl.1*
673 %{_mandir}/man1/plserver.1*
674
675 %files tcl-devel
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/libplplottcltkd.so
678 %attr(755,root,root) %{_libdir}/libtclmatrixd.so
679 %{_libdir}/libplplottcltkd.la
680 %{_libdir}/libtclmatrixd.la
681 %{_includedir}/plplot/pltcl.h
682 %{_includedir}/plplot/pltk.h
683 %{_includedir}/plplot/tclMatrix.h
684 %{_pkgconfigdir}/plplotd-tcl.pc
685 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_tcl.sh
686 %{_examplesdir}/%{name}-%{version}/tcl
687 %{_examplesdir}/%{name}-%{version}/tk
688
689 %files tcl-static
690 %defattr(644,root,root,755)
691 %{_libdir}/libplplottcltkd.a
692 %{_libdir}/libtclmatrixd.a
693
694 %files octave
695 %defattr(644,root,root,755)
696 %doc bindings/octave/{BUGS,FGA,README,ToDo,USAGE,plplot_octave_txt}
697 %attr(755,root,root) %{_libdir}/octave/*/oct/*/plplot_octave.oct
698 %{_datadir}/octave/site/m/PLplot
699 %{_datadir}/plplot_octave
700
701 %files octave-examples
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave.sh
704 %{_examplesdir}/%{name}-%{version}/octave
705
706 %files -n python-plplot
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{py_sitedir}/_plplotcmodule.so
709 %attr(755,root,root) %{py_sitedir}/plplot_widgetmodule.so
710 %{py_sitedir}/plplot.py
711 %{py_sitedir}/plplotc.py
712
713 %files -n python-plplot-examples
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_python.sh
716 %{_examplesdir}/%{name}-%{version}/python
This page took 0.067696 seconds and 3 git commands to generate.