]> git.pld-linux.org Git - packages/plplot.git/blob - plplot.spec
- actually use wx* BRs, build wxwidgets binding and driver (also BR: agg-devel)
[packages/plplot.git] / plplot.spec
1 # TODO:
2 # - java, itcl, perl_pdl - why disabled?
3 # - D binding
4 # - AQT (AquaTerm/AQTAdapter.h)
5 # - svgalib (bcond)?
6 # - system libharu/hpdf (libhpdf, hpdf.h)
7 #
8 # Conditional build:
9 %bcond_without  gnome2          # GNOME 2 and pygtk bindings
10 %bcond_with     perl_pdl        # enable perl examples in tests
11 %bcond_with     java            # build Java binding
12 %bcond_with     itcl            # build iTCL binding
13 #
14 Summary:        PLplot - a library of functions that are useful for making scientific plots
15 Summary(pl.UTF-8):      PLplot - biblioteka funkcji przydatnych do tworzenia wykresów naukowych
16 Name:           plplot
17 Version:        5.9.9
18 Release:        1
19 License:        LGPL v2+
20 Group:          Libraries
21 Source0:        http://downloads.sourceforge.net/plplot/%{name}-%{version}.tar.gz
22 # Source0-md5:  9f2c8536a58875d97ab6b29bbed67d26
23 Patch0:         %{name}-octave.patch
24 Patch1:         %{name}-qhull.patch
25 Patch2:         %{name}-link.patch
26 Patch3:         %{name}-cmake.patch
27 Patch4:         %{name}-nofonts.patch
28 URL:            http://plplot.sourceforge.net/
29 BuildRequires:  QtGui-devel
30 BuildRequires:  QtSvg-devel
31 BuildRequires:  QtXml-devel
32 BuildRequires:  agg-devel
33 BuildRequires:  cmake >= 2.6.4
34 BuildRequires:  docbook-style-dsssl
35 BuildRequires:  fftw3-devel
36 BuildRequires:  fftw3-single-devel
37 BuildRequires:  freetype-devel >= 2.1.0
38 BuildRequires:  gcc-c++
39 BuildRequires:  gcc-fortran
40 #BuildRequires: gd-devel
41 %{?with_itcl:BuildRequires:     itcl-devel}
42 BuildRequires:  jadetex
43 %{?with_java:BuildRequires:     jdk}
44 BuildRequires:  lapack-devel
45 BuildRequires:  libLASi-devel
46 %{?with_gnome2:BuildRequires:   libgnomeprintui-devel >= 2.2}
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libltdl-devel
49 BuildRequires:  libpng-devel
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  octave-devel >= 2:3.4.2
52 BuildRequires:  pango-devel
53 %{?with_perl_pdl:BuildRequires: perl-PDL}
54 BuildRequires:  perl-XML-DOM
55 BuildRequires:  perl-XML-Parser
56 BuildRequires:  perl-XML-SAX-Expat
57 BuildRequires:  pkgconfig
58 BuildRequires:  pango-devel
59 BuildRequires:  python-PyQt4-devel
60 BuildRequires:  python-numpy-devel >= 15.3
61 BuildRequires:  python-devel >= 1:2.3
62 %{?with_gnome2:BuildRequires:   python-pygtk-devel >= 2:2.13.0}
63 BuildRequires:  qhull-devel >= 2011.1
64 BuildRequires:  qt4-build
65 BuildRequires:  qt4-qmake
66 BuildRequires:  rpm-pythonprov
67 BuildRequires:  sed >= 4.0
68 BuildRequires:  sip
69 BuildRequires:  swig
70 BuildRequires:  swig-python
71 BuildRequires:  tcl-devel >= 8.5
72 BuildRequires:  tetex-dvips
73 BuildRequires:  texinfo
74 BuildRequires:  tk-devel >= 8.5
75 BuildRequires:  wxGTK2-unicode-devel >= 2.6.0
76 BuildRequires:  xorg-lib-libXext-devel
77 BuildRequires:  xorg-lib-libICE-devel
78 BuildRequires:  xorg-lib-libX11-devel
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         octave_oct_sitedir      %(octave-config --oct-site-dir)
82 %define         octave_m_sitedir        %(octave-config --m-site-dir)
83
84 %description
85 PLplot is a library of functions that are useful for making scientific
86 plots. It can be used from within compiled languages such as C, C++,
87 FORTRAN and Java, and interactively from interpreted languages such as
88 Octave, Python, Perl and Tcl.
89
90 The PLplot library can be used to create standard X-Y plots, semilog
91 plots, log-log plots, contour plots, 3D surface plots, mesh plots, bar
92 charts and pie charts. Multiple graphs (of the same or different
93 sizes) may be placed on a single page with multiple lines in each
94 graph.
95
96 A variety of output file devices such as PostScript, PNG, JPEG, LaTeX
97 and others, as well as interactive devices such as xwin, tk, xterm and
98 Tektronics devices are supported. New devices can be easily added by
99 writing a small number of device dependent routines.
100
101 %description -l pl.UTF-8
102 PLplot to biblioteka funkcji przydatnych do tworzenia wykresów
103 naukowych. Może być używana z poziomu języków kompilowanych takich jak
104 C, C++, FORTRAN czy Java, albo interaktywnie z poziomu języków
105 interpretowanych takich jak Octave, Python, Perl czy Tcl.
106
107 Bibliotekę PLplot można wykorzystać do tworzenia standardowych
108 wykresów X-Y, wykresów półlogarytmicznych, wykresów konturowych,
109 wykresów powierzchni trójwymiarowych, wykresów siatek, wykresów
110 słupkowych i kołowych. Na jednej stronie można umieścić wiele wykresów
111 (o tych samych lub różnych rozmiarach), na jednym wykresie może być
112 wiele linii.
113
114 Obsługiwanych jest wiele urządzeń wyjściowych, w tym PostScript, PNG,
115 JPEG, LaTeX i inne, a także urządzenia interaktywne, takie jak xwin,
116 tk, xterm i Tektronics. Nowe urządzenia można łatwo dodać pisząc parę
117 zależnych od urządzenia funkcji.
118
119 %package driver-ntk
120 Summary:        ntk driver for PLplot library
121 Summary(pl.UTF-8):      Sterownik ntk dla biblioteki PLplot
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description driver-ntk
126 ntk (new tk) driver for PLplot library. It supports Tcl/Tk output.
127
128 %description driver-ntk -l pl.UTF-8
129 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście
130 poprzez Tcl/Tk.
131
132 %package driver-psttf
133 Summary:        psttf driver for PLplot library
134 Summary(pl.UTF-8):      Sterownik psttf dla biblioteki PLplot
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description driver-psttf
139 psttf driver for PLplot library. It's PostScript driver using LASi to
140 provide fonts.
141
142 %description driver-psttf -l pl.UTF-8
143 Sterownik psttf dla biblioteki PLplot. Jest to sterownik
144 postscriptowy, wykorzystujący LASi do obsługi fontów.
145
146 %package driver-tk
147 Summary:        Tk drivers for PLplot library
148 Summary(pl.UTF-8):      Sterowniki Tk dla biblioteki PLplot
149 Group:          Libraries
150 Requires:       %{name}-tcl = %{version}-%{release}
151
152 %description driver-tk
153 Tk and tkwin drivers for PLplot library. They support Tcl/Tk output.
154
155 %description driver-tk -l pl.UTF-8
156 Sterownik Tk i tkwin dla biblioteki PLplot. Obsługują wyjście poprzez
157 Tcl/Tk.
158
159 %package driver-cairo
160 Summary:        Cairo driver for PLplot library
161 Summary(pl.UTF-8):      Sterownik cairo dla biblioteki PLplot
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164
165 %description driver-cairo
166 Cairo driver for PLplot library. It supports JPEG and PNG output
167 formats.
168
169 %description driver-cairo -l pl.UTF-8
170 Sterownik cairo dla biblioteki PLplot. Obsługuje formaty wyjścia JPEG
171 i PNG.
172
173 %package driver-qt4
174 Summary:        Qt4 driver for PLplot library
175 Summary(pl.UTF-8):      Sterownik Qt4 dla biblioteki PLplot
176 Group:          Libraries
177 Requires:       %{name}-qt4 = %{version}-%{release}
178
179 %description driver-qt4
180 Qt4 driver for PLplot library. Supports Qt4 output.
181
182 %description driver-qt4 -l pl.UTF-8
183 Sterownik Qt4 dla biblioteki PLplot. Obsługuje wyjście poprzez Qt4.
184
185 %package driver-wxwidgets
186 Summary:        wxWidgets driver for PLplot library
187 Summary(pl.UTF-8):      Sterownik wxWidgets dla biblioteki PLplot
188 Group:          Libraries
189 Requires:       %{name}-wxWidgets = %{version}-%{release}
190
191 %description driver-wxwidgets
192 wxWidgets driver for PLplot library. Supports wxWidgets output.
193
194 %description driver-wxwidgets -l pl.UTF-8
195 Sterownik wxWidgets dla biblioteki PLplot. Obsługuje wyjście poprzez
196 wxWidgets.
197
198 %package driver-xwin
199 Summary:        xwin driver for PLplot library
200 Summary(pl.UTF-8):      Sterownik xwin dla biblioteki PLplot
201 Group:          Libraries
202 Requires:       %{name} = %{version}-%{release}
203
204 %description driver-xwin
205 xwin driver for PLplot library. It supports X Window System output.
206
207 %description driver-xwin -l pl.UTF-8
208 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście do
209 okna systemu X Window.
210
211 %package devel
212 Summary:        Header files for PLplot library
213 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PLplot
214 Group:          Development/Libraries
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       freetype-devel >= 2.1
217 Requires:       qhull-devel
218 Obsoletes:      plplot-static
219
220 %description devel
221 Header files for PLplot library.
222
223 %description devel -l pl.UTF-8
224 Pliki nagłówkowe biblioteki PLplot.
225
226 %package c++
227 Summary:        PLplot library - C++ binding
228 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla C++
229 Group:          Libraries
230 Requires:       %{name} = %{version}-%{release}
231
232 %description c++
233 PLplot library - C++ binding.
234
235 %description c++ -l pl.UTF-8
236 Biblioteka PLplot - wiązanie dla C++.
237
238 %package c++-devel
239 Summary:        PLplot library - C++ binding development files
240 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla C++
241 Group:          Development/Libraries
242 Requires:       %{name}-c++ = %{version}-%{release}
243 Requires:       %{name}-devel = %{version}-%{release}
244 Requires:       libstdc++-devel
245 Obsoletes:      plplot-c++-static
246
247 %description c++-devel
248 PLplot library - C++ binding development files.
249
250 %description c++-devel -l pl.UTF-8
251 Biblioteka PLplot - pliki programistyczne wiązania dla C++.
252
253 %package f77
254 Summary:        PLplot library - FORTRAN 77 binding
255 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 77
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258
259 %description f77
260 PLplot library - FORTRAN 77 binding.
261
262 %description f77 -l pl.UTF-8
263 Biblioteka PLplot - wiązanie dla języka FORTRAN 77.
264
265 %package f77-devel
266 Summary:        PLplot library - FORTRAN 77 binding development files
267 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
268 Group:          Development/Libraries
269 Requires:       %{name}-devel = %{version}-%{release}
270 Requires:       %{name}-f77 = %{version}-%{release}
271 Requires:       gcc-fortran
272 Obsoletes:      plplot-f77-static
273
274 %description f77-devel
275 PLplot library - FORTRAN 77 binding development files.
276
277 %description f77-devel -l pl.UTF-8
278 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
279 77.
280
281 %package f95
282 Summary:        PLplot library - FORTRAN 95 binding
283 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 95
284 Group:          Libraries
285 Requires:       %{name} = %{version}-%{release}
286
287 %description f95
288 PLplot library - FORTRAN 95 binding.
289
290 %description f95 -l pl.UTF-8
291 Biblioteka PLplot - wiązanie dla języka FORTRAN 95.
292
293 %package f95-devel
294 Summary:        PLplot library - FORTRAN 95 binding development files
295 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 95
296 Group:          Development/Libraries
297 Requires:       %{name}-devel = %{version}-%{release}
298 Requires:       %{name}-f95 = %{version}-%{release}
299 Requires:       gcc-fortran
300
301 %description f95-devel
302 PLplot library - FORTRAN 95 binding development files.
303
304 %description f95-devel -l pl.UTF-8
305 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
306 95.
307
308 %package java
309 Summary:        PLplot library - Java binding
310 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Javy
311 Group:          Libraries
312 Requires:       %{name} = %{version}-%{release}
313
314 %description java
315 PLplot library - Java binding.
316
317 %description java -l pl.UTF-8
318 Biblioteka PLplot - wiązanie dla Javy.
319
320 %package java-devel
321 Summary:        PLplot library - Java binding development files
322 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Javy
323 Group:          Development/Libraries
324 Requires:       %{name}-devel = %{version}-%{release}
325 Requires:       %{name}-java = %{version}-%{release}
326 Obsoletes:      plplot-java-static
327
328 %description java-devel
329 PLplot library - Java binding development files.
330
331 %description java-devel -l pl.UTF-8
332 Biblioteka PLplot - pliki programistyczne wiązania dla Javy.
333
334 %package tcl
335 Summary:        PLplot library - Tcl/Tk binding
336 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Tcl/Tk
337 Group:          Libraries
338 Requires:       %{name} = %{version}-%{release}
339
340 %description tcl
341 PLplot library - Tcl/Tk binding.
342
343 %description tcl -l pl.UTF-8
344 Biblioteka PLplot - wiązanie dla Tcl/Tk.
345
346 %package tcl-devel
347 Summary:        PLplot library - Tcl/Tk binding development files
348 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk
349 Group:          Development/Libraries
350 Requires:       %{name}-devel = %{version}-%{release}
351 Requires:       %{name}-tcl = %{version}-%{release}
352 %{?with_itcl:Requires:  itcl-devel}
353 Obsoletes:      plplot-tcl-static
354
355 %description tcl-devel
356 PLplot library - Tcl/Tk binding development files.
357
358 %description tcl-devel -l pl.UTF-8
359 Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk.
360
361 %package qt4
362 Summary:        PLplot library - Qt4 binding
363 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Qt4
364 Group:          Libraries
365 Requires:       %{name} = %{version}-%{release}
366
367 %description qt4
368 PLplot library - Qt4 binding.
369
370 %description qt4 -l pl.UTF-8
371 Biblioteka PLplot - wiązanie dla Qt4.
372
373 %package qt4-devel
374 Summary:        PLplot library - Qt4 binding development files
375 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Qt4
376 Group:          Development/Libraries
377 Requires:       %{name}-qt4 = %{version}-%{release}
378 Requires:       %{name}-devel = %{version}-%{release}
379 Requires:       QtGui-devel
380 Requires:       QtSvg-devel
381 Requires:       QtXml-devel
382
383 %description qt4-devel
384 PLplot library - Qt4 binding development files.
385
386 %description qt4-devel -l pl.UTF-8
387 Biblioteka PLplot - pliki programistyczne wiązania dla Qt4.
388
389 %package wxwidgets
390 Summary:        PLplot library - wxWidgets binding
391 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla wxWidgets
392 Group:          Libraries
393 Requires:       %{name} = %{version}-%{release}
394 Requires:       wxGTK2-unicode >= 2.6.0
395
396 %description wxwidgets
397 PLplot library - wxwidgets binding.
398
399 %description wxwidgets -l pl.UTF-8
400 Biblioteka PLplot - wiązanie dla wxWidgets.
401
402 %package wxwidgets-devel
403 Summary:        PLplot library - wxWidgets binding development files
404 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla wxWidgets
405 Group:          Development/Libraries
406 Requires:       %{name}-wxwidgets = %{version}-%{release}
407 Requires:       %{name}-devel = %{version}-%{release}
408 Requires:       wxGTK2-unicode-devel >= 2.6.0
409
410 %description wxwidgets-devel
411 PLplot library - wxWidgets binding development files.
412
413 %description wxwidgets-devel -l pl.UTF-8
414 Biblioteka PLplot - pliki programistyczne wiązania dla wxWidgets.
415
416 %package octave
417 Summary:        PLplot library - Octave binding
418 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka Octave
419 Group:          Libraries
420 Requires:       %{name} = %{version}-%{release}
421
422 %description octave
423 PLplot library - Octave binding.
424
425 %description octave -l pl.UTF-8
426 Biblioteka PLplot - wiązanie dla języka Octave.
427
428 %package octave-examples
429 Summary:        PLplot library - examples for Octave binding
430 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla języka Octave
431 Group:          Development/Libraries
432 Requires:       %{name}-devel = %{version}-%{release}
433 Requires:       %{name}-octave = %{version}-%{release}
434
435 %description octave-examples
436 PLplot library - examples for Octave binding.
437
438 %description octave-examples -l pl.UTF-8
439 Biblioteka PLplot - przykłady do wiązania dla języka Octave.
440
441 %package -n python-plplot
442 Summary:        PLplot library - Python binding
443 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona
444 Group:          Libraries/Python
445 Requires:       %{name} = %{version}-%{release}
446 Requires:       %{name}-tcl = %{version}-%{release}
447 %pyrequires_eq  python-libs
448 Requires:       python-numpy
449
450 %description -n python-plplot
451 PLplot library - Python binding.
452
453 %description -n python-plplot -l pl.UTF-8
454 Biblioteka PLplot - wiązanie dla Pythona.
455
456 %package -n python-plplot-qt4
457 Summary:        PLplot library - PyQt4 binding
458 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla PyQt4
459 Group:          Libraries/Python
460 Requires:       python-plplot = %{version}-%{release}
461 %pyrequires_eq  python-libs
462 Requires:       python-numpy
463
464 %description -n python-plplot-qt4
465 PLplot library - Python/PyQt4 binding.
466
467 %description -n python-plplot-qt4 -l pl.UTF-8
468 Biblioteka PLplot - wiązanie dla Pythona/PyQt4.
469
470 %package -n python-plplot-examples
471 Summary:        PLplot library - Python binding examples
472 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla Pythona
473 Group:          Libraries/Python
474 Requires:       %{name}-devel = %{version}-%{release}
475 Requires:       python-plplot = %{version}-%{release}
476
477 %description -n python-plplot-examples
478 PLplot library - Python binding examples.
479
480 %description -n python-plplot-examples -l pl.UTF-8
481 Biblioteka PLplot - przykłady do wiązania dla Pythona.
482
483 %prep
484 %setup -q
485 %patch0 -p1
486 %patch1 -p1
487 %patch2 -p1
488 %patch3 -p1
489 %patch4 -p1
490
491 %build
492 mkdir build
493 cd build
494 %cmake .. \
495 %if %{with java}
496         -DJAVA_HOME=/usr/%{_lib}/java \
497 %else
498         -DENABLE_java=OFF \
499 %endif
500         -DF77_INCLUDE_DIR=%{_includedir}/plplot \
501         -DF95_MOD_DIR=%{_includedir}/plplot \
502         -DOCTAVE_INCLUDE_PATH=%{_includedir}/octave \
503         -DOCTAVE_OCT_DIR=%{octave_oct_sitedir} \
504         -DOCTAVE_M_DIR=%{octave_m_sitedir} \
505         -DUSE_RPATH=OFF \
506         -DENABLE_tk=ON \
507         -DENABLE_ocaml=OFF \
508         -DENABLE_lua=OFF \
509         -DENABLE_ada=OFF \
510         -DENABLE_itcl=%{!?with_itcl:OFF}%{?with_itcl:ON} \
511         -DENABLE_itk=%{!?with_itcl:OFF}%{?with_itcl:ON} \
512         -DHAVE_PTHREAD=ON \
513         -DPLD_ntk=ON \
514         -DPLD_plmeta=ON \
515         -DPLD_cgm=ON \
516         -DPLD_pstex=ON \
517         -DPL_FREETYPE_FONT_PATH=/usr/share/fonts/TTF \
518         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk2-unicode-config \
519         -DwxWidgets_USE_UNICODE=ON \
520         %{!?with_perl_pdl:-DENABLE_pdl=OFF}
521
522 #        -DCMAKE_Java_RUNTIME=$(JAVA_HOME)/bin/java \
523 #        -DCMAKE_Java_COMPILER=$(JAVA_HOME)/bin/javac \
524 #        -DCMAKE_Java_ARCHIVE=$(JAVA_HOME)/bin/jar
525
526 %{__make}
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530 install -d $RPM_BUILD_ROOT%{_examplesdir}
531
532 %{__make} -C build install \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 mv $RPM_BUILD_ROOT%{_datadir}/plplot%{version}/examples \
536         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
537
538 rm -rf installed-docs
539 mv $RPM_BUILD_ROOT%{_docdir}/plplot installed-docs
540
541 %if %{with java}
542 # java must stay in libdir - JNI wrapper included
543 mv $RPM_BUILD_ROOT%{_libdir}/java/plplot/examples \
544         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java
545 mv $RPM_BUILD_ROOT%{_libdir}/java/plplot/core/README.javaAPI installed-docs
546 %endif
547
548 %clean
549 rm -rf $RPM_BUILD_ROOT
550
551 %post   -p /sbin/ldconfig
552 %postun -p /sbin/ldconfig
553
554 %post   c++ -p /sbin/ldconfig
555 %postun c++ -p /sbin/ldconfig
556
557 %post   f77 -p /sbin/ldconfig
558 %postun f77 -p /sbin/ldconfig
559
560 %post   f95 -p /sbin/ldconfig
561 %postun f95 -p /sbin/ldconfig
562
563 %post   tcl -p /sbin/ldconfig
564 %postun tcl -p /sbin/ldconfig
565
566 %post   qt4 -p /sbin/ldconfig
567 %postun qt4 -p /sbin/ldconfig
568
569 %post   wxwidgets -p /sbin/ldconfig
570 %postun wxwidgets -p /sbin/ldconfig
571
572 %files
573 %defattr(644,root,root,755)
574 %doc ABOUT AUTHORS ChangeLog.release Copyright FAQ NEWS PROBLEMS README README.release SERVICE ToDo
575 %doc installed-docs/README.{1st.csa,1st.nn,csa,nn,drivers}
576 %attr(755,root,root) %{_bindir}/plm2gif
577 %attr(755,root,root) %{_bindir}/plpr
578 %attr(755,root,root) %{_bindir}/plrender
579 %attr(755,root,root) %{_bindir}/pltek
580 %attr(755,root,root) %{_bindir}/pstex2eps
581 %attr(755,root,root) %{_libdir}/libcsirocsa.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libcsirocsa.so.0
583 %attr(755,root,root) %{_libdir}/libcsironn.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libcsironn.so.0
585 %attr(755,root,root) %{_libdir}/libnistcd.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libnistcd.so.0
587 %attr(755,root,root) %{_libdir}/libqsastime.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/libqsastime.so.0
589 %attr(755,root,root) %{_libdir}/libplplotd.so.*.*.*
590 %attr(755,root,root) %ghost %{_libdir}/libplplotd.so.11
591 %{_mandir}/man1/plm2gif.1*
592 %{_mandir}/man1/plpr.1*
593 %{_mandir}/man1/plrender.1*
594 %{_mandir}/man1/pltek.1*
595 %{_mandir}/man1/pstex2eps.1*
596 %dir %{_libdir}/plplot%{version}
597 %dir %{_libdir}/plplot%{version}/driversd
598 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cgm.so
599 %{_libdir}/plplot%{version}/driversd/cgm.driver_info
600 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/mem.so
601 %{_libdir}/plplot%{version}/driversd/mem.driver_info
602 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/null.so
603 %{_libdir}/plplot%{version}/driversd/null.driver_info
604 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/plmeta.so
605 %{_libdir}/plplot%{version}/driversd/plmeta.driver_info
606 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ps.so
607 %{_libdir}/plplot%{version}/driversd/ps.driver_info
608 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pstex.so
609 %{_libdir}/plplot%{version}/driversd/pstex.driver_info
610 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/svg.so
611 %{_libdir}/plplot%{version}/driversd/svg.driver_info
612 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xfig.so
613 %{_libdir}/plplot%{version}/driversd/xfig.driver_info
614 %dir %{_datadir}/plplot%{version}
615 %{_datadir}/plplot%{version}/*.map
616 %{_datadir}/plplot%{version}/*.pal
617 %{_datadir}/plplot%{version}/*.fnt
618
619 %files driver-cairo
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cairo.so
622 %{_libdir}/plplot%{version}/driversd/cairo.driver_info
623
624 %files driver-ntk
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ntk.so
627 %{_libdir}/plplot%{version}/driversd/ntk.driver_info
628
629 %files driver-psttf
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/psttf.so
632 %{_libdir}/plplot%{version}/driversd/psttf.driver_info
633
634 %files driver-tk
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tk.so
637 %{_libdir}/plplot%{version}/driversd/tk.driver_info
638 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tkwin.so
639 %{_libdir}/plplot%{version}/driversd/tkwin.driver_info
640
641 %files driver-qt4
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/qt.so
644 %{_libdir}/plplot%{version}/driversd/qt.driver_info
645
646 %files driver-wxwidgets
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/wxwidgets.so
649 %{_libdir}/plplot%{version}/driversd/wxwidgets.driver_info
650
651 %files driver-xwin
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xwin.so
654 %{_libdir}/plplot%{version}/driversd/xwin.driver_info
655
656 %files devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libcsirocsa.so
659 %attr(755,root,root) %{_libdir}/libcsironn.so
660 %attr(755,root,root) %{_libdir}/libnistcd.so
661 %attr(755,root,root) %{_libdir}/libplplotd.so
662 %attr(755,root,root) %{_libdir}/libqsastime.so
663 %dir %{_includedir}/plplot
664 %{_includedir}/plplot/cd.h
665 %{_includedir}/plplot/defines.h
666 %{_includedir}/plplot/disptab.h
667 %{_includedir}/plplot/drivers.h
668 %{_includedir}/plplot/pdf.h
669 %{_includedir}/plplot/plConfig.h
670 %{_includedir}/plplot/plDevs.h
671 %{_includedir}/plplot/pldebug.h
672 %{_includedir}/plplot/pldll.h
673 %{_includedir}/plplot/plevent.h
674 %{_includedir}/plplot/plplot.h
675 %{_includedir}/plplot/plplotP.h
676 %{_includedir}/plplot/plstrm.h
677 %{_includedir}/plplot/qsastime.h
678 %{_includedir}/plplot/qsastimedll.h
679 # xwin driver (uses X11 headers)
680 %{_includedir}/plplot/plxwd.h
681 # -gnome
682 %{_includedir}/plplot/gcw.h
683 %{_includedir}/plplot/plplotcanvas.h
684 %{_pkgconfigdir}/plplotd.pc
685 %dir %{_examplesdir}/%{name}-%{version}
686 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test.sh
687 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c.sh
688 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test-interactive.sh
689 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c_interactive.sh
690 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_diff.sh
691 %{_examplesdir}/%{name}-%{version}/c
692 %{_examplesdir}/%{name}-%{version}/cmake
693 %{_examplesdir}/%{name}-%{version}/CMakeLists.txt
694 %{_examplesdir}/%{name}-%{version}/lena.*
695 %{_examplesdir}/%{name}-%{version}/Makefile
696 %if %{with perl_pdl}
697 # perl examples use PDL::Graphics::PLplot module found in perl-PDL
698 %{_examplesdir}/%{name}-%{version}/perl
699 %endif
700
701 %files c++
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libplplotcxxd.so.*.*.*
704 %attr(755,root,root) %ghost %{_libdir}/libplplotcxxd.so.10
705
706 %files c++-devel
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/libplplotcxxd.so
709 %{_includedir}/plplot/plstream.h
710 %{_pkgconfigdir}/plplotd-c++.pc
711 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_cxx.sh
712 %{_examplesdir}/%{name}-%{version}/c++
713
714 %files f77
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libplplotf77cd.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libplplotf77cd.so.9
718 %attr(755,root,root) %{_libdir}/libplplotf77d.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libplplotf77d.so.9
720
721 %files f77-devel
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libplplotf77cd.so
724 %attr(755,root,root) %{_libdir}/libplplotf77d.so
725 %{_includedir}/plplot/plplot_parameters.h
726 %{_pkgconfigdir}/plplotd-f77.pc
727 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f77.sh
728 %{_examplesdir}/%{name}-%{version}/f77
729
730 %files f95
731 %defattr(644,root,root,755)
732 %doc bindings/f95/readme_f95.txt
733 %attr(755,root,root) %{_libdir}/libplplotf95cd.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libplplotf95cd.so.9
735 %attr(755,root,root) %{_libdir}/libplplotf95d.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libplplotf95d.so.9
737
738 %files f95-devel
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libplplotf95cd.so
741 %attr(755,root,root) %{_libdir}/libplplotf95d.so
742 %{_includedir}/plplot/plplot.mod
743 %{_includedir}/plplot/plplot_flt.mod
744 %{_includedir}/plplot/plplotp.mod
745 %{_pkgconfigdir}/plplotd-f95.pc
746 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f95.sh
747 %{_examplesdir}/%{name}-%{version}/f95
748
749 %if %{with java}
750 %files java
751 %defattr(644,root,root,755)
752 %dir %{_libdir}/java/plplot
753 %dir %{_libdir}/java/plplot/core
754 %attr(755,root,root) %{_libdir}/java/plplot/core/*.so
755 %{_libdir}/java/plplot/core/*.class
756 %{_libdir}/java/plplot/core/*.java
757
758 %files java-devel
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_java.sh
761 %{_examplesdir}/%{name}-%{version}/java
762 %endif
763
764 %files tcl
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_bindir}/pltcl
767 %attr(755,root,root) %{_bindir}/plserver
768 %attr(755,root,root) %{_libdir}/libplplottcltkd.so.*.*.*
769 %attr(755,root,root) %ghost %{_libdir}/libplplottcltkd.so.9
770 %attr(755,root,root) %{_libdir}/libtclmatrixd.so.*.*.*
771 %attr(755,root,root) %ghost %{_libdir}/libtclmatrixd.so.9
772 %{_datadir}/plplot%{version}/*.tcl
773 %{_datadir}/plplot%{version}/tcl
774 %{_mandir}/man1/pltcl.1*
775 %{_mandir}/man1/plserver.1*
776
777 %files tcl-devel
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libplplottcltkd.so
780 %attr(755,root,root) %{_libdir}/libtclmatrixd.so
781 %{_includedir}/plplot/pltcl.h
782 %{_includedir}/plplot/pltk.h
783 %{_includedir}/plplot/tclMatrix.h
784 %{_pkgconfigdir}/plplotd-tcl.pc
785 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_tcl.sh
786 %{_examplesdir}/%{name}-%{version}/tcl
787 %{_examplesdir}/%{name}-%{version}/tk
788
789 %files qt4
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %ghost %{_libdir}/libplplotqtd.so.0
792 %attr(755,root,root) %{_libdir}/libplplotqtd.so.0.0.1
793
794 %files qt4-devel
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libplplotqtd.so
797 %{_includedir}/plplot/qt.h
798 %{_pkgconfigdir}/plplotd-qt.pc
799
800 %files wxwidgets
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libplplotwxwidgetsd.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libplplotwxwidgetsd.so.0
804
805 %files wxwidgets-devel
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libplplotwxwidgetsd.so
808 %{_includedir}/plplot/wxPLplot*.h
809 %{_pkgconfigdir}/plplotd-wxwidgets.pc
810
811 %files octave
812 %defattr(644,root,root,755)
813 %doc bindings/octave/{BUGS,FGA,README,ToDo,USAGE}
814 %attr(755,root,root) %{octave_oct_sitedir}/plplot_octave.oct
815 %{octave_m_sitedir}/PLplot
816 %{_datadir}/plplot_octave
817 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave_interactive.sh
818
819 %files octave-examples
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave.sh
822 %{_examplesdir}/%{name}-%{version}/octave
823
824 %files -n python-plplot
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{py_sitedir}/_plplotcmodule.so
827 %attr(755,root,root) %{py_sitedir}/plplot_widgetmodule.so
828 %{py_sitedir}/Plframe.py
829 %{py_sitedir}/plplotc.py
830 %{py_sitedir}/plplot.py
831 %{py_sitedir}/TclSup.py
832
833 %files -n python-plplot-qt4
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{py_sitedir}/plplot_pyqt4.so
836
837 %files -n python-plplot-examples
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_python.sh
840 %{_examplesdir}/%{name}-%{version}/python
This page took 0.08083 seconds and 3 git commands to generate.