]> git.pld-linux.org Git - packages/plplot.git/blob - plplot.spec
- %description <name> for correct %package
[packages/plplot.git] / plplot.spec
1 #
2 # Conditional build:
3 %bcond_with     perl_pdl        # enable perl examples in tests
4 %bcond_with     java            # build Java binding
5 %bcond_with     itcl            # build iTCL binding
6 #
7 Summary:        PLplot - a library of functions that are useful for making scientific plots
8 Summary(pl.UTF-8):      PLplot - biblioteka funkcji przydatnych do tworzenia wykresów naukowych
9 Name:           plplot
10 Version:        5.9.6
11 Release:        2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/plplot/%{name}-%{version}.tar.gz
15 # Source0-md5:  772c772bde3a107e5f06d21cefa7f6b6
16 Patch0:         %{name}-octave.patch
17 URL:            http://plplot.sourceforge.net/
18 BuildRequires:  QtGui-devel
19 BuildRequires:  QtSvg-devel
20 BuildRequires:  QtXml-devel
21 BuildRequires:  cmake
22 BuildRequires:  docbook-style-dsssl
23 BuildRequires:  fftw3-devel
24 BuildRequires:  fftw3-single-devel
25 BuildRequires:  freetype-devel >= 2.1.0
26 BuildRequires:  gcc-c++
27 BuildRequires:  gcc-fortran
28 %{?with_itcl:BuildRequires:     itcl-devel}
29 BuildRequires:  jadetex
30 %{?with_java:BuildRequires:     jdk}
31 BuildRequires:  lapack-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libltdl-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  octave-devel
37 BuildRequires:  pango-devel
38 %{?with_perl_pdl:BuildRequires: perl-PDL}
39 BuildRequires:  perl-XML-DOM
40 BuildRequires:  perl-XML-Parser
41 BuildRequires:  perl-XML-SAX-Expat
42 BuildRequires:  pkgconfig
43 BuildRequires:  pango-devel
44 BuildRequires:  python-PyQt4-devel
45 BuildRequires:  python-numpy-devel >= 15.3
46 BuildRequires:  python-devel >= 1:2.3
47 BuildRequires:  python-pygtk-devel >= 2:2.12.1
48 BuildRequires:  qhull-devel
49 BuildRequires:  qt4-build
50 BuildRequires:  qt4-qmake
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  sed >= 4.0
53 BuildRequires:  sip
54 BuildRequires:  swig
55 BuildRequires:  swig-python
56 BuildRequires:  tcl-devel >= 8.4.11-3
57 BuildRequires:  tetex-dvips
58 BuildRequires:  texinfo
59 BuildRequires:  tk-devel
60 BuildRequires:  xorg-lib-libXext-devel
61 BuildRequires:  xorg-lib-libICE-devel
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # libcsironn.so.0.0.1, hypot is on libm and libcsironn IS linked with libm
66 %define         no_install_post_check_so        1
67
68 %define         octave_oct_sitedir      %(octave-config --oct-site-dir)
69 %define         octave_m_sitedir        %(octave-config --m-site-dir)
70
71 %description
72 PLplot is a library of functions that are useful for making scientific
73 plots. It can be used from within compiled languages such as C, C++,
74 FORTRAN and Java, and interactively from interpreted languages such as
75 Octave, Python, Perl and Tcl.
76
77 The PLplot library can be used to create standard X-Y plots, semilog
78 plots, log-log plots, contour plots, 3D surface plots, mesh plots, bar
79 charts and pie charts. Multiple graphs (of the same or different
80 sizes) may be placed on a single page with multiple lines in each
81 graph.
82
83 A variety of output file devices such as PostScript, PNG, JPEG, LaTeX
84 and others, as well as interactive devices such as xwin, tk, xterm and
85 Tektronics devices are supported. New devices can be easily added by
86 writing a small number of device dependent routines.
87
88 %description -l pl.UTF-8
89 PLplot to biblioteka funkcji przydatnych do tworzenia wykresów
90 naukowych. Może być używana z poziomu języków kompilowanych takich jak
91 C, C++, FORTRAN czy Java, albo interaktywnie z poziomu języków
92 interpretowanych takich jak Octave, Python, Perl czy Tcl.
93
94 Bibliotekę PLplot można wykorzystać do tworzenia standardowych
95 wykresów X-Y, wykresów półlogarytmicznych, wykresów konturowych,
96 wykresów powierzchni trójwymiarowych, wykresów siatek, wykresów
97 słupkowych i kołowych. Na jednej stronie można umieścić wiele wykresów
98 (o tych samych lub różnych rozmiarach), na jednym wykresie może być
99 wiele linii.
100
101 Obsługiwanych jest wiele urządzeń wyjściowych, w tym PostScript, PNG,
102 JPEG, LaTeX i inne, a także urządzenia interaktywne, takie jak xwin,
103 tk, xterm i Tektronics. Nowe urządzenia można łatwo dodać pisząc parę
104 zależnych od urządzenia funkcji.
105
106 %package driver-ntk
107 Summary:        ntk driver for PLplot library
108 Summary(pl.UTF-8):      Sterownik ntk dla biblioteki PLplot
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description driver-ntk
113 ntk (new tk) driver for PLplot library. It supports Tcl/Tk output.
114
115 %description driver-ntk -l pl.UTF-8
116 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście
117 poprzez Tcl/Tk.
118
119 %package driver-tk
120 Summary:        Tk drivers for PLplot library
121 Summary(pl.UTF-8):      Sterowniki Tk dla biblioteki PLplot
122 Group:          Libraries
123 Requires:       %{name}-tcl = %{version}-%{release}
124
125 %description driver-tk
126 Tk and tkwin drivers for PLplot library. They support Tcl/Tk output.
127
128 %description driver-tk -l pl.UTF-8
129 Sterownik Tk i tkwin dla biblioteki PLplot. Obsługują wyjście poprzez
130 Tcl/Tk.
131
132 %package driver-cairo
133 Summary:        Cairo driver for PLplot library
134 Summary(pl.UTF-8):      Sterownik cairo dla biblioteki PLplot
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description driver-cairo
139 Cairo driver for PLplot library.
140 It supports JPEG and PNG output formats.
141
142 %description driver-cairo -l pl.UTF-8
143 Sterownik cairo dla biblioteki PLplot.
144 Obsługuje formaty wyjścia JPEG i PNG.
145
146 %package driver-qt4
147 Summary:        Qt4 driver for PLplot library
148 Summary(pl.UTF-8):      Sterownik Qt4 dla biblioteki PLplot
149 Group:          Libraries
150 Requires:       %{name}-qt4 = %{version}-%{release}
151
152 %description driver-qt4
153 Tk driver for PLplot library. Supports Qt4 output.
154
155 %description driver-qt4 -l pl.UTF-8
156 Sterownik Qt4 dla biblioteki PLplot. Obsługuje wyjście poprzez Qt4.
157
158 %package driver-xwin
159 Summary:        xwin driver for PLplot library
160 Summary(pl.UTF-8):      Sterownik xwin dla biblioteki PLplot
161 Group:          Libraries
162 Requires:       %{name} = %{version}-%{release}
163
164 %description driver-xwin
165 xwin driver for PLplot library. It supports X Window System output.
166
167 %description driver-xwin -l pl.UTF-8
168 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście do
169 okna systemu X Window.
170
171 %package devel
172 Summary:        Header files for PLplot library
173 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PLplot
174 Group:          Development/Libraries
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       freetype-devel >= 2.1
177 Requires:       qhull-devel
178 Obsoletes:      plplot-static
179
180 %description devel
181 Header files for PLplot library.
182
183 %description devel -l pl.UTF-8
184 Pliki nagłówkowe biblioteki PLplot.
185
186 %package c++
187 Summary:        PLplot library - C++ binding
188 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla C++
189 Group:          Libraries
190 Requires:       %{name} = %{version}-%{release}
191
192 %description c++
193 PLplot library - C++ binding.
194
195 %description c++ -l pl.UTF-8
196 Biblioteka PLplot - wiązanie dla C++.
197
198 %package c++-devel
199 Summary:        PLplot library - C++ binding development files
200 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla C++
201 Group:          Development/Libraries
202 Requires:       %{name}-c++ = %{version}-%{release}
203 Requires:       %{name}-devel = %{version}-%{release}
204 Requires:       libstdc++-devel
205 Obsoletes:      plplot-c++-static
206
207 %description c++-devel
208 PLplot library - C++ binding development files.
209
210 %description c++-devel -l pl.UTF-8
211 Biblioteka PLplot - pliki programistyczne wiązania dla C++.
212
213 %package f77
214 Summary:        PLplot library - FORTRAN 77 binding
215 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 77
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218
219 %description f77
220 PLplot library - FORTRAN 77 binding.
221
222 %description f77 -l pl.UTF-8
223 Biblioteka PLplot - wiązanie dla języka FORTRAN 77.
224
225 %package f77-devel
226 Summary:        PLplot library - FORTRAN 77 binding development files
227 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
228 Group:          Development/Libraries
229 Requires:       %{name}-devel = %{version}-%{release}
230 Requires:       %{name}-f77 = %{version}-%{release}
231 Requires:       gcc-fortran
232 Obsoletes:      plplot-f77-static
233
234 %description f77-devel
235 PLplot library - FORTRAN 77 binding development files.
236
237 %description f77-devel -l pl.UTF-8
238 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
239 77.
240
241 %package f95
242 Summary:        PLplot library - FORTRAN 95 binding
243 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 95
244 Group:          Libraries
245 Requires:       %{name} = %{version}-%{release}
246
247 %description f95
248 PLplot library - FORTRAN 95 binding.
249
250 %description f95 -l pl.UTF-8
251 Biblioteka PLplot - wiązanie dla języka FORTRAN 95.
252
253 %package f95-devel
254 Summary:        PLplot library - FORTRAN 95 binding development files
255 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
256 Group:          Development/Libraries
257 Requires:       %{name}-devel = %{version}-%{release}
258 Requires:       %{name}-f95 = %{version}-%{release}
259 Requires:       gcc-fortran
260
261 %description f95-devel
262 PLplot library - FORTRAN 95 binding development files.
263
264 %description f95-devel -l pl.UTF-8
265 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
266 95.
267
268 %package java
269 Summary:        PLplot library - Java binding
270 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Javy
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273
274 %description java
275 PLplot library - Java binding.
276
277 %description java -l pl.UTF-8
278 Biblioteka PLplot - wiązanie dla Javy.
279
280 %package java-devel
281 Summary:        PLplot library - Java binding development files
282 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Javy
283 Group:          Development/Libraries
284 Requires:       %{name}-devel = %{version}-%{release}
285 Requires:       %{name}-java = %{version}-%{release}
286 Obsoletes:      plplot-java-static
287
288 %description java-devel
289 PLplot library - Java binding development files.
290
291 %description java-devel -l pl.UTF-8
292 Biblioteka PLplot - pliki programistyczne wiązania dla Javy.
293
294 %package tcl
295 Summary:        PLplot library - Tcl/Tk binding
296 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Tcl/Tk
297 Group:          Libraries
298 Requires:       %{name} = %{version}-%{release}
299
300 %description tcl
301 PLplot library - Tcl/Tk binding.
302
303 %description tcl -l pl.UTF-8
304 Biblioteka PLplot - wiązanie dla Tcl/Tk.
305
306 %package tcl-devel
307 Summary:        PLplot library - Tcl/Tk binding development files
308 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk
309 Group:          Development/Libraries
310 Requires:       %{name}-devel = %{version}-%{release}
311 Requires:       %{name}-tcl = %{version}-%{release}
312 %{?with_itcl:Requires:  itcl-devel}
313 Obsoletes:      plplot-tcl-static
314
315 %description tcl-devel
316 PLplot library - Tcl/Tk binding development files.
317
318 %description tcl-devel -l pl.UTF-8
319 Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk.
320
321 %package qt4
322 Summary:        PLplot library - Qt4 binding
323 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Qt4
324 Group:          Libraries
325 Requires:       %{name} = %{version}-%{release}
326
327 %description qt4
328 PLplot library - Qt4 binding.
329
330 %description qt4 -l pl.UTF-8
331 Biblioteka PLplot - wiązanie dla Qt4.
332
333 %package qt4-devel
334 Summary:        PLplot library - Qt4 binding development files
335 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Qt4
336 Group:          Development/Libraries
337 Requires:       %{name}-qt4 = %{version}-%{release}
338 Requires:       %{name}-devel = %{version}-%{release}
339 Requires:       QtGui-devel
340 Requires:       QtSvg-devel
341 Requires:       QtXml-devel
342
343 %description qt4-devel
344 PLplot library - Qt4 binding development files.
345
346 %description qt4-devel -l pl.UTF-8
347 Biblioteka PLplot - pliki programistyczne wiązania dla Qt4.
348
349 %package octave
350 Summary:        PLplot library - Octave binding
351 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka Octave
352 Group:          Libraries
353 Requires:       %{name} = %{version}-%{release}
354
355 %description octave
356 PLplot library - Octave binding.
357
358 %description octave -l pl.UTF-8
359 Biblioteka PLplot - wiązanie dla języka Octave.
360
361 %package octave-examples
362 Summary:        PLplot library - examples for Octave binding
363 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla języka Octave
364 Group:          Development/Libraries
365 Requires:       %{name}-devel = %{version}-%{release}
366 Requires:       %{name}-octave = %{version}-%{release}
367
368 %description octave-examples
369 PLplot library - examples for Octave binding.
370
371 %description octave-examples -l pl.UTF-8
372 Biblioteka PLplot - przykłady do wiązania dla języka Octave.
373
374 %package -n python-plplot
375 Summary:        PLplot library - Python binding
376 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona
377 Group:          Libraries/Python
378 Requires:       %{name} = %{version}-%{release}
379 %pyrequires_eq  python-libs
380 Requires:       python-numpy
381
382 %description -n python-plplot
383 PLplot library - Python binding.
384
385 %description -n python-plplot -l pl.UTF-8
386 Biblioteka PLplot - wiązanie dla Pythona.
387
388 %package -n python-plplot-qt4
389 Summary:        PLplot library - Python Qt4 binding
390 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona Qt4
391 Group:          Libraries/Python
392 Requires:       python-plplot = %{version}-%{release}
393 %pyrequires_eq  python-libs
394 Requires:       python-numpy
395
396 %description -n python-plplot-qt4
397 PLplot library - Python Qt4 binding.
398
399 %description -n python-plplot-qt4 -l pl.UTF-8
400 Biblioteka PLplot - wiązanie dla Pythona Qt4.
401
402 %package -n python-plplot-examples
403 Summary:        PLplot library - Python binding examples
404 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla Pythona
405 Group:          Libraries/Python
406 Requires:       %{name}-devel = %{version}-%{release}
407 Requires:       python-plplot = %{version}-%{release}
408
409 %description -n python-plplot-examples
410 PLplot library - Python binding examples.
411
412 %description -n python-plplot-examples -l pl.UTF-8
413 Biblioteka PLplot - przykłady do wiązania dla Pythona.
414
415 %prep
416 %setup -q
417 %patch0 -p1
418
419 %build
420 mkdir build
421 cd build
422 cmake \
423         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
424         -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
425 %if %{with java}
426         -DJAVA_HOME=/usr/%{_lib}/java \
427 #        -DCMAKE_Java_RUNTIME=$(JAVA_HOME)/bin/java \
428 #        -DCMAKE_Java_COMPILER=$(JAVA_HOME)/bin/javac \
429 #        -DCMAKE_Java_ARCHIVE=$(JAVA_HOME)/bin/jar
430 %else
431         -DENABLE_java=OFF \
432 %endif
433         -DHAVE_PTHREAD=ON \
434         -DOCTAVE_INCLUDE_PATH=%{_includedir}/octave \
435         -DOCTAVE_OCT_DIR=%{octave_oct_sitedir} \
436         -DOCTAVE_M_DIR=%{octave_m_sitedir} \
437         -DUSE_RPATH=OFF \
438         -DENABLE_tk=ON \
439         -DENABLE_ocaml=OFF \
440         -DENABLE_lua=OFF \
441         -DENABLE_ada=OFF \
442         -DENABLE_itcl=%{!?with_itcl:OFF}%{?with_itcl:ON} \
443         -DENABLE_itk=%{!?with_itcl:OFF}%{?with_itcl:ON} \
444         -DPLD_ntk=ON \
445         -DPLD_plmeta=ON \
446         -DPLD_cgm=ON \
447         -DPLD_pstex=ON \
448         -DwxWidgets_CONFIG_EXECUTABLE=wx-gtk2-unicode-config \
449         -DwxWidgets_USE_UNICODE=ON \
450         %{!?with_perl_pdl:-DENABLE_pdl=OFF} \
451         ../
452
453 %{__make}
454
455 %install
456 rm -rf $RPM_BUILD_ROOT
457 install -d $RPM_BUILD_ROOT%{_examplesdir}
458
459 cd build
460 %{__make} install \
461         DESTDIR=$RPM_BUILD_ROOT
462
463 mv $RPM_BUILD_ROOT%{_datadir}/plplot%{version}/examples \
464         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
465
466 rm -rf installed-docs
467 mv $RPM_BUILD_ROOT%{_docdir}/plplot installed-docs
468
469 %if %{with java}
470 # java must stay in libdir - JNI wrapper included
471 mv $RPM_BUILD_ROOT%{_libdir}/java/plplot/examples \
472         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java
473 mv $RPM_BUILD_ROOT%{_libdir}/java/plplot/core/README.javaAPI installed-docs
474 %endif
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %post   -p /sbin/ldconfig
480 %postun -p /sbin/ldconfig
481
482 %post   c++ -p /sbin/ldconfig
483 %postun c++ -p /sbin/ldconfig
484
485 %post   f77 -p /sbin/ldconfig
486 %postun f77 -p /sbin/ldconfig
487
488 %post   f95 -p /sbin/ldconfig
489 %postun f95 -p /sbin/ldconfig
490
491 %post   tcl -p /sbin/ldconfig
492 %postun tcl -p /sbin/ldconfig
493
494 %post   qt4 -p /sbin/ldconfig
495 %postun qt4 -p /sbin/ldconfig
496
497 %files
498 %defattr(644,root,root,755)
499 %doc AUTHORS ChangeLog Copyright FAQ NEWS PROBLEMS README SERVICE ToDo
500 %doc build/installed-docs/README.{1st.csa,1st.nn,csa,nn,drivers}
501 %attr(755,root,root) %{_bindir}/plm2gif
502 %attr(755,root,root) %{_bindir}/plpr
503 %attr(755,root,root) %{_bindir}/plrender
504 %attr(755,root,root) %{_bindir}/pltek
505 %attr(755,root,root) %{_bindir}/pstex2eps
506 %attr(755,root,root) %{_libdir}/libcsirocsa.so.*.*.*
507 %attr(755,root,root) %ghost %{_libdir}/libcsirocsa.so.0
508 %attr(755,root,root) %{_libdir}/libcsironn.so.*.*.*
509 %attr(755,root,root) %ghost %{_libdir}/libcsironn.so.0
510 %attr(755,root,root) %{_libdir}/libnistcd.so.*.*.*
511 %attr(755,root,root) %ghost %{_libdir}/libnistcd.so.0
512 %attr(755,root,root) %{_libdir}/libqsastime.so.*.*.*
513 %attr(755,root,root) %ghost %{_libdir}/libqsastime.so.0
514 %attr(755,root,root) %{_libdir}/libplplotd.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libplplotd.so.9
516 %{_mandir}/man1/plm2gif.1*
517 %{_mandir}/man1/plpr.1*
518 %{_mandir}/man1/plrender.1*
519 %{_mandir}/man1/pltek.1*
520 %{_mandir}/man1/pstex2eps.1*
521 %dir %{_libdir}/plplot%{version}
522 %dir %{_libdir}/plplot%{version}/driversd
523 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cgm.so
524 %{_libdir}/plplot%{version}/driversd/cgm.rc
525 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/mem.so
526 %{_libdir}/plplot%{version}/driversd/mem.rc
527 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/null.so
528 %{_libdir}/plplot%{version}/driversd/null.rc
529 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/plmeta.so
530 %{_libdir}/plplot%{version}/driversd/plmeta.rc
531 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ps.so
532 %{_libdir}/plplot%{version}/driversd/ps.rc
533 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pstex.so
534 %{_libdir}/plplot%{version}/driversd/pstex.rc
535 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/svg.so
536 %{_libdir}/plplot%{version}/driversd/svg.rc
537 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xfig.so
538 %{_libdir}/plplot%{version}/driversd/xfig.rc
539 %dir %{_datadir}/plplot%{version}
540 %{_datadir}/plplot%{version}/*.map
541 %{_datadir}/plplot%{version}/*.pal
542 %{_datadir}/plplot%{version}/*.fnt
543
544 %files driver-cairo
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cairo.so
547 %{_libdir}/plplot%{version}/driversd/cairo.rc
548
549 %files driver-ntk
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ntk.so
552 %{_libdir}/plplot%{version}/driversd/ntk.rc
553
554 %files driver-tk
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tk.so
557 %{_libdir}/plplot%{version}/driversd/tk.rc
558 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tkwin.so
559 %{_libdir}/plplot%{version}/driversd/tkwin.rc
560
561 %files driver-qt4
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/qt.so
564 %{_libdir}/plplot%{version}/driversd/qt.rc
565
566 %files driver-xwin
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xwin.so
569 %{_libdir}/plplot%{version}/driversd/xwin.rc
570
571 %files devel
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libcsirocsa.so
574 %attr(755,root,root) %{_libdir}/libcsironn.so
575 %attr(755,root,root) %{_libdir}/libnistcd.so
576 %attr(755,root,root) %{_libdir}/libplplotd.so
577 %attr(755,root,root) %{_libdir}/libqsastime.so
578 %{_includedir}/plplot
579 %exclude %{_includedir}/plplot/pltcl.h
580 %exclude %{_includedir}/plplot/pltk.h
581 %exclude %{_includedir}/plplot/tclMatrix.h
582 %{_pkgconfigdir}/plplotd.pc
583 %dir %{_examplesdir}/%{name}-%{version}
584 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test.sh
585 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c.sh
586 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test-interactive.sh
587 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c_interactive.sh
588 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_diff.sh
589 %{_examplesdir}/%{name}-%{version}/c
590 %{_examplesdir}/%{name}-%{version}/cmake
591 %{_examplesdir}/%{name}-%{version}/CMakeLists.txt
592 %{_examplesdir}/%{name}-%{version}/lena.*
593 %{_examplesdir}/%{name}-%{version}/Makefile
594 %if %{with perl_pdl}
595 # perl examples use PDL::Graphics::PLplot module found in perl-PDL
596 %{_examplesdir}/%{name}-%{version}/perl
597 %endif
598
599 %files c++
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/libplplotcxxd.so.*.*.*
602 %attr(755,root,root) %ghost %{_libdir}/libplplotcxxd.so.9
603
604 %files c++-devel
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/libplplotcxxd.so
607 %{_pkgconfigdir}/plplotd-c++.pc
608 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_cxx.sh
609 %{_examplesdir}/%{name}-%{version}/c++
610
611 %files f77
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/libplplotf77cd.so.*.*.*
614 %attr(755,root,root) %ghost %{_libdir}/libplplotf77cd.so.9
615 %attr(755,root,root) %{_libdir}/libplplotf77d.so.*.*.*
616 %attr(755,root,root) %ghost %{_libdir}/libplplotf77d.so.9
617
618 %files f77-devel
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/libplplotf77cd.so
621 %attr(755,root,root) %{_libdir}/libplplotf77d.so
622 %{_pkgconfigdir}/plplotd-f77.pc
623 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f77.sh
624 %{_examplesdir}/%{name}-%{version}/f77
625
626 %files f95
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/libplplotf95cd.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libplplotf95cd.so.9
630 %attr(755,root,root) %{_libdir}/libplplotf95d.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libplplotf95d.so.9
632
633 %files f95-devel
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/libplplotf95cd.so
636 %attr(755,root,root) %{_libdir}/libplplotf95d.so
637 %{_pkgconfigdir}/plplotd-f95.pc
638 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f95.sh
639 %{_examplesdir}/%{name}-%{version}/f95
640
641 %if %{with java}
642 %files java
643 %defattr(644,root,root,755)
644 %doc installed-docs/README.javaAPI
645 %dir %{_libdir}/java/plplot
646 %dir %{_libdir}/java/plplot/core
647 %attr(755,root,root) %{_libdir}/java/plplot/core/*.so
648 %{_libdir}/java/plplot/core/*.class
649 %{_libdir}/java/plplot/core/*.java
650
651 %files java-devel
652 %defattr(644,root,root,755)
653 %doc installed-docs/README.javaAPI
654 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_java.sh
655 %{_examplesdir}/%{name}-%{version}/java
656 %endif
657
658 %files tcl
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/pltcl
661 %attr(755,root,root) %{_bindir}/plserver
662 %attr(755,root,root) %{_libdir}/libplplottcltkd.so.*.*.*
663 %attr(755,root,root) %ghost %{_libdir}/libplplottcltkd.so.9
664 %attr(755,root,root) %{_libdir}/libtclmatrixd.so.*.*.*
665 %attr(755,root,root) %ghost %{_libdir}/libtclmatrixd.so.9
666 %{_datadir}/plplot%{version}/*.tcl
667 %{_datadir}/plplot%{version}/tcl
668 %{_mandir}/man1/pltcl.1*
669 %{_mandir}/man1/plserver.1*
670
671 %files tcl-devel
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libplplottcltkd.so
674 %attr(755,root,root) %{_libdir}/libtclmatrixd.so
675 %{_includedir}/plplot/pltcl.h
676 %{_includedir}/plplot/pltk.h
677 %{_includedir}/plplot/tclMatrix.h
678 %{_pkgconfigdir}/plplotd-tcl.pc
679 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_tcl.sh
680 %{_examplesdir}/%{name}-%{version}/tcl
681 %{_examplesdir}/%{name}-%{version}/tk
682
683 %files qt4
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %ghost %{_libdir}/libplplotqtd.so.0
686 %attr(755,root,root) %{_libdir}/libplplotqtd.so.0.0.1
687
688 %files qt4-devel
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libplplotqtd.so
691 %{_pkgconfigdir}/plplotd-qt.pc
692
693 %files octave
694 %defattr(644,root,root,755)
695 %doc bindings/octave/{BUGS,FGA,README,ToDo,USAGE,plplot_octave_txt}
696 %attr(755,root,root) %{octave_oct_sitedir}/plplot_octave.oct
697 %{octave_m_sitedir}/PLplot
698 %{_datadir}/plplot_octave
699 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave_interactive.sh
700
701 %files octave-examples
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave.sh
704 %{_examplesdir}/%{name}-%{version}/octave
705
706 %files -n python-plplot
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{py_sitedir}/_plplotcmodule.so
709 %attr(755,root,root) %{py_sitedir}/plplot_widgetmodule.so
710 %{py_sitedir}/Plframe.py
711 %{py_sitedir}/plplotc.py
712 %{py_sitedir}/plplot.py
713 %{py_sitedir}/TclSup.py
714
715 %files -n python-plplot-qt4
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{py_sitedir}/plplot_pyqt4.so
718
719 %files -n python-plplot-examples
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_python.sh
722 %{_examplesdir}/%{name}-%{version}/python
This page took 0.068628 seconds and 3 git commands to generate.