]> git.pld-linux.org Git - packages/plplot.git/blob - plplot.spec
- 5.9.6
[packages/plplot.git] / plplot.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome           # don't build gnome driver
4 %bcond_with     perl_pdl        # enable perl examples in tests
5 %bcond_with     java            # build Java binding
6 %bcond_without  svga            # don't build linuxvga driver
7 #
8 Summary:        PLplot - a library of functions that are useful for making scientific plots
9 Summary(pl.UTF-8):      PLplot - biblioteka funkcji przydatnych do tworzenia wykresów naukowych
10 Name:           plplot
11 Version:        5.9.6
12 Release:        0.1
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/plplot/%{name}-%{version}.tar.gz
16 # Source0-md5:  772c772bde3a107e5f06d21cefa7f6b6
17 Patch0:         %{name}-FHS.patch
18 Patch1:         %{name}-lib64.patch
19 Patch2:         %{name}-tk.patch
20 Patch3:         %{name}-tcl.patch
21 Patch4:         %{name}-octave3.patch
22 Patch5:         %{name}-gnome-python.patch
23 Patch6:         gcc43.patch
24 URL:            http://plplot.sourceforge.net/
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake >= 1:1.8.3
27 BuildRequires:  cd-devel >= 1.3-2
28 BuildRequires:  docbook-style-dsssl
29 BuildRequires:  fftw3-devel
30 BuildRequires:  fftw3-single-devel
31 BuildRequires:  freetype-devel >= 2.1.0
32 BuildRequires:  gcc-g77
33 BuildRequires:  gd-devel
34 BuildRequires:  itcl-devel
35 BuildRequires:  jadetex
36 %{?with_java:BuildRequires:     jdk}
37 BuildRequires:  lapack-devel
38 %{?with_gnome:BuildRequires:    libgnomecanvas-devel}
39 %{?with_gnome:BuildRequires:    libgnomeprintui-devel >= 2.2}
40 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.0}
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libpng-devel
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  octave-devel
47 BuildRequires:  perl-XML-DOM
48 BuildRequires:  perl-XML-Parser
49 BuildRequires:  perl-XML-SAX-Expat
50 BuildRequires:  pkgconfig
51 BuildRequires:  python-Numeric-devel >= 15.3
52 BuildRequires:  python-devel >= 1:2.3
53 %{?with_gnome:BuildRequires:    python-gnome-devel >= 2.0}
54 BuildRequires:  python-pygtk-devel >= 2:2.12.1
55 BuildRequires:  qhull-devel
56 BuildRequires:  rpm-pythonprov
57 BuildRequires:  sed >= 4.0
58 %{?with_svga:BuildRequires:     svgalib-devel}
59 BuildRequires:  swig
60 BuildRequires:  swig-python
61 BuildRequires:  tcl-devel >= 8.4.11-3
62 BuildRequires:  tetex-dvips
63 BuildRequires:  texinfo
64 BuildRequires:  tk-devel
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _ulibdir        %{_prefix}/lib
68 %define         octave_oct_sitedir      %(octave-config --oct-site-dir)
69 %define         octave_m_sitedir        %(octave-config --m-site-dir)
70
71 %description
72 PLplot is a library of functions that are useful for making scientific
73 plots. It can be used from within compiled languages such as C, C++,
74 FORTRAN and Java, and interactively from interpreted languages such as
75 Octave, Python, Perl and Tcl.
76
77 The PLplot library can be used to create standard X-Y plots, semilog
78 plots, log-log plots, contour plots, 3D surface plots, mesh plots, bar
79 charts and pie charts. Multiple graphs (of the same or different
80 sizes) may be placed on a single page with multiple lines in each
81 graph.
82
83 A variety of output file devices such as PostScript, PNG, JPEG, LaTeX
84 and others, as well as interactive devices such as xwin, tk, xterm and
85 Tektronics devices are supported. New devices can be easily added by
86 writing a small number of device dependent routines.
87
88 %description -l pl.UTF-8
89 PLplot to biblioteka funkcji przydatnych do tworzenia wykresów
90 naukowych. Może być używana z poziomu języków kompilowanych takich jak
91 C, C++, FORTRAN czy Java, albo interaktywnie z poziomu języków
92 interpretowanych takich jak Octave, Python, Perl czy Tcl.
93
94 Bibliotekę PLplot można wykorzystać do tworzenia standardowych
95 wykresów X-Y, wykresów półlogarytmicznych, wykresów konturowych,
96 wykresów powierzchni trójwymiarowych, wykresów siatek, wykresów
97 słupkowych i kołowych. Na jednej stronie można umieścić wiele wykresów
98 (o tych samych lub różnych rozmiarach), na jednym wykresie może być
99 wiele linii.
100
101 Obsługiwanych jest wiele urządzeń wyjściowych, w tym PostScript, PNG,
102 JPEG, LaTeX i inne, a także urządzenia interaktywne, takie jak xwin,
103 tk, xterm i Tektronics. Nowe urządzenia można łatwo dodać pisząc parę
104 zależnych od urządzenia funkcji.
105
106 %package driver-gd
107 Summary:        GD driver for PLplot library
108 Summary(pl.UTF-8):      Sterownik GD dla biblioteki PLplot
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description driver-gd
113 GD driver for PLplot library. It supports JPEG and PNG output formats.
114
115 %description driver-gd -l pl.UTF-8
116 Sterownik GD dla biblioteki PLplot. Obsługuje formaty wyjścia JPEG i
117 PNG.
118
119 %package driver-linuxvga
120 Summary:        linuxvga driver for PLplot library
121 Summary(pl.UTF-8):      Sterownik linuxvga dla biblioteki PLplot
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description driver-linuxvga
126 linuxvga driver for PLplot library. It supports svgalib output.
127
128 %description driver-gd -l pl.UTF-8
129 Sterownik linuxvga dla biblioteki PLplot. Obsługuje wyjście poprzez
130 svgalib.
131
132 %package driver-gnome
133 Summary:        GNOME driver for PLplot library
134 Summary(pl.UTF-8):      Sterownik GNOME dla biblioteki PLplot
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description driver-gnome
139 GNOME driver for PLplot library. It supports GnomeCanvas output.
140
141 %description driver-gnome -l pl.UTF-8
142 Sterownik GNOME dla biblioteki PLplot. Obsługuje wyjście do widgetu
143 GnomeCanvas.
144
145 %package driver-ntk
146 Summary:        ntk driver for PLplot library
147 Summary(pl.UTF-8):      Sterownik ntk dla biblioteki PLplot
148 Group:          Libraries
149 Requires:       %{name} = %{version}-%{release}
150
151 %description driver-ntk
152 ntk (new tk) driver for PLplot library. It supports Tcl/Tk output.
153
154 %description driver-ntk -l pl.UTF-8
155 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście
156 poprzez Tcl/Tk.
157
158 %package driver-tk
159 Summary:        Tk drivers for PLplot library
160 Summary(pl.UTF-8):      Sterowniki Tk dla biblioteki PLplot
161 Group:          Libraries
162 Requires:       %{name}-tcl = %{version}-%{release}
163
164 %description driver-tk
165 Tk and tkwin drivers for PLplot library. They support Tcl/Tk output.
166
167 %description driver-ntk -l pl.UTF-8
168 Sterownik Tk i tkwin dla biblioteki PLplot. Obsługują wyjście poprzez
169 Tcl/Tk.
170
171 %package driver-xwin
172 Summary:        xwin driver for PLplot library
173 Summary(pl.UTF-8):      Sterownik xwin dla biblioteki PLplot
174 Group:          Libraries
175 Requires:       %{name} = %{version}-%{release}
176
177 %description driver-xwin
178 xwin driver for PLplot library. It supports X Window System output.
179
180 %description driver-xwin -l pl.UTF-8
181 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście do
182 okna systemu X Window.
183
184 %package devel
185 Summary:        Header files for PLplot library
186 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PLplot
187 Group:          Development/Libraries
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       freetype-devel >= 2.1
190 Requires:       qhull-devel
191
192 %description devel
193 Header files for PLplot library.
194
195 %description devel -l pl.UTF-8
196 Pliki nagłówkowe biblioteki PLplot.
197
198 %package static
199 Summary:        Static PLplot library
200 Summary(pl.UTF-8):      Statyczna biblioteka PLplot
201 Group:          Development/Libraries
202 Requires:       %{name}-devel = %{version}-%{release}
203
204 %description static
205 Static PLplot library.
206
207 %description static -l pl.UTF-8
208 Statyczna biblioteka PLplot.
209
210 %package c++
211 Summary:        PLplot library - C++ binding
212 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla C++
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description c++
217 PLplot library - C++ binding.
218
219 %description c++ -l pl.UTF-8
220 Biblioteka PLplot - wiązanie dla C++.
221
222 %package c++-devel
223 Summary:        PLplot library - C++ binding development files
224 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla C++
225 Group:          Development/Libraries
226 Requires:       %{name}-c++ = %{version}-%{release}
227 Requires:       %{name}-devel = %{version}-%{release}
228 Requires:       libstdc++-devel
229
230 %description c++-devel
231 PLplot library - C++ binding development files.
232
233 %description c++-devel -l pl.UTF-8
234 Biblioteka PLplot - pliki programistyczne wiązania dla C++.
235
236 %package c++-static
237 Summary:        PLplot library - C++ binding static library
238 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla C++
239 Group:          Development/Libraries
240 Requires:       %{name}-c++-devel = %{version}-%{release}
241
242 %description c++-static
243 PLplot library - C++ binding static library.
244
245 %description c++-static -l pl.UTF-8
246 Biblioteka PLplot - biblioteka statyczna wiązania dla C++.
247
248 %package f77
249 Summary:        PLplot library - FORTRAN 77 binding
250 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 77
251 Group:          Libraries
252 Requires:       %{name} = %{version}-%{release}
253
254 %description f77
255 PLplot library - FORTRAN 77 binding.
256
257 %description f77 -l pl.UTF-8
258 Biblioteka PLplot - wiązanie dla języka FORTRAN 77.
259
260 %package f77-devel
261 Summary:        PLplot library - FORTRAN 77 binding development files
262 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
263 Group:          Development/Libraries
264 Requires:       %{name}-devel = %{version}-%{release}
265 Requires:       %{name}-f77 = %{version}-%{release}
266 Requires:       gcc-g77
267
268 %description f77-devel
269 PLplot library - FORTRAN 77 binding development files.
270
271 %description f77-devel -l pl.UTF-8
272 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
273 77.
274
275 %package f77-static
276 Summary:        PLplot library - FORTRAN 77 binding static library
277 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN 77
278 Group:          Development/Libraries
279 Requires:       %{name}-f77-devel = %{version}-%{release}
280
281 %description f77-static
282 PLplot library - FORTRAN 77 binding static library.
283
284 %description f77-static -l pl.UTF-8
285 Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN
286 77.
287
288 %package java
289 Summary:        PLplot library - Java binding
290 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Javy
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293
294 %description java
295 PLplot library - Java binding.
296
297 %description java -l pl.UTF-8
298 Biblioteka PLplot - wiązanie dla Javy.
299
300 %package java-devel
301 Summary:        PLplot library - Java binding development files
302 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Javy
303 Group:          Development/Libraries
304 Requires:       %{name}-devel = %{version}-%{release}
305 Requires:       %{name}-java = %{version}-%{release}
306 Obsoletes:      plplot-java-static
307
308 %description java-devel
309 PLplot library - Java binding development files.
310
311 %description java -l pl.UTF-8
312 Biblioteka PLplot - pliki programistyczne wiązania dla Javy.
313
314 %package tcl
315 Summary:        PLplot library - Tcl/Tk binding
316 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Tcl/Tk
317 Group:          Libraries
318 Requires:       %{name} = %{version}-%{release}
319
320 %description tcl
321 PLplot library - Tcl/Tk binding.
322
323 %description tcl -l pl.UTF-8
324 Biblioteka PLplot - wiązanie dla Tcl/Tk.
325
326 %package tcl-devel
327 Summary:        PLplot library - Tcl/Tk binding development files
328 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk
329 Group:          Development/Libraries
330 Requires:       %{name}-devel = %{version}-%{release}
331 Requires:       %{name}-tcl = %{version}-%{release}
332 Requires:       itcl-devel
333
334 %description tcl-devel
335 PLplot library - Tcl/Tk binding development files.
336
337 %description tcl-devel -l pl.UTF-8
338 Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk.
339
340 %package tcl-static
341 Summary:        PLplot library - Tcl/Tk binding static library
342 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk
343 Group:          Development/Libraries
344 Requires:       %{name}-tcl-devel = %{version}-%{release}
345
346 %description tcl-static
347 PLplot library - Tcl/Tk binding static library.
348
349 %description tcl-static -l pl.UTF-8
350 Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk.
351
352 %package gnome
353 Summary:        PLplot library - GNOME binding
354 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla GNOME
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description gnome
359 PLplot library - GNOME binding.
360
361 %description gnome -l pl.UTF-8
362 Biblioteka PLplot - wiązanie dla GNOME.
363
364 %package gnome-devel
365 Summary:        PLplot library - GNOME binding development files
366 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla GNOME
367 Group:          Development/Libraries
368 Requires:       %{name}-devel = %{version}-%{release}
369 Requires:       %{name}-gnome = %{version}-%{release}
370
371 %description gnome-devel
372 PLplot library - GNOME binding development files.
373
374 %description gnome-devel -l pl.UTF-8
375 Biblioteka PLplot - pliki programistyczne wiązania dla GNOME.
376
377 %package gnome-static
378 Summary:        PLplot library - GNOME binding static library
379 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla GNOME
380 Group:          Development/Libraries
381 Requires:       %{name}-gnome-devel = %{version}-%{release}
382
383 %description gnome-static
384 PLplot library - GNOME binding static library.
385
386 %description gnome-static -l pl.UTF-8
387 Biblioteka PLplot - biblioteka statyczna wiązania dla GNOME.
388
389 %package octave
390 Summary:        PLplot library - Octave binding
391 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka Octave
392 Group:          Libraries
393 Requires:       %{name} = %{version}-%{release}
394
395 %description octave
396 PLplot library - Octave binding.
397
398 %description octave -l pl.UTF-8
399 Biblioteka PLplot - wiązanie dla języka Octave.
400
401 %package octave-examples
402 Summary:        PLplot library - examples for Octave binding
403 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla języka Octave
404 Group:          Development/Libraries
405 Requires:       %{name}-devel = %{version}-%{release}
406 Requires:       %{name}-octave = %{version}-%{release}
407
408 %description octave-examples
409 PLplot library - examples for Octave binding.
410
411 %description octave-examples -l pl.UTF-8
412 Biblioteka PLplot - przykłady do wiązania dla języka Octave.
413
414 %package -n python-plplot
415 Summary:        PLplot library - Python binding
416 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona
417 Group:          Libraries/Python
418 Requires:       %{name} = %{version}-%{release}
419 %pyrequires_eq  python-libs
420 Requires:       python-Numeric
421
422 %description -n python-plplot
423 PLplot library - Python binding.
424
425 %description -n python-plplot -l pl.UTF-8
426 Biblioteka PLplot - wiązanie dla Pythona.
427
428 %package -n python-plplot-gnome
429 Summary:        PLplot library - Python GNOME binding
430 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona GNOME
431 Group:          Libraries/Python
432 Requires:       %{name} = %{version}-%{release}
433 %pyrequires_eq  python-libs
434
435 %description -n python-plplot-gnome
436 PLplot library - Python GNOME binding.
437
438 %description -n python-plplot-gnome -l pl.UTF-8
439 Biblioteka PLplot - wiązanie dla Pythona GNOME.
440
441 %package -n python-plplot-examples
442 Summary:        PLplot library - Python binding examples
443 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla Pythona
444 Group:          Libraries/Python
445 Requires:       %{name}-devel = %{version}-%{release}
446 Requires:       python-plplot = %{version}-%{release}
447
448 %description -n python-plplot-examples
449 PLplot library - Python binding examples.
450
451 %description -n python-plplot-examples -l pl.UTF-8
452 Biblioteka PLplot - przykłady do wiązania dla Pythona.
453
454 %prep
455 %setup -q
456 %patch0 -p1
457 %if "%{_lib}" == "lib64"
458 %patch1 -p1
459 %endif
460 %patch2 -p1
461 %patch3 -p1
462 %patch4 -p1
463 %patch5 -p1
464 %patch6 -p1
465
466 sed -i -e 's#/usr/include/tcl8.4/tcl-private/generic#%{_includedir}/tcl-private/generic#g' configure* \
467         cf/tcl.ac
468
469 cp -f bindings/python/plplot.py.Numeric bindings/python/plplot.py
470
471 %build
472 cp -f /usr/share/automake/config.* libltdl
473 %{__libtoolize}
474 %{__aclocal} -I cf
475 %{__autoconf}
476 %{__autoheader}
477 %{__automake}
478 %configure \
479         DATA_DIR="%{_libdir}/%{name}%{version}/data" \
480         PYTHON_INC_DIR=/usr/include/python%{py_ver} \
481         TCLINCDIR="%{_includedir}/tcl-private/generic" \
482         TCLLIBDIR="%{_ulibdir}" \
483         TKLIBDIR="%{_ulibdir}" \
484         ITCLLIBDIR="%{_ulibdir}" \
485         ITKLIBDIR="%{_ulibdir}" \
486         %{!?with_svga:--disable-linuxvga} \
487         %{!?with_perl_pdl:--enable-pdl} \
488         --enable-conex \
489         --enable-dg300 \
490         --enable-imp \
491         %{?with_java:JAVA_HOME=/usr/%{_lib}/java} \
492         %{!?with_java:--disable-java} \
493         --enable-ljii \
494         --enable-ljiip \
495         --enable-mskermit \
496         --enable-ntk \
497         --enable-octave \
498         --enable-tek4010 \
499         --enable-tek4010f \
500         --enable-tek4107 \
501         --enable-tek4107f \
502         --enable-versaterm \
503         --enable-vlt \
504         --enable-xterm \
505         --with-pkg-config \
506         --with-pthreads
507
508 %{__make} -j1 \
509         OCTAVE_M_DIR=%{octave_m_sitedir} \
510         OCTAVE_OCT_DIR=%{octave_oct_sitedir}
511
512 %install
513 rm -rf $RPM_BUILD_ROOT
514 install -d $RPM_BUILD_ROOT%{_examplesdir}
515
516 %{__make} install \
517         DESTDIR=$RPM_BUILD_ROOT \
518         OCTAVE_M_DIR=%{octave_m_sitedir} \
519         OCTAVE_OCT_DIR=%{octave_oct_sitedir}
520
521 mv -f $RPM_BUILD_ROOT%{_libdir}/plplot%{version}/data/examples \
522         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
523
524 rm -rf installed-docs
525 mv -f $RPM_BUILD_ROOT%{_docdir}/plplot installed-docs
526
527 %if %{with java}
528 # java must stay in libdir - JNI wrapper included
529 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/examples \
530         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java
531 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/core/README.javaAPI installed-docs
532 %endif
533
534 %clean
535 rm -rf $RPM_BUILD_ROOT
536
537 %post   -p /sbin/ldconfig
538 %postun -p /sbin/ldconfig
539
540 %post   c++ -p /sbin/ldconfig
541 %postun c++ -p /sbin/ldconfig
542
543 %post   f77 -p /sbin/ldconfig
544 %postun f77 -p /sbin/ldconfig
545
546 %post   tcl -p /sbin/ldconfig
547 %postun tcl -p /sbin/ldconfig
548
549 %files
550 %defattr(644,root,root,755)
551 %doc AUTHORS ChangeLog Copyright FAQ NEWS PROBLEMS README SERVICE TODO* ToDo
552 %doc installed-docs/{README.1st.csa,README.1st.nn,README.csa,README.nn,README.drivers}
553 %attr(755,root,root) %{_bindir}/plm2gif
554 %attr(755,root,root) %{_bindir}/plpr
555 %attr(755,root,root) %{_bindir}/plrender
556 %attr(755,root,root) %{_bindir}/pltek
557 %attr(755,root,root) %{_bindir}/pstex2eps
558 %attr(755,root,root) %{_libdir}/libcsirocsa.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libcsirocsa.so.0
560 %attr(755,root,root) %{_libdir}/libcsironn.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libcsironn.so.0
562 %attr(755,root,root) %{_libdir}/libplplotd.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libplplotd.so.11
564 %{_mandir}/man1/plm2gif.1*
565 %{_mandir}/man1/plpr.1*
566 %{_mandir}/man1/plrender.1*
567 %{_mandir}/man1/pltek.1*
568 %{_mandir}/man1/pstex2eps.1*
569 %dir %{_libdir}/plplot%{version}
570 %{_libdir}/plplot%{version}/data
571 %dir %{_libdir}/plplot%{version}/driversd
572 # drivers list; *.la are used (by libltdl)
573 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cgm.so
574 %{_libdir}/plplot%{version}/driversd/cgm.la
575 %{_libdir}/plplot%{version}/driversd/cgm.rc
576 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/dg300.so
577 %{_libdir}/plplot%{version}/driversd/dg300.la
578 %{_libdir}/plplot%{version}/driversd/dg300.rc
579 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/hpgl.so
580 %{_libdir}/plplot%{version}/driversd/hpgl.la
581 %{_libdir}/plplot%{version}/driversd/hpgl.rc
582 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/impress.so
583 %{_libdir}/plplot%{version}/driversd/impress.la
584 %{_libdir}/plplot%{version}/driversd/impress.rc
585 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljii.so
586 %{_libdir}/plplot%{version}/driversd/ljii.la
587 %{_libdir}/plplot%{version}/driversd/ljii.rc
588 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljiip.so
589 %{_libdir}/plplot%{version}/driversd/ljiip.la
590 %{_libdir}/plplot%{version}/driversd/ljiip.rc
591 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/mem.so
592 %{_libdir}/plplot%{version}/driversd/mem.la
593 %{_libdir}/plplot%{version}/driversd/mem.rc
594 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/null.so
595 %{_libdir}/plplot%{version}/driversd/null.la
596 %{_libdir}/plplot%{version}/driversd/null.rc
597 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pbm.so
598 %{_libdir}/plplot%{version}/driversd/pbm.la
599 %{_libdir}/plplot%{version}/driversd/pbm.rc
600 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/plmeta.so
601 %{_libdir}/plplot%{version}/driversd/plmeta.la
602 %{_libdir}/plplot%{version}/driversd/plmeta.rc
603 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ps.so
604 %{_libdir}/plplot%{version}/driversd/ps.la
605 %{_libdir}/plplot%{version}/driversd/ps.rc
606 #%attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pstex.so
607 #%{_libdir}/plplot%{version}/driversd/pstex.la
608 #%{_libdir}/plplot%{version}/driversd/pstex.rc
609 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tek.so
610 %{_libdir}/plplot%{version}/driversd/tek.la
611 %{_libdir}/plplot%{version}/driversd/tek.rc
612 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xfig.so
613 %{_libdir}/plplot%{version}/driversd/xfig.la
614 %{_libdir}/plplot%{version}/driversd/xfig.rc
615
616 %files driver-gd
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gd.so
619 %{_libdir}/plplot%{version}/driversd/gd.la
620 %{_libdir}/plplot%{version}/driversd/gd.rc
621
622 %if %{with gnome}
623 %files driver-gnome
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gcw.so
626 %{_libdir}/plplot%{version}/driversd/gcw.la
627 %{_libdir}/plplot%{version}/driversd/gcw.rc
628
629 %files gnome
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/libplplotgnome2d.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libplplotgnome2d.so.0
633
634 %files gnome-devel
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/libplplotgnome2d.so
637 %{_libdir}/libplplotgnome2d.la
638 %{_pkgconfigdir}/plplotd-gnome2.pc
639
640 %files gnome-static
641 %defattr(644,root,root,755)
642 %{_libdir}/libplplotgnome2d.a
643
644 %files -n python-plplot-gnome
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{py_sitedir}/cplplotcanvasmodule.so
647 %attr(755,root,root) %{py_sitedir}/gcwmodule.so
648 %{py_sitedir}/plplotcanvas.py
649 %endif
650
651 %if %{with svga}
652 %files driver-linuxvga
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/linuxvga.so
655 %{_libdir}/plplot%{version}/driversd/linuxvga.la
656 %{_libdir}/plplot%{version}/driversd/linuxvga.rc
657 %endif
658
659 %files driver-ntk
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ntk.so
662 %{_libdir}/plplot%{version}/driversd/ntk.la
663 %{_libdir}/plplot%{version}/driversd/ntk.rc
664
665 %files driver-tk
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tk.so
668 %{_libdir}/plplot%{version}/driversd/tk.la
669 %{_libdir}/plplot%{version}/driversd/tk.rc
670 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tkwin.so
671 %{_libdir}/plplot%{version}/driversd/tkwin.la
672 %{_libdir}/plplot%{version}/driversd/tkwin.rc
673
674 %files driver-xwin
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xwin.so
677 %{_libdir}/plplot%{version}/driversd/xwin.la
678 %{_libdir}/plplot%{version}/driversd/xwin.rc
679
680 %files devel
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/plplot-config
683 %attr(755,root,root) %{_bindir}/plplot_libtool
684 %attr(755,root,root) %{_libdir}/libcsirocsa.so
685 %attr(755,root,root) %{_libdir}/libcsironn.so
686 %attr(755,root,root) %{_libdir}/libplplotd.so
687 %{_libdir}/libcsirocsa.la
688 %{_libdir}/libcsironn.la
689 %{_libdir}/libplplotd.la
690 %{_includedir}/plplot
691 %exclude %{_includedir}/plplot/pltcl.h
692 %exclude %{_includedir}/plplot/pltk.h
693 %exclude %{_includedir}/plplot/tclMatrix.h
694 %{_pkgconfigdir}/plplotd.pc
695 %{_mandir}/man1/plplot_libtool.1*
696 %dir %{_examplesdir}/%{name}-%{version}
697 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test.sh
698 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c.sh
699 %{_examplesdir}/%{name}-%{version}/Makefile
700 %{_examplesdir}/%{name}-%{version}/c
701 %if %{with perl_pdl}
702 # perl examples use PDL::Graphics::PLplot module found in perl-PDL
703 %{_examplesdir}/%{name}-%{version}/perl
704 %endif
705
706 %files static
707 %defattr(644,root,root,755)
708 %{_libdir}/libcsirocsa.a
709 %{_libdir}/libcsironn.a
710 %{_libdir}/libplplotd.a
711
712 %files c++
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libplplotcxxd.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libplplotcxxd.so.9
716
717 %files c++-devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libplplotcxxd.so
720 %{_libdir}/libplplotcxxd.la
721 %{_pkgconfigdir}/plplotd-c++.pc
722 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_cxx.sh
723 %{_examplesdir}/%{name}-%{version}/c++
724
725 %files c++-static
726 %defattr(644,root,root,755)
727 %{_libdir}/libplplotcxxd.a
728
729 %files f77
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libplplotf77cd.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libplplotf77cd.so.9
733 %attr(755,root,root) %{_libdir}/libplplotf77d.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libplplotf77d.so.9
735
736 %files f77-devel
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libplplotf77cd.so
739 %attr(755,root,root) %{_libdir}/libplplotf77d.so
740 %{_libdir}/libplplotf77cd.la
741 %{_libdir}/libplplotf77d.la
742 %{_pkgconfigdir}/plplotd-f77.pc
743 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f77.sh
744 %{_examplesdir}/%{name}-%{version}/f77
745
746 %files f77-static
747 %defattr(644,root,root,755)
748 %{_libdir}/libplplotf77cd.a
749 %{_libdir}/libplplotf77d.a
750
751 %if %{with java}
752 %files java
753 %defattr(644,root,root,755)
754 %doc installed-docs/README.javaAPI
755 %dir %{_libdir}/java/plplot
756 %dir %{_libdir}/java/plplot/core
757 %attr(755,root,root) %{_libdir}/java/plplot/core/*.so
758 %{_libdir}/java/plplot/core/*.class
759 %{_libdir}/java/plplot/core/*.java
760
761 %files java-devel
762 %defattr(644,root,root,755)
763 %doc installed-docs/README.javaAPI
764 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_java.sh
765 %{_examplesdir}/%{name}-%{version}/java
766 %endif
767
768 %files tcl
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_bindir}/pltcl
771 %attr(755,root,root) %{_bindir}/plserver
772 %attr(755,root,root) %{_libdir}/libplplottcltkd.so.*.*.*
773 %attr(755,root,root) %ghost %{_libdir}/libplplottcltkd.so.11
774 %attr(755,root,root) %{_libdir}/libtclmatrixd.so.*.*.*
775 %attr(755,root,root) %ghost %{_libdir}/libtclmatrixd.so.11
776 %{_mandir}/man1/pltcl.1*
777 %{_mandir}/man1/plserver.1*
778
779 %files tcl-devel
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libplplottcltkd.so
782 %attr(755,root,root) %{_libdir}/libtclmatrixd.so
783 %{_libdir}/libplplottcltkd.la
784 %{_libdir}/libtclmatrixd.la
785 %{_includedir}/plplot/pltcl.h
786 %{_includedir}/plplot/pltk.h
787 %{_includedir}/plplot/tclMatrix.h
788 %{_pkgconfigdir}/plplotd-tcl.pc
789 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_tcl.sh
790 %{_examplesdir}/%{name}-%{version}/tcl
791 %{_examplesdir}/%{name}-%{version}/tk
792
793 %files tcl-static
794 %defattr(644,root,root,755)
795 %{_libdir}/libplplottcltkd.a
796 %{_libdir}/libtclmatrixd.a
797
798 %files octave
799 %defattr(644,root,root,755)
800 %doc bindings/octave/{BUGS,FGA,README,ToDo,USAGE,plplot_octave_txt}
801 %attr(755,root,root) %{octave_oct_sitedir}/plplot_octave.oct
802 %{octave_m_sitedir}/PLplot
803 %{_datadir}/plplot_octave
804
805 %files octave-examples
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave.sh
808 %{_examplesdir}/%{name}-%{version}/octave
809
810 %files -n python-plplot
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{py_sitedir}/_plplotcmodule.so
813 %attr(755,root,root) %{py_sitedir}/plplot_widgetmodule.so
814 %{py_sitedir}/plplot.py
815 %{py_sitedir}/plplotc.py
816
817 %files -n python-plplot-examples
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_python.sh
820 %{_examplesdir}/%{name}-%{version}/python
This page took 0.122041 seconds and 3 git commands to generate.