]> git.pld-linux.org Git - packages/plplot.git/blob - plplot.spec
- release 3
[packages/plplot.git] / plplot.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome           # don't build gnome driver
4 %bcond_with     perl_pdl        # enable perl examples in tests
5 %bcond_with     java            # build Java binding
6 %bcond_without  svga            # don't build linuxvga driver
7 #
8 Summary:        PLplot - a library of functions that are useful for making scientific plots
9 Summary(pl.UTF-8):      PLplot - biblioteka funkcji przydatnych do tworzenia wykresów naukowych
10 Name:           plplot
11 Version:        5.8.0
12 Release:        3
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/plplot/%{name}-%{version}.tar.gz
16 # Source0-md5:  63e954448b12056aeecf2b53cd97f1f5
17 Patch0:         %{name}-FHS.patch
18 Patch1:         %{name}-lib64.patch
19 Patch2:         %{name}-tk.patch
20 Patch3:         %{name}-tcl.patch
21 Patch4:         %{name}-octave3.patch
22 Patch5:         %{name}-gnome-python.patch
23 Patch6:         gcc43.patch
24 URL:            http://plplot.sourceforge.net/
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake >= 1:1.8.3
27 BuildRequires:  cd-devel >= 1.3-2
28 BuildRequires:  docbook-style-dsssl
29 BuildRequires:  fftw3-devel
30 BuildRequires:  freetype-devel >= 2.1.0
31 BuildRequires:  gcc-g77
32 BuildRequires:  gd-devel
33 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.0}
34 %{?with_gnome:BuildRequires:    libgnomeprintui-devel >= 2.2}
35 %{?with_gnome:BuildRequires:    libgnomecanvas-devel}
36 BuildRequires:  itcl-devel
37 BuildRequires:  jadetex
38 %{?with_java:BuildRequires:     jdk}
39 BuildRequires:  lapack-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool
44 BuildRequires:  octave-devel
45 BuildRequires:  perl-XML-SAX-Expat
46 BuildRequires:  perl-XML-Parser
47 BuildRequires:  perl-XML-DOM
48 BuildRequires:  pkgconfig
49 BuildRequires:  python-Numeric-devel >= 15.3
50 BuildRequires:  python-devel >= 1:2.3
51 %{?with_gnome:BuildRequires:    python-gnome-devel >= 2.0}
52 BuildRequires:  python-pygtk-devel >= 2:2.12.1
53 BuildRequires:  qhull-devel
54 BuildRequires:  sed >= 4.0
55 %{?with_svga:BuildRequires:     svgalib-devel}
56 BuildRequires:  swig
57 BuildRequires:  swig-python
58 BuildRequires:  tcl-devel >= 8.4.11-3
59 BuildRequires:  tetex-dvips
60 BuildRequires:  texinfo
61 BuildRequires:  tk-devel
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _ulibdir        %{_prefix}/lib
65 %define         octave_oct_sitedir      %(octave-config --oct-site-dir)
66 %define         octave_m_sitedir        %(octave-config --m-site-dir)
67
68 %description
69 PLplot is a library of functions that are useful for making scientific
70 plots. It can be used from within compiled languages such as C, C++,
71 FORTRAN and Java, and interactively from interpreted languages such as
72 Octave, Python, Perl and Tcl.
73
74 The PLplot library can be used to create standard X-Y plots, semilog
75 plots, log-log plots, contour plots, 3D surface plots, mesh plots, bar
76 charts and pie charts. Multiple graphs (of the same or different
77 sizes) may be placed on a single page with multiple lines in each
78 graph.
79
80 A variety of output file devices such as PostScript, PNG, JPEG, LaTeX
81 and others, as well as interactive devices such as xwin, tk, xterm and
82 Tektronics devices are supported. New devices can be easily added by
83 writing a small number of device dependent routines.
84
85 %description -l pl.UTF-8
86 PLplot to biblioteka funkcji przydatnych do tworzenia wykresów
87 naukowych. Może być używana z poziomu języków kompilowanych takich jak
88 C, C++, FORTRAN czy Java, albo interaktywnie z poziomu języków
89 interpretowanych takich jak Octave, Python, Perl czy Tcl.
90
91 Bibliotekę PLplot można wykorzystać do tworzenia standardowych
92 wykresów X-Y, wykresów półlogarytmicznych, wykresów konturowych,
93 wykresów powierzchni trójwymiarowych, wykresów siatek, wykresów
94 słupkowych i kołowych. Na jednej stronie można umieścić wiele wykresów
95 (o tych samych lub różnych rozmiarach), na jednym wykresie może być
96 wiele linii.
97
98 Obsługiwanych jest wiele urządzeń wyjściowych, w tym PostScript, PNG,
99 JPEG, LaTeX i inne, a także urządzenia interaktywne, takie jak xwin,
100 tk, xterm i Tektronics. Nowe urządzenia można łatwo dodać pisząc parę
101 zależnych od urządzenia funkcji.
102
103 %package driver-gd
104 Summary:        GD driver for PLplot library
105 Summary(pl.UTF-8):      Sterownik GD dla biblioteki PLplot
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description driver-gd
110 GD driver for PLplot library. It supports JPEG and PNG output formats.
111
112 %description driver-gd -l pl.UTF-8
113 Sterownik GD dla biblioteki PLplot. Obsługuje formaty wyjścia JPEG i
114 PNG.
115
116 %package driver-linuxvga
117 Summary:        linuxvga driver for PLplot library
118 Summary(pl.UTF-8):      Sterownik linuxvga dla biblioteki PLplot
119 Group:          Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description driver-linuxvga
123 linuxvga driver for PLplot library. It supports svgalib output.
124
125 %description driver-gd -l pl.UTF-8
126 Sterownik linuxvga dla biblioteki PLplot. Obsługuje wyjście poprzez
127 svgalib.
128
129 %package driver-gnome
130 Summary:        GNOME driver for PLplot library
131 Summary(pl.UTF-8):      Sterownik GNOME dla biblioteki PLplot
132 Group:          Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description driver-gnome
136 GNOME driver for PLplot library. It supports GnomeCanvas output.
137
138 %description driver-gnome -l pl.UTF-8
139 Sterownik GNOME dla biblioteki PLplot. Obsługuje wyjście do widgetu
140 GnomeCanvas.
141
142 %package driver-ntk
143 Summary:        ntk driver for PLplot library
144 Summary(pl.UTF-8):      Sterownik ntk dla biblioteki PLplot
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147
148 %description driver-ntk
149 ntk (new tk) driver for PLplot library. It supports Tcl/Tk output.
150
151 %description driver-ntk -l pl.UTF-8
152 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście
153 poprzez Tcl/Tk.
154
155 %package driver-tk
156 Summary:        Tk drivers for PLplot library
157 Summary(pl.UTF-8):      Sterowniki Tk dla biblioteki PLplot
158 Group:          Libraries
159 Requires:       %{name}-tcl = %{version}-%{release}
160
161 %description driver-tk
162 Tk and tkwin drivers for PLplot library. They support Tcl/Tk output.
163
164 %description driver-ntk -l pl.UTF-8
165 Sterownik Tk i tkwin dla biblioteki PLplot. Obsługują wyjście poprzez
166 Tcl/Tk.
167
168 %package driver-xwin
169 Summary:        xwin driver for PLplot library
170 Summary(pl.UTF-8):      Sterownik xwin dla biblioteki PLplot
171 Group:          Libraries
172 Requires:       %{name} = %{version}-%{release}
173
174 %description driver-xwin
175 xwin driver for PLplot library. It supports X Window System output.
176
177 %description driver-xwin -l pl.UTF-8
178 Sterownik ntk (new tk) dla biblioteki PLplot. Obsługuje wyjście do
179 okna systemu X Window.
180
181 %package devel
182 Summary:        Header files for PLplot library
183 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PLplot
184 Group:          Development/Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       freetype-devel >= 2.1
187 Requires:       qhull-devel
188
189 %description devel
190 Header files for PLplot library.
191
192 %description devel -l pl.UTF-8
193 Pliki nagłówkowe biblioteki PLplot.
194
195 %package static
196 Summary:        Static PLplot library
197 Summary(pl.UTF-8):      Statyczna biblioteka PLplot
198 Group:          Development/Libraries
199 Requires:       %{name}-devel = %{version}-%{release}
200
201 %description static
202 Static PLplot library.
203
204 %description static -l pl.UTF-8
205 Statyczna biblioteka PLplot.
206
207 %package c++
208 Summary:        PLplot library - C++ binding
209 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla C++
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description c++
214 PLplot library - C++ binding.
215
216 %description c++ -l pl.UTF-8
217 Biblioteka PLplot - wiązanie dla C++.
218
219 %package c++-devel
220 Summary:        PLplot library - C++ binding development files
221 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla C++
222 Group:          Development/Libraries
223 Requires:       %{name}-c++ = %{version}-%{release}
224 Requires:       %{name}-devel = %{version}-%{release}
225 Requires:       libstdc++-devel
226
227 %description c++-devel
228 PLplot library - C++ binding development files.
229
230 %description c++-devel -l pl.UTF-8
231 Biblioteka PLplot - pliki programistyczne wiązania dla C++.
232
233 %package c++-static
234 Summary:        PLplot library - C++ binding static library
235 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla C++
236 Group:          Development/Libraries
237 Requires:       %{name}-c++-devel = %{version}-%{release}
238
239 %description c++-static
240 PLplot library - C++ binding static library.
241
242 %description c++-static -l pl.UTF-8
243 Biblioteka PLplot - biblioteka statyczna wiązania dla C++.
244
245 %package f77
246 Summary:        PLplot library - FORTRAN 77 binding
247 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka FORTRAN 77
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250
251 %description f77
252 PLplot library - FORTRAN 77 binding.
253
254 %description f77 -l pl.UTF-8
255 Biblioteka PLplot - wiązanie dla języka FORTRAN 77.
256
257 %package f77-devel
258 Summary:        PLplot library - FORTRAN 77 binding development files
259 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN 77
260 Group:          Development/Libraries
261 Requires:       %{name}-devel = %{version}-%{release}
262 Requires:       %{name}-f77 = %{version}-%{release}
263 Requires:       gcc-g77
264
265 %description f77-devel
266 PLplot library - FORTRAN 77 binding development files.
267
268 %description f77-devel -l pl.UTF-8
269 Biblioteka PLplot - pliki programistyczne wiązania dla języka FORTRAN
270 77.
271
272 %package f77-static
273 Summary:        PLplot library - FORTRAN 77 binding static library
274 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN 77
275 Group:          Development/Libraries
276 Requires:       %{name}-f77-devel = %{version}-%{release}
277
278 %description f77-static
279 PLplot library - FORTRAN 77 binding static library.
280
281 %description f77-static -l pl.UTF-8
282 Biblioteka PLplot - biblioteka statyczna wiązania dla języka FORTRAN
283 77.
284
285 %package java
286 Summary:        PLplot library - Java binding
287 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Javy
288 Group:          Libraries
289 Requires:       %{name} = %{version}-%{release}
290
291 %description java
292 PLplot library - Java binding.
293
294 %description java -l pl.UTF-8
295 Biblioteka PLplot - wiązanie dla Javy.
296
297 %package java-devel
298 Summary:        PLplot library - Java binding development files
299 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Javy
300 Group:          Development/Libraries
301 Requires:       %{name}-devel = %{version}-%{release}
302 Requires:       %{name}-java = %{version}-%{release}
303 Obsoletes:      plplot-java-static
304
305 %description java-devel
306 PLplot library - Java binding development files.
307
308 %description java -l pl.UTF-8
309 Biblioteka PLplot - pliki programistyczne wiązania dla Javy.
310
311 %package tcl
312 Summary:        PLplot library - Tcl/Tk binding
313 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Tcl/Tk
314 Group:          Libraries
315 Requires:       %{name} = %{version}-%{release}
316
317 %description tcl
318 PLplot library - Tcl/Tk binding.
319
320 %description tcl -l pl.UTF-8
321 Biblioteka PLplot - wiązanie dla Tcl/Tk.
322
323 %package tcl-devel
324 Summary:        PLplot library - Tcl/Tk binding development files
325 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk
326 Group:          Development/Libraries
327 Requires:       %{name}-devel = %{version}-%{release}
328 Requires:       %{name}-tcl = %{version}-%{release}
329 Requires:       itcl-devel
330
331 %description tcl-devel
332 PLplot library - Tcl/Tk binding development files.
333
334 %description tcl-devel -l pl.UTF-8
335 Biblioteka PLplot - pliki programistyczne wiązania dla Tcl/Tk.
336
337 %package tcl-static
338 Summary:        PLplot library - Tcl/Tk binding static library
339 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk
340 Group:          Development/Libraries
341 Requires:       %{name}-tcl-devel = %{version}-%{release}
342
343 %description tcl-static
344 PLplot library - Tcl/Tk binding static library.
345
346 %description tcl-static -l pl.UTF-8
347 Biblioteka PLplot - biblioteka statyczna wiązania dla Tcl/Tk.
348
349 %package gnome
350 Summary:        PLplot library - GNOME binding
351 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla GNOME
352 Group:          Libraries
353 Requires:       %{name} = %{version}-%{release}
354
355 %description gnome
356 PLplot library - GNOME binding.
357
358 %description gnome -l pl.UTF-8
359 Biblioteka PLplot - wiązanie dla GNOME.
360
361 %package gnome-devel
362 Summary:        PLplot library - GNOME binding development files
363 Summary(pl.UTF-8):      Biblioteka PLplot - pliki programistyczne wiązania dla GNOME
364 Group:          Development/Libraries
365 Requires:       %{name}-gnome = %{version}-%{release}
366 Requires:       %{name}-devel = %{version}-%{release}
367
368 %description gnome-devel
369 PLplot library - GNOME binding development files.
370
371 %description gnome-devel -l pl.UTF-8
372 Biblioteka PLplot - pliki programistyczne wiązania dla GNOME.
373
374 %package gnome-static
375 Summary:        PLplot library - GNOME binding static library
376 Summary(pl.UTF-8):      Biblioteka PLplot - biblioteka statyczna wiązania dla GNOME
377 Group:          Development/Libraries
378 Requires:       %{name}-gnome-devel = %{version}-%{release}
379
380 %description gnome-static
381 PLplot library - GNOME binding static library.
382
383 %description gnome-static -l pl.UTF-8
384 Biblioteka PLplot - biblioteka statyczna wiązania dla GNOME.
385
386 %package octave
387 Summary:        PLplot library - Octave binding
388 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla języka Octave
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description octave
393 PLplot library - Octave binding.
394
395 %description octave -l pl.UTF-8
396 Biblioteka PLplot - wiązanie dla języka Octave.
397
398 %package octave-examples
399 Summary:        PLplot library - examples for Octave binding
400 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla języka Octave
401 Group:          Development/Libraries
402 Requires:       %{name}-devel = %{version}-%{release}
403 Requires:       %{name}-octave = %{version}-%{release}
404
405 %description octave-examples
406 PLplot library - examples for Octave binding.
407
408 %description octave-examples -l pl.UTF-8
409 Biblioteka PLplot - przykłady do wiązania dla języka Octave.
410
411 %package -n python-plplot
412 Summary:        PLplot library - Python binding
413 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona
414 Group:          Libraries/Python
415 Requires:       %{name} = %{version}-%{release}
416 %pyrequires_eq  python-libs
417 Requires:       python-Numeric
418
419 %description -n python-plplot
420 PLplot library - Python binding.
421
422 %description -n python-plplot -l pl.UTF-8
423 Biblioteka PLplot - wiązanie dla Pythona.
424
425 %package -n python-plplot-gnome
426 Summary:        PLplot library - Python GNOME binding
427 Summary(pl.UTF-8):      Biblioteka PLplot - wiązanie dla Pythona GNOME
428 Group:          Libraries/Python
429 Requires:       %{name} = %{version}-%{release}
430 %pyrequires_eq  python-libs
431
432 %description -n python-plplot-gnome
433 PLplot library - Python GNOME binding.
434
435 %description -n python-plplot-gnome -l pl.UTF-8
436 Biblioteka PLplot - wiązanie dla Pythona GNOME.
437
438 %package -n python-plplot-examples
439 Summary:        PLplot library - Python binding examples
440 Summary(pl.UTF-8):      Biblioteka PLplot - przykłady do wiązania dla Pythona
441 Group:          Libraries/Python
442 Requires:       %{name}-devel = %{version}-%{release}
443 Requires:       python-plplot = %{version}-%{release}
444
445 %description -n python-plplot-examples
446 PLplot library - Python binding examples.
447
448 %description -n python-plplot-examples -l pl.UTF-8
449 Biblioteka PLplot - przykłady do wiązania dla Pythona.
450
451 %prep
452 %setup -q
453 %patch0 -p1
454 %if "%{_lib}" == "lib64"
455 %patch1 -p1
456 %endif
457 %patch2 -p1
458 %patch3 -p1
459 %patch4 -p1
460 %patch5 -p1
461 %patch6 -p1
462
463 sed -i -e 's#/usr/include/tcl8.4/tcl-private/generic#%{_includedir}/tcl-private/generic#g' configure* \
464         cf/tcl.ac
465
466 cp -f bindings/python/plplot.py.Numeric bindings/python/plplot.py
467
468 %build
469 cp -f /usr/share/automake/config.* libltdl
470 %{__libtoolize}
471 %{__aclocal} -I cf
472 %{__autoconf}
473 %{__autoheader}
474 %{__automake}
475 %configure \
476         DATA_DIR="%{_libdir}/%{name}%{version}/data" \
477         PYTHON_INC_DIR=/usr/include/python%{py_ver} \
478         TCLINCDIR="%{_includedir}/tcl-private/generic" \
479         TCLLIBDIR="%{_ulibdir}" \
480         TKLIBDIR="%{_ulibdir}" \
481         ITCLLIBDIR="%{_ulibdir}" \
482         ITKLIBDIR="%{_ulibdir}" \
483         %{!?with_svga:--disable-linuxvga} \
484         %{!?with_perl_pdl:--enable-pdl} \
485         --enable-conex \
486         --enable-dg300 \
487         --enable-imp \
488         %{?with_java:JAVA_HOME=/usr/%{_lib}/java} \
489         %{!?with_java:--disable-java} \
490         --enable-ljii \
491         --enable-ljiip \
492         --enable-mskermit \
493         --enable-ntk \
494         --enable-octave \
495         --enable-tek4010 \
496         --enable-tek4010f \
497         --enable-tek4107 \
498         --enable-tek4107f \
499         --enable-versaterm \
500         --enable-vlt \
501         --enable-xterm \
502         --with-pkg-config \
503         --with-pthreads
504
505 %{__make} -j1 \
506         OCTAVE_M_DIR=%{octave_m_sitedir} \
507         OCTAVE_OCT_DIR=%{octave_oct_sitedir}
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d $RPM_BUILD_ROOT%{_examplesdir}
512
513 %{__make} install \
514         DESTDIR=$RPM_BUILD_ROOT \
515         OCTAVE_M_DIR=%{octave_m_sitedir} \
516         OCTAVE_OCT_DIR=%{octave_oct_sitedir}
517
518 mv -f $RPM_BUILD_ROOT%{_libdir}/plplot%{version}/data/examples \
519         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
520
521 rm -rf installed-docs
522 mv -f $RPM_BUILD_ROOT%{_docdir}/plplot installed-docs
523
524 %if %{with java}
525 # java must stay in libdir - JNI wrapper included
526 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/examples \
527         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/java
528 mv -f $RPM_BUILD_ROOT%{_libdir}/java/plplot/core/README.javaAPI installed-docs
529 %endif
530
531 %clean
532 rm -rf $RPM_BUILD_ROOT
533
534 %post   -p /sbin/ldconfig
535 %postun -p /sbin/ldconfig
536
537 %post   c++ -p /sbin/ldconfig
538 %postun c++ -p /sbin/ldconfig
539
540 %post   f77 -p /sbin/ldconfig
541 %postun f77 -p /sbin/ldconfig
542
543 %post   tcl -p /sbin/ldconfig
544 %postun tcl -p /sbin/ldconfig
545
546 %files
547 %defattr(644,root,root,755)
548 %doc AUTHORS ChangeLog Copyright FAQ NEWS PROBLEMS README SERVICE TODO* ToDo
549 %doc installed-docs/{README.1st.csa,README.1st.nn,README.csa,README.nn,README.drivers}
550 %attr(755,root,root) %{_bindir}/plm2gif
551 %attr(755,root,root) %{_bindir}/plpr
552 %attr(755,root,root) %{_bindir}/plrender
553 %attr(755,root,root) %{_bindir}/pltek
554 %attr(755,root,root) %{_bindir}/pstex2eps
555 %attr(755,root,root) %{_libdir}/libcsirocsa.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libcsirocsa.so.0
557 %attr(755,root,root) %{_libdir}/libcsironn.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libcsironn.so.0
559 %attr(755,root,root) %{_libdir}/libplplotd.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libplplotd.so.11
561 %{_mandir}/man1/plm2gif.1*
562 %{_mandir}/man1/plpr.1*
563 %{_mandir}/man1/plrender.1*
564 %{_mandir}/man1/pltek.1*
565 %{_mandir}/man1/pstex2eps.1*
566 %dir %{_libdir}/plplot%{version}
567 %{_libdir}/plplot%{version}/data
568 %dir %{_libdir}/plplot%{version}/driversd
569 # drivers list; *.la are used (by libltdl)
570 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/cgm.so
571 %{_libdir}/plplot%{version}/driversd/cgm.la
572 %{_libdir}/plplot%{version}/driversd/cgm.rc
573 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/dg300.so
574 %{_libdir}/plplot%{version}/driversd/dg300.la
575 %{_libdir}/plplot%{version}/driversd/dg300.rc
576 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/hpgl.so
577 %{_libdir}/plplot%{version}/driversd/hpgl.la
578 %{_libdir}/plplot%{version}/driversd/hpgl.rc
579 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/impress.so
580 %{_libdir}/plplot%{version}/driversd/impress.la
581 %{_libdir}/plplot%{version}/driversd/impress.rc
582 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljii.so
583 %{_libdir}/plplot%{version}/driversd/ljii.la
584 %{_libdir}/plplot%{version}/driversd/ljii.rc
585 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ljiip.so
586 %{_libdir}/plplot%{version}/driversd/ljiip.la
587 %{_libdir}/plplot%{version}/driversd/ljiip.rc
588 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/mem.so
589 %{_libdir}/plplot%{version}/driversd/mem.la
590 %{_libdir}/plplot%{version}/driversd/mem.rc
591 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/null.so
592 %{_libdir}/plplot%{version}/driversd/null.la
593 %{_libdir}/plplot%{version}/driversd/null.rc
594 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pbm.so
595 %{_libdir}/plplot%{version}/driversd/pbm.la
596 %{_libdir}/plplot%{version}/driversd/pbm.rc
597 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/plmeta.so
598 %{_libdir}/plplot%{version}/driversd/plmeta.la
599 %{_libdir}/plplot%{version}/driversd/plmeta.rc
600 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ps.so
601 %{_libdir}/plplot%{version}/driversd/ps.la
602 %{_libdir}/plplot%{version}/driversd/ps.rc
603 #%attr(755,root,root) %{_libdir}/plplot%{version}/driversd/pstex.so
604 #%{_libdir}/plplot%{version}/driversd/pstex.la
605 #%{_libdir}/plplot%{version}/driversd/pstex.rc
606 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tek.so
607 %{_libdir}/plplot%{version}/driversd/tek.la
608 %{_libdir}/plplot%{version}/driversd/tek.rc
609 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xfig.so
610 %{_libdir}/plplot%{version}/driversd/xfig.la
611 %{_libdir}/plplot%{version}/driversd/xfig.rc
612
613 %files driver-gd
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gd.so
616 %{_libdir}/plplot%{version}/driversd/gd.la
617 %{_libdir}/plplot%{version}/driversd/gd.rc
618
619 %if %{with gnome}
620 %files driver-gnome
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/gcw.so
623 %{_libdir}/plplot%{version}/driversd/gcw.la
624 %{_libdir}/plplot%{version}/driversd/gcw.rc
625
626 %files gnome
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/libplplotgnome2d.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libplplotgnome2d.so.0
630
631 %files gnome-devel
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libplplotgnome2d.so
634 %{_libdir}/libplplotgnome2d.la
635 %{_pkgconfigdir}/plplotd-gnome2.pc
636
637 %files gnome-static
638 %defattr(644,root,root,755)
639 %{_libdir}/libplplotgnome2d.a
640
641 %files -n python-plplot-gnome
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{py_sitedir}/cplplotcanvasmodule.so
644 %attr(755,root,root) %{py_sitedir}/gcwmodule.so
645 %{py_sitedir}/plplotcanvas.py
646 %endif
647
648 %if %{with svga}
649 %files driver-linuxvga
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/linuxvga.so
652 %{_libdir}/plplot%{version}/driversd/linuxvga.la
653 %{_libdir}/plplot%{version}/driversd/linuxvga.rc
654 %endif
655
656 %files driver-ntk
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/ntk.so
659 %{_libdir}/plplot%{version}/driversd/ntk.la
660 %{_libdir}/plplot%{version}/driversd/ntk.rc
661
662 %files driver-tk
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tk.so
665 %{_libdir}/plplot%{version}/driversd/tk.la
666 %{_libdir}/plplot%{version}/driversd/tk.rc
667 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/tkwin.so
668 %{_libdir}/plplot%{version}/driversd/tkwin.la
669 %{_libdir}/plplot%{version}/driversd/tkwin.rc
670
671 %files driver-xwin
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/plplot%{version}/driversd/xwin.so
674 %{_libdir}/plplot%{version}/driversd/xwin.la
675 %{_libdir}/plplot%{version}/driversd/xwin.rc
676
677 %files devel
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/plplot-config
680 %attr(755,root,root) %{_bindir}/plplot_libtool
681 %attr(755,root,root) %{_libdir}/libcsirocsa.so
682 %attr(755,root,root) %{_libdir}/libcsironn.so
683 %attr(755,root,root) %{_libdir}/libplplotd.so
684 %{_libdir}/libcsirocsa.la
685 %{_libdir}/libcsironn.la
686 %{_libdir}/libplplotd.la
687 %{_includedir}/plplot
688 %exclude %{_includedir}/plplot/pltcl.h
689 %exclude %{_includedir}/plplot/pltk.h
690 %exclude %{_includedir}/plplot/tclMatrix.h
691 %{_pkgconfigdir}/plplotd.pc
692 %{_mandir}/man1/plplot_libtool.1*
693 %dir %{_examplesdir}/%{name}-%{version}
694 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/plplot-test.sh
695 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_c.sh
696 %{_examplesdir}/%{name}-%{version}/Makefile
697 %{_examplesdir}/%{name}-%{version}/c
698 %if %{with perl_pdl}
699 # perl examples use PDL::Graphics::PLplot module found in perl-PDL
700 %{_examplesdir}/%{name}-%{version}/perl
701 %endif
702
703 %files static
704 %defattr(644,root,root,755)
705 %{_libdir}/libcsirocsa.a
706 %{_libdir}/libcsironn.a
707 %{_libdir}/libplplotd.a
708
709 %files c++
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/libplplotcxxd.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libplplotcxxd.so.9
713
714 %files c++-devel
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libplplotcxxd.so
717 %{_libdir}/libplplotcxxd.la
718 %{_pkgconfigdir}/plplotd-c++.pc
719 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_cxx.sh
720 %{_examplesdir}/%{name}-%{version}/c++
721
722 %files c++-static
723 %defattr(644,root,root,755)
724 %{_libdir}/libplplotcxxd.a
725
726 %files f77
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libplplotf77cd.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libplplotf77cd.so.9
730 %attr(755,root,root) %{_libdir}/libplplotf77d.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libplplotf77d.so.9
732
733 %files f77-devel
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libplplotf77cd.so
736 %attr(755,root,root) %{_libdir}/libplplotf77d.so
737 %{_libdir}/libplplotf77cd.la
738 %{_libdir}/libplplotf77d.la
739 %{_pkgconfigdir}/plplotd-f77.pc
740 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_f77.sh
741 %{_examplesdir}/%{name}-%{version}/f77
742
743 %files f77-static
744 %defattr(644,root,root,755)
745 %{_libdir}/libplplotf77cd.a
746 %{_libdir}/libplplotf77d.a
747
748 %if %{with java}
749 %files java
750 %defattr(644,root,root,755)
751 %doc installed-docs/README.javaAPI
752 %dir %{_libdir}/java/plplot
753 %dir %{_libdir}/java/plplot/core
754 %attr(755,root,root) %{_libdir}/java/plplot/core/*.so
755 %{_libdir}/java/plplot/core/*.class
756 %{_libdir}/java/plplot/core/*.java
757
758 %files java-devel
759 %defattr(644,root,root,755)
760 %doc installed-docs/README.javaAPI
761 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_java.sh
762 %{_examplesdir}/%{name}-%{version}/java
763 %endif
764
765 %files tcl
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/pltcl
768 %attr(755,root,root) %{_bindir}/plserver
769 %attr(755,root,root) %{_libdir}/libplplottcltkd.so.*.*.*
770 %attr(755,root,root) %ghost %{_libdir}/libplplottcltkd.so.11
771 %attr(755,root,root) %{_libdir}/libtclmatrixd.so.*.*.*
772 %attr(755,root,root) %ghost %{_libdir}/libtclmatrixd.so.11
773 %{_mandir}/man1/pltcl.1*
774 %{_mandir}/man1/plserver.1*
775
776 %files tcl-devel
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libplplottcltkd.so
779 %attr(755,root,root) %{_libdir}/libtclmatrixd.so
780 %{_libdir}/libplplottcltkd.la
781 %{_libdir}/libtclmatrixd.la
782 %{_includedir}/plplot/pltcl.h
783 %{_includedir}/plplot/pltk.h
784 %{_includedir}/plplot/tclMatrix.h
785 %{_pkgconfigdir}/plplotd-tcl.pc
786 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_tcl.sh
787 %{_examplesdir}/%{name}-%{version}/tcl
788 %{_examplesdir}/%{name}-%{version}/tk
789
790 %files tcl-static
791 %defattr(644,root,root,755)
792 %{_libdir}/libplplottcltkd.a
793 %{_libdir}/libtclmatrixd.a
794
795 %files octave
796 %defattr(644,root,root,755)
797 %doc bindings/octave/{BUGS,FGA,README,ToDo,USAGE,plplot_octave_txt}
798 %attr(755,root,root) %{octave_oct_sitedir}/plplot_octave.oct
799 %{octave_m_sitedir}/PLplot
800 %{_datadir}/plplot_octave
801
802 %files octave-examples
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_octave.sh
805 %{_examplesdir}/%{name}-%{version}/octave
806
807 %files -n python-plplot
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{py_sitedir}/_plplotcmodule.so
810 %attr(755,root,root) %{py_sitedir}/plplot_widgetmodule.so
811 %{py_sitedir}/plplot.py
812 %{py_sitedir}/plplotc.py
813
814 %files -n python-plplot-examples
815 %defattr(644,root,root,755)
816 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/test_python.sh
817 %{_examplesdir}/%{name}-%{version}/python
This page took 0.288932 seconds and 3 git commands to generate.